
SIwave™ Scripting Guide

ANSYS, Inc.
Southpointe
2600 Ansys Drive
Canonsburg, PA 15317
ansysinfo@ansys.com
https://www.ansys.com
(T) 724-746-3304
(F) 724-514-9494

  Release 2025 R2
  July 2025

ANSYS, Inc. and
ANSYS Europe,
Ltd. are UL
registered ISO
9001:2015
companies.

mailto:ansysinfo@ansys.com
https://www.ansys.com/


SIwave™ Scripting Guide

Copyright and Trademark Information

© 2002-2025 ANSYS, Inc. Unauthorized use, distribution or duplication is prohibited.

ANSYS, Ansys Workbench, AUTODYN, CFX, FLUENT and any and all ANSYS, Inc. brand,
product, service and feature names, logos and slogans are registered trademarks or trademarks
of ANSYS, Inc. or its subsidiaries located in the United States or other countries. ICEM CFD is a
trademark used by ANSYS, Inc. under license. All other brand, product, service and feature
names or trademarks are the property of their respective owners. FLEXlm and FLEXnet are
trademarks of Flexera Software LLC.

Disclaimer Notice

THIS ANSYS SOFTWARE PRODUCT AND PROGRAMDOCUMENTATION INCLUDE TRADE
SECRETS AND ARE CONFIDENTIAL AND PROPRIETARY PRODUCTS OF ANSYS, INC.,
ITS SUBSIDIARIES, OR LICENSORS. The software products and documentation are furnished
by ANSYS, Inc., its subsidiaries, or affiliates under a software license agreement that contains
provisions concerning non-disclosure, copying, length and nature of use, compliance with
exporting laws, warranties, disclaimers, limitations of liability, and remedies, and other
provisions. The software products and documentation may be used, disclosed, transferred, or
copied only in accordance with the terms and conditions of that software license agreement.

ANSYS, Inc. and ANSYS Europe, Ltd. are UL registered ISO 9001: 2015 companies.

U.S. Government Rights

For U.S. Government users, except as specifically granted by the ANSYS, Inc. software license
agreement, the use, duplication, or disclosure by the United States Government is subject to
restrictions stated in the ANSYS, Inc. software license agreement and FAR 12.212 (for non-
DOD licenses).

Third-Party Software

See the legal information in the product help files for the complete Legal Notice for Ansys
proprietary software and third-party software. If you are unable to access the Legal Notice,
please contact ANSYS, Inc.

2

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Table of Contents
Table of Contents Contents-1

1 - Introduction to Scripting 1-1

Running a Script 1-1

Using the IronPython Command Shell 1-1

Introduction to IronPython 1-2

Scope 1-2

Python Compatibility 1-2

Advantages of IronPython 1-3

Indentation in IronPython 1-3

Indenting Functions 1-3

Indenting If Conditions 1-3

Methods in IronPython 1-4

Finding Methods 1-4

Help 1-4

2 - Script Commands 2-1

CloseProject 2-12

CloseProjectNoForce 2-12

Equals 2-13

GetActiveProject 2-13

GetFileDir 2-14

GetFilePath 2-14

GetName 2-14

GetNetworkDataSolution 2-15

GetNetworkDataSolutionDefinition 2-15

GetProjectDirectory 2-15

GetProjectList 2-16

SIwave™ Scripting Guide

Contents-1

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

GetTopDesignList 2-16

GetVersion 2-16

ImportAnfFile 2-17

ImportOdb 2-17

IsSolutionDataAvailable 2-17

OpenProject 2-18

Quit 2-18

ReferenceEquals 2-18

RestoreWindow 2-19

Save 2-19

ScrActivateCktElem 2-20

ScrActivateDcPowerTreePinAggregation 2-21

ScrActivateInfiniteGroundPlane 2-22

ScrAddEquipotentialRegion 2-23

ScrAddError 2-24

ScrAddInfo 2-24

ScrAddLayer 2-25

ScrAddMaterial 2-26

ScrAddOneLayerPadstack 2-27

ScrAddWarning 2-27

ScrAppendSteppedSweep 2-28

ScrAppendSweep 2-29

ScrAssign4PtBondwireProfile 2-30

ScrAssign5PtBondwireProfile 2-31

ScrAssignBondwireTerminalType 2-32

ScrAssignComplexSolderballProfile 2-33

ScrAssignLowBondwireProfile 2-34

ScrAssignSimpleSolderballProfile 2-35

Contents-2

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrAssignSketchedBondwireProfile 2-36

ScrAssignSketchedBondwireProfileFromArray 2-37

ScrAssignSolderballTerminalType 2-38

ScrBooleanUnite 2-38

ScrChangePartType 2-39

ScrCleanUpOverlappingtraces 2-39

ScrClearAllSweeps 2-40

ScrClipDesign 2-40

ScrClipDesignAroundNets 2-41

ScrCloseProject 2-42

ScrCloseProjectNoSave 2-42

ScrComputeFwsSubckt 2-42

ScrComputeFwsSubcktForNamedSim 2-42

ScrConvertPlanesToTraces 2-43

ScrConvertTracesToPlanes 2-44

ScrConvertTracesToPlanesByNet 2-44

ScrCopyImageToClipBoard 2-44

ScrCorrectValChkErrorsWarnings 2-45

ScrCreatePinGroups 2-45

ScrCreatePinGroupByDist 2-47

ScrCreatePinGroupsByGrid 2-48

ScrCreatePinGroupByNet 2-49

ScrCreatePortsOnPart 2-50

ScrDeleteAllNets 2-50

ScrDeleteCktElem 2-50

ScrDeleteDcSolution 2-51

ScrDeleteLayer 2-52

ScrDeleteNet 2-52

Contents-3

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrDeleteNets 2-53

ScrDeleteNetsGivenInFile 2-53

ScrDeletePadstack 2-53

ScrDeletePinGroup 2-54

ScrDeleteSimulation 2-54

ScrDrawCapacitor 2-55

ScrDrawCircle 2-56

ScrDrawInductor 2-57

ScrDrawPolygon 2-58

ScrDrawPort 2-59

ScrDrawRectangle 2-60

ScrDrawResistor 2-61

ScrDrawTrace 2-62

ScrDrawVia 2-63

ScrDrawVoltageProbe 2-64

ScrDrawVoltageSource 2-65

ScrEditCktElemName 2-66

ScrEditLayerName 2-67

ScrEditMaterial 2-67

ScrEditNetName 2-68

ScrEditPadStackName 2-68

ScrEnableCavityFieldCoupling 2-69

ScrEnableCoPlaneCoupling 2-69

ScrEnableErcSimSetup 2-69

ScrEnableFwsRelativeErrorTol 2-70

ScrEnableGUIRefresh 2-71

ScrEnableIntraPlaneCoupling 2-71

ScrEnableSplitPlaneCoupling 2-71

Contents-4

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrEnableTraceCoupling 2-72

ScrExport3DModel 2-72

ScrExportAnf 2-73

ScrExportComponentFile 2-73

ScrExportCpaSimReport (IronPython) 2-74

ScrExportDcPowerDataToIcepak 2-74

ScrExportDcPowerTree 2-75

ScrExportDcSimReport 2-76

ScrExportDcSimReportColorBarProperties 2-76

ScrExportDcSimReportOptions 2-77

ScrExportDcSimReportScaling 2-77

ScrExportDcSimReportUnits 2-78

ScrExportElementData 2-79

ScrExportEmiScanReport 2-79

ScrExportIcepakProject 2-80

ScrExportIcepakSimReport 2-81

ScrExportIcepakSimReportColorBarProperties 2-81

ScrExportIcepakSimReportScaling 2-82

ScrExportIcepakSimReportUnits 2-82

ScrExportLayerStackup 2-83

ScrExportNamedSimToTouchstone 2-83

ScrExportNetDelayReport 2-84

ScrExportSettingsFile 2-84

ScrExportSettingsFileSetOptions 2-84

ScrExportSNAReport 2-85

ScrExportSyzSimToTouchstone 2-87

ScrExportToTouchstone 2-87

ScrExportVprobeData 2-89

Contents-5

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrExportXfl 2-89

ScrExportZ0ScanReport 2-90

ScrExportZ0ScanReportColorBarProperties 2-91

ScrExportZ0ScanReportScaling 2-92

ScrFitAll 2-92

ScrFitSelection 2-92

ScrFitToViewingWindow 2-92

ScrFwsEnforceCausality 2-93

ScrGenerateConnectionReport 2-94

ScrGenerateICDieNetwork 2-95

ScrGetActiveComponentList 2-96

ScrGetBondwiresOfBwModel 2-96

ScrGetBwModelNameList 2-96

ScrGetCktElemTerminalNetNames 2-97

ScrGetComponentList 2-98

ScrGetCurrentViewingWindow 2-98

ScrGetDcConnectedNets 2-99

ScrGetDcThermalDataDir 2-99

ScrGetDesignBoundingBox 2-100

ScrGetDieLayerName 2-100

ScrGetDieNameList 2-101

ScrGetExcitationCoord 2-102

ScrGetLayerMaterial 2-102

ScrGetLayerNameList 2-102

ScrGetLayerThickness 2-103

ScrGetLayerType 2-103

ScrGetLayoutLengthUnit 2-103

ScrGetMetalLayerFillerMaterial 2-104

Contents-6

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrGetNetlistOfBondwireProfile 2-104

ScrGetNetNameList 2-104

ScrGetNetsAndCktElemsBetweenComponents 2-105

ScrGetNetsAndCktElemsBetweenNets 2-106

ScrGetNumSinks 2-107

ScrGetNumSources 2-108

ScrGetPadstackNameList 2-108

ScrGetPinGroupNameList 2-109

ScrGetPinPadstackName 2-109

ScrGetPinsOnNet 2-110

ScrGetPinsOnPart 2-111

ScrGetPwrGndNetNameList 2-111

ScrGetRLCsBetweenNets 2-112

ScrGetSinkNameList 2-113

ScrGetSourceNameList 2-114

ScrGetStackupLayerThickness 2-114

ScrGetUniqueSimulationName 2-115

ScrImportAnf 2-115

ScrImportCapacitorDeratingTable 2-116

ScrImportComponentFile 2-116

ScrImportComponentMapFile 2-117

ScrImportCpaSimulationOptions 2-118

ScrImportCpmOrPloc 2-119

Option Keywords and Example Values 2-119

ScrImportDDXFile 2-120

ScrImportEDB 2-121

ScrImportGDSII 2-121

ScrImportIPC2581 2-122

Contents-7

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrImportLayerStackup 2-122

ScrImportLayerStackupFile 2-123

ScrImportLayerStackupXML 2-123

ScrImportPmap 2-124

ScrImportSettingsFile 2-124

ScrImportSIwaveSimulationOptions 2-125

ScrImportXfl 2-126

ScrInterpolateSpectrum 2-126

ScrLogMessage 2-127

ScrMergeConnectedNets 2-127

ScrNetGetLength 2-128

ScrNetIsDisjoint 2-128

ScrNetIsSelected 2-129

ScrNetSeparate 2-129

ScrNetSetDummy 2-129

ScrNetSetSelected 2-130

ScrPlaceCircuitElement 2-131

ScrPlaceCircuitElementsToNearestRefPin 2-133

ScrPlaceFreqDependentSrc 2-134

ScrPlacePortsAcrossRLCs 2-135

ScrPlacePortsAtPinsOnSelectedNets 2-136

ScrPlacePortsAtPinsOnSelectedNetsExcludePart 2-137

ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut 2-138

ScrPlotResModeVoltageDiff 2-139

ScrPreserveNetsGivenInFile 2-139

ScrReadDCLoopResInfo 2-140

ScrRestoreResonantModeMinFreq 2-140

ScrRestoreSIwaveDCGeometryProcessingDefaultValues 2-140

Contents-8

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrRestoreSIwaveSIPIGeometryProcessingDefaultValues 2-141

ScrRunDcSimulation 2-141

ScrRunDDRWizard 2-141

ScrRunFarFieldSimulation 2-142

ScrRunFrequencySweepSimulation 2-142

ScrRunIcepakSimulation 2-142

ScrRunInducedVoltageSimulation 2-143

ScrRunNearFieldSimulation 2-143

ScrRunResonantModeSimulation 2-144

ScrRunSimulation 2-145

ScrRunSpiceSubcktSimulation 2-145

ScrRunSyzParameterSimulation 2-145

ScrRunValidationCheck 2-146

ScrRunValidationCheckWithOptions 2-147

ScrSanitizeLayout 2-148

ScrSanitizeNets 2-148

ScrSaveProjectAs 2-149

ScrSaveSimulationMessages 2-149

ScrSaveToPngFile 2-149

ScrSelectDcConnectedNets 2-150

ScrSelectNet 2-150

ScrSelectNetsBetweenComponents 2-151

ScrSelectNetsBetweenNets 2-151

ScrSeparateDisjointNets 2-152

ScrSet4PtBwProfile 2-152

ScrSet5PtBwProfile 2-153

ScrSetAntiPadOnLayer 2-154

ScrSetBwModel 2-155

Contents-9

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrSetBwSuppLayer 2-155

ScrSetBwTermLayer 2-156

ScrSetCapacitorDcBiasDeratingSim 2-157

ScrSetCapacitorTemperatureDeratingSim 2-158

ScrSetConformalCoatLayers 2-158

ScrSetCrosstalkScanParameters 2-158

ScrSetCrossTalkThreshold 2-159

ScrSetDcMinPlaneAreaToMesh 2-159

ScrSetDcMinVoidAreaToMesh 2-159

ScrSetDcPowerDataThresholds 2-160

ScrSetDieElevation 2-160

ScrSetDieThickness 2-161

ScrSetEmiScannerParameters 2-162

ScrSetEnergyErrorPercentInDcSimulation 2-163

ScrSetExternalExcitations 2-163

ScrSetFarFieldSimOptions 2-164

ScrSetFwsColFitOptions 2-164

ScrSetFwsLaunchDesignerNexxim 2-165

ScrSetFwsPassivityAlg 2-165

ScrSetFwsPortRefZ 2-166

ScrSetFwsPzOptions 2-166

ScrSetFwsSsfAlg 2-167

ScrSetFwsSubcktFormat 2-167

ScrSetFwsUseCommonGround 2-168

ScrSetHFSS3DLayoutSimOptions 2-168

ScrSetHpcLicenseType 2-169

ScrSetHpcLicenseVendor 2-169

ScrSetIcepakBoardOutlineFidelity 2-170

Contents-10

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrSetIcepakCabinetDimensions 2-170

ScrSetIcepakComponentConfig 2-171

ScrSetIcepakMeshingDetail 2-171

ScrSetIcepakSimReportImageHeight 2-172

ScrSetIcepakTemperatureFile 2-172

ScrSetIcepakThermalEnv 2-173

ScrSetIdealGroundNodeInDcSimulation 2-174

ScrSetInducedVoltageMultipleIncidenceSpherical 2-175

ScrSetInducedVoltageSingleIncidenceCartesian 2-176

ScrSetInducedVoltageSingleIncidenceSpherical 2-177

ScrSetInfiniteGroundPlaneLocation 2-178

ScrSetLayerMaterial 2-178

ScrSetLayerThickness 2-179

ScrSetLayerType 2-179

ScrSetLayerVisibility 2-179

ScrSetLayoutLengthUnit 2-181

ScrSetLocalRefinementPercentInDcSimulation 2-181

ScrSetLogFreqPointDist 2-181

ScrSetLowBwProfile 2-182

ScrSetMaxRefinePassesInDcSimulation 2-182

ScrSetMeshBondwiresInDcSimulation 2-183

ScrSetMeshViasInDcSimulation 2-183

ScrSetMetalLayerFillerMaterial 2-184

ScrSetMinCutoutArea 2-184

ScrSetMinPadAreaToMesh 2-185

ScrSetMinPlaneAreaToMesh 2-185

ScrSetMinRefinePassesInDcSimulation 2-185

ScrSetNearFieldExportDataPath 2-186

Contents-11

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrSetNearFieldMeshingFrequencyDefault 2-187

ScrSetNearFieldMeshingFrequencyPoints 2-187

ScrSetNearFieldMeshingFrequencyRange 2-188

ScrSetNearFieldSamplePointSpacing 2-188

ScrSetNearFieldSolverOptions 2-189

ScrSetNearFieldSurfaceOffset 2-190

ScrSetNumBondwireSidesInDcSimulation 2-191

ScrSetNumCpusToUse 2-191

ScrSetNumModesToCompute 2-191

ScrSetNumViaSidesInDcSimulation 2-192

ScrSetOptionsFor3DModelExport 2-192

ScrSetPadOnLayer 2-195

ScrSetPadstackMaterial 2-195

ScrSetPadstackViaPlatingAbsolute 2-195

ScrSetPadstackViaPlatingRatio 2-196

ScrSetPlotAfterDcSimulation 2-197

ScrSetPlotLayers 2-197

ScrSetPlotSyzMag 2-197

ScrSetPlotSyzPhase 2-197

ScrSetPortNamingConvention 2-198

ScrSetPowerGroundNets 2-199

ScrSetPowerGroundNetsFromFile 2-199

ScrSetProjectModified 2-199

ScrSetPsiOptionsFromFile 2-200

ScrSetPsiPortType 2-200

ScrSetPsiSyzInterpOptions 2-200

ScrSetRefineBondwiresInDcSimulation 2-201

ScrSetRefineDcSimulation 2-202

Contents-12

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrSetRefineViasInDcSimulation 2-202

ScrSetRemoveCutoutsByArea 2-202

ScrSetResonantModeMaxFreq 2-203

ScrSetResonantModeMinFreq 2-203

ScrSetRLCValues 2-204

ScrSetSignalNets 2-205

ScrSetSignalNetsFromFile 2-206

ScrSetSimulationName 2-207

ScrSetSIwaveSolverMemLimit 2-208

ScrSetSketchedBwProfile 2-209

ScrSetSketchedBwProfileFromArray 2-210

ScrSetSnapLengthThreshold 2-211

ScrSetSolderballMaterial 2-211

ScrSetSolderballParameters 2-212

ScrSetSourceMagnitude 2-213

ScrSetSparamModelSetup 2-214

ScrSetSpiceModelSetup 2-215

ScrSetSpiceSubcktFormat 2-216

ScrSetStackupLayerThickness 2-216

ScrSetStackupLayerThicknessUnit 2-217

ScrSetSweepFreqRange 2-217

ScrSetSweepMaxFreq 2-217

ScrSetSweepMinFreq 2-218

ScrSetSweepNumFreqPoints 2-218

ScrSetSyzInterpSweep 2-218

ScrSetSyzInterpSweepParams 2-219

ScrSetTDCrosstalkScanParameters 2-220

ScrSetThermalPadOnLayer 2-221

Contents-13

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrSetTouchstoneExportFormatToDb 2-222

ScrSetTouchstonePortOrder 2-222

ScrSetTouchstonePortRemapping 2-223

ScrSetTraceCouplingDistance 2-223

ScrSetUniformTemperature 2-224

ScrSetZ0ScanParameters 2-224

ScrSetZ0ScanReportImageHeight 2-225

ScrShowDcPowerTreePowerLossOfNets 2-226

ScrShowSelectedNetsOnly 2-226

ScrSIwaveEnable_3D_DDM 2-226

ScrSIwaveEnableHFSSRegions 2-227

ScrSIwaveEnableReturnCurrentDistribution 2-227

ScrSIwaveIncludeSourceParasitics 2-227

ScrSIwaveSyzComputeExactDcPoint 2-228

ScrSIwaveSyzEnforceCausality 2-228

ScrSIwaveSyzEnforcePassivity 2-229

ScrUnselectAll 2-229

ScrUpdateComponentTree 2-229

ScrUseIcepakTemperatureDataInDc 2-230

ScrUseTouchstonePortRemapping 2-230

Solve 2-230

StopSimLink 2-231

SupportSParamLink 2-231

Index Index-1

Contents-14

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



1 - Introduction to Scripting
SIwave has the ability to run saved scripts in Python. It also contains a native Python command
shell.

The following topics contain more information about scripting in SIwave:

Running a Script

SIwave Script Commands

Running a Script
To run a script file in SIwave:

1. Click Tools. From the Scripting area, click Run Script.
TheOpen window appears.

2. Use the file browser to locate and select a *.py script file.
3. ClickOpen.

The script is executed.

To run a script file from a command line:

1. Type the following:
<path to siwave.exe> <path to *.siw file> -RunScript <path to *.py
file>

SIwave opens and the script is executed.

Alternatively, type the following to run the script and close SIwave:

<path to siwave.exe> <path to *.siw file> -RunScriptAndExit <path
to *.py file>

To run a script from the Python command shell:

1. Click Tools. From the Scripting area, click IronPython Command Shell.
The command window appears.

2. Type an appropriate script commands and press Enter.

Using the IronPython Command Shell
This section describes IronPython and using the IronPython Command Shell in SIwave. It is
written for those already familiar with scripting in any language.

To launch the IronPython Command Shell:

SIwave™ Scripting Guide
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1. Click Tools. From the Scripting area, click IronPython Command Shell.
The IronPython Command Window appears.

Introduction to IronPython
IronPython is an implementation of the Python programming language targeting the .NET
runtime. IronPython uses the Python programming language syntax and standard Python
libraries and can additionally use .NET classes and objects to give the best of both worlds. This
usage of .NET classes is seamless in that a class defined in a .NET assembly can be used as a
base class of a python class.

Scope

This section of the help provides a basic introduction to the use of IronPython in SIwave. If you
require a full tutorial on Python or IronPython, there are many online resources.

Python Compatibility

The version of IronPython in use is 2.7 and built on .NET framework version 4.0. While most
Python files will execute under IronPython with no changes, Python libraries that make use of
extensions written in the C programming language (NumPy or SciPy, for instance) cannot be
expected to work in IronPython. In such cases, it might be possible to locate .NET

Introduction to Scripting 1-2
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implementation of such libraries or explore the use of IronClad
(http://code.google.com/p/ironclad/).

Advantages of IronPython

The advantages that IronPython provides are significant:

l Python has a large ecosystem with plenty of supporting libraries, Visual IDEs and
debuggers. It is actively developed and enhanced.

l IronPython has access to the entire .NET ecosystem. This allows us, for instance, to create
a modern GUI using the System.Windows.Forms assembly from IronPython code and call
any other .NET assembly.

l The Python syntax of dictionaries is somewhat easier to read and write when supplying
arguments to the scripting methods.

Indentation in IronPython
Python is a language in which white space (spaces and tabs) is syntactically significant. You
must understand the basics of indentation before scripting in python.

Any statement that introduces a block of code should be written so that every line of the block
has the same indent (leading spaces or tabs) and the indent should be at least one more than
the indent of the introducing statement.

Note:

Python recommends the use of spaces over tabs.

Indenting Functions

Define a function that starts at 0 indentation:

def multInt(a,b):

Every line following def multInt that is expected to be a part of the function, must be indented
to line up with the function.

def multInt(a,b):

    return a

Indenting If Conditions

Each line that belongs to the body of this function should have an indent that is more than the
indent used by the if statement.

def multInt(a,b):

Introduction to Scripting 1-3
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If a%2 == 0:

       return (a * b) + 100

    else:

       return (a * b) + 1000

Methods in IronPython

Finding Methods

To list all methods available in the string module,import the module:

import string

Then get the directory listing:

dir(string)

This returns a list of all the methods available (as well as some __somename__ internal names
that can be ignored).

Help

Once you know a function name, you can get more help on it using the built-in helpmethod.
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2 - Script Commands
The following scripts are available in SIwave:

l CloseProject
l CloseProjectNoForce
l GetActiveProject
l GetFileDir
l GetFilePath
l GetName
l GetNetworkDataSolution
l GetNetworkDataSolutionDefinition
l GetProjectDirectory
l GetProjectList
l GetTopDesignList
l GetVersion
l ImportAnfFile
l ImportODB
l IsSolutionDataAvailable
l OpenProject
l Quit
l ReferenceEquals
l RestoreWindow
l Save
l ScrActivateCktElem
l ScrActivateDcPowerTreePinAggregation
l ScrActivateInfiniteGroundPlane
l ScrAddEquipotentialRegion
l ScrAddError
l ScrAddInfo
l ScrAddLayer
l ScrAddMaterial
l ScrAddOneLayerPadstack
l ScrAddWarning
l ScrAppendSteppedSweep
l ScrAppendSweep
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l ScrAssign4PtBondwireProfile
l ScrAssign5PtBondwireProfile
l ScrAssignBondwireTerminalType
l ScrAssignComplexSolderballProfile
l ScrAssignLowBondwireProfile
l ScrAssignSimpleSolderballProfile
l ScrAssignSketchedBondwireProfile
l ScrAssignSketchedBondwireProfileFromArray
l ScrAssignSolderballTerminalType
l ScrBooleanUnite
l ScrChangePartType
l ScrCleanUpOvelappingtraces
l ScrClearAllSweeps
l ScrClipDesign
l ScrClipDesignAroundNets
l ScrCloseProject
l ScrCloseProjectNoSave
l ScrComputeFwsSubckt
l ScrComputeFwsSubcktForNamedSim
l ScrConvertPlanesToTraces
l ScrConvertTracesToPlanes
l ScrConvertTracesToPlanesByNet
l ScrCopyImageToClipBoard
l ScrCorrectValChkErrorsWarnings
l ScrCreatePinGroups
l ScrCreatePinGroupByDist
l ScrCreatePinGroupsByGrid
l ScrCreatePinGroupByNet
l ScrCreatePortsOnPart
l ScrDeleteAllNets
l ScrDeleteCktElem
l ScrDeleteDcSolution
l ScrDeleteLayer
l ScrDeleteNet
l ScrDeleteNets
l ScrDeleteNetsGivenInFile
l ScrDeletePadstack
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l ScrDeletePinGroup
l ScrDeleteSimulation
l ScrDrawCapacitor
l ScrDrawCircle
l ScrDrawInductor
l ScrDrawPolygon
l ScrDrawPort
l ScrDrawRectangle
l ScrDrawResistor
l ScrDrawTrace
l ScrDrawVia
l ScrDrawVoltageProbe
l ScrDrawVoltageSource
l ScrEditCktElemName
l ScrEditLayerName
l ScrEditMaterial
l ScrEditNetName
l ScrEditPadStackName
l ScrEnableCavityFieldCoupling
l ScrEnableCoPlaneCoupling
l ScrEnableErcSimSetup
l ScrEnableFwsRelativeErrorTol
l ScrEnableGUIRefresh
l ScrEnableIntraPlaneCoupling
l ScrEnableSplitPlaneCoupling
l ScrEnableTraceCoupling
l ScrExport3DModel
l ScrExportAnf
l ScrExportComponentFile
l ScrExportCpaSimReport
l ScrExportDcPowerDataToIcepak
l ScrExportDcPowerTree
l ScrExportDcSimReport
l ScrExportDcSimReportColorBarProperties
l ScrExportDcSimReportOptions
l ScrExportDcSimReportScaling
l ScrExportDcSimReportUnits
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l ScrExportElementData
l ScrExportEmiScanReport
l ScrExportIcepakProject
l ScrExportIcepakSimReport
l ScrExportIcepakSimReportColorBarProperties
l ScrExportIcepakSimReportScaling
l ScrExportIcepakSimReportUnits
l ScrExportLayerStackup
l ScrExportNamedSimToTouchstone
l ScrExportNetDelayReport
l ScrExportSettingsFile
l ScrExportSettingsFileSetOptions
l ScrExportSNAReport
l ScrExportSyzSimToTouchstone
l ScrExportToTouchstone
l ScrExportVprobeData
l ScrExportXfl
l ScrExportZ0ScanReport
l ScrExportZ0ScanReportColorBarProperties
l ScrExportZ0ScanReportScaling
l ScrFitAll
l ScrFitSelection
l ScrFitToViewingWindow
l ScrFwsEnforceCausality
l ScrGenerateConnectionReport
l ScrGenerateICDieNetwork
l ScrGetActiveComponentList
l ScrGetBondwiresOfBwModel
l ScrGetBwModelNameList
l ScrGetCktElemTerminalNetNames
l ScrGetComponentList
l ScrGetCurrentViewingWindow
l ScrGetDcConnectedNets
l ScrGetDcThermalDataDir
l ScrGetDesignBoundingBox
l ScrGetDieLayerName
l ScrGetDieNameList
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l ScrGetExcitationCoord
l ScrGetLayerMaterial
l ScrGetLayerNameList
l ScrGetLayerThickness
l ScrGetLayerType
l ScrGetLayoutLengthUnit
l ScrGetMetalLayerFillerMaterial
l ScrGetNetlistOfBondwireProfile
l ScrGetNetNameList
l ScrGetNetsAndCktElemsBetweenComponents
l ScrGetNetsAndCktElemsBetweenNets
l ScrGetNumSinks
l ScrGetNumSources
l ScrGetPinGroupNameList
l ScrGetPinPadstackName
l ScrGetPinsOnNet
l ScrGetPinsOnPart
l ScrGetPwrGndNetNameList
l ScrGetRLCsBetweenNets
l ScrGetSinkNameList
l ScrGetSourceNameList
l ScrGetStackupLayerThickness
l ScrGetUniqueSimulationName
l ScrImportAnf
l ScrImportCapacitorDeratingTable
l ScrImportComponentFile
l ScrImportComponentMapFile
l ScrImportCpaSimulationOptions
l ScrImportCpmOrPloc
l ScrImportDDXFile
l ScrImportEDB
l ScrImportGDSII
l ScrImportIPC2581
l ScrImportLayerStackup
l ScrImportLayerStackupFile
l ScrImportLayerStackupXML
l ScrImportPmap
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l ScrImportSettingsFile
l ScrImportSIwaveSimulationOptions
l ScrImportXfl
l ScrInterpolateSpectrum
l ScrLogMessage
l ScrMergeConnectedNets
l ScrNetGetLength
l ScrNetIsDisjoint
l ScrNetIsSelected
l ScrNetSeparate
l ScrNetSetDummy
l ScrNetSetSelected
l ScrPlaceCircuitElement
l ScrPlaceCircuitElementsToNearestRefPin
l ScrPlaceFreqDependentSrc
l ScrPlacePortsAcrossRLCs
l ScrPlacePortsAtPinsOnSelectedNets
l ScrPlacePortsAtPinsOnSelectedNetsExcludePart
l ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut
l ScrPlotResModeVoltageDiff
l ScrPreserveNetsGivenInFile
l ScrReadDCLoopResInfo'
l ScrRestoreResonantModeMinFreq
l ScrRestoreSIwaveDCGeometryProcessingDefaultValues
l ScrRestoreSIwaveSIPIGeometryProcessingDefaultValues
l ScrRunDcSimulation
l ScrRunDDRWizard
l ScrRunFarFieldSimulation
l ScrRunFrequencySweepSimulation
l ScrRunIcepakSimulation
l ScrRunInducedVoltageSimulation
l ScrRunNearFieldSimulation
l ScrRunResonantModeSimulation
l ScrRunSimulation
l ScrRunSpiceSubcktSimulation
l ScrRunSyzParameterSimulation
l ScrRunValidationCheck
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l ScrRunValidationCheckWithOptions
l ScrSanitizeLayout
l ScrSanitizeNets
l ScrSaveProjectAs
l ScrSaveSimulationMessages
l ScrSaveToPngFile
l ScrSelectDcConnectedNets
l ScrSelectNet
l ScrSelectNetsBetweenComponents
l ScrSelectNetsBetweenNets
l ScrSeparateDisjointNets
l ScrSet4PtBwProfile
l ScrSet5PtBwProfile
l ScrSetAntiPadOnLayer
l ScrSetBwModel
l ScrSetBwSuppLayer
l ScrSetBwTermLayer
l ScrSetCapacitorDcBiasDeratingSim
l ScrSetCapacitorTemperatureDeratingSim
l ScrSetConformalCoatLayers
l ScrSetCrosstalkScanParameters
l ScrSetCrossTalkThreshold
l ScrSetDcMinPlaneAreaToMesh
l ScrSetDcMinVoidAreaToMesh
l ScrSetDcPowerDataThresholds
l ScrSetDieElevation
l ScrSetDieThickness
l ScrSetEmiScannerParameters
l ScrSetEnergyErrorPercentInDcSimulation
l ScrSetExternalExcitations
l ScrSetFarFieldSimOptions
l ScrSetFwsColFitOptions
l ScrSetFwsLaunchDesignerNexxim
l ScrSetFwsPassivityAlg
l ScrSetFwsPortRefZ
l ScrSetFwsPzOptions
l ScrSetFwsSsfAlg
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l ScrSetFwsSubcktFormat
l ScrSetFwsUseCommonGround
l ScrSetHFSS3DLayoutSimOptions
l ScrSetHpcLicenseType
l ScrSetHpcLicenseVendor
l ScrSetIcepakBoardOutlineFidelity
l ScrSetIcepakCabinetDimensions
l ScrSetIcepakComponentConfig
l ScrSetIcepakMeshingDetail
l ScrSetIcepakSimReportImageHeight
l ScrSetIcepakTemperatureFile
l ScrSetIcepakThermalEnv
l ScrSetIdealGroundNodeInDcSimulation
l ScrSetInducedVoltageMultipleIncidenceSpherical
l ScrSetInducedVoltageSingleIncidenceCartesian
l ScrSetInducedVoltageSingleIncidenceSpherical
l ScrSetInfiniteGroundPlaneLocation
l ScrSetLayerMaterial
l ScrSetLayerThickness
l ScrSetLayerType
l ScrSetLayerVisibility
l ScrSetLayoutLengthUnit
l ScrSetLocalRefinementPercentInDcSimulation
l ScrSetLogFreqPointDist
l ScrSetLowBwProfile
l ScrSetMaxRefinePassesInDcSimulation
l ScrSetMeshBondwiresInDcSimulation
l ScrSetMeshViasInDcSimulation
l ScrSetMetalLayerFillerMaterial
l ScrSetMinCutoutArea
l ScrSetMinPadAreaToMesh
l ScrSetMinPlaneAreaToMesh
l ScrSetMinRefinePassesInDcSimulation
l ScrSetNearFieldExportDataPath
l ScrSetNearFieldMeshingFrequencyDefault
l ScrSetNearFieldMeshingFrequencyPoints
l ScrSetNearFieldMeshingFrequencyRange
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l ScrSetNearFieldSamplePointSpacing
l ScrSetNearFieldSolverOptions
l ScrSetNearFieldSurfaceOffset
l ScrSetNumBondwireSidesInDcSimulation
l ScrSetNumCpusToUse
l ScrSetNumModesToCompute
l ScrSetNumViaSidesInDcSimulation
l ScrSetOptionsFor3DModelExport
l ScrSetPadOnLayer
l ScrSetPadstackMaterial
l ScrSetPadstackViaPlatingAbsolute
l ScrSetPadstackViaPlatingRatio
l ScrSetPlotAfterDcSimulation
l ScrSetPlotLayers
l ScrSetPlotSyzMag
l ScrSetPlotSyzPhase
l ScrSetPortNamingConvention
l ScrSetPowerGroundNets
l ScrSetPowerGroundNetsFromFile
l ScrSetProjectModified
l ScrSetPsiOptionsFromFile
l ScrSetPsiPortType
l ScrSetPsiSyzInterpOptions
l ScrSetRefineBondwiresInDcSimulation
l ScrSetRefineDcSimulation
l ScrSetRefineViasInDcSimulation
l ScrSetRemoveCutoutsByArea
l ScrSetResonantModeMaxFreq
l ScrSetResonantModeMinFreq
l ScrSetRLCValues
l ScrSetSignalNets
l ScrSetSignalNetsFromFile
l ScrSetSimulationName
l ScrSetSIwaveSolverMemLimit
l ScrSetSketchedBwProfile
l ScrSetSketchedBwProfileFromArray
l ScrSetSnapLengthThreshold
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l ScrSetSolderballMaterial
l ScrSetSolderballParameters
l ScrSetSIwaveSolverMemLimit
l ScrSetSourceMagnitude
l ScrSetSparamModelSetup
l ScrSetSpiceModelSetup
l ScrSetSpiceSubcktFormat
l ScrSetStackupLayerThickness
l ScrSetStackupLayerThicknessUnit
l ScrSetSweepFreqRange
l ScrSetSweepMaxFreq
l ScrSetSweepMinFreq
l ScrSetSweepNumFreqPoints
l ScrSetSyzInterpSweep
l ScrSetSyzInterpSweepParams
l ScrSetTDCrosstalkScanParameters
l ScrSetThermalPadOnLayer
l ScrSetTouchstoneExportFormatToDb
l ScrSetTouchstonePortOrder
l ScrSetTouchstonePortRemapping
l ScrSetTraceCouplingDistance
l ScrSetUniformTemperature
l ScrSetZ0ScanParameters
l ScrSetZ0ScanReportImageHeight
l ScrShowDcPowerTreePowerLossOfNets
l ScrShowSelectedNetsOnly
l ScrSIwaveEnable_3D_DDM
l ScrSIwaveEnableHFSSRegions
l ScrSIwaveEnableReturnCurrentDistribution
l ScrSIwaveIncludeSourceParasitics
l ScrSIwaveSyzComputeExactDcPoint
l ScrSIwaveSyzEnforceCausality
l ScrSIwaveSyzEnforcePassivity
l ScrUnselectAll
l ScrUpdateComponentTree
l ScrUseIcepakTemperatureDataInDc
l ScrUseTouchstonePortRemapping
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l Solve
l StopSimLink
l SupportSParamLink

Note:

l This list contains all current SIwave scripting functions. Running dir(oApp) or
dir(oDoc) from the CommandWindow may show additional scripts. These are
scripts that are either obsolete or that are part of the Electronics Desktop scripting
environment and do not serve any function in SIwave.

l TPA is no longer supported. Ansys recommends using CPA.
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CloseProject
Closes the specified project and opens a new "Untitled" project.

UI Command: Click File > New.

Syntax: obj.CloseProject(<projectName>)

Parameters: BSTR projectName

Return Value: None.

PY Example: oApp.CloseProject('project.siw')

Note:

The behavior of CloseProject() and CloseProjectNoForce() is identical when the
SIwave UI is invoked in graphical/interactive mode.

However, when invoked in extractor/non-interactive mode:

l CloseProject() will result in termination of the siwave.exe process.
l CloseProjectNoForce() will close any open projects, but will keep the siwave.exe
process active (so that subsequent script commands can be issued).

CloseProjectNoForce
Closes the specified project and opens a new "Untitled" project.

UI Command: Click File > New.

Syntax: obj.CloseProjectNoForce(<projectName>)

Parameters: BSTR projectName

Return Value: None.

PY Example: oApp.CloseProjectNoForce('project.siw')

Note:

The behavior of CloseProjectNoForce() and CloseProject() is identical when the
SIwave UI is invoked in graphical/interactive mode.

However, when invoked in extractor/non-interactive mode:

l CloseProject() will result in termination of the siwave.exe process.
l CloseProjectNoForce() will close any open projects, but will keep the siwave.exe
process active (so that subsequent script commands can be issued).
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Equals
Comparison operator. Returns whether two objects are equal.

UI Command: N/A

Syntax: obj.Equals(<comparisonObject>)

Parameters: VAR comparisonObject

Return Value: TRUE or FALSE

PY Example: oDoc.Equals(oDoc)

GetActiveProject
Returns the active project in SIwave.

UI Command: None.

Syntax: obj.GetActiveProject()

Parameters: None.

Return Value: Object of active project.

PY Example: oDoc = oApp.GetActiveProject()
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GetFileDir
Returns the directory path of the open project.

UI Command: None.

Syntax: obj.GetFileDir()

Parameters: None.

Return Value: BSTR directory path

PY Example: oDoc.GetFileDir()

GetFilePath
Returns the directory path of the open project.

UI Command: None.

Syntax: obj.GetFilePath()

Parameters: None.

Return Value: BSTR directory path

PY Example: oDoc.GetFilePath()

GetName
Returns the name of the open SIwave project.

UI Command: None.

Syntax: obj.GetName()

Parameters: None.

Return Value: BSTR project name

PY Example: oDoc.GetName()
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GetNetworkDataSolution
Returns network data for a previously run SYZ simulation.

UI Command: None.

Syntax: obj.GetNetworkDataSolution(<solnName>)

Parameters: BSTR solnName (name of a previously run SYZ simulation)

Return Value: BSTR network data

PY Example: oDoc.GetNetworkDataSolution('SYZ Sim 1')

GetNetworkDataSolutionDefinition
Returns port names for a previously run SYZ simulation.

UI Command: None.

Syntax: obj.GetNetworkDataSolutionDefinition(<solnName>)

Parameters: BSTR solnName (name of a previously run SYZ simulation)

Return Value: ARRAY of BSTR port names

PY Example: oDoc.GetNetworkDataSolutionDefinition('SYZ Sim 1')

GetProjectDirectory
Returns the directory path of the open project.

UI Command: None.

Syntax: obj.GetProjectDirectory()

Parameters: None.

Return Value: BSTR directory path

PY Example: oApp.GetProjectDirectory()
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GetProjectList
Returns a list of all projects that are open in SIwave.

UI Command: None.

Syntax: obj.GetProjectList()

Parameters: None.

Return Value: ARRAY of strings containing names of all open projects.

PY Example: oDoc.GetProjectList()

GetTopDesignList
Returns a list of all designs that are open in SIwave.

UI Command: None.

Syntax: obj.GetTopDesignList()

Parameters: None.

Return Value: ARRAY of strings containing names of all open designs.

PY Example: oDoc.GetTopDesignList()

GetVersion
Returns SIwave version information.

UI Command: None.

Syntax: obj.GetVersion()

Parameters: None.

Return Value: BSTR version information

PY Example: oApp.GetVersion()
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ImportAnfFile
Imports an ANF file into a new project.

UI Command: Import > ANF.

Syntax: obj.ImportAnfFile(<filePath>)

Parameters: BSTR filePath

Return Value: None.

PY Example: oApp.ImportAnfFile('C:/KWH/GSG.anf')

ImportOdb
Imports an ODB++ file into a new project.

UI Command: Import >ODB++.

Syntax: obj.ImportOdb (<ODB++Filename>, <controlFilename>)

Parameters:
BSTR ODB++Filename

BSTR controlFilename (this string can be empty if no XML control file is used)

Return Value: None.

PY Example: oApp.ImportOdb('test.tgz','test.xml')

IsSolutionDataAvailable
Checks for the existence of an SYZ simulation.

UI Command: None.

Syntax: obj.IsSolutionDataAvailable(<solnName>)

Parameters: BSTR solnName (name of a previously run SYZ simulation)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.IsSolutionDataAvailable('SYZ Sim 1')
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OpenProject
Opens a previously created project, or imports an EDB folder, IPC2581 file, or ODB++ file.

UI Command: File >Open.

Syntax: obj.OpenProject(<filePath>)

Parameters: BSTR filePath

Return Value: None.

PY Example: oApp.OpenProject('C:/KWH/GSG_model.siw')

Quit
Quits SIwave and closes the IronPython Command Window.

UI Command: File > Exit.

Syntax: obj.Quit

Parameters: None.

Return Value: None.

PY Example: oApp.Quit()

ReferenceEquals
Compares two objects and returns whether they are the same.

UI Command: None.

Syntax: obj.ReferenceEquals(<obj1>, <obj2>)

Parameters: obj1, obj2 (any type)

Return Value: BOOL

PY Example: oDoc.ReferenceEquals(obj1, obj2)
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RestoreWindow
Restores a minimized SIwave window.

UI Command: None.

Syntax: obj.RestoreWindow

Parameters: None.

Return Value: None.

PY Example: oApp.RestoreWindow()

Save
Saves all changes made until the point in the scripting file where this function is called.

UI Command: File > Save.

Syntax: obj.Save

Parameters: None.

Return Value: None.

PY Example: oDoc.Save()
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ScrActivateCktElem
Activates or deactivates specified circuit elements.

UI Command: None.

Syntax:
obj.ScrActivateCktElem(<elementName>, <elementType>,
<activate?>)

Parameters:

BSTR elementName

BSTR elementType (select from: cap, ind, res, port, vprobe, csource, vsource)

BOOL activate? (True to activate or False to deactivate)

Return Value:

INT result:

l 0 – Function succeeded
l 1 – Invalid input parameters (i.e., empty strings)
l 2 – Invalid second parameter (does not match cap, ind, res, port, vprobe,
csource, vsource)

l 3 – Specified circuit element could not be located in layout

PY Example:
oDoc.ScrActivateCktElem ('Port1','port',False)

oDoc.ScrActivateCktElem ('Port2','port',True)
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ScrActivateDcPowerTreePinAggregation

Aggregates or unsets pins in a Power Tree on a net within a component.

UI Command: Results Tab > DC IR Drop > [Simulation Name] > Export Power Tree
> Aggregate pins on a net within a component as one block.

Syntax:
obj.ScrActivateDcPowerTreePinAggregation
(<aggregatePins>)

Parameters: BOOL aggregatePins (True to activate or False to deactivate)

Return Value:

INT:

l 0 – if False; unset pins aggregation for the next power tree export
l 1 – if True; sets pins aggregation for the next power tree export

PY Example: oDoc.ScrActivateDcPowerTreePinAggregation('1')

Note:

Use before ScrExportDcPowerTree.
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ScrActivateInfiniteGroundPlane
Activates an infinite ground plane.

UI Command: Simulation >Options > SI/PI Advanced. Check/uncheck the Introduce
infinite ground plane box.

Syntax: obj.ScrActivateInfiniteGroundPlane(<activate>)

Parameters: BOOL activate (True to activate infinite ground plane or False to deactivate
infinite ground plane)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrActivateInfiniteGroundPlane('1')

Note:

To activate an infinite ground layer a specified distance beneath the bottom layer, refer
to ScrSetInfiniteGroundPlaneLocation.

Script Commands 2-22

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrAddEquipotentialRegion
Creates an equipotential region located at a specified pin.

UI Command: None.

Syntax:
obj.ScrAddEquipotentialRegion (<partName>, <refDes>,
<pinName> , <regionOnTop>)

Parameters:

BSTR partName

BSTR refDes

BSTR pinName

BOOL regionOnTop (True to create the equipotential region above the top
metal layer, False to create it below the bottom metal layer)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrAddEquipotentialRegion('T1_A','U1','10',True)
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ScrAddError
Logs an error to the Information / Errors / Warnings window.

UI Command: None.

Syntax: obj.ScrAddError(<error>)

Parameters: BSTR error

Return Value: None.

PY Example: oDoc.ScrAddError('This is my error.')

ScrAddInfo
Logs information to the Information / Errors / Warnings window.

UI Command: None.

Syntax: obj.ScrAddInfo(<information>)

Parameters: BSTR information

Return Value: None.

PY Example: oDoc.ScrAddInfo('This is my information.')
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ScrAddLayer
Adds a new layer above/below a given reference layer.

UI Command: Click Home > Layer stackup Editor. Then click either Add Above Selected
Layer or Add Below Selected Layer.

Syntax:
obj. ScrAddLayer (<newLayerName>, <referenceLayerName>,
<aboveBelow>, <layerTypeIndex>, <layerThickness>,
<materialName>)

Parameters:

BSTR newLayerName

BSTR referenceLayerName

BOOL aboveBelow (True to place new layer above; False to place it below)

INT layerTypeIndex (0 for dielectric, 1 for metal, 2 for wirebond)

INT layerThickness

BSTRmaterialName

Return Value: None.

PY Example:
oDoc.ScrAddLayer('new layer name','reference layer
name',True,1,0.1,'copper')
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ScrAddMaterial
Adds a new material to the database.

UI Command: Home > Edit Materials > [Conductors/Dielectrics] > Add.

Syntax:
obj.ScrAddMaterial (<materialType>, <materialName>,
<materialProperty1>, <materialProperty2>)

Parameters:

BSTRmaterialType (conductor or dielectric)

BSTR materialName

DOUBLE materialProperty1 (conductivity for conductor or permittivity for
dielectric)

DOUBLE materialProperty2 (permeability for conductor or loss tangent for
dielectric)

Return Value:

INT result:

l 0 – Function succeeded
l 1 – Material type is not "conductor" or "dielectric"
l 2 – Material name already exists in library
l 3 – Material parameters are not within an acceptable range

PY Example: oDoc.ScrAddMaterial('dielectric','Name',5,0.02)
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ScrAddOneLayerPadstack
Adds a new padstack.

UI Command: Home > Edit Padstacks > Add.

Syntax:
obj.ScrAddOneLayerPadstack (<padstackName>, <layerName>,
<shapeName>, <width>, <height>)

Parameters:

BSTR padstackName

BSTR layerName

BSTR shapeName (None, Circle, Oblong, or Rectangle)

BSTR width

BSTR height

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAddOneLayerPadstack('NEW_PADSTACK','METAL-
1','Circle','0.5mm','0.5mm')

ScrAddWarning
Logs a warning to the Information / Errors / Warnings window.

UI Command: None.

Syntax: obj.ScrAddWarning(<warning>)

Parameters: BSTR warning

Return Value: None.

PY Example: oDoc.ScrAddWarning('This is my warning.')
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ScrAppendSteppedSweep
Defines a frequency sweep with the specified step size for the specified simulation type.

UI Command: From any simulation sweep setup tab, add a frequency sweep with a Linear
Step distribution.

Syntax:
obj.ScrAppendSteppedSweep(<simType>, <minimumFrequency>,
<maximumFrequency>, <stepSize>)

Parameters:

BSTR simType ("ac", "ff", "nf", "syz", "psi_syz", "psi_ac", or "hfss_syz")

DOUBLE minimumFrequency

DOUBLE maximumFrequency

DOUBLE stepSize (in Hz)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAppendSteppedSweep('syz', 5000000.0,
5005000000.0, 100000000.0)
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ScrAppendSweep
Defines a frequency sweep with the specified number of frequencies for the specified
simulation type.

UI Command: From any simulation sweep setup tab, add a frequency sweep with a Linear or
By Decade distribution.

Syntax:
obj.ScrAppendSweep(<simType>, <minimumFrequency>,
<maximumFrequency>, <numPts>, <isLog>)

Parameters:

BSTR simType ("ac", "ff", "nf", "syz", "psi_syz", "psi_ac", or "hfss_syz")

DOUBLE minimumFrequency

DOUBLE maximumFrequency

INT numPts (number of frequencies in the frequency distribution)

BOOL isLog (True for By Decade distribution, False for Linear distribution)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAppendSweep('syz',5000000.0,5000000000.0,4,True)

This creates a By Decade frequency sweep from 5MHz to 5GHz
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ScrAssign4PtBondwireProfile
Creates a 4 point bondwire profile for a layer.

UI Command: Home > Bondwire Model Editor. Select JEDEC 4-Point from theModel
drop-down menu.

Syntax:
obj.ScrAssign4PtBondwireProfile
(<layerOrProfileName>, <h1>, <h2>, <radius>,
<supportLayerName>, <terminationLayerName>)

Parameters:

BSTR layerOrProfileName (either the name of a layer containing bondwires or
a specific bondwire model name)

DOUBLE h1

DOUBLE h2

DOUBLE radius

BSTR supportLayerName

BSTR terminationLayerName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAssign4PtBondwireProfile('die2_
die3',0.3,0.3,0.01,'Signal','Power')
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ScrAssign5PtBondwireProfile
Creates a 5 point bondwire profile for a layer.

UI Command: Home > Bondwire Model Editor. Select JEDEC 5-Point from theModel
drop-down menu.

Syntax:
obj.ScrAssign5PtBondwireProfile(<layerOrProfileName>,
<h1>, <h2>, <radius>, <alpha>, <beta>,
<supportLayerName>, <terminationLayerName>)

Parameters:

BSTR layerOrProfileName (either the name of a layer containing bondwires or
a specific bondwire model name)

DOUBLE h1

DOUBLE h2

DOUBLE radius

DOUBLE alpha (angle in degrees)

DOUBLE beta (angle in degrees)

BSTR supportLayerName

BSTR terminationLayerName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAssign5PtBondwireProfile('die1_
die3',0.31,0.32,0.011,85.1,5.1,'Top','Ground')
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ScrAssignBondwireTerminalType
Sets bondwire terminals to either sink or source terminal type.

UI Command: Home > Bondwire Model Editor.

Syntax:
obj.ScrAssignBondwireTerminalType(<netNameRegExp>,
<refDesRegExp>, <pinNameRegExp>, <isSink>)

Parameters:

BSTR netNameRegExp

BSTR refDesRegExp

BSTR pinNameRegExp

BOOL isSink (True for Sink, False for Source)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAssignBondwireTerminalType('*Net_2*','RT*','100-
*',True)
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ScrAssignComplexSolderballProfile
Creates a complex solderball profile for a layer.

UI Command: Home > Solderball Properties. Select Complex from the Type drop-down
menu.

Syntax:
obj.ScrAssignComplexSolderballProfile(<padstackName>,
<height>, <radius>, <midRadius>, <frustumHeight>,
<placement>, <terminalType>)

Parameters:

BSTR padstackName

DOUBLE height

DOUBLE radius

DOUBLE midRadius

DOUBLE frustrumHeight

INT placement (0 for Above, 1 for Below)

INT terminalType (0 for Sink, 1 for Source)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAssignComplexSolderballProfile
('BGA',0.5,0.18,0.225,0.1666,0,0)
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ScrAssignLowBondwireProfile
Creates a low bondwire profile for a layer.

UI Command: Home > Bondwire Model Editor. Select Low from theModel drop-down
menu.

Syntax:
obj.ScrAssignLowBondwireProfile(<layerName>, <h1>,
<h2>, <radius>, <alpha>, <beta>,
<supportLayerName>, <terminationLayerName>)

Parameters:

BSTR layerName (name of a layer containing bondwires)

DOUBLE h1

DOUBLE h2

DOUBLE radius

DOUBLE alpha

DOUBLE beta

BSTR supportLayerName

BSTR terminationLayerName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAssignLowBondwireProfile('die2_
die3',0.3,0.3,0.01,0.1,0.1,'Signal','Power')
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ScrAssignSimpleSolderballProfile
Creates a simple solderball profile for a layer.

UI Command: Home > Solderball Properties. Select Simple from the Type drop-down
menu.

Syntax:
obj.ScrAssignSimpleSolderballProfile(<padstackName>,
<height>, <radius>, <placement>, <terminalType>)

Parameters:

BSTR padstackName

DOUBLE height

DOUBLE radius

INT placement (0 for Above, 1 for Below)

INT terminalType (0 for Sink, 1 for Source)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAssignSimpleSolderballProfile('BGA', 0.5, 0.225,
0, 0)
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ScrAssignSketchedBondwireProfile
Creates a sketched bondwire profile for a layer.

UI Command: Home > Bondwire Model Editor. Select Sketched from theModel drop-
down menu.

Syntax:
obj.ScrAssignSketchedBondwireProfile
(<layerOrProfileName>, <filePath>, <radius>,
<supportLayerName>, <terminationLayerName>)

Parameters:

BSTR layerOrProfileName (can be either the name of a layer containing
bondwires or a specific bondwire model name)

BSTR filePath

INT radius

BSTR supportLayerName

BSTR terminationLayerName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAssignSketchedBondwireProfile('die1_die2',
'F:\TestScriptsForDocumentation\bw_pts.bwp', 0.012,
'Top', 'Ground')
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ScrAssignSketchedBondwireProfileFromArray
Creates a sketched bondwire profile for a layer, from an array.

UI Command: Home > Bondwire Model Editor. Select Sketched from theModel drop-
down menu.

Syntax:
obj.ScrAssignSketchedBondwireProfile(<layerName>,
<units>, <bwPoints>, <radius>, <supportLayerName>,
<terminationLayerName>)

Parameters:

BSTR layerName

BSTR units

ARRAY bwPoints (array of xy coordinates)

INT radius

BSTR supportLayerName

BSTR terminationLayerName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAssignSketchedBondwireProfileFromArray('die1_
die2', 'mm', xyPoints, 0.012, 'Top', 'Ground')
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ScrAssignSolderballTerminalType
Sets specified Solderball Terminals to either Sink or Source type.

UI Command: Home > Solderball Properties. 

Syntax:
obj.ScrAssignSolderballTerminalType(<netNameRegExp>,
<referenceDesigRegExp>, <pinNameRegExp>, <isSink>)

Parameters:

BSTR netNameRegExp (narrows solderball terminals by net name)

BSTR referenceDesigRegExp (narrows solderball terminals by reference
designator)

BSTR pinNameRegExp (narrows solderball terminals by pin name)

BOOL isSink (TRUE sets sinks; FALSE sets sources)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrAssignSolderballTerminalType('*Net_2*', 'RT*',
'100-*', True)

ScrBooleanUnite
Performs a boolean unite on geometry from the specified nets.

UI Command: Tools > Unite. 

Syntax: obj.ScrBooleanUnite(<netNameList>)

Parameters: ARRAY netNameList

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrBooleanUnite(['netName1','netName2','netName3'])
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ScrChangePartType
Changes the part type for a specified part name.

UI Command: None.

Syntax: obj.ScrChangePartType(<partName>, <newType>)

Parameters:

BSTR partName

BSTR newType

l For existing parts with two pins, valid types: capacitor, inductor, resistor,
port, voltage probe, current source, voltage source

l For other existing parts, newType cannot be any of these

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrChangePartType('288DIMMDDR4_EDGE_CONN-
BASE','Discrete Device')

ScrCleanUpOverlappingtraces
Converts overlapping traces to planes and then merges them.

UI Command: None.

Syntax: obj.ScrCleanUpOverlappingtraces(<layerNames>)

Parameters: ARRAY layerNames

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrCleanUpOverlappingtraces
(['layer1','layer2','layer3'])
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ScrClearAllSweeps
Removes all frequency sweeps assigned to a particular simulation type.

UI Command: Simulation > SIwave > [Simulation Type]. Select the values in the
Frequency Range Setup box and click Delete Selection.

Syntax: obj.ScrClearAllSweeps (<sweepType>)

Parameters: BSTR sweepType (must be one of the following: "ac", "ff", "nf", "psi_syz", "syz"
or "hfss_syz")

Return Value:

BOOL

l 0 – Failure (sweepType is not a valid type)
l 1 – Success

PY Example: oDoc.ScrClearAllSweeps('ff')

ScrClipDesign
Clips designated nets using a specified polygon.

UI Command: None.

Syntax: obj.ScrClipDesign (<netNames>, <points>)

Parameters:
ARRAY netNames (nets to be clipped)

ARRAY points (vertices of clipping polygon)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:

netNames = ['VCC', 'GND', 'Heg', 'NET-1', 'NET-2',
'PWR']

points = [0.0, 0.0, 10.0, 20.0, 40.0, 40.0, 40.0,
0.0, 16.0, 4.0]

outcome = obj.ScrClipDesign (netNames, points)
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ScrClipDesignAroundNets
Clips the design around nets.

UI Command: None.

Syntax:

obj.ScrClipDesignAroundNets(<netNames>,
<clipExtentDistance>, <simplifiedExtent>,
<traceCuttingOption>, <ignoreLayerVisibility>,
<reverseCutting>)

Parameters:

ARRAY netNames (array of strings holding the net names of the selected
nets)

BSTR clipExtentDistance (distance to push from the selected nets; must
include units and will not support wavelength based distance)

BOOL simplifiedExtent (TRUE to simplify edges or FALSE)

INT traceCuttingOption

l 0 – Cut traces that cross the boundary.
l 1 – Include all traces that overlap the extent.
l 2 – Include only traces that are completely inside the extent.

BOOL ignoreLayerVisibility (TRUE to ignore or FALSE)

BOOL reverseCutting (TRUE to clip outside the polygon or FALSE to keep
objects inside the clipping polygon)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrClipDesignAroundNets (netNames, '1mm', True, 0,
True, False)
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ScrCloseProject
Closes the current active project and opens a new "Untitled" project.

UI Command: Click File > New.

Syntax: obj.ScrCloseProject()

Parameters: None.

Return Value: None.

PY Example: oDoc.ScrCloseProject()

ScrCloseProjectNoSave
Closes the current active project and opens a new "Untitled" project.

UI Command: Click File > New.

Syntax: obj.ScrCloseProjectNoSave()

Parameters: None.

Return Value: None.

PY Example: oDoc.ScrCloseProjectNoSave()

ScrComputeFwsSubckt
Computes a full-wave Spice subcircuit representing the specified S-parameter solution.

The ScrSetFwsSubcktFormat() function specifies the Spice format to use.

UI Command: Click Results > SYZ > [simulation name] > Compute FWS sub-circuit.

Syntax: obj.ScrComputeFwsSubckt(<syzSimName>, <path>)

Parameters:
BSTR syzSimName

BSTR path (save location)

Return Value:
INT
l 0 – Success
l Non-zero value – Failure

PY Example:
oDoc.ScrComputeFwsSubckt('SYZ Sweep 1',
'C:/sweep1')

ScrComputeFwsSubcktForNamedSim
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Computes a full-wave Spice subcircuit for a specified simulation.

The ScrSetFwsSubcktFormat() function specifies the Spice format to use.

UI Command: Click Results > [simulation type] > [simulation name] > Compute FWS
sub-circuit.

Syntax:
obj.ScrComputeFwsSubcktForNamedSim(<simType>,
<simName>, <path>)

Parameters:

BSTR simType

BSTR simName

BSTR path

Return Value:
INT
l 0 – Success
l Non-zero value – Failure

PY Example:
oDoc.ScrComputeFwsSubcktForNamedSim('syz', 'SYZ
Sweep 1', 'C:/sweep1')

ScrConvertPlanesToTraces
Performs plane to trace conversion on specified nets.

UI Command: Click Tools > Convert Planes to Traces.

Syntax: obj.ScrConvertPlanesToTraces (<netNameList>)

Parameters: ARRAY netNameList

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrConvertPlanesToTraces(['GND','P28VA'])
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ScrConvertTracesToPlanes
Performs trace to plane conversion on a specified trace.

UI Command: Click Tools > Convert Traces to Planes.

Syntax:
obj.ScrConvertTracesToPlanes (<layerName>, <netName>,
<mergeAll>, <minVoidArea>, <unitName>)

Parameters:

BSTR layerName

BSTR netName (If net name is "all", traces of all nets on the layer will be
converted)

BOOL mergeAll (TRUEmerges all planes; FALSE does not)

DOUBLE minVoidArea (all voids smaller than this value will be deleted)

BSTR unitName ("m", "meters", "mm", "cm", "um", "microns", "inches", "mils",
"nanometers", "nm", or "feet")

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrConvertTracesToPlanes
('BOTTOM','GND',True,0.001,'mm')

ScrConvertTracesToPlanesByNet
Performs trace to plane conversion by a specified net.

UI Command: Click Tools > Convert Traces to Planes.

Syntax: obj.ScrConvertTracesToPlanesByNet (<netNameList)

Parameters: ARRAY netNameList

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrConvertTracesToPlanes(['GND','P28VA'])

ScrCopyImageToClipBoard
Copies the Modeling workspace to the clipboard.

UI Command: Right-click in the Modeling workspace and select Copy Image.

Syntax: obj.ScrCopyImageToClipBoard()

Parameters: None.
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Copies the Modeling workspace to the clipboard.

Return Value: None.

PY Example: oDoc.ScrCopyImageToClipBoard()

ScrCorrectValChkErrorsWarnings
Used after "ScrRunValidationCheck " on page 2-146 and "ScrRunValidationCheckWithOptions"
on page 2-147 to apply autofixes to errors and warnings found during checks.

UI Command: None.

Syntax: obj.ScrCorrectValChkErrorsWarnings (<fixOptionArray>)

Parameters:

ARRAY fixOptionsArray (0 - deselects an option, 1 - selects an option)

Autofixes, as follows:

l 0 - disjoint errors
l 1 - overlapping via errors
l 2 - bondwire orientation errors
l 3- misalignment warnings
l 4 - bondwire misalignment warnings
l 5 - floating node errors

Return Value:
System.Int16 object at 0x000000000000002E [0]

(0 indicates successful completion of the command)

PY Example:
oDoc.ScrCorrectValChkErrorsWarnings
(['1','1','1','1','1','1'])

ScrCreatePinGroups
Creates a pin group containing specified pins.

UI Command: Tools > Create/Manage Pin Groups.

Syntax:
obj.ScrCreatePinGroups(<partName>, <refDes>,
<pinNumbers>, <groupName>, <applyToAllComponents>)

Parameters:

BSTR partName

BSTR refDes

ARRAY pinNumbers

BSTR groupName

BOOL applyToAllComponents (True = pin group should be created for all
parts with the given part name. When set to True, refDes is ignored.)

Return Value: BOOL
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Creates a pin group containing specified pins.
l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrCreatePinGroups('CSP_BGA', 'BGA',
['1','2','3','4'], 'new_group_1', False)
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ScrCreatePinGroupByDist
Creates a pin group for pins a given distance from a specified pin.

UI Command: Tools > Create/Manage Pin Groups.

Syntax:
obj.ScrCreatePinGroupByDist (<partName>, <refDes>,
<pinNumber>, <groupName>, <maxDistance>,
<selectFromAllNets>)

Parameters:

BSTR partName

BSTR refDes

BSTR pinNumber

BSTR groupName

BSTR maxDistance

BOOL selectFromAllNets (True = pins will be selected regardless of their
nets. False = only pins from the same net as the specified pin are included.)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrCreatePinGroupByDist('T1_A', 'U1', '14',
'TestPinGroupA', '450um', True)
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ScrCreatePinGroupsByGrid
Creates a pin group by dividing a component into a grid.

UI Command: Tools > Create/Manage Pin Groups.

Syntax:
obj.ScrCreatePinGroupsByGrid (<partName>, <refDes>,
<numRows>, <numCols>, <applyPerNet>,
<applyToAllComponents>)

Parameters:

BSTR partName

BSTR refDes

LONG numRows

LONG numCols

BOOL applyPerNet

BOOL applyToAllComponents

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrCreatePinGroupsByGrid ('DDR4_X4_FBGA78-10X13,,',
'U1', 3, 2, False, True)

Script Commands 2-48

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrCreatePinGroupByNet
Creates a pin group consisting of pins from a specified part within a specified net.

UI Command: Tools > Create/Manage Pin Groups.

Syntax:
obj.ScrCreatePinGroupByNet (<partName>, <refDes>,
<netName>, <groupName>, <applyToAllComponents>)

Parameters:

BSTR partName

BSTR refDes

BSTR netName

BSTR groupName

BOOL applyToAllComponents (True= pin groups will be created on all parts of
the specified partName regardless of the refDes; the resulting group names
will have an index number appended for uniqueness)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrCreatePinGroupByNet ('T1_A', 'U1', 'GND', 'U1_
GND', False)
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ScrCreatePortsOnPart
Creates ports between pins on the specified part.

Note: The positive terminals are either the specified pins, the pins on the specified net, or the
intersection of the two sets if both parameters are not empty. The negative terminal is selected as the
closest pin on the reference net.

UI Command: Tools > Create/Manage Pin Groups.

Syntax:
obj.ScrCreatePortsOnPart (<partName>, <refDes>,
<posNet>, <posPinList>, <refNet>, <impedance>)

Parameters:

BSTR partName

BSTR refDes

BSTR posNet

ARRAY posPinList

BSTR refNet

BSTR impedance

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrCreatePortsOnPart('CP90-P4969-90', 'V1P1',
'VREG_S9A_0P8', ['pin1','pin2','pin3'], 'AGND', '35ohm')

ScrDeleteAllNets
Deletes all nets in the design.

UI Command: Right-click nets, Edit > Delete.

Syntax: obj.ScrDeleteAllNets()

Parameters: None.

Return Value: None.

PY Example: oDoc.ScrDeleteAllNets()

ScrDeleteCktElem
Deletes a specified circuit element.

UI Command: Right-click element, Edit > Delete.

Syntax: obj.ScrDeleteCktElem(<refDes>)

Parameters: BSTR refDes
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Deletes a specified circuit element.

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrDeleteCktElem('C_1')

ScrDeleteDcSolution
Deletes a DC solution.

UI Command: Results > DC IR Drop > [Solution Name] > Delete Solution.

Syntax: obj.ScrDeleteDcSolution()

Parameters: None.

Return Value: None.

PY Example: oDoc.ScrDeleteDcSolution()
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ScrDeleteLayer
Deletes a specified layer.

UI Command: Home > Layer Stackup Editor. Select layer and click Delete Selected
Layers.

Syntax: obj.ScrDeleteLayer(<layerName>)

Parameters: None.

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrDeleteLayer('BOTTOM')

ScrDeleteNet
Deletes a specified net.

UI Command: None.

Syntax: obj.ScrDeleteNet(<netName>)

Parameters: BSTR netName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrDeleteNet('net69')

Script Commands 2-52

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrDeleteNets
Deletes all nets in a given array.

UI Command: None.

Syntax: obj.ScrDeleteNets(<netNames>)

Parameters: ARRAY netNames

Return Value: None.

PY Example: oDoc.ScrDeleteNets(['net5','net6','net7','net8'])

ScrDeleteNetsGivenInFile
Deletes all nets named in a given file.

UI Command: None.

Syntax: obj.ScrDeleteNetsGivenInFile(<fileName>)

Parameters: BSTR fileName (file path; file must have net names enclosed in double
quotes)

Return Value: None.

PY Example:
oDoc.ScrDeleteNetsGivenInFile('C:/NetFiles/nets_to_
delete.txt')

ScrDeletePadstack
Deletes a specified padstack.

UI Command: None.

Syntax: obj.ScrDeletePadstack(<padstackName>)

Parameters: BSTR padstackName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrDeletePadstack('Stack')
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ScrDeletePinGroup
Deletes a specified pin group.

UI Command: None.

Syntax:
obj.ScrDeletePinGroup(<pin_group_
name>,<deleteRefCktElems>)

Parameters:

BSTR pin_group_name

BOOL deleteRefCktElems (True = deletes references circuit element(s); False
= referenced circuit element(s) remove the reference to the pin group and
change the reference to the first pin of the pin group.)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrDeletePinGroup('U1_GND_Group', True)

ScrDeleteSimulation
Delete a specified simulation or all simulations within a category (i.e., all DC IR Drop
Simulations).

UI Command: From the Simulation tab, navigate to the Results window. Then right-click a
solution or solution category and select Delete Solution/Category.

Syntax: obj.ScrDeleteSimulation(<simType>, <simName>)

Parameters:

BSTR simType (choose from: "ac", "dc", "eigen", "ff", "nf", "psi_ac", "psi_syz",
"syz", "hfss_syz", "pdn", "cpa", "icepak", "iv", "emi_scan", "em_mttf", "z0_
scan", "crosstalk_scan", "td_crosstalk_scan")

BSTR simName (enter the name of a specific simulation or "all" to delete all
simulations in the selected category (i.e., simType)

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrDeleteSimulation('dc', 'DCIR_122cel_uniform')
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ScrDrawCapacitor
Draws a capacitor in the specified location with specified parameters.

UI Command: Home > Circuit Elements > Add Capacitor.

Syntax:
obj.ScrDrawCapacitor(<capName>, <partName>, <px>, <py>,
<nx>, <ny>, <posLayerName>, <negLayerName>, <capVal>,
<seriesIndVal>, <seriesResVal>)

Parameters:

BSTR capName

BSTR partName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

DOUBLE capVal (capacitance, in Farads)

DOUBLE seriesIndVal (parasitic inductance, in Henries)

DOUBLE seriesResVal (parasitic resistance, in Ohms)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawCapacitor
('Cappy','CL03A103KP3NNN',8500,4500,6000,-
500,'SURFACE','BASE',1E-07,1E-11,0)
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ScrDrawCircle
Draws a circular plane.

UI Command: Home > Draw Circle.

Syntax:
obj.ScrDrawCircle(<ctrX>, <ctrY>, <radius>, <layerName>,
<netName>, <unit>)

Parameters:

DOUBLE ctrX (x coordinate of the center point)

DOUBLE ctrY (y coordinate of the center point)

DOUBLE radius

BSTR layerName

BSTR netName

BSTR unit

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawCircle(100, 100, 20, 'Top Metal', 'NET-1',
'mm')
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ScrDrawInductor
Draws an inductor in the specified location with specified parameters.

UI Command: Home > Circuit Elements > Add Inductor.

Syntax:
obj.ScrDrawInductor(<indName>, <partName>, <px>, <py>,
<nx>, <ny>, <posLayerName>, <negLayerName>, <indVal>)

Parameters:

BSTR indName

BSTR partName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

DOUBLE indVal (inductance, in Henries)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawInductor('Indy','RLC_XYZ_
I',8500,4500,6000,1000,'SURFACE','BASE',1E-09)
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ScrDrawPolygon
Draws a polygonal plane.

UI Command: Home > Draw Polygon.

Syntax:
obj.ScrDrawPolygon(<points>, <layerName>, <netName>,
<unit>)

Parameters:

ARRAY points (x, y, x, y, x, y, ...)

BSTR layerName

BSTR netName

BSTR unit

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawPolygon([-10,10,5,-5,-25,-20,20,0], 'Top
Metal', 'NET-1', 'mm')
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ScrDrawPort
Draws a port in the specified location with specified parameters.

UI Command: Home > Circuit Elements > Add Port.

Syntax:
obj.ScrDrawPort(<portName>, <px>, <py>, <nx>, <ny>,
<posLayerName>, <negLayerName>, <refZe>)

Parameters:

BSTR portName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

DOUBLE refZe (reference impedance, in Ohms)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawPort
('Porty',8500,4500,6000,1000,'SURFACE','BASE',0.1)
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ScrDrawRectangle
Draws a rectangular plane.

UI Command: Home > Draw Rectangle.

Syntax:
obj.ScrDrawRectangle(<x1>, <y1>, <x2>, <y2>,
<layerName>, <netName>, <unit>)

Parameters:

DOUBLE x1

DOUBLE y1

DOUBLE x2

DOUBLE y2

BSTR layerName

BSTR netName

BSTR unit

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawRectangle (100, 100, 200, 200, 'Top Metal',
'NET-1', 'mm')
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ScrDrawResistor
Draws a resistor in the specified location with specified parameters.

UI Command: Home > Circuit Elements > Add Resistor.

Syntax:
obj.ScrDrawResistor(<resName>, <partName>, <px>, <py>,
<nx>, <ny>, <posLayerName>, <negLayerName>, <resVal>)

Parameters:

BSTR resName

BSTR partName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

DOUBLE resVal (resistance, in Ohms)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawResistor('Resist','BBQ_
4L1FE',8500,4500,6000,1000,'SURFACE','BASE',50)
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ScrDrawTrace
Draws a trace.

UI Command: Home > Draw Trace.

Syntax:
obj.ScrDrawTrace(<points>, <width>, <layerName>,
<netName>, <unit>)

Parameters:

ARRAY points (x, y, x, y, x, y, ...)

DOUBLE width

BSTR layerName

BSTR netName

BSTR unit

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawTrace([-10,10,5,-5,-25,-20,20,0], '0.5',
'Top Metal', 'NET-1', 'mm')
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ScrDrawVia
Draws a via.

UI Command: Home > Drop Via.

Syntax:
obj.ScrDrawVia(<ctrX>, <ctrY>, <topLayer>, <botLayer>,
<padstack>, <netName>, <offsetX>, <offsetY>, <rotAngle>,
<unit>)

Parameters:

DOUBLE ctrX

DOUBLE ctrY

BSTR topLayer

BSTR botLayer

BSTR padstack

BSTR netName

DOUBLE offsetX

DOUBLE offsetY

DOUBLE rotAngle

BSTR unit

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawVia(100, 100, 'Top Metal', 'Bottom Metal',
'Thru Via', 'NET-1', 0.0, 0.0, 0.0, 'mm')
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ScrDrawVoltageProbe
Draws a voltage probe in the specified location with specified parameters.

UI Command: Home > Circuit Elements > Add Voltage Probe.

Syntax:
obj.ScrDrawVoltageProbe(<probeName>, <px>, <py>, <nx>,
<ny>, <posLayerName>, <negLayerName>)

Parameters:

BSTR probeName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawVoltageProbe
('ProbeOno',6500,4000,5000,1500,'SURFACE','BASE')
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ScrDrawVoltageSource
Draws a frequency independent voltage source in the specified location with specified
parameters.

UI Command: Home > Circuit Elements > Add Voltage Source.

Syntax:
obj.ScrDrawVoltageSource(<sourceName>, <partName>, <px>,
<py>, <nx>, <ny>, <posLayerName>, <negLayerName>, <mag>,
<phase>, <seriesRes>)

Parameters:

BSTR sourceName

BSTR partName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

DOUBLE mag (magnitude, in Volts)

DOUBLE phase (phase, in degrees)

DOUBLE seriesRes (parasitic resistance, in Ohms)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrDrawVoltageSource('Sourcey','PRT1_
00543',5000,4500,4500,3000,'SURFACE','BASE',1,0,1E-06)
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ScrEditCktElemName
Edits an existing circuit element's name.

UI Command: Components window. Right-click [circuit element] > Edit
Circuit Element. Change name.

Syntax: obj.ScrEditCktElemName(<name>, <type> <newName>)

Parameters:

BSTR name

BSTR type ("cap", "ind", "res", "port", "vprobe", "csource", or "vsource")

BSTR newName

Return Value:

INT:

l 0 – Success
l 1 – One of the input parameters is an empty string.
l 2 – type value is unacceptable.
l 3 – Cannot find component to rename.
l 4 – newName is already taken.

PY Example:
oDoc.ScrEditCktElemName('port_old', 'port', 'port_
new')
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ScrEditLayerName
Sets a new name for a specified layer.

UI Command: Click Home > Layer Stackup Editor. Enter a value in the Name field.

Syntax: obj.ScrEditLayerName(<layerName>, <newLayerName>)

Parameters:
BSTR layerName

BSTR newLayerName

Return Value: None.

PY Example: oDoc.ScrEditLayerName('MY LAYER','MY NEW LAYER')

ScrEditMaterial
Edits an existing material.

UI Command: Home > Edit Materials.

Syntax:
obj.ScrEditMaterial(<matType>, <matName>,
<epsOrSigma>, <ltOrPerm>)

Parameters:

BSTR matType (conductor or dielectric)

BSTR matName

DOUBLE epsOrSigma (conductivity for conductor or permittivity for dielectric)

DOUBLE ltOrPerm (permeability for conductor or loss tangent for dielectric)

Return Value:

INT result:

l 0 – Success
l 1 – Material type is not "conductor" or "dielectric"
l 2 – Material name does not exist in library
l 3 – Material parameters are not within an acceptable range

PY Example:
oDoc.ScrEditMaterial('conductor', 'unobtanium',
5.7E+07, 0.5)
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ScrEditNetName
Edits an existing net's name.

UI Command: Nets window. Right-click net and select Edit Net Name.

Syntax: obj.ScrEditNetName(<netName>, <newNetName>)

Parameters:
BSTR netName

BSTR newNetName

Return Value: None.

PY Example: oDoc.ScrEditNetName('MY NET', 'MY NEW NET')

ScrEditPadStackName
Edits an existing padstack's name.

UI Command: Home > Edit Padstacks. Enter a new Name.

Syntax:
obj.ScrEditPadStackName(<oldPadstackName>,
<newPadstackName>)

Parameters:
BSTR oldPadstackName

BSTR newPadstackName

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrEditPadStackName('MY PADSTACK',
'MY NEW PADSTACK')
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ScrEnableCavityFieldCoupling
Enables or disables cavity field coupling detection and solution during simulation.

Note: Does not apply to DC IR simulations.

UI Command: Simulation >Options to open the SIwave Options window. On
SI/PI Advanced tab, select Cavity field check box.

Syntax: obj.ScrEnableCavityFieldCoupling <flag>

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

PY Example: oDoc.ScrEnableCavityFieldCoupling(1)

ScrEnableCoPlaneCoupling
Enables or disables coplanar waveguide coupling detection and solution during simulation.

Note: Does not apply to DC IR simulations.

UI Command: Simulation >Options to open the SIwave Options window. On
SI/PI Advanced tab, select Coplane check box.

Syntax: obj.ScrEnableCoPlaneCoupling <flag>

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

PY Example: oDoc.ScrEnableCoPlaneCoupling(1)

ScrEnableErcSimSetup
For PSI simulations, enables or disables option to perform ERC during simulation setup

UI Command: Simulation > PSI Options. Select Perform ERC during simulation setup.

Syntax: obj.ScrEnableErcSimSetup(<flag>)

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

PY Example: oDoc.ScrEnableErcSimSetup(1)
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ScrEnableFwsRelativeErrorTol
Enables or disables relative error tolerance.

UI Command: Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit.
Select Advanced > Enable Relative Error Tolerance.

Syntax: obj.ScrEnableFwsRelativeErrorTol <flag>

Parameters: BOOL flag (True enables; False disables)

Return Value: None.

PY Example: oDoc.ScrEnableFwsRelativeErrorTol(True)
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ScrEnableGUIRefresh
Enables or disables refreshing GUI.

UI Command: None.

Syntax: obj.ScrEnableGUIRefresh <flag>

Parameters: BOOL flag (True enables; False disables)

Return Value: None.

PY Example: oDoc.ScrEnableGUIRefresh (True)

ScrEnableIntraPlaneCoupling
Enables or disables low-frequency intra-plane coupling detection and solution during
simulation.

Note: Does not apply to DC IR simulations.

UI Command: Simulation >Options to open the SIwave Options window. On
SI/PI Advanced tab, select Intra-plane check box.

Syntax: obj.ScrEnableIntraPlaneCoupling <flag>

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

PY Example: oDoc.ScrEnableIntraPlaneCoupling(1)

ScrEnableSplitPlaneCoupling
Enables or disables split plane coupling detection and solution during simulation.

Note: Does not apply to DC IR simulations.

UI Command: Simulation >Options to open the SIwave Options window. On
SI/PI Advanced tab, select Split-plane check box.

Syntax: obj.ScrEnableSplitPlaneCoupling <flag>

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

PY Example: oDoc.ScrEnableSplitPlaneCoupling(1)
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ScrEnableTraceCoupling
Enables or disables trace coupling detection and solution during simulation.

Note: Does not apply to DC IR simulations.

UI Command: Simulation >Options to open the SIwave Options window. On
SI/PI Advanced tab, select Trace check box.

Syntax: obj.ScrEnableTraceCoupling <flag>

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

PY Example: oDoc.ScrEnableTraceCoupling(1)

ScrExport3DModel
Exports a 3D Model file.

UI Command: Export > Export to [HFSS 3D, Q3D Extractor].

Syntax: obj.ScrExport3DModel <exportTypeName> <outFilePath>

Parameters:
BSTR exportTypeName (HFSS, MAXWELL, Q3D, or X_B/X_T)

BSTR outFilePath (including extension)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrExport3DModel
('Q3D','C:/SampleFiles/test.aedt')
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ScrExportAnf
Exports an Ansys Neutral File (*.anf).

UI Command: Export > ANF.

Syntax: obj.ScrExportAnf <filePath>

Parameters: BSTR filePath (including extension)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrExportAnf('D:/Tests/testExport.anf')

ScrExportComponentFile
Exports a component file (*.cmp) to be paired with an exported ANF file.

UI Command: Export > Component File.

Syntax: obj.ScrExportComponentFile <filePath>

Parameters: BSTR filePath (including extension)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrExportComponentFile
('D:/Tests/testExport.cmp')
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ScrExportCpaSimReport (IronPython)
Exports a CPA simulation report in HTML format.

UI Command: Results > RLGC > [Simulation Name] > Export Simulation Report.

Syntax: obj.ScrExportCpaSimReport(<simName>, <filePath>)

Parameters:
BSTR simName

BSTR filePath

Return Value:

INT:

l 0 – Success
l 1 – Cannot find CPA simulation by simName provided.
l 2 – Export failed.

PY Example:
oDoc.ScrExportCpaSimReport('CPA Sim
1','C:/Directory/')

ScrExportDcPowerDataToIcepak
Enables or disables generation of DC power data for use in thermal simulations.

UI Command: None.

Syntax: obj.ScrExportDcPowerDataToIcepak(<exportPowerData>)

Parameters: BOOL exportPowerData (True = enable; False = disable)

Return Value: None.

PY Example: oDoc.ScrExportDcPowerDataToIcepak(True)
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ScrExportDcPowerTree

Note:

Use after ScrActivateDcPowerTreePinAggregation.

Exports a DC power tree of a previously run DC simulation.

UI Command: Results > DC IR > [Simulation Name] > Export Power Tree.

Syntax:
obj.ScrExportDcPowerTree(<simName>, <thresholds_
csv_file>, <output_image_file>)

Parameters:

BSTR simName (DC IR simulation must already be completed)

BSTR thresholds_csv_file (path to CSV file containing voltage and current
threshold values for every node; include file extension)

BSTR output_image_file (path to the file the tree will be exported to; include
file extension)

Return Value:

INT:

l 0 – Success
l 1 – Cannot find DC simulation by simName provided.
l 2 – Export failed.

PY Example:
oDoc.ScrExportDcPowerTree('DC Drop 1',
'D:/thresholds.csv', 'D:/pwrtree.png')
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ScrExportDcSimReport
Exports a simulation report for a previously run DC simulation.

To specify additional options, see: ScrExportDcSimReportColorBarProperties,
ScrExportDcSimReportOptions, ScrExportDcSimReportScaling, and
ScrExportDcSimReportUnits.

UI Command: Results > DC IR > [Simulation Name] > Export Report.

Syntax:
obj.ScrExportDcSimReport(<simName>,
<backgroundColor>, <htmReportFilenameWithPath>)

Parameters:

BSTR simName (DC IR simulation must already be completed)

BSTR backgroundColor ('black', 'white', or '', where empty string uses the
current SIwave background colors)

BSTR htmReportFilenameWithPath

Return Value:

INT:

l 0 – Success
l 1 – Cannot find DC simulation by simName provided.
l 2 – Export failed.

PY Example:
oDoc.ScrExportDcSimReport('DC IR Sim 1', 'white',
'C:/Project1/report.htm')

ScrExportDcSimReportColorBarProperties
Used before ScrExportDcSimReport to set color bar properties for DC report generation.

UI Command: Advanced > Color Scale. Select Color Bar Properties.

Syntax:
obj.ScrExportDcSimReportColorBarProperties
(<numDiv>, <numDigit>, <bFlipColorScale>,
<bWhiteBeyondMinMax>)

Parameters:

INT numDiv

INT numDigit

BOOL bFlipColorScale

BOOL bWhiteBeyondMinMax

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrExportDcSimReportColorBarProperties
(14,3,False,True)
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ScrExportDcSimReportOptions
Used before ScrExportDcSimReport to set options for DC report generation.

UI Command: Results > DC IR > [Simulation Name] > Export Report. Specify options.

Syntax:
obj.ScrExportDcSimReportOptions(<showDevices>,
<filtersXmlFilenameWithPath>)

Parameters:

BOOL showDevices (True to show devices and device names for devices with
pins on signal nets that are involved in the current simulation)

BSTR filtersXmlFilenameWithPath (full path to XML file containing filters for
current, voltage or power plots on selected layers and nets)

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrExportDcSimReportOptions(True,
'C:/Projects/filter.xml')

ScrExportDcSimReportScaling
Used before ScrExportDcSimReport to set scaling options for DC report generation.

UI Command: None.

Syntax:
obj.ScrExportDcSimReportScaling(<layerName>,
<plotType>, <minVal>, <maxVal>, <bLogScale>)

Parameters:

BSTR layerName (specify a layer name, "All", or "All Bondwires/Vias")

BSTR plotType ("Current Density", "Voltage", "Power Density", "Via Current",
or "All")

DOUBLE minVal

DOUBLE maxVal

BOOL bLogScale (True = Log; False = Linear)

**Use -1 for both minVal & maxVal to set the plot range back to original and
also to set bLogScale independently without affecting the range.

Return Value:

INT:

l 0 – Success
l 1 – layerName value is unacceptable.
l 2 – plotType value is unacceptable.

PY Example:
oDoc.ScrExportDcSimReportScaling
('All','Voltage',0.00,50.0,True)

Script Commands 2-77

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrExportDcSimReportUnits
Used before ScrExportDcSimReport to set units for DC report generation.

UI Command: Results > DC IR > [Simulation Name] > Export Report.

Syntax:
obj.ScrExportDcSimReportUnits(<curDenUnits>,
<vltUnits>, <pwrDenUnits>)

Parameters:

BSTR curDenUnits ("A/um^2", "A/mil^2", "A/mm^2", "A/cm^2", "A/in^2", or
"A/m^2")

BSTR vltUnits ("uV", "mV", or "V")

BSTR pwrDenUnits ("W/um^3", "W/mil^3", "W/mm^3", "W/cm^3", "W/in^3", or
"W/m^3")

Return Value:

INT:

l 0 – Success
l 1 – curDenUnits value is unacceptable.
l 2 – vltUnits value is unacceptable.
l 3 – curDenUnits value is unacceptable.

PY Example:
oDoc.ScrExportDcSimReportUnits
('A/um^2','V','W/um^3')
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ScrExportElementData
Exports the element data from a DC simulation report.

UI Command: Results > DC IR > [Simulation Name] > Export Element Data.

Syntax:
obj.ScrExportElementData(<simName>, <fileName>,
<tabTitle>)

Parameters:

BSTR simName

BSTR fileName

BSTR tabTitle

Return Value:

INT:

l 0 – Success
l 3 – Cannot find DC simulation by simName provided.
l Else – Export failed.

PY Example:
oDoc.ScrExportElementData('DC Script Sim',
'D:/Tests/viaReportOut.txt', 'Vias')

ScrExportEmiScanReport
Generates an HTML EMI scanner report, with images of violations.

UI Command: Results > EMI Scanner > [SimulationName] > Export Report with
Images.

Syntax: obj.ScrExportEmiScanReport(<simName>, <reportPath>)

Parameters:
BSTR simName

BSTR reportPath (include file extension)

Return Value:

INT:

l 0 – Success
l 1 – Cannot find simulation by simName provided.
l 2 – Export failed.

PY Example:
oDoc.ScrExportEmiScanReport("EMI Scan Sim 1",
"D:/AutomationTest/EMI.htm")
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ScrExportIcepakProject
Exports an Icepak project for standalone use. A DC simulation may be specified to provide
power data to the Icepak project.

UI Command: Export > Icepak.

Syntax:
obj.ScrExportIcepakProject(<projectPath>,
<dcSimName>)

Parameters:
BSTR projectPath

BSTR dcSimName (leave string empty to omit)

Return Value:

INT

l 0 – Success
l 1 – Project directory could not be created.
l 2 – An EDB could not be exported for the project.
l 3 – Error generating the project import script.
l 4 – Specified DC simulation could not be found OR failure generating
Icepak launch script.

PY Example:
oDoc.ScrExportIcepakProject('D:/icepakProj',
'DC Sim 1')
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ScrExportIcepakSimReport
Generates an HTML report file containing Icepak thermal plots taken at various elevations.

To specify additional options, see: ScrExportIcepakSimReportColorBarProperties,
ScrExportIcepakSimReportScaling, and ScrExportIcepakSimReportUnits.

UI Command: Results > Temperature > Export Report.

Syntax:
obj.ScrExportIcepakSimReport(<simName>,
<fileNameWithPath>)

Parameters:
BSTR simName

BSTR fileNameWithPath (include file extension)

Return Value:

INT:

l 0 – Success
l 1 – Cannot find Icepak simulation by simName provided.
l 2 – Export failed.

PY Example:
oDoc.ScrExportIcepakSimReport("Icepak Script Sim",
"D:/AutomationTest/ScriptReportTest.htm")

ScrExportIcepakSimReportColorBarProperties
Used before ScrExportIcepakSimReport to set color bar properties for Icepak report
generation.

UI Command: Advanced > Color Scale. Select Color Bar Properties.

Syntax:
obj.ScrExportIcepakSimReportColorBarProperties
(<numDiv>, <numDigit>, <bFlipColorScale>,
<bWhiteBeyondMinMax>)

Parameters:

INT numDiv

INT numDigit

BOOL bFlipColorScale

BOOL bWhiteBeyondMinMax

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrExportIcepakSimReportColorBarProperties
(14,3,False,True)
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ScrExportIcepakSimReportScaling
Used before ScrExportIcepakSimReport to set scaling options for Icepak report generation.

UI Command: None.

Syntax:
obj.ScrExportIcepakSimReportScaling(<minVal>,
<maxVal>, <bLogScale>)

Parameters:

DOUBLE minVal

DOUBLE maxVal

BOOL bLogScale (True = Log; False = Linear)

**Use -1 for both minVal & maxVal to set the plot range back to original and
also to set bLogScale independently without affecting the range.

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrExportIcepakSimReportScaling
(0.00,50.0,False)

ScrExportIcepakSimReportUnits
Used before ScrExportIcepakSimReport to set units for Icepak report generation.

UI Command: None.

Syntax: obj.ScrExportIcepakSimReportUnits(<tempUnits>)

Parameters: BSTR tempUnits ("C", "F", or "K")

Return Value:

INT:

l 0 – Success
l 1 – tempUnits value is unacceptable.

PY Example: oDoc.ScrExportIcepakSimReportUnits('F')
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ScrExportLayerStackup
Exports the current layer stackup to a specified file (*.stk OR *.xml).

UI Command: Export > Layer Stackup, OR Export > Layer Stackup XML.

Syntax: obj.ScrExportLayerStackup(<outputFileName>)

Parameters: BSTR outputFileName (include extension)

Return Value: None.

PY Example:
oDoc.ScrExportLayerStackup
('C:/Documents/stack.stk')

ScrExportNamedSimToTouchstone
Exports SYZ simulation results to a specified touchstone file.

UI Command: Results > SYZ > [Simulation Name] > Export Touchstone File.

Syntax:
obj.ScrExportNamedSimToTouchstone(<simType>,
<simName>, <file>)

Parameters:

BSTR simType (syz, psi_syz, or hfss_syz)

BSTR simName (previously run simulation)

BSTR touchstonefilePath (full path for the touchstone file to be generated)

Note:

Adding the file name and extension are not necessary; however, if
the file name and extension are included, accurately specify the
number of ports in the extension (i.e., *.sNp) or two extensions will
appear in the exported file (e.g., testExport.s2p.s4p).

Return Value:

Memory address and integer in brackets (e.g., <System.Int16 object at
0x00000000000000x2E [0]>):

INT:

l 0 – Success
l 1 – simType value is unacceptable.
l 2 – simName does not exist OR path cannot be created.

PY Example:
oDoc.ScrExportNamedSimToTouchstone('hfss_syz', 'Sim
1', 'D:/results/testExport.s2p')
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ScrExportNetDelayReport
Exports a net delay report in HTML format.

UI Command: Simulation > Signal Net Analyzer. Click Export Net Delays and select
appropriate options.

Syntax:
obj.ScrExportNetDelayReport(<reportPath>,
<netNameRegExp>, <lengthUnits>, <delayUnits>,
<onlyDieToBall>)

Parameters:

BSTR reportPath (full file path for report to be exported)

BSTR netNameRegExp (regular expression; use '.*' to include all nets)

BSTR lengthUnits (pass empty string to use default 'microns')

BSTR delayUnits (pass empty string to use default 'ps')

BOOL onlyDieToBall (True to enforceOnly include paths from Die pin to
BGA solderball option; else False)

Return Value:

INT

l 0 – Success
l 1 – Licensing Failure

PY Example:
oDoc.ScrExportNetDelayReport
('C:/MyFiles/netdelay.htm','.*','','',1)

ScrExportSettingsFile
Exports an SIwave Settings file (*.sef).

Use ScrExportSettingsFileSetOptions to specify additional options.

UI Command: Export > Settings File.

Syntax: obj.ScrExportSettingsFile(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrExportSettingsFile('C:/Path/my_settings.sef')

ScrExportSettingsFileSetOptions
Selects Settings File (*.sef) options used with ScrExportSettingsFile.

UI Command: Export > Settings File. Use the check boxes to select export options.
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Selects Settings File (*.sef) options used with ScrExportSettingsFile.

Syntax: obj.ScrExportSettingsFileSetOptions(<optionArray>)

Parameters:

ARRAY optionArray of BOOLs (1 = enable export; 0 = disable export)

INDEX:

l 0 – Plane Extents
l 1 – Solder Balls and Bumps
l 2 – Bondwires
l 3 – Net Selections
l 4 – Differential Nets and Extended Differential Nets
l 5 – Extended Nets
l 6 – Padstacks (includes Padshapes)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrExportSettingsFileSetOptions([1,0,1,0,0,1,0])

ScrExportSNAReport
Exports a Signal Net Analyzer output report in either HTML or CSV format.

UI Command: Simulation > Signal Net Analyzer. From the Signal Net Analyzer window,
click Export Table.

Syntax:
obj.ScrExportSNAReport(<reportPath>, <netNameRegExp>,
<lengthUnits>, <delayUnits>,
<onlyDieToBall>,<exportToCSV>)

Parameters:

BSTR reportPath (full file path for report to be exported)

BSTR netNameRegExp (regular expression; use '.*' to include all nets)

BSTR lengthUnits (pass empty string to use default 'mm')

BSTR delayUnits (pass empty string to use default 'ps')

BOOL onlyDieToBall (True to enforceOnly include paths from Die pin to
BGA solderball option; else False)

BOOL exportToCSV (True to export to CSV file; False to export to HTML file)

Return Value:

INT

l 0 – Success
l 1 – Licensing Failure

PY Example: HTML File:
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Exports a Signal Net Analyzer output report in either HTML or CSV format.

oDoc.ScrExportSNAReport
('C:/MyFiles/snaRpt.htm','.*','','',0,0)

CSV File:

oDoc.ScrExportSNAReport
('C:/MyFiles/snaRpt.csv','.*','microns','ns',0,1)
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ScrExportSyzSimToTouchstone
Exports SYZ simulation results to a specified touchstone file.

UI Command: Results > SYZ > [Simulation Name] > Export Touchstone File.

Syntax:
obj.ScrExportSyzSimToTouchstone(<syzSimName>,
<touchstonePath>)

Parameters:

BSTR syzSimName

BSTR touchstonefilePath (full path for the touchstone file to be generated)

Note:

Adding the file name and extension are not necessary; however, if
the file name and extension are included, accurately specify the
number of ports in the extension (i.e., *.sNp) or two extensions will
appear in the exported file (e.g., testExport.s2p.s4p).

Return Value:

Memory address and integer in brackets (e.g., <System.Int16 object at
0x00000000000000x2E [0]>):

INT:

l 0 – Success
l 1 – simType value is unacceptable.

PY Example:
oDoc.ScrExportSyzSimToTouchstone('SYZ Sweep 1',
'C:/sweep1/testExport.s2p')

ScrExportToTouchstone
Exports the active dataset as SYZ data in touchstone format.

UI Command: Results > SYZ > [Simulation Name] > Export Touchstone File.

Syntax: obj.ScrExportToTouchstone(<filePath>)

Parameters:

BSTR touchstonefilePath (full path for the touchstone file to be generated)

Note:

Adding the file name and extension are not necessary; however, if
the file name and extension are included, accurately specify the
number of ports in the extension (i.e., *.sNp) or two extensions will
appear in the exported file (e.g., testExport.s2p.s4p).

Return Value: Memory address and integer in brackets (e.g., <System.Int16 object at
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Exports the active dataset as SYZ data in touchstone format.

0x00000000000000x2E [0]>):

INT:

l 0 – Success
l 1 – simType value is unacceptable.

PY Example:
oDoc.ScrExportToTouchstone
('D:/Tests/testExport.s2p')
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ScrExportVprobeData
Exports voltage probe data for a specified AC sweep to a text file.

UI Command: None.

Syntax:
obj.ScrExportVprobeData(<acSimName>,
<bstrVprobeFilePath>)

Parameters:
BSTR acSimName

BSTR bstrVprobeFilePath (include file extension *.vpb)

Return Value:

INT

l 0 – Success
l 1 – AC simulation name does not exist OR file path cannot be created.

PY Example:
oDoc.ScrExportVprobeData('AC Sweep 1',
'C:/Files/probe_data.vpb')

ScrExportXfl
Exports an XFL file.

UI Command: Export > XFL.

Syntax: obj.ScrExportXfl(<filePath>)

Parameters: BSTR filePath (path for export)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrExportXfl('C:/Directory/filename.xfl')
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ScrExportZ0ScanReport
Generates an HTML report file containing impedance plots taken for every layer.

To specify additional report options, use ScrExportZ0ScanReportColorBarProperties and
ScrExportZ0ScanReportScaling.

UI Command: Results > Impedance Scan > Export Report.

Syntax:
obj.ScrExportZ0ScanReport(<simName>,
<fileNameWithPath>)

Parameters:
BSTR simName

BSTR fileNameWithPath (include file extension)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrExportZ0ScanReport('Z0 Scan 1',
'D:/AutomationTest/ScriptReportTest.htm')
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ScrExportZ0ScanReportColorBarProperties
Used before ScrExportZ0ScanReport to set color bar properties for impedance report
generation.

UI Command: Advanced > Color Scale. Select Color Bar Properties.

Syntax:
obj.ScrExportZ0ScanReportColorBarProperties
(<numDiv>, <numDigit>, <bFlipColorScale>,
<bWhiteBeyondMinMax>)

Parameters:

INT numDiv

INT numDigit

BOOL bFlipColorScale

BOOL bWhiteBeyondMinMax

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrExportZ0ScanReportColorBarProperties
(14,3,False,True)
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ScrExportZ0ScanReportScaling
Used before ScrExportZ0ScanReport to set scaling options for impedance report generation.

UI Command: None.

Syntax:
obj.ScrExportZ0ScanReportScaling(<minVal>,
<maxVal>, <bLogScale>)

Parameters:

DOUBLE minVal

DOUBLE maxVal

BOOL bLogScale (True = Log; False = Linear)

**Use -1 for both minVal & maxVal to set the plot range back to original and
also to set bLogScale independently without affecting the range.

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrExportZ0ScanReportScaling(0.00,50.0,True)

ScrFitAll
Fits the design to the modeling workspace.

UI Command: View > Fit All.

Syntax: obj.ScrFitAll

Parameters: None.

Return Value: None.

PY Example: oDoc.ScrFitAll()

ScrFitSelection
Fits selected object(s) to the modeling workspace.

UI Command: View > Fit Selection.

Syntax: obj.ScrFitSelection

Parameters: None.

Return Value: None.

PY Example: oDoc.ScrFitSelection()

ScrFitToViewingWindow
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Fits selected object(s) to the viewing window. See: GetCurrentViewingWindow.

UI Command: None.

Syntax: obj.ScrFitToViewingWindow(<unit>, <viewBox>)

Parameters:
BSTR unit (unit of measure)

ARRAY viewBox (structured array containing X,Y coordinates)

Return Value: None.

PY Example:
oDoc.ScrFitToViewingWindow('um',['-54','-
27','54','27'])

ScrFwsEnforceCausality
Controls option to check whether s-parameter data is passive.

UI Command: Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit. Select
Enforce Causality check box.

Syntax: obj.ScrFwsEnforceCausality(<flag>)

Parameters: BOOL flag (True to enforce)

Return Value: None.

PY Example: oDoc.ScrFwsEnforceCausality(True)
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ScrGenerateConnectionReport
Exports a net connection report to a specified HTML file in the project directory.

UI Command: Advanced > Export Connection Report.

Syntax: obj.ScrGenerateConnectionReport(<fileName>)

Parameters: BSTR fileName (including file extension)

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrGenerateConnectionReport('connRpt.html')
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ScrGenerateICDieNetwork
Generates an IC die network.

UI Command: Tools > Create IC Die Network. Set options in IC Die Network Generation
window.

Syntax:

obj.ScrGenerateICDieNetwork (<icPartName>,
<refDes>, <net>, <networkName>, <resVal>,
<useStarPattern>, <capVal>, <esr>, <toNet>,
<useAutoRadius>, <resRadius>, <capRadius>)

Parameters:

BSTR icPartName

BSTR refDes

BSTR net

BSTR networkName

BSTR resVal

BOOL useStarPattern (True = star pattern; False = grid pattern)

BSTR capVal

BSTR esr

BSTR toNet

BOOL useAutoRadius (True = auto radius; False = specify radius)

BSTR resRadius (leave string blank for auto radius)

BSTR capRadius (leave string blank for auto radius)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrGenerateICDieNetwork('CD90-P2913-1', 'U13',
'AGND', 'U13_AGND', '3.0mOhm', True, '', '', '',
True, '', '')
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ScrGetActiveComponentList
Returns list of all active components of a specified type.

UI Command: None.

Syntax: obj.ScrGetActiveComponentList(<compType>)

Parameters: BSTR compType (can be "All", "RLC", or any category shown in the
Components workspace, e.g. "Discrete Devices", "Pin Groups")

Return Value: ARRAY nameList

PY Example: oDoc.ScrGetActiveComponentList('Current Sources')

ScrGetBondwiresOfBwModel
Returns list of all bondwires associated with the given bondwire model.

UI Command: None.

Syntax: obj.ScrGetBondwiresOfBwModel(<modelName>)

Parameters: BSTR modelName

Return Value: ARRAY bwList (list of bondwires)

PY Example: oDoc.ScrGetBondwiresOfBwModel('Z1-MT8530-LOOP1')

ScrGetBwModelNameList
Returns list of all bondwire models.

UI Command: None.

Syntax: obj.ScrGetBwModelNameList()

Parameters: None.

Return Value: ARRAY bwModelNameList (list of bondwire models)

PY Example: oDoc.ScrGetBwModelNameList()
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ScrGetCktElemTerminalNetNames
Returns names of the two nets to which a specified circuit element is connected.

UI Command: None.

Syntax:
obj.ScrGetCktElemTerminalNetNames(<name>, <type>,
<pnet>, <nnet>)

Parameters:

BSTR name (the circuit element Reference Designator)

BSTR type ("cap", "ind", "res", "port", "vprobe", "csource" or "vsource")

ARRAY pnet

ARRAY nnet

Return Value:

INT

l 0 – Success
l 1 – Either name OR type is not specified.
l 2 – Type is unrecognized.
l 3 – Name cannot be found.
l 4 – Circuit element's positive terminal is floating (has not been connected
to a net).

l 5 – Circuit element's negative terminal is floating (has not been connected
to a net).

PY Example:
oDoc.ScrGetCktElemTerminalNetNames
('C1','cap',pnet,nnet)
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ScrGetComponentList
Returns an array containing names of all parts of the specified type.

UI Command: None.

Syntax: obj.ScrGetComponentList(<compType>)

Parameters:

BSTR compType ("all", "rlc", "capacitors", "inductors", "resistors", "ports",
"voltage probes", "current sources", "voltage sources", "integrated circuits",
"input/output", or "discrete devices"; separate using a comma to specify more
than one type)

Return Value: ARRAY componentList

PY Example:
oDoc.ScrGetComponentList('rlc, ports, integrated
circuits')

ScrGetCurrentViewingWindow
Returns the position of the viewing window.

UI Command: None.

Syntax: obj.ScrGetCurrentViewingWindow(<units>)

Parameters: BSTR units

Return Value: ARRAY containing X,Y coordinates. Results can be used with
ScrFitToViewingWindow.

PY Example: oDoc.ScrGetCurrentViewingWindow('um')

Script Commands 2-98

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrGetDcConnectedNets
Returns an array containing all nets and RLCs that form a connection to the specified net.

UI Command: None.

Syntax:
obj.ScrGetDcConnectedNets(<netNameList>, <nets>,
<cktElems>)

Parameters:

ARRAY netNameList (input list of net names that are connected)

ARRAY nets (list of net names that are DC-connected to the input list)

ARRAY cktElems (names of circuit elements that form connections between
the DC-connected nets)

Return Value:

BOOL

l 0 – Success
l 1 – Failure

PY Example:
oDoc.ScrGetDcConnectedNets(netNameList, nets,
cktElems)

ScrGetDcThermalDataDir
Sets variable thermalDataDirBstr to the path of the DC Thermal directory.

UI Command: None.

Syntax:
obj.ScrGetDcThermalDataDir(<simName>,
<thermalDataDirBstr>)

Parameters:
BSTR simName (DC simulation name)

ARRAY thermalDataDirBstr (empty)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:

thermalDataDirBstr = []

oDoc.ScrGetDcThermalDataDir('DC IR Sim
1',thermalDataDirBstr)
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ScrGetDesignBoundingBox
Assigns the design's bounding box, in specified units, to variable designBBox.

UI Command: None.

Syntax: obj.ScrGetDesignBoundingBox(<units>, <designBBox>)

Parameters:
BSTR units ('um', 'in', 'm', 'microns', 'mils', 'mm', 'cm', 'inches', or 'meters')

ARRAY designBBox (empty)

Return Value:

ARRAY designBBox populates with 3D bounding box
coordinates, represented by corner points (x1,y1,z1) and (x2, y2, z2).

BOOL:

l 1 – Success
l 0 – Failure

PY Example:
designBBox= []

oDoc.ScrGetDesignBoundingBox('mm',designBBox)

ScrGetDieLayerName
Returns the layer on which a specified die exists.

UI Command: None.

Syntax: obj.ScrGetDieLayerName(<dieName>)

Parameters: BSTR dieName

Return Value: BSTR layer name

PY Example: oDoc.ScrGetDieLayerName('DIE')
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ScrGetDieNameList
Returns an array containing all die names.

UI Command: None.

Syntax: obj.ScrGetDieNameList()

Parameters: None.

Return Value: ARRAY dieNameList

PY Example: oDoc.ScrGetDieNameList()

Script Commands 2-101

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrGetExcitationCoord
Returns excitation coordinates of a specified terminal on a net.

UI Command: None.

Syntax:
obj.ScrGetExcitationCoord(<netName>,
<terminalName>)

Parameters:
STRING netName

STRING terminalName (name of a terminal on the specified net)

Return Value: ARRAY containing X,Y coordinates

PY Example: oDoc.ScrGetExcitationCoord(netName, terminalName)

ScrGetLayerMaterial
Returns the material of a specified layer.

UI Command: None.

Syntax: obj.ScrGetLayerMaterial(<layerName>)

Parameters: BSTR layerName

Return Value: BSTR materialName

PY Example: oDoc.ScrGetLayerMaterial('BOTTOM')

ScrGetLayerNameList
Returns an array containing names of all layers in the project.

UI Command: None.

Syntax: obj.ScrGetLayerNameList()

Parameters: None.

Return Value: ARRAY layerNameList

PY Example: oDoc.ScrGetLayerNameList()
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ScrGetLayerThickness
Returns the thickness of a specified layer.

UI Command: None.

Syntax: obj.ScrGetLayerThickness(<layerName>)

Parameters: BSTR layerName

Return Value: DOUBLE layer thickness

PY Example: oDoc.ScrGetLayerThickness('TOP_LAYER')

ScrGetLayerType
Returns a specified layer's type.

UI Command: None.

Syntax: obj.ScrGetLayerType(<layerName>)

Parameters: BSTR layerName

Return Value:

INT

l 0 – Dielectric
l 1 – Metal
l 2 –Wirebond

PY Example: oDoc.ScrGetLayerType('SURFACE_LAYER')

ScrGetLayoutLengthUnit
Returns the current unit of measure.

UI Command: None.

Syntax: obj.ScrGetLayoutLengthUnit()

Parameters: None.

Return Value: BSTR unit

PY Example: oDoc.ScrGetLayoutLengthUnit()
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ScrGetMetalLayerFillerMaterial
Returns a specified metal layer's filler material.

UI Command: None.

Syntax: obj.ScrGetMetalLayerFillerMaterial(<layerName>)

Parameters: BSTR layerName

Return Value: BSTR materialName

PY Example: oDoc.ScrGetMetalLayerFillerMaterial('LAYER3')

ScrGetNetlistOfBondwireProfile
Returns a list of nets associated with a given bondwire profile

UI Command: None.

Syntax: obj.ScrGetNetlistOfBondwireProfile(<profileName>)

Parameters: BSTR profileName

Return Value: ARRAY netNameList

PY Example: oDoc.ScrGetNetlistOfBondwireProfile('Bw Profile')

ScrGetNetNameList
Returns a list of nets in the project.

UI Command: None.

Syntax: obj.ScrGetNetNameList()

Parameters: None.

Return Value: ARRAY netNameList

PY Example: oDoc.ScrGetNetNameList()
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ScrGetNetsAndCktElemsBetweenComponents
Returns a list of all power/ground nets and RLCs that form a connection between specified
components.

UI Command: None.

Syntax:
obj.ScrGetNetsAndCktElemsBetweenComponents
(<partName1>, <refDes1>, <partName2>, <refDes2>,
<nets>, <cktElems>)

Parameters:

BSTR partName1

BSTR refDes1

BSTR partName2

BSTR refDes2

ARRAY nets (empty)

ARRAY cktElems (empty)

Return Value:

ARRAY nets (filled)

ARRAY cktElems (filled)

INT outcome:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrGetNetsAndCktElemsBetweenComponents
('288DIMMDDR4_EDGE_CONN-BASE', 'J1', 'DDR4_X4_
FBGA78-10X13','U1', nets2, elems2)
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ScrGetNetsAndCktElemsBetweenNets
Returns a list of all nets and RLCs that form a connection between specified components.

UI Command: None.

Syntax:
obj.ScrGetNetsAndCktElemsBetweenNets(<net1>,
<net2>, <refDes2>, <nets>, <cktElems>)

Parameters:

BSTR net1

BSTR net2

ARRAY nets (empty)

ARRAY cktElems (empty)

Return Value:

ARRAY nets (filled)

ARRAY cktElems (filled)

INT outcome:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrGetNetsAndCktElemsBetweenNets('VDD', 'GND',
nets, elems)
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ScrGetNumSinks
Returns the number of sink terminals on a net.

UI Command: None.

Syntax: obj.ScrGetNumSinks(<netName>)

Parameters: STRING netName

Return Value: INTEGER (number of sink terminals on the specified net)

PY Example: oDoc.ScrGetNumSinks(netName)
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ScrGetNumSources
Returns the number of source terminals on a net.

UI Command: None.

Syntax: obj.ScrGetNumSources(<netName>)

Parameters: STRING netName

Return Value: INTEGER (number of source terminals on the specified net)

PY Example: oDoc.ScrGetNumSources(netName)

ScrGetPadstackNameList
Returns a list of all padstack names in the project.

UI Command: None.

Syntax: obj.ScrGetPadstackNameList()

Parameters: None.

Return Value: ARRAY padstackNameList

PY Example: oDoc.ScrGetPadstackNameList()
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ScrGetPinGroupNameList
Returns a list of all pin group names on specified part(s) or in the entire project.

UI Command: None.

Syntax: obj.ScrGetPinGroupNameList(<partName>,<refDes>)

Parameters:
BSTR partName (leave empty to search entire project)

BSTR refDes (leave empty to search entire project)

Return Value: ARRAY pinGroupNameList

PY Example: oDoc.ScrGetPinGroupNameList()

ScrGetPinPadstackName
Returns the padstack name associated with a specified pin.

UI Command: None.

Syntax:
obj.ScrGetPinPadstackName(<partName>, <refDes>,
<pinName>)

Parameters:

BSTR partName

BSTR refDes

BSTR pinName

Return Value: BSTR padstackName

PY Example: oDoc.ScrGetPinPadstackName('DIE','U1','394')
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ScrGetPinsOnNet
Returns a list of identifying information for pins on a specified net.

UI Command: None.

Syntax:
obj.ScrGetPinsOnNet(<netName>, <partName>,
<refDes>, <pinNames>, <partNames>, <refDesOut>)

Parameters:

BSTR netName

BSTR partName (use empty string or "any" to disable this filter)

BSTR refDes (use empty string or "any" to disable this filter)

ARRAY pinNames (empty)

ARRAY partNames (empty)

ARRAY refDesOut (empty)

Return Value:

ARRAY pinNames (filled)

ARRAY partNames (filled)

ARRAY refDesOut (filled)

BOOL outcome:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrGetPinsOnNet ('GND', 'ANY', '', pins,
parts, refDesList)
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ScrGetPinsOnPart
Returns a list of identifying information for pins on a specified part.

UI Command: None.

Syntax:
obj.ScrGetPinsOnPart(<partName>, <refDes>,
<pinNames>, <netNames>)

Parameters:

BSTR partName

BSTR refDes

ARRAY pinNames (empty)

ARRAY netNames (empty)

Return Value:

ARRAY pinNames (filled)

ARRAY netNames (filled)

BOOL outcome:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrGetPinsOnPart('T1_A', 'U1', pins, nets)

ScrGetPwrGndNetNameList
Returns a list of Power/Ground nets in the project.

UI Command: None.

Syntax: obj.ScrGetPwrGndNetNameList()

Parameters: None.

Return Value: ARRAY pwrGndNetNameList

PY Example: oDoc.ScrGetPwrGndNetNameList()
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ScrGetRLCsBetweenNets
Finds RLCs that directly connect any pair of nets from the specified list.

UI Command: None.

Syntax:
obj.ScrGetRLCsBetweenNets(<netNameList>,
<includeR>, <includeL>, <includeC>, <ctkElems>)

Parameters:

ARRAY netNameList

BOOL includeR

BOOL includeL

BOOL includeC

ARRAY cktElems (empty)

Return Value:

ARRAY cktElems (filled)

INT outcome:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrGetRLCsBetweenNets(netsIn1, False, False,
True, elems1)
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ScrGetSinkNameList
Returns a list of the sink terminals on a net.

UI Command: None.

Syntax: obj.ScrGetSinkNameList(<netName>)

Parameters: STRING netName

Return Value: ARRAY (list of all sink terminals on the specified net)

PY Example: oDoc.ScrGetSinkNameList(netName)
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ScrGetSourceNameList
Returns a list of the source terminals on a net.

UI Command: None.

Syntax: obj.ScrGetSourceNameList(<netName>)

Parameters: STRING netName

Return Value: ARRAY list of sources (list of all source terminals on the specified net)

PY Example: oDoc.ScrGetSourceNameList(netName)

ScrGetStackupLayerThickness
Returns the thickness of a specified layer.

UI Command: None.

Syntax: obj.ScrGetStackupLayerThickness(<layerName>)

Parameters: BSTR layerName

Return Value: BSTR layer thickness

PY Example: oDoc.ScrGetStackupLayerThickness('Layer 1')
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ScrGetUniqueSimulationName
Generates a unique simulation name based on a given simulation type.

UI Command: None.

Syntax: obj.ScrGetUniqueSimulatioName(<simType>)

Parameters: BSTR simType ("ac", "dc", "eigen", "ff", "nf", "syz", or "hfss_syz")

Return Value: BSTR uniqueSimName

PY Example: oDoc.ScrGetUniqueSimulationName('nf')

ScrImportAnf
Imports a specified Ansys Neutral File (*.anf)

UI Command: Import > ANF.

Syntax: obj.ScrImportAnf(<anfBstr>)

Parameters: BSTR anfBstr (file path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrImportAnf('C:/anfFiles/design1.anf')
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ScrImportCapacitorDeratingTable
Assigns capacitor derating attributes and opens modified SIwave file.

UI Command: Simulation >Options. Under DC Bias, click Open.

Syntax:
obj.ScrImportCapacitorDeratingTable
(<bDeratingTablePath>, <errors>)

Parameters:
BSTR bDeratingTablePath

ARRAY errors

Return Value:
INT number of capacitors in the derating file that could not be found in the
design.

l -1 – Failure

PY Example:
oDoc.ScrImportCapacitorDeratingTable
('C:/csvfiles/derating_table.csv','errors')

ScrImportComponentFile
Imports a specified component file (*.cmp)

UI Command: Import > Component File.

Syntax: obj.ScrImportComponentFile(<cmpBstr>)

Parameters: BSTR cmpBstr (file path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrImportComponentFile
('C:/ComponentFiles/design1.cmp')
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ScrImportComponentMapFile
Imports a specified component mapping file (*.cmp)

UI Command: Import > Component File.

Syntax: obj.ScrImportComponentMapFile(<fileName>)

Parameters: BSTR fileName (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrImportComponentMapFile
('C:/ComponentFiles/design1.cmp')
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ScrImportCpaSimulationOptions
Loads an SIwave Simulation Settings file (*.sws).

UI Command: Click Simulation. From the CPA area, selectOptions. From the options
window, click Import Settings.

Syntax: obj.ScrImportCpaSimulationOptions(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrImportCpaSimulationOptions('C:/Path/simulation_
settings.sws')
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ScrImportCpmOrPloc
Imports a CPM or PLOC file.

UI Command: Import > Ansys CPM/PLOC File.

Syntax:
obj.ScrImportCpmOrPloc(<plocFileName>, <partName>,
<refName>, <controlFileName>)

Parameters:

BSTR plocFileName (can also be CPM file name)

BSTR partName

BSTR refName (Reference Designator)

BSTR controlFileName (containing keywords listed below; for auto
connection, use empty string)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrImportCpmOrPloc
('C:/SAMPLEFILES/cpmfile.cpm','CSP_BGA','BGA','')

Option Keywords and Example Values
DieCenterX -149.997058

DieCenterY 484.129583

FlipDie TRUE

RotationAngle 0

ScalingFactor 0.9

Tolerance 0.0

CreatePorts TRUE

CreateSources FALSE
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ScrImportDDXFile
Imports a DDX file; the file's settings are substituted for the active project's settings when the
DDR wizard is run and can be saved to the project afterward.

UI Command: Simulation > DDRwizard > Load Configuration File.

Syntax: obj.ScrImportDDXFile(<filename>)

Parameters: BSTR filename (full file path)

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrImportDDXFile('c:/example_file.ddx')
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ScrImportEDB
Imports an EDB folder into a new project.

UI Command: Import > Ansys EDB.

Syntax: obj.ScrImportEDB (<folderPath>)

Parameters: BSTR filePath

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oApp.ScrImportEDB('C:/Files/Edb')

ScrImportGDSII
Imports a GDSII file (*.strm, *.gds) into a new project.

UI Command: Import >GDSII.

Syntax: obj.ScrImportGDSII(<filePath>, <controlFilePath>)

Parameters:
BSTR filePath

BSTR controlFilePath (pass an empty string to use the default control file)

Return Value:

INT:

l 0 – Success
l 1 – Failure generating control file
l 2 – Error translating the file

PY Example: oDoc.ScrImportGDSII('C:/Files/MyProject.gds','')
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ScrImportIPC2581
Imports an IPC2581 file, as well as optional RLC part value and XML control files, into a new
project

UI Command: Import > IPC2581. 

Syntax:
obj.ScrImportIPC2581 (<designFile>, <controlFile>,
<partFile>)

Parameters:

BSTR designFile (full path)

BSTR controlFile (full path, use empty string for none)

BSTR partFile (full path, use empty string for none)

Return Value:

INT:

l 0 – Success
l 1 – Error translating the file.
l 2 – Error reading part mapping file.

PY Example:
oApp.ScrImportIPC2581('C:/Files/mydesign.cvg',
'C:/Files/controlfile.xml',
'C:/Files/partfile.dat')

ScrImportLayerStackup
Imports a layer stackup file.

UI Command: Import > Layer Stackup.

Syntax: obj.ScrImportLayerStackup(<fileName>)

Parameters: BSTR fileName (full path)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrImportLayerStackup('C:/StackupFiles/stack1.stk')
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ScrImportLayerStackupFile
Imports a layer stackup file.

UI Command: Import > Layer Stackup.

Syntax: obj.ScrImportLayerStackupFile(<fileName>)

Parameters: BSTR fileName (full path)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrImportLayerStackupFile
('C:/StackupFiles/stack1.stk')

ScrImportLayerStackupXML
Imports a layer stackup XML file.

UI Command: Import > Layer Stackup XML.

Syntax: obj.ScrImportLayerStackupXML(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrImportLayerStackupXML
('C:/StackupFiles/stack1.xml')
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ScrImportPmap
Imports a *.pmap file to map locally defined capacitor and inductor part names to s-parameter
models from the component library

UI Command: None.

Syntax: obj.ScrImportPmap(<fileName>)

Parameters: BSTR fileName (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrImportPmap('C:/Files/foo.pmap')

ScrImportSettingsFile
Loads an SIwave Settings file (*.sef).

UI Command: Import > Settings File.

Syntax: obj.ScrImportSettingsFile(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrImportSettingsFile('C:/Path/my_settings.sef')
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ScrImportSIwaveSimulationOptions
Loads an SIwave Simulation Settings file (*.sws).

UI Command: Click Simulation. From the SIwave area, selectOptions. From the options
window, click Import Settings.

Syntax: obj.ScrImportSIwaveSimulationOptions(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrImportSIwaveSimulationOptions
('C:/Path/simulation_settings.sws')
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ScrImportXfl
Imports an XFL file.

UI Command: Import > XFL File.

Syntax: obj.ScrImportXfl(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrImportXfl('C:/Directory/filename.xfl')

ScrInterpolateSpectrum
Specifies interpolation option for Frequency Sweep, Far Field, or Near Field simulations.

Important: Interpolation is active by default and Ansys recommends not changing this setting.

UI Command:
From the Simulationmenu, click either Compute Frequency Sweep,
Compute Far Field, or Compute Near Field. Then, select or deselect the
Interpolate spectrum at missing frequency points check box .

Syntax: obj.ScrInterpolateSpectrum(<interpolate>)

Parameters: BOOL interpolate

Return Value: None.

PY Example: oDoc.ScrInterpolateSpectrum(True)
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ScrLogMessage
Logs a specified message to the Messages window and to the project *.log file.

UI Command: None.

Syntax: obj.ScrLogMessage(<message>)

Parameters: BSTR message

Return Value: None.

PY Example: oDoc.LogMessage('This is my message.')

ScrMergeConnectedNets
Merges connected nets in a specified list.

UI Command: None.

Syntax: obj.ScrMergeConnectedNets(<inNetNameList>)

Parameters: ARRAY inNetNameList

Return Value: ARRAY outNetNameList (if no nets are connected, this will be the same as
inNetNameList)

PY Example:

inNetNameList = ['NET_1','NET_2']

outNetNameList = obj.ScrMergeConnectedNets
(inNetNameList)
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ScrNetGetLength
Computes the shortest length between a specified source and sink.

UI Command: None.

Syntax:
Dim length = obj.ScrNetGetLength(<netName>,
<sourceName>, <sinkName>)

Parameters:

BSTR netName

BSTR sourceName

BSTR sinkName

Return Value: DOUBLE length (returns 0.0 if net, source, or sink does not exist)

PY Example:
oDoc.ScrNetGetLength('HOT_INS_DIS', 'D1:HOT_INS_
DIS:292', 'P1:HOT_INS_DIS:E4')

ScrNetIsDisjoint
Checks whether a net is disjoint.

UI Command: None.

Syntax: obj.ScrNetIsDisjoint(<netName>)

Parameters: BSTR netName

Return Value:

BOOL

l 0 – Not Disjoint
l 1 – Disjoint

PY Example: oDoc.ScrNetIsDisjoint('MY-NET')
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ScrNetIsSelected
Checks whether a net is selected.

UI Command: None.

Syntax: obj.ScrNetIsSelected(<netName>)

Parameters: BSTR netName

Return Value:

BOOL

l 0 – Not Selected
l 1 – Selected

PY Example: oDoc.ScrNetIsSelected('MY-NET')

ScrNetSeparate
If a net is disjoint, separates it and sets new net names.

UI Command: None.

Syntax: obj.ScrNetSeparate(<netName>)

Parameters: BSTR netName

Return Value: None.

PY Example: oDoc.ScrNetSeparate('MY-NET')

ScrNetSetDummy
Sets a specified net to be a dummy net and appends DUMMY_ to the front of the net name.

UI Command: None.

Syntax: obj.ScrNetSetDummy(<netName>)

Parameters: BSTR netName

Return Value: None.

PY Example: oDoc.ScrNetSetDummy('MY-NET')
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ScrNetSetSelected
Selects or deselects a specified net.

UI Command: None.

Syntax: obj.ScrNetSetSelected(<netName>, <select>)

Parameters:
BSTR netName

BOOL select (1 = select; 0 = deselect)

Return Value: None.

PY Example: oDoc.ScrNetSetSelected('MY-NET', 1)
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ScrPlaceCircuitElement
Attaches a circuit element of the specified type to the design.

The element can be connected between any two points, pins or pin groups.

UI Command: Home > Circuit Elements > Add [Capacitor / Inductor / Resistor / Port /
Voltage Probe / Voltage Source / Current Source].

Syntax:

obj.ScrPlaceCircuitElement(<givenElementName>,
<givenPartName>, <circuitElementType>,
<posTermConnectionType>, <posTermParam1>,
<posTermParam2>, <posTermParam3>,
<refTermConnectionType>, <refTermParam1>,
<refTermParam2>, <refTermParam3>, <capVal>, <indVal>,
<resVal>, <refZRe>, <mag>, <phase>)

Parameters:

BSTR givenElementName (name of circuit element to be created)

BSTR givenPartName (part name of circuit element to be created)

INT circuitElementType (0 = capacitor; 1 = inductor; 2 = resistor; 3 = port; 4 =
current source; 5 = voltage source; 6 = voltage probe)

INTposTermConnectionType (0 = attachment to PIN; 1 = attachment to PIN
GROUP; 2 = attachment at COORDINATES)

BSTR posTermParam1 (partName or x)

BSTR posTermParam2 (refDes or y)

BSTR posTermParam3 (pinName, groupName, or layerName)

INT refTermConnectionType (0 = attachment to PIN; 1 = attachment to PIN
GROUP; 2 = attachment at COORDINATES)

BSTR refTermParam1 (partName or x)

BSTR refTermParam2 (refDes or y)

BSTR refTermParam3 (pinName, groupName, or layerName)

double capVal (capacitance)

double indVal (inductance)

double resVal (resistance)

double refZRe (impedance)

double mag (magnitude)

double phase (phase)
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Attaches a circuit element of the specified type to the design.

The element can be connected between any two points, pins or pin groups.

Use an empty string for any parameters that are not applicable.

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:

oDoc.ScrPlaceCircuitElement ('cap_1', 'cap_part',
0, 1, '100354431', 'Q3', 'pinGrp_4', 1,
'100349132', 'U26', 'pinGroup_10', 4.7e-9, 2e-11,
3e-3, 0.0, 0.0, 0.0)
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ScrPlaceCircuitElementsToNearestRefPin
Creates ports or sources connecting to the nearest reference pins of the given reference
terminal net.

UI Command: None.

Syntax:

obj.ScrPlaceCircuitElementsToNearestRefPin
(<circuitElementType <val>, <posPartName>,
<posUnitName>, <posNetName>, <refPartName>,
<refUnitName>, <refNetName>, <newElemList>)

Parameters:

INT circuitElementType (3 = port; 4 = current source; 5 = voltage source)

DOUBLE val

BSTR posPartName

BSTR posUnitName

BSTR posNetName

BSTR refPartName

BSTR refUnitName

BSTR refNetName

ARRAY newElemList

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrPlaceCircuitElementsToNearestRefPin (3,
50.0, 'SQFP28X28_208', 'U1', 'ARBLINK', 'SQFP28X28_
208', 'U2', 'GND', newElemList)
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ScrPlaceFreqDependentSrc
Creates a frequency dependent source.

UI Command: None.

Syntax:

obj.ScrPlaceFreqDependentSrc(<givenElementName>,
<circuitElementType>, <posTermConnectionType>,
<posTermParam1>, <posTermParam2>, <posTermParam3>,
<refTermConnectionType>, <refTermParam1>,
<refTermParam2>, <refTermParam3>, <filename>)

Parameters:

BSTR givenElementName

INT circuitElementType (4 = current source; 5 = voltage source)

INT posTermConnectionType (0 = pin; 1 = pin group; 2 = coordinate)

BSTR posTermParam1 (part name for pins or pin groups; x coordinate for
coordinate connections)

BSTR posTermParam2 (reference designator for pins or pin groups; y
coordinate for coordinate connections)

BSTR posTermParam3 (pin name or pin group name; ignored for coordinate
connections)

INT refTermConnectionType (0 = pin; 1 = pin group; 2 = coordinate)

BSTR refTermParam1 (part name for pins or pin groups; x coordinate for
coordinate connections)

BSTR refTermParam2 (reference designator for pins or pin groups; y
coordinate for coordinate connections)

BSTR refTermParam3 (pin name or pin group name; ignored for coordinate
connections)

BSTR filename

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrPlaceFreqDependentSrc('I1', 4, 2, '1.0',
'1.0', 'METAL-1', 2, '2.0', '1.0', 'METAL-1',
'e:/SrcFreqData.txt')

Script Commands 2-134

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrPlacePortsAcrossRLCs
Creates ports across specified RLCs.

UI Command: None.

Syntax:
obj.ScrPlacePortsAcrossRLCs(<zref>, <rlcName>,
<rlcType>, <portsCreated>)

Parameters:

DOUBLE zref

BSTR rlcName

BSTR rlcType ('cap' for capacitor; 'ind' for inductor; 'res' for resistor)

ARRAY portsCreated (empty)

Return Value:

ARRAY portsCreated (list of port names)

INT outcome:

l 0 – Success
l 1 – Name or type is an empty string
l 2 – rlcType is invalid
l 3 – Specified RLC could not be found
l 4 – Error filling the array portsCreated

PY Example:

portsCreated=[]

oDoc.ScrPlacePortsAcrossRLCs
(50,'C3A3','cap',portsCreated)
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ScrPlacePortsAtPinsOnSelectedNets
Creates ports with specified impedance for each of the pins found in a specified reference net.

UI Command: None.

Syntax:
obj.ScrPlacePortsAtPinsOnSelectedNets(<zref>,
<refNetName>, <connectToPinGroup>, <portsCreated>)

Parameters:

DOUBLE zref (impedance)

BSTR refNetName (reference net)

BOOL connectToPinGroup

ARRAY portsCreated (empty)

Return Value:

ARRAY portsCreated (filled)

INT:

l 0 – Success
l Else – Failure

PY Example:

portsCreated = []

oDoc.ScrPlacePortsAtPinsOnSelectedNets(50.0, 'MY_
NET', 1, portsCreated)
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ScrPlacePortsAtPinsOnSelectedNetsExcludePart
Creates ports between pins on the selected nets and the reference net unless the pins belong
to the specified part.

UI Command: None.

Syntax:
obj.ScrPlacePortsAtPinsOnSelectedNetsExcludePart
(<zref>, <refNetName>, <partName>, <refDes>,
<connectToPinGroup>, <portsCreated>)

Parameters:

DOUBLE zref

BSTR refNetName

BSTR partName

BSTR refDes

BOOL connectToPinGroup

ARRAY portsCreated (empty)

Return Value:

ARRAY portsCreated (filled)

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrPlacePortsAtPinsOnSelectedNetsExcludePart
(50.0, 'GND', 'T1_A', 'U1', false, ports)
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ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut
Creates ports between pins on the selected nets and the reference net while outputting the port
names and pin names.

UI Command: None.

Syntax:
obj.ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut
(<zref>, <refNetName>, <connectToPinGroup>,
<portsCreated>, <posPinNames>, <refPinNames>)

Parameters:

DOUBLE zref

BSTR refNetName

BOOL connectToPinGroup (True = connect; False = do not connect)

ARRAY portsCreated (empty)

ARRAY posPinNames (empty)

ARRAY refPinNames (empty)

Return Value:

ARRAY portsCreated (filled)

ARRAY posPinNames (filled)

ARRAY refPinNames (filled)

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut
(50.0, 'GND', false, ports, posPins, refPins)
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ScrPlotResModeVoltageDiff
Generates voltage difference surface plots for the specified resonant mode simulation.

Note: A layer pair can be specified and, if present, will restrict the voltage difference computation to just
these two layers. If the layer pair is omitted, plots will be generated for all possible layer pair
combinations.

UI Command: None.

Syntax:
obj.ScrPlotResModeVoltageDiff(<resonantSimName>,
<layerA>, <layerB>)

Parameters:

BSTR resonantSimName

BSTR layerA

BSTR layerB

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrPlotResModeVoltageDiff('Resonant Sim 1',
'SURFACE', 'INNER1')

ScrPreserveNetsGivenInFile
Deletes all nets except those specified in a text file.

Note: The file should contain net names in quotation marks.

UI Command: None.

Syntax: obj.ScrPreserveNetsGivenInFile(<fileName>)

Parameters: BSTR fileName (full path)

Return Value: None.

PY Example:
oDoc.ScrPreserveNetsGivenInFile('C:/My
Files/nets.txt')
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ScrReadDCLoopResInfo
Given the name of an SIwave DC simulation, exports a list of sources and a corresponding list
of loop resistance values.

UI Command: Results > DC IR Drop > Loop Resistance Info.

Syntax:
obj.ScrReadDCLoopResInfo(<simName>, <sourceNames>,
<loopResData>)

Parameters:

BSTR simName

ARRAY sourceNames (empty)

ARRAY loopResData (empty)

Return Value:

ARRAY sourceNames (filled)

ARRAY loopResData (filled)

INT:

l 0 – Success
l Else – Failure

PY Example:

sourceNames = []

loopResData = []

oDoc.ScrReadDCLoopResInfo('DC IR Sim 1',
sourceNames, loopResData)

ScrRestoreResonantModeMinFreq
Restores the minimum suggested resonant mode frequency.

UI Command: Simulation > Compute Resonant Modes. Click Restore Recommended
Minimum Frequency.

Syntax: obj.ScrRestoreResonantModeMinFreq()

Parameters: None.

Return Value: None.

PY Example: oDoc.ScrRestoreResonantModeMinFreq()

ScrRestoreSIwaveDCGeometryProcessingDefaultValues
Restores the default DC geometry processing values.

UI Command:
From the Simulation tab > SIwave area, selectOptions to open the SIwave
Options window. Navigate to the DC Advanced tab, then click Restore Defaults
adjacent to any/all of the three parameters at the top of the window (i.e., Ignore
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Restores the default DC geometry processing values.

geometry smaller than, Ignore voids smaller than, and/or Snap vertices
separated by less than).

Syntax: obj.ScrRestoreSIwaveDCGeometryProcessingDefaultValues()

Parameters: None.

Return Value: None.

PY Example:
oDoc.ScrRestoreSIwaveDCGeometryProcessingDefaultValues
()

ScrRestoreSIwaveSIPIGeometryProcessingDefaultValues
Restores the default SI/PI geometry processing values.

UI Command:

From the Simulation tab > SIwave area, selectOptions to open the SIwave Options
window. Navigate to the SI/PI Advanced tab, then click Restore Defaults adjacent to
any/all of the four parameters in theGeometry Processing area (i.e., Do not mesh
voids smaller than, Explicitly mesh pads larger than, Ignore planes smaller
than, and/or Snap vertices separated by less than).

Syntax: obj.ScrRestoreSIwaveSIPIGeometryProcessingDefaultValues()

Parameters: None.

Return Value: None.

PY Example:
oDoc.ScrRestoreSIwaveSIPIGeometryProcessingDefaultValues
()

ScrRunDcSimulation
Runs a DC IR simulation.

UI Command: Simulation > Compute DC IR.

Syntax: obj.ScrRunDcSimulation(<reprocessGeom>)

Parameters: INT reprocessGeom (1 = runs the simulation; 0 = sets up the simulation but
does not run it)

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrRunDcSimulation(1)

ScrRunDDRWizard
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Runs the DDR wizard using the active project's current settings.

UI Command: Simulation > DDRwizard.

Syntax: obj.ScrRunDDRWizard()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrRunDDRWizard()

ScrRunFarFieldSimulation
Runs a Far Field simulation.

UI Command: Simulation > Compute Far Field.

Syntax: obj.ScrRunFarFieldSimulation()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrRunFarFieldSimulation()

ScrRunFrequencySweepSimulation
Runs a Frequency Sweep simulation.

UI Command: Simulation > Compute Frequency Sweeps.

Syntax: obj.ScrRunFrequencySweepSimulation()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrRunFrequencySweepSimulation()

ScrRunIcepakSimulation
Runs an Icepak simulation.

UI Command: Simulation > Icepak.
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Runs an Icepak simulation.

Syntax: obj.ScrRunIcepakSimulation(<icepakSimName>, <dcSimName>)

Parameters:
BSTR icepakSimName

BSTR dcSimName

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrRunIcepakSimulation('Icepak 4', 'DC IR Sim 1')

ScrRunInducedVoltageSimulation
Runs a Plane Wave Induced Voltage simulation for one frequency with a single incident wave.

UI Command: Simulation > Compute Induced Voltage.

Syntax:
obj.ScrRunInducedVoltageSimulation(<freq>, <phi>,
<theta>, <e0_phi>, <e0_theta>, <magnitude>)

Parameters:

DOUBLE freq

DOUBLE phi (for incident vector in spherical system)

DOUBLE theta (for incident vector in spherical system)

DOUBLE e0_phi (for polarization vector in XY cartesian system on the
orthogonal plane of the incident vector)

DOUBLE e0_theta (for polarization vector in XY cartesian system on the
orthogonal plane of the incident vector)

DOUBLE magnitude

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrRunInducedVoltageSimulation(1500000, 10, 45, 1,
3, 1)

ScrRunNearFieldSimulation

Note:

Use after ScrSetNearFieldExportDataPath.
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Runs a Near Field simulation.

UI Command: Simulation > Compute Near Field.

Syntax: obj.ScrRunNearFieldSimulation(<freq>, <computeH>)

Parameters:
DOUBLE freq(uency)

INT computeH (obsolete variable; use either 0 or 1)

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrRunNearFieldSimulation(5.0, 0)

ScrRunResonantModeSimulation
Runs a Resonant Modes simulation.

UI Command: Simulation > Compute Resonant Modes.

Syntax: obj.ScrRunResonantModeSimulation()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrRunResonantModeSimulation()
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ScrRunSimulation
Runs the specified simulation.

UI Command: Simulation > [Simulation Type].

Syntax: obj.ScrRunSimulation(<simType>, <simName>)

Parameters:

BSTR simType (choose from: "ac", "dc", "ddrwizard", "eigen", "ff", "nf", "psi_
ac", "psi_syz", "syz", "hfss_syz", "pdn", "cpa", "icepak", "iv", "emi_scan", "em_
mttf", "z0_scan", "crosstalk_scan", "td_crosstalk_scan")

BSTR simName

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrRunSimulation('syz', 'SYZ Sweep 1')

ScrRunSpiceSubcktSimulation
Computes Spice Subcircuit based on a previously run SYZ sweep.

UI Command: Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit.

Syntax: obj.ScrRunSpiceSubcktSimulation()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrRunSpiceSubcktSimulation()

ScrRunSyzParameterSimulation
Computes an SYZ sweep.

UI Command: Simulation > Compute SYZ Parameters.

Syntax: obj.ScrRunSyzParameterSimulation()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrRunSyzParameterSimulation()
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ScrRunValidationCheck
Runs a Validation Check on the current project.

UI Command: Tools > Validation Check.

Syntax: obj.ScrRunValidationCheck

Parameters: None.

Return Value: ARRAY results (number of errors, number of warnings)

PY Example: oDoc.ScrRunValidationCheck()
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ScrRunValidationCheckWithOptions
Runs a Validation Check using specified parameters.

UI Command: Tools > Validation Check.

Syntax:
obj.ScrRunValidationCheckWithOption (<optionArray>,
<simType>)

Parameters:

ARRAY optionArray (0 - deselects an option, 1 - selects an option)

l Self-Intersecting Polygons
l Disjoint Nets (Floating Nodes)
l DC-Short Errors
l Identical/Overlapping Vias
l Bondwire Collisions
l Illegal Bondwire Connections
l Misalignments
l Less Than Two Terminals

INT simType

l 0 – No Associated Simulation
l 1 – Resonant Modes
l 2 – Frequency Sweep
l 3 – SYZ Parameters
l 4 – Far Field
l 5 – Near Field
l 6 – DC Current/Voltage
l 7 – PSI AC or SYZ
l 8 – 3D Export
l 9 – CPA Solution
l 10 – Impedance/Crosstalk Scan

Return Value: None.

PY Example:
oDoc.ScrRunValidationCheckWithOptions
(['1','1','1','1','1','0','1','0'],'3')
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ScrSanitizeLayout
Runs the Sanitize Layout operation on all Power/Ground nets in the project.

UI Command: Tools > Sanitize Layout.

Syntax: obj.ScrSanitizeLayout()

Parameters: None.

Return Value: None.

PY Example: oDoc.ScrSanitizeLayout()

ScrSanitizeNets
Runs the Sanitize Layout operation on specified nets.

UI Command: Tools > Sanitize Layout.

Syntax: obj.ScrSanitizeNets(<netNameList>)

Parameters: ARRAY netNameList (containing strings)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSanitizeNets(['NET-1','NET-2','NET-3'])
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ScrSaveProjectAs
Saves the current project under a different file name.

UI Command: File > Save As.

Syntax: obj.ScrSaveProjectAs(<projName>)

Parameters: BSTR projName (without file extension)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSaveProjectAs
('C:/Users/Ansys/Documents/Ansys/pcb1')

ScrSaveSimulationMessages
Saves messages for a specified simulation in a specified folder.

UI Command: None.

Syntax: obj.ScrSaveSimulationMessages(<simName>,<outFilePath>)

Parameters:
BSTR simName

BSTR outFilePath

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSaveSimulationMessages('Sweep1','C:/FilePath/')

ScrSaveToPngFile
Saves the current modeling workspace as an image file (*.png).

UI Command: None.

Syntax: obj.ScrSaveToPngFile(<fileName>)

Parameters: BSTR fileName (full path with extension)

Return Value: None.

PY Example: oDoc.ScrSaveToPngFile('D:/capture.png')
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ScrSelectDcConnectedNets
Selects all nets and RLCs which form a connection to the specified net.

UI Command: None.

Syntax: obj.ScrSelectDcConnectedNets(<netNameList>)

Parameters: ARRAY netNameList

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSelectDcConnectedNets
(['VCC','GND','Heq','NET-1','NET-2','PWR'])

ScrSelectNet
Selects or deselects a specified net.

UI Command: None.

Syntax: obj.ScrSelectNet(<netName>,<select>)

Parameters:
BSTR netName

INT select (1 selects the net; 0 deselects it)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSelectNet('GND', 1)
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ScrSelectNetsBetweenComponents
Selects all Power/Ground nets and RLCs that form a connection between the specified
components.

UI Command: None.

Syntax:
obj.ScrSelectNetsBetweenComponents(<partname1>,
<refDes1>, <partname2>, <refDes2>)

Parameters:

BSTR partname1

BSTR refDes1

BSTR partname2

BSTR refDes2

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSelectNetsBetweenComponents('288DIMMDDR4_
EDGE_CONN-BASE', 'J1', 'DDR4_X4_FBGA78-10X13,,',
'U1')

ScrSelectNetsBetweenNets
Selects all nets and RLCs that form a connection between the specified nets.

UI Command: None.

Syntax: obj.ScrSelectNetsBetweenNets(<net1>, <net2>)

Parameters:
BSTR net1

BSTR net2

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSelectNetsBetweenNets('VDD', 'GND')
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ScrSeparateDisjointNets
Separates all electrically disjoint nets into independent nets.

UI Command: None.

Syntax: obj.ScrSeparateDisjointNets()

Parameters: None.

Return Value: INT numSeparatedNets

PY Example: oDoc.ScrSeparateDisjointNets()

ScrSet4PtBwProfile
Assigns a 4 point bondwire profile to all bondwires of a given model.

UI Command: None.

Syntax:
obj.ScrSet4PtBwProfile(<modelName>, <h1>, <h2>,
<radius>)

Parameters:

BSTR modelName

DOUBLE h1

DOUBLE h2

DOUBLE radius

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSet4PtBwProfile('WB_PROFILE_1', 100, 200,
20)

Script Commands 2-152

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrSet5PtBwProfile
Assigns a 5 point bondwire profile to all bondwires of a given model.

UI Command: None.

Syntax:
obj.ScrSet5PtBwProfile(<modelName>, <h1>, <h2>,
<radius>, <alpha>, <beta>)

Parameters:

BSTR modelName

DOUBLE h1

DOUBLE h2

DOUBLE radius

DOUBLE alpha

DOUBLE beta

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSet5PtBwProfile('WB_PROFILE_1', 100, 200,
20, 85, 5)
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ScrSetAntiPadOnLayer
Adds or changes a given padstack's antipads. Can also be used to delete antipads.

Note: If an antipad already exists, the script alters it. If one does not exist, the script creates one.

UI Command: None.

Syntax:
obj.ScrSetAntiPadOnLayer(<padstackName>,
<layerName>, <shapeName>, <widthString>,
<heightString>)

Parameters:

BSTR padstackName

layerName

shapeName ("None" to delete an antipad; otherwise, "Circle", "Oblong", or
"Rectangle")

widthString (including unit of measure)

heightString (including unit of measure)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetAntiPadOnLayer('VIA_M1_M2', 'METAL-1',
'Rectangle', '0.1cm', '0.1cm')

Script Commands 2-154

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrSetBwModel
Sets the given model to bondwires

UI Command: None.

Syntax: obj.ScrSetBwModel(<bwIndexArray>, <bwModelName>)

Parameters:
ARRAY bwIndexArray

BSTR bwModelName

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetBwModel(bwList, 'WB_profile_1')

ScrSetBwSuppLayer
Sets the support layer of given bondwires.

UI Command: None.

Syntax:
obj.ScrSetBwSuppLayer(<bwIndexArray>,
<suppLayerName>)

Parameters:
ARRAY bwIndexArray

BSTR suppLayerName

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetBwSuppLayer(bwList, 'CU-1')
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ScrSetBwTermLayer
Sets the termination layer of given bondwires.

UI Command: None.

Syntax:
obj.ScrSetBwTermLayer(<bwIndexArray>,
<termLayerName>)

Parameters:
ARRAY bwIndexArray

BSTR termLayerName

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetBwTermLayer(bwList, 'WB_loop2')
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ScrSetCapacitorDcBiasDeratingSim
Opens Set Capacitor Temperature and DC Bias Voltage window and select simulation for
DC bias derating.

UI Command: Click Simulation >Options > Use bias voltage computed by DC IR
simulation. Select simulation.

Syntax:
obj.ScrSetCapacitorDcBiasDeratingSim
(<simulationName>)

Parameters: BSTR simulationName

Return Value:

INT

l 1 – Failure
l 0 – Success

PY Example:
oDoc.ScrSetCapacitorDcBiasDeratingSim('Simulation
Name')
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ScrSetCapacitorTemperatureDeratingSim
Opens Set Capacitor Temperature and DC Bias Voltage window and select simulation for
temperature derating.

UI Command: Click Simulation >Options > Use temperature computed by Icepak
simulation. Select simulation.

Syntax:
obj.ScrSetCapacitorTemperatureDeratingSim
(<simulationName>)

Parameters: BSTR simulationName

Return Value:

INT

l 1 – Failure
l 0 – Success

PY Example:
oDoc.ScrSetCapacitorTemperatureDeratingSim
('Simulation Name')

ScrSetConformalCoatLayers
Introduce or remove conformal coating (a set of dielectric layers on the top and bottom of
every package and PCB in the design).

These layers have a default material of "SolderMask" and a default thickness of 15 microns.

UI Command: None.

Syntax: obj.ScrSetConformalCoatLayers(<setConformalCoat>)

Parameters: INT setConformalCoat (1 = add conformal coat layers, 0 = remove all
conformal coat layers)

Return Value: INT number of layers changed, added, or removed.

PY Example: oDoc.ScrSetConformalCoatLayers(1)

ScrSetCrosstalkScanParameters
Specifies the parameters for running a Crosstalk Scan via ScrRunSimulation.

UI Command: Simulation > Crosstalk Scan > Frequency Domain. Set values for the
solver options.

Syntax:

obj.ScrSetCrosstalkScanParameters
(<FEXTWarningLevel>, <FEXTViolationThreshold>,
<NEXTWarningLevel>, <NEXTViolationThreshold>,
<freq>, <minTraceLengthInMM>)

Parameters:
DOUBLE FEXTWarningLevel

DOUBLE FEXTViolationThreshold
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Specifies the parameters for running a Crosstalk Scan via ScrRunSimulation.

DOUBLE NEXTWarningLevel

DOUBLE NEXTViolationThreshold

DOUBLE freq

DOUBLE minTraceLengthInMM

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetCrosstalkScanParameters(15, 30, 12, 24,
1000000000, 1.2)

ScrSetCrossTalkThreshold
Specifies the cross-talk threshold to use when determining which structures are coupled, in
dB.

UI Command: Click Simulation >Options to open the SIwave Options window. Click SI/PI
Advanced tab and enter a value in the Cross-talk threshold box.

Syntax: obj.ScrSetCrossTalkThreshold(<xtalkInDb>)

Parameters: DOUBLE xtalkInDb (specified value MUST be negative)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetCrossTalkThreshold(-60.0)

ScrSetDcMinPlaneAreaToMesh
For DC IR simulations, sets the minimum plane area to be meshed.

UI Command: Simulation >Options > SI/PI Advanced. Enter a value in the Ignore planes
smaller than field.

Syntax:
obj.ScrSetDcMinPlaneAreaToMesh
(<minPlaneAreaToMesh>)

Parameters: BSTRminPlaneAreaToMesh (including unit of measure)

Return Value: None.

PY Example: oDoc.ScrSetDcMinPlaneAreaToMesh('5669.2mil2')

ScrSetDcMinVoidAreaToMesh
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For DC IR simulations, sets the minimum void area to be meshed.

UI Command: Simulation >Options > DC Advanced. Enter a value in the Ignore voids
smaller than field.

Syntax:
obj.ScrSetDcMinVoidAreaToMesh
(<dcMinVoidAreaToMesh>)

Parameters: BSTR dcMinVoidAreaToMesh (including unit of measure)

Return Value: None.

PY Example: oDoc.ScrSetDcMinVoidAreaToMesh('3199.01mil2')

ScrSetDcPowerDataThresholds
For DC IR simulations, sets the minimum thermal cell size and minimum power per cell.

Note: These settings are no longer visible in SIwave, and are only applicable for exporting data
for Icepak in an old format.

UI Command: None.

Syntax:
obj.ScrSetDcPowerDataThresholds
(<minThermCellSizeInUm>,<minPwrLossPerCellInMilliwatts)

Parameters:
DOUBLE minThermCellSizeInUm

DOUBLE minPwrLossPerCellInMilliwatts

Return Value: None.

PY Example: oDoc.ScrSetDcPowerDataThresholds(12.0, 1.75)

ScrSetDieElevation
Sets a specified die's elevation.

UI Command: Advanced > Die Stackup.

Syntax: obj.ScrSetDieElevation(<dieName>,<elevation>)

Parameters:
BSTR dieName

DOUBLE elevation

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetDieElevation('DIE_1', 100.0)
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ScrSetDieThickness
Sets a specified die's thickness.

UI Command: Advanced > Die Stackup.

Syntax: obj.ScrSetDieThickness(<dieName>,<thickness>)

Parameters:
BSTR dieName

DOUBLE thickness

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetDieThickness('DIE_1', 100.0)
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ScrSetEmiScannerParameters
Sets the parameters for running an EMI scan via ScrRunSimulation.

If this function is not called, the scan runs with the EMI parameters already set in the file.

If none are set, the scan runs using the default "EM Rules" with auto-tagging.

UI Command: Simulation > EMI Scanner.

Syntax:
obj.ScrSetEmiScannerParameters
(<rulesXmlFilenameWithPath>, <rulesProfileIndex>,
<tagsXmlFilenameWithPath>)

Parameters:

BSTR rulesXmlFilenameWithPath (If rulesXmlFilenameWithPath is left an
empty string, rulesProfileIndex is used)

INT rulesProfileIndex, where:

l 0 – Rules file specified by <rulesXmlFilenameWithPath>
l 1 – EM Rules – [install_dir]/config/EMIScanner/Defaults/EM_emsat.xml
l 2 – SI Rules – [install_dir]/config/EMIScanner/Defaults/SI_emsat.xml
l 3 – EM+SI Rules – [install_dir]/config/EMIScanner/Defaults/EM_SI_
emsat.xml

l 4 – Rules (0-100MHz) – [install_dir]/config/EMIScanner/Defaults/EMSAT-
STGprofile-000-100Mb.cfg

l 5 – Rules (100MHz-500MHz) – [install_
dir]/config/EMIScanner/Defaults/EMSAT-STGprofile-100-500Mb.cfg

l 6 – Rules (500MHz-1000MHz) – [install_
dir]/config/EMIScanner/Defaults/EMSAT-STGprofile-500-1000Mb.cfg

l 7 – Rules (1GHz+) – [install_dir]/config/EMIScanner/Defaults/EMSAT-
STGprofile-1Gb-and-higher.cfg

BSTR tagsXmlFilenameWithPath

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetEmiScannerParameters
('C:/Projects/rules.xml', 0,
'C:/Projects/tags.tgs')
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ScrSetEnergyErrorPercentInDcSimulation
For DC IR simulations, sets the minimum void area to be meshed.

UI Command: Simulation >Options > DC Advanced. Enter a value in the Energy Error
field.

Syntax:
obj.ScrSetEnergyErrorPercentInDcSimulation
(<energyErrorPercent>)

Parameters: DOUBLE energyErrorPercent

Return Value: None.

PY Example: oDoc.ScrSetEnergyErrorPercentInDcSimulation('5.1')

ScrSetExternalExcitations
Directs SIwave to use external (non-linear) excitation files containing current or voltage source
frequency response data.

UI Command:

From the Simulationmenu, click either Compute Frequency Sweep,
Compute Far Field, or Compute Near Field. Select the Use sources
defined in an external file check box and specify the source of the
excitations.

Syntax: obj.ScrSetExternalExcitations(<filePath>)

Parameters: BSTR filePath

Return Value: None.

PY Example: oDoc.ScrSetExternalExcitations('C:/sources.txt')
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ScrSetFarFieldSimOptions
Sets options for Far Fields simulations.

UI Command: Simulation > Compute Far Field. Set Phi and Theta options.

Syntax:
obj.ScrSetFarFieldSimOptions(<phiStart>, <phiStop>,
<phiStepSize>, <thetaStart>, <thetaStop>,
<thetaStepSize>)

Parameters:

DOUBLE phiStart

DOUBLE phiStop

INT phiStepSize

DOUBLE thetaStart

DOUBLE thetaStop

INT thetaStepSize

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetFarFieldSimOptions(0, 360, 10, 0, 180,
10)

ScrSetFwsColFitOptions
Controls FWS Sub-circuit column fitting options.

UI Command:
Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Specify Column
Fitting options.

Syntax: obj.ScrSetFwsColFitOptions(<option>)

Parameters:

INT option, where:

l 0 – One matrix entry at a time
l 1 – One matrix column at a time

Return Value: None.

PY Example: oDoc.ScrSetFwsColFitOptions(0)
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ScrSetFwsLaunchDesignerNexxim
After computing a Full Wave SPICE Subcircuit, opens the results in Electronics Desktop.

UI Command: None.

Syntax: obj.ScrSetFwsLaunchDesignerNexxim(<launch>)

Parameters: INT launch (1 = launch; 0 = do not launch)

Return Value: None.

PY Example: oDoc.ScrSetFwsLaunchDesignerNexxim(1)

ScrSetFwsPassivityAlg
Controls FWS Sub-circuit Full Wave SPICE export passivity options.

UI Command:
Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Select passivity
enforcement options.

Syntax: obj.ScrSetFwsPassivityAlg(<option>)

Parameters:

INT option, where:

l 0 – Do not enforce passivity
l 1 – Passivity enforcement through convex optimization
l 2 – Passivity enforcement by perturbation
l 3 – Passivity enforcement by IFPV (iterative fitting of passivity violations)

Return Value: None.

PY Example: oDoc.ScrSetFwsPassivityAlg(0)

Script Commands 2-165

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrSetFwsPortRefZ
For Full Wave SPICE, sets whether port reference impedances are to be renormalized and, if
so, specifies reference impedance.

UI Command:

Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Enter a value in
the Renormalize all S-parameters to __ ohms before generating model
option.

Syntax: obj.ScrSetFwsPortRefZ(renormalize, refZ)

Parameters:

BOOL renormalize, where:

l TRUE – Renormalize
l FALSE – Do not renormalize

DOUBLE refZ (reference impedence, value ignored if renormalize = FALSE)

Return Value: None.

PY Example: oDoc.ScrSetFwsPortRefZ(True, 75.0)

ScrSetFwsPzOptions
For Full Wave SPICE, sets pole/zero fitting options.

UI Command:

Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Select the options
in the HSPICE/Spectre Pole/Zero Fitting Options box for the fitting error
tolerance, and maximum pole/zero order.

Syntax: obj.ScrSetFwsPzOptions(<fitError>, <maxOrder>)

Parameters:
DOUBLE fitError (fitting error tolerance)

INT maxOrder (maximum pole/zero order)

Return Value: None.

PY Example: oDoc.ScrSetFwsPzOptions(0.001, 200)
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ScrSetFwsSsfAlg
For Full Wave SPICE, specifies State-Space Fitting Algorithm options.

UI Command:
Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Specify State-
Space Fitting Algorithm options.

Syntax: obj.ScrSetFwsSsfAlg(<algorithm>)

Parameters:

INT algorithm, where:

l 0 – TWS
l 1 – Iterative Rational Function

Return Value: None.

PY Example: oDoc.ScrSetFwsSsfAlg(0)

ScrSetFwsSubcktFormat
Specifies the full-wave Spice subcircuit format for export.

UI Command:
Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Select the Spice
subcircuit format from the Full Wave Spice Subcircuit Format box.

Syntax: obj.ScrSetFwsSubcktFormat(<format>)

Parameters:

INT format, where:

l 0 – HSPICE-compatible format
l 1 – Maxwell Spice compatible format
l 2 – PSPICE compatible format
l 3 – Cadence Spectre compatible format
l 4 – Nexxim S-element format
l 5 – State space model
l 6 – Simplorer model

Return Value: None.

PY Example: oDoc.ScrSetFwsSubcktFormat(0)
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ScrSetFwsUseCommonGround
For full-wave Spice subcircuit generation, specifies whether to use a common ground for all
ports.

UI Command:
Click Results > [Simulation Name] > Compute FWS Sub-circuit to open
the Compute Full Wave SPICE Subcircuit window. Select the Use
common ground for Spice output check box.

Syntax: obj.ScrSetFwsUseCommonGround(<useCommonGround>)

Parameters:

BOOL, where:

l FALSE – Do not use common ground.
l TRUE – Use common ground.

Return Value: None.

PY Example: oDoc.ScrSetFwsUseCommonGround(True)

ScrSetHFSS3DLayoutSimOptions
Imports simulation settings for an HFSS 3D Layout Simulation.

UI Command: Click Simulation > HFSS 3D Layout. Click Import Settings and select a file.

Syntax: obj.ScrSetHFSS3DLayoutSimOptions(<filename>)

Parameters: BSTR filename (full file path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetHFSS3DLayoutSimOptions
('c:/simsettings.dss')
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ScrSetHpcLicenseType
Sets the HPC license type.

Important: Use ScrSetHpcLicenseVendor to choose license vendor.

UI Command: Simulation >Options. On theMultiprocessing tab, select Use
HPC licensing and eitherWorkgroup (formerly 'Pool') or Pack.

Syntax: obj.ScrSetHpcLicenseType(<licenseType>)

Parameters: BSTR licenseType ('workgroup' or 'pack'; case insensitive; use 'mp' to
deselect Use HPC licensing)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetHpcLicenseType('pack')

ScrSetHpcLicenseVendor
Sets the HPC license vendor.

Important: Use ScrSetHpcLicenseType to choose license type.

UI Command:
Simulation >Options. On theMultiprocessing tab, select Use
HPC licensing and either Use Ansys HPC licenses or Use
legacy Electronics HPC licenses.

Syntax: obj.ScrSetHpcLicenseVendor(<vendor>)

Parameters: BSTR vendor ('ansys' or 'electronics', case insensitive)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetHpcLicenseVendor('Electronics')
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ScrSetIcepakBoardOutlineFidelity
Specifies the minimum edge length when modifying the board outline for export to Icepak. This
minimum edge length is used when discretizing arcs into a series of straight lines and when
simplifying the outline to remove very small edges.

UI Command: None.

Syntax: obj.ScrSetIcepakBoardOutlineFidelity(<distInMM>)

Parameters: DOUBLE distInMM

Return Value:

INT

l 0 – Success
l 1 – Specified distance is too small

PY Example: oDoc.ScrSetIcepakBoardOutlineFidelity(1.5)

ScrSetIcepakCabinetDimensions
Configures the cabinet settings for Icepak convection simulations.

UI Command: None.

Syntax:
obj.ScrSetIcepakCabinetDimensions
(<horizPadPercent>, <vertAbovePadPercent>,
<vertBelowPadPercent>)

Parameters:

DOUBLE horizPadPercent

DOUBLE vertAbovePadPercent

DOUBLE vertBelowPadPercent

Return Value:

INT:

l 0 – Success
l 1 – Specified percentages are invalid.

PY Example:
oDoc.ScrSetIcepakCabinetDimensions(35.0, 125.0,
55.0)
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ScrSetIcepakComponentConfig
Selects a component settings file to use for Icepak convection simulations.

UI Command: None.

Syntax: obj.ScrSetIcepakComponentConfig(<fileName>)

Parameters: BSTR fileName (full file path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetIcepakComponentConfig
('D:/Tests/IcepakScriptTest.pwrd')

ScrSetIcepakMeshingDetail
Sets the meshing detail level for Icepak simulations.

UI Command: None.

Syntax: obj.ScrSetIcepakMeshingDetail(<meshLevel>)

Parameters: BSTR meshLevel

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrSetIcepakMeshingDetail('basic')
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ScrSetIcepakSimReportImageHeight
When generating Icepak reports or Icepak report data in a DC report, specifies the resolution
(in pixels) of the smaller dimension of the images. For designs where the board is wider than it
is tall, this corresponds to the y-resolution of the image.

UI Command: None.

Syntax: obj.ScrSetIcepakSimReportImageHeight(<imgHeight>)

Parameters: LONG imgHeight

Return Value:

BOOL

l 0 – Failure (invalid height)
l 1 – Success

PY Example: oDoc.ScrSetIcepakSimReportImageHeight(1024)

ScrSetIcepakTemperatureFile
Specifies an external Icepak solution file (*.sitemp) for use in specifying temperature for a DC
simulation.

UI Command: Simulation > Compute DC IR. Select Import temperature map from
Icepak. Select External .sitemp file. Click Browse and select file.

Syntax: obj.ScrSetIcepakTemperatureFile(<sitempFilename>)

Parameters: BSTR sitempFilename (full file path)

Return Value:

BOOL

l 0 – Failure (file does not exist)
l 1 – Success

PY Example: oDoc.ScrSetIcepakTemperatureFile('d:/abcd.sitemp')
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ScrSetIcepakThermalEnv
Sets the thermal environment settings to use for Icepak simulations.

UI Command: Simulation > Icepak. Select an appropriate settings.

Syntax:

obj.ScrSetIcepakThermalEnv(<convection>,
<forcedAir>, <topOrAmbientTempC>,
<topOrOverallFlowDir>, <topOrOverallFlowSpeed>,
<bottomTempC>, <bottomFlowDir>, <bottomFlowSpeed>,
<gravVecX>, <gravVecY>, <gravVecZ>)

Parameters:

BOOL convection (TRUE = convection; FALSE = conduction)

BOOL forcedAir (TRUE = forced convection; FALSE = natural convection)

DOUBLE topOrAmbientTempC (temperature above PCB, in Celsius)

BSTR topOrOverallFlowDir (flow direction above PCB)

DOUBLE topOrOverallFlowSpeed (flow speed above PCB)

DOUBLE bottomTempC (temperature below PCB, in Celsius)

BSTR bottomFlowDir (flow direction below PCB)

DOUBLE bottomFlowSpeed (flow speed below PCB)

DOUBLE gravVecX (gravity vector x for natural convection)

DOUBLE gravVecY (gravity vector y for natural convection)

DOUBLE gravVecZ (gravity vector z for natural convection)

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example:
oDoc.ScrSetIcepakThermalEnv(True, True, 22.3, '+Y',
2.5, 0.0, '', 0.0, 0.0, 0.0, 0.0)
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ScrSetIdealGroundNodeInDcSimulation
For a DC IR simulation, sets the Ideal Ground Node (the precise 0V).

IMPORTANT: This script should be called before running a DC solve using
ScrRunDcSimulation or ScrRunSimulation with tag dc.

UI Command: Simulation > Compute DC IR. Select an ideal ground node.

Syntax:
obj.ScrSetIdealGroundNodeInDcSimulation(<circuit_
element_name>, <node_type_id>)

Parameters:

BSTR circuit_element_name (name of the circuit element in the design on
which the ideal ground is)

INT node_type_id (which terminal of the circuit element is ideal ground),
where:

l 0 – Neither Terminal
l 1 – Negative Terminal
l 2 – Positive Terminal

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetIdealGroundNodeInDcSimulation('VU6', 1)
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ScrSetInducedVoltageMultipleIncidenceSpherical
For a Plane Wave Induced Voltage simulation with multiple incident waves specified in
spherical system having a sweep of phi & theta angles and the polarization, specified as either
having 1 on X or 1 on Y or both, on the orthogonal plane of every incidence vector.

IMPORTANT: This script and ScrAppendSweep should be called before running a Plane Wave
Induced Voltage solve using ScrRunSimulation with tag iv.

UI Command: Simulation > Compute Induced Voltage. Specify settings.

Syntax:

obj.ScrSetInducedVoltageMultipleIncidenceSpherical
(<phi_start>, <phi_stop>, <phi_step>, <theta_
start>, <theta_stop>, <theta_step>, <phi_checked>,
<theta_checked>, <save_for_all_angles>,
<Magnitude>)

Parameters:

DOUBLE phi_start (for sweep in phi)

DOUBLE phi_stop (for sweep in phi)

DOUBLE phi_step (for sweep in phi)

DOUBLE theta_start (for sweep in theta)

DOUBLE theta_stop (for sweep in theta)

DOUBLE theta_step (for sweep in theta)

DOUBLE e0_phi (polarization for phi sweep)

DOUBLE e0_theta (polarization for theta sweep)

INT save_for_all_angles (1 = save; 0 = do not save)

DOUBLE magnitude

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetInducedVoltageMultipleIncidenceSpherical
(0, 20, 5, 90, 105, 5, 0, 0, 0, 1)
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ScrSetInducedVoltageSingleIncidenceCartesian
For a Plane Wave Induced Voltage simulation with a single incident wave and polarization both
specified in cartesian system on the XYZ plane. The incident wave vector and the polarization
vector should be orthogonal. This is tested by verifying if the dot product of the vectors leads
to zero.

IMPORTANT: This script and ScrAppendSweep should be called before running a Plane Wave
Induced Voltage solve using ScrRunSimulation with tag iv.

UI Command: Simulation > Compute Induced Voltage. Specify settings.

Syntax:
obj.ScrSetInducedVoltageSingleIncidenceCartesian
(<incidence_x>, <incidence_y>, <incidence_z>, <e0_
x>, <e0_y>, <e0_z>, <e0_magnitude>)

Parameters:

DOUBLE incidence_x (for incident vector)

DOUBLE incidence_y (for incident vector)

DOUBLE incidence_z (for incident vector)

DOUBLE e0_x (for polarization vector)

DOUBLE e0_y (for polarization vector)

DOUBLE e0_z (for polarization vector)

DOUBLE e0_magnitude

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetInducedVoltageSingleIncidenceCartesian
(1, 0, 0, 0, 1, 1, 1)
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ScrSetInducedVoltageSingleIncidenceSpherical
For a Plane Wave Induced Voltage simulation with a single incident wave specified in spherical
system (degrees) and polarization specified as a XY vector on the orthogonal plane of
incidence vector.

IMPORTANT: This script and ScrAppendSweep should be called before running a Plane Wave
Induced Voltage solve using ScrRunSimulation with tag iv.

UI Command: Simulation > Compute Induced Voltage. Specify settings.

Syntax:
obj.ScrSetInducedVoltageSingleIncidenceSpherical
(<phi>, <theta>, <e0_phi>, <e0_theta>, <e0_
magnitude>)

Parameters:

DOUBLE phi (for incident vector)

DOUBLE theta (for incident vector)

DOUBLE e0_phi (for polarization vector)

DOUBLE e0_theta (for polarization vector)

DOUBLE e0_magnitude

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetInducedVoltageSingleIncidenceSpherical
(10, 45, 1, 3, 1)
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ScrSetInfiniteGroundPlaneLocation
Introduces an infinite ground plane the specified distance below the bottom layer.

UI Command: Simulation >Options > SI/PI Advanced. Select Introduce infinite ground
plane and enter a value in mils.

Syntax: obj.ScrSetInfiniteGroundPlaneLocation(<elev>)

Parameters: DOUBLE elev

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetInfiniteGroundPlaneLocation('3.1')

ScrSetLayerMaterial
Assigns a specified material to a specified layer.

UI Command: Home > Layer stackup Editor. Click Edit Layer Properties. Select a
material from theMaterial drop-down menu.

Syntax:
obj.ScrSetLayerMaterial(<layerNameBstr>,
<layerMaterialBstr>)

Parameters:
BSTR layerNameBstr

BSTR layerMaterialBstr

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetLayerMaterial('SURFACE', 'copper')
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ScrSetLayerThickness
Changes the thickness of a specified layer. The thickness value must be in the project's
underlying length units.

UI Command: Home > Layer stackup Editor. Click Edit Layer Properties. Enter the
thickness in the Thickness field.

Syntax:
obj.ScrSetLayerThickness(<layerNameBstr>,
<thickness>, <redraw>)

Parameters:

BSTR layerNameBstr

DOUBLE thickness

BOOL redraw (TRUE = redraw; FALSE = do not redraw)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetLayerThickness('SURFACE', 0.035, True)

ScrSetLayerType
Sets a specified layer's type.

UI Command: Home > Layer stackup Editor. Select the layer you want to update. Then
select a material type from the Type drop-down menu.

Syntax: obj.ScrSetLayerType(<layerName>, <layerTypeIndex>)

Parameters:

BSTR layerName

INT layerTypeIndex, where:

l 0 – Dielectric
l 1 – Metal
l 2 –Wirebond

Return Value: None.

PY Example: oDoc.ScrSetLayerType('layer name', 1)

ScrSetLayerVisibility
Sets the visibility of the specified layer, or of specific object types on that layer.

UI Command: Select a layer in the Layers Workspace. Turn on visibility for the layer or for
specific object types using the check boxes.

Syntax:
obj.ScrSetLayerVisibility(<layerNameBstr>,
<planeVis>, <traceVis>, <padVis>, <viaVis>,
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Sets the visibility of the specified layer, or of specific object types on that layer.

<cktElemVis>)

Parameters:

BSTR layerNameBstr

BOOL planeVis (TRUE = planes visible; FALSE = planes not visible)

BOOL traceVis (TRUE = traces visible; FALSE = traces not visible)

BOOL padVis (TRUE = pads visible; FALSE = pads not visible)

BOOL viaVis (TRUE = vias visible; FALSE = vias not visible)

BOOL cktElemVis (TRUE = circuit elements visible; FALSE = circuit elements
not visible)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetLayerVisibility('L1', True, True, True,
True, False)
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ScrSetLayoutLengthUnit
Sets the layout length unit.

UI Command: None.

Syntax: obj.ScrSetLayoutLengthUnit <unitName>

Parameters: BSTR unitName ("microns", "um", "mils", "mm", "cm", "inches", or "meters")

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetLayoutLengthUnit('um')

ScrSetLocalRefinementPercentInDcSimulation
For a DC IR simulation, sets the local refinement percentage.

UI Command: Simulation >Options > DC Advanced. Enter a value in the Local
Refinement field.

Syntax:
obj.ScrSetLocalRefinementPercentInDcSimulation
(<localRefinePercent>)

Parameters: DOUBLE localRefinePercent

Return Value: None.

PY Example: oDoc.ScrSetLocalRefinementPercentInDcSimulation(20)

ScrSetLogFreqPointDist
Sets the distribution type for frequency sweeps.

UI Command: None.

Syntax: obj.ScrSetLogFreqPointDist(<flag>)

Parameters: INT flag (1 = log-based frequency distribution; 0 = linear distribution)

Return Value: None.

PY Example: oDoc.ScrSetLogFreqPointDist(1)
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ScrSetLowBwProfile
Sets low bondwire profile to all bondwires of a specified model.

UI Command: None.

Syntax:
obj.ScrSetLowBwProfile(<bwModelName>, <h1>, <h2>,
<radius>, <alpha>, <beta>, <units>)

Parameters:

BSTR bwModelName

DOUBLE h1

DOUBLE h2

DOUBLE radius

DOUBLE alpha

DOUBLE beta

BSTR units

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetLowBwProfile('WB_PROFILE_1', 100, 200,
20, 85, 5, 'mm')

ScrSetMaxRefinePassesInDcSimulation
Sets the maximum number of mesh refinement passes for DC IR drop simulations.

UI Command:
Simulation > Compute DC IR. ClickOther solver options button and
choose the DC Advanced tab. From the Adaptive Mesh Refinement
Parameters group, type a value in theMaximum Number of Passes box.

Syntax:
obj.ScrSetMaxRefinePassesInDcSimulation
(<maxPasses>)

Parameters: INT maxPasses

Return Value: None.

PY Example: oDoc.ScrSetMaxRefinePassesInDcSimulation(5)
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ScrSetMeshBondwiresInDcSimulation
Sets the Mesh Bondwires setting.

UI Command: Simulation >Options. Click DC Advanced tab and selectMesh Bondwires
check box.

Syntax: obj.ScrSetMeshBondwiresInDcSimulation(<meshBws>)

Parameters: BOOL meshBws (TRUE = mesh bondwires; FALSE = do not mesh bondwires)

Return Value: None.

PY Example: oDoc.ScrSetMeshBondwiresInDcSimulation(1)

ScrSetMeshViasInDcSimulation
Specifies whether to mesh vias during DC IR drop simulations.

UI Command: Simulation > Compute DC IR. ClickOther solver options button and
choose the DC Advanced tab. Select Mesh Vias.

Syntax: obj.ScrSetMeshViasInDcSimulation(<meshVias>)

Parameters: BOOL meshVias (TRUE = mesh vias; FALSE = do not mesh vias)

Return Value: None.

PY Example: oDoc.ScrSetMeshViasInDcSimulation(True)
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ScrSetMetalLayerFillerMaterial

Assigns a specified filler material to a specified metal layer.

UI Command: Home > Layer Stackup Editor. Select metal layer and change Dielectric
Fill.

Syntax:
obj.ScrSetMetalLayerFillerMaterial(<layerNameBstr>,
<layerFillerMaterialBstr>)

Parameters:
BSTR layerNameBstr

BSTR layerFillerMaterialBstr

Return Value:

BOOL

0 – Failure

1 – Success

PY Example:
oDoc.ScrSetMetalLayerFillerMaterial('SURFACE', 'FR-
4')

ScrSetMinCutoutArea
Controls the cutout defeaturing area threshold; all cutouts below this value are ignored during
simulations.

This function is not applicable to DC IR drop simulations, during which all salient geometry is
meshed and simulated (no cutouts are defeatured).

UI Command: Simulation >Options. Enter the area threshold in the Do not explicitly
mesh any voids than field.

Syntax: obj.ScrSetMinCutoutArea(<minVoidArea>, <unitsBstr>)

Parameters:
DOUBLE minVoidArea

BSTR unitsBstr

Return Value: None.

PY Example: oDoc.ScrSetMinCutoutArea(10, 'mm')
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ScrSetMinPadAreaToMesh
Sets the minimum pad area for meshing.

UI Command: Simulation >Options > SI/PI Advanced. Enter a value in the Explicitly
mesh pads larger than field.

Syntax: obj.ScrSetMinPadAreaToMesh(<minPadAreaToMesh>)

Parameters: BSTRminPadAreaToMesh (including unit of measure)

Return Value: None.

PY Example: oDoc.ScrSetMinPadAreaToMesh('112000mil2')

ScrSetMinPlaneAreaToMesh
Sets the minimum plane area for meshing.

UI Command: Simulation >Options > SI/PI Advanced. Enter a value in the Ignore planes
smaller than field.

Syntax: obj.ScrSetMinPlaneAreaToMesh(<minPlaneAreaToMesh>)

Parameters: BSTRminPlaneAreaToMesh (including unit of measure)

Return Value: None.

PY Example: oDoc.ScrSetMinPlaneAreaToMesh('5769.2mil2')

ScrSetMinRefinePassesInDcSimulation
Sets the minimum number of mesh refinement passes for DC IR drop simulations.

UI Command:
Simulation > Compute DC Current/Voltage. From the Adaptive Mesh
Refinement Parameters group, type a value in theMinimum Number of
Passes field.

Syntax:
obj.ScrSetMinRefinePassesInDcSimulation
(<minPasses>)

Parameters: INT minPasses

Return Value: None.

PY Example: oDoc.ScrSetMinRefinePassesInDcSimulation(1)
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ScrSetNearFieldExportDataPath

For Near Field simulations, sets an export directory for Near Field data in *.and or *.nfd format.

UI Command:
Simulation > Compute Near Field. Beneath the Near Field Solver Options,
area, check the box and navigate to an appropriate directory to save the
exported data.

Syntax: obj.ScrSetNearFieldExportDataPath('[User-selected
directory path]')

Parameters: BSTR export path (output file name with complete path)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetNearFieldExportDataPath('D:/NF_
export.and')

Note:

Use before ScrRunNearFieldSimulation.
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ScrSetNearFieldMeshingFrequencyDefault
For Near Field simulations, selects the Default meshing frequency.

UI Command: Simulation > Compute Near Field. ForMeshing Frequencies for the
Observation Mesh, select Default.

Syntax: obj.ScrSetNearFieldMeshingFrequencyDefault()

Parameters: None.

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetNearFieldMeshingFrequencyDefault()

ScrSetNearFieldMeshingFrequencyPoints
For Near Field simulations, selects the Points meshing frequency.

UI Command: Simulation > Compute Near Field. ForMeshing Frequencies for the
Observation Mesh, select Points and enter values.

Syntax:
obj.ScrSetNearFieldMeshingFrequencyPoints
(<freqPoints>)

Parameters: ARRAY freqPoints (contains strings in ascending order; uses Hz)

Return Value:

INT

l 1 – Success
l 2 – Array values aren't strings
l 3 – One or more strings wasn't fully numeric
l 4 – Duplicate value or bad order

PY Example:
oDoc.ScrSetNearFieldMeshingFrequencyPoints
(['5e+10','1e+11','1.2e+11'])
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ScrSetNearFieldMeshingFrequencyRange
For Near Field simulations, selects the Range meshing frequency.

UI Command: Simulation > Compute Near Field. ForMeshing Frequencies for the
Observation Mesh, select Points and enter values.

Syntax:
obj.ScrSetNearFieldMeshingFrequencyRange
(<startFreq>,<stopFreq>)

Parameters:
DOUBLE startFreq (in Hz)

DOUBLE stopFreq (in Hz)

Return Value:

INT

l 1 – Success
l Else – Error

PY Example:
oDoc.ScrSetNearFieldMeshingFrequencyRange
(5e+10,1e+11)

ScrSetNearFieldSamplePointSpacing
Modifies the "Maximum Edge Length" option for Near Field simulations.

UI Command: Simulation > Compute Near Field. SetMaximum Edge Length.

Syntax: obj.ScrSetNearFieldSamplePointSpacing(<spacing>)

Parameters: DOUBLE spacing (in the project's native units)

Return Value:

BOOL:

l 0 – Failure (spacing too small)
l 1 – Success

PY Example: oDoc.ScrSetNearFieldSamplePointSpacing(132.034)
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ScrSetNearFieldSolverOptions
For Near Field simulations, sets options for number of passes and error tolerance.

UI Command:
Simulation > Compute Near Field. Under Near Field Solver Options, enter
values forMin. Adapt Passes,Max. Adapt Passes, and Global Error
Tolerance.

Syntax:
obj.ScrSetNearFieldSolverOptions(<minAdaptPasses>,
<maxAdaptPasses>, <gErrorTol>)

Parameters:

INT minAdaptPasses

INT maxAdaptPasses

DOUBLE gErrorTol

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetNearFieldSolverOptions(1, 10, 0.5)
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ScrSetNearFieldSurfaceOffset
Controls the position of the surface over which near fields are computed. The positions are
offset values in the design's length units with respect to the design's bounding cuboid.

UI Command: Simulation > Compute Near Field. Enter offset values in the Cuboid
Surface Positions box.

Syntax:
obj.ScrSetNearFieldSurfaceOffset(<px>, <nx>, <py>,
<ny>, <pz>, <nz>)

Parameters:

DOUBLE px (positive x)

DOUBLE nx (negative x)

DOUBLE py (positive y)

DOUBLE ny (negative y)

DOUBLE pz (positive z)

DOUBLE nz (negative z)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetNearFieldSurfaceOffset(1.0, 1.0, 1.0,
1.0, 1.0, 1.0)

Script Commands 2-190

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

ScrSetNumBondwireSidesInDcSimulation
For DC IR simulations, sets the number of Bondwire sides.

UI Command: Simulation >Options. On DC Advanced tab, set number for
Bondwire Discretization.

Syntax:
obj.ScrSetNumBondwireSidesInDcSimulation
(<numBwSides>)

Parameters: INT numBwSides

Return Value: None.

PY Example: oDoc.ScrSetNumBondwireSidesInDcSimulation(12)

ScrSetNumCpusToUse
Sets the number of CPUs (cores) to use during simulation.

UI Command: Simulation >Options. ClickMultiprocessing. Select the Number of CPUs
to use when computing solution.

Syntax: obj.ScrSetNumCpusToUse(<numCpus>)

Parameters: INT numCpus

Return Value: None.

PY Example: oDoc.ScrSetNumCpusToUse(4)

ScrSetNumModesToCompute
Sets the number of modes to solve for during resonant simulations.

UI Command: Simulation > Compute Resonant Modes. Enter a value in the # of Modes
to Compute field.

Syntax: obj.ScrSetNumModesToCompute(<numModes>)

Parameters: INT numModes

Return Value: None.

PY Example: oDoc.ScrSetNumModesToCompute(10)
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ScrSetNumViaSidesInDcSimulation
Sets the number of sides to use when generating polyhedral mesh approximations to
cylindrical vias during DC IR drop simulations.

UI Command:
Simulation > Compute DC IR. ClickOther solver options button and
choose the DC Advanced tab. Select the number of sides in the Via
Discretization field.

Syntax: obj.ScrSetNumViaSidesInDcSimulation(<numViaSides>)

Parameters: INT numViaSides

Return Value: None.

PY Example: oDoc.ScrSetNumViaSidesInDcSimulation(8)

ScrSetOptionsFor3DModelExport
Selects an options file for exporting a 3D model.

UI Command: Export > 3D Export Options.

Syntax: obj.ScrSetOptionsFor3DModelExport(<filePath>)

Parameters: BSTR filePath

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetOptionsFor3DModelExport
('C:/Files/options.config')

List of options and example values:

NUM_PADS_FACET_COUNT 8

NUM_ANTIPAD_FACET_COUNT 8

DEFAULT_SOLDERBALL_FACET_COUNT 8

VIA_SEGMENTS 8

DEFAULT_BONDWIRE_FACET_COUNT 6

UNITE_NETS 0

EXCLUDE_TERMINALS_FROM_UNITE 1

TOTAL_VIA_FILL 0

IGNORE_DIELECTRICS 0
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List of options and example values:

SEPARATE_DIELECTRICS 1

UNITE_LAYERS_WITH_SAME_MATERIALS 1

IGNORE_UNCONNECTED_PADS 1

CLIP_TRACES 0

CUT_DIELECTRICS 0

CREATE_SHEET_BODIES 0

GENERATE_TERMINALS 0

IGNORE_PLANES_WITH_AREA_LESS_THAN_THRESOLD 1

IGNORE_FLOAT_BODIES 0

MIN_PLANE_AREA 0.358979

MIN_EDGE_LENGTH_PADS 1um

MIN_EDGE_LENGTH_PLANES 1um

MIN_EDGE_LENGTH_TRACES 1um

MIN_DIELECTRIC_EDGE_LENGTH 10um

DIELECTRIC_EXPANSION_FACTOR 0.100000

IGNORE_HOLES 1

MIN_HOLE_AREA 0.358979

REMOVE-PLATING_TAILS 0

SUBTRACT_METAL_FROM_SUBSTRATE 0

DISCRETIZE_ARCS 0

CHOP_TRACE_ENDS 0

AIRBOX_THICKNESS_FACTOR 1.100000

AIRBOX_PAD_AMOUNT_PLUS_Z 0.500000

AIRBOX_PAD_AMOUNT_MINUS_Z 0.500000

PORT_PAD_AMOUNT 0.500000

CREATE_PORTS_FOR_PWR_GND_NETS 0

PORTS_FOR_PWR_GND_NETS 0
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List of options and example values:

LAUNCH_HFSS 1

USE_CAUSAL_MATERIALS 1

AUTO_DC_THICKNESS 1

HFSS_VERSION 2014

SOLVE_CAPACITANCE 1

SOLVE_DC_RESISTANCE 0

SOLVE_DC_INDUCTANCE_RESISTANCE 0

SOLVE_AC_INDUCTANCE_RESISTANCE 0

SOLVE_PROJECT 0

LAUNCH_Q3D 1

ASSIGN_SOLDER_BALLS_AS_SOURCES 0

Q3D_MERGE_SOURCES 0

Q3D_MERGE_SINKS 0

Q3D_VERSION 2014

ACIS_VERSION 0
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ScrSetPadOnLayer
Changes an existing pad's shape or dimension; deletes an existing pad (by passing a shape of
"None"); or adds a pad to the specified layer.

UI Command: Home > Edit Padstacks.

Syntax:
obj.ScrSetPadOnLayer(<padstackName>, <layerName>,
<shape>, <width>, <height>)

Parameters:

BSTR padstackName

BSTR layerName

BSTR shape ("None", "Circle", "Oblong", or "Rectangle")

BSTR width (including unit of measure)

BSTR height (including unit of measure)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetPadOnLayer('VIA_M1_M2', 'METAL-1',
'Circle', '0.6mm', '0.6mm')

ScrSetPadstackMaterial
Changes a padstack's material.

UI Command: Home > Edit Padstacks.

Syntax:
obj.ScrSetPadstackMaterial(<padstackName>,
<materialName>)

Parameters:
BSTR padstackName

BSTR materialName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetPadstackMaterial('VIA_M1_M2',
'magnesium')

ScrSetPadstackViaPlatingAbsolute
Changes a padstack's via plating absolute value.

UI Command: Home > Edit Padstacks. Select Absolute and set value.
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Changes a padstack's via plating absolute value.

Syntax:
obj.ScrSetPadstackViaPlatingAbsolute
(<padstackName>, <viaPlatingAbsolute>)

Parameters:
BSTR padstackName

BSTR viaPlatingAbsolute (including unit of measure; assumed to be meters if
no unit specified)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetPadstackViaPlatingAbsolute('VIA_M1_M2',
'0.1mm')

ScrSetPadstackViaPlatingRatio
Changes a padstack's via plating ratio.

UI Command: Home > Edit Padstacks. Select Ratio and select value.

Syntax:
obj.ScrSetPadstackViaPlatingRatio(<padstackName>,
<value>)

Parameters:
BSTR padstackName

DOUBLE value (percentage between 0 and 1; e.g., 0.6 = 60%)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetPadstackViaPlatingRatio('VIA_M1_M2',
0.6)
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ScrSetPlotAfterDcSimulation
Controls whether current/power/voltage plots are generated after DC IR drop simulations
conclude.

UI Command: Simulation > Compute DC IR. ClickOther Solver Options > DC. Select
Plot Current Density and Voltage Distribution.

Syntax: obj.ScrSetPlotAfterDcSimulation(<plot>)

Parameters: BOOL plot (TRUE = plot; FALSE = do not plot)

Return Value: None.

PY Example: oDoc.ScrSetPlotAfterDcSimulation(True)

ScrSetPlotLayers
Sets the layers specified for a Frequency Sweep.

UI Command: Simulation > Compute Frequency Sweeps. From the Voltage Surface
Plot Options area, select layers.

Syntax: obj.ScrSetPlotLayers(<plotLayer>,<refLayer>)

Parameters:
BSTR plotLayer

BSTR refLayer (ground)

Return Value:

INT:

l 0 – Success
l Else – Failure

PY Example: oDoc.ScrSetPlotLayers('L2','GND')

ScrSetPlotSyzMag
Selects "Plot Magnitude" for various simulations.

UI Command: Results > [Simulation Type] > [Simulation Name] > Plot Magnitude.

Syntax: obj.ScrSetPlotSyzMag(<flag>)

Parameters: BOOL flag (TRUE = plot magnitude; FALSE = do not plot magnitude)

Return Value: None.

PY Example: oDoc.ScrSetPlotSyzMag(1)

ScrSetPlotSyzPhase
Selects "Plot Phase Animation" for various simulations.

UI Command: Results > [Simulation Type] > [Simulation Name] > View Results >
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Selects "Plot Phase Animation" for various simulations.

Phase Animation.

Syntax: obj.ScrSetPlotSyzPhase(<flag>)

Parameters: BOOL flag (TRUE = plot phase animation; FALSE = do not plot phase
animation)

Return Value: None.

PY Example: oDoc.ScrSetPlotSyzPhase(1)

ScrSetPortNamingConvention
Sets the port naming convention used in the following port generation commands:

ScrPlacePortsAtPinsOnSelectedNets, ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut,
ScrPlacePortsAtPinsOnSelectedNetsExcludePart

UI Command: None.

Syntax:
obj.ScrSetPortNamingConvention
(<namingConvention>)

Parameters: BSTR namingConvention

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetPortNamingConvention('TestPort_
$POSTERMINAL_$NETNAME_Test')
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ScrSetPowerGroundNets
Selects nets to be designated power and ground nets.

UI Command: Power/Ground Identification in Nets window.

Syntax:
obj.ScrSetPowerGroundNets(<netNames>,
<appendToCurrentNetsSelected>)

Parameters:

ARRAY netNames

BOOL appendToCurrentNetsSelected (TRUE = nets already set to
power/ground remain power/ground; FALSE = all nets not in the array are set
to non-power/ground.)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetPowerGroundNets
(['Net1','Net2','Net3'],1)

ScrSetPowerGroundNetsFromFile
Selects nets to be designated power and ground nets.

UI Command: Power/Ground Identification in Nets window.

Syntax:
obj.ScrSetPowerGroundNetsFromFile(<filePath>,
<appendToCurrentNetsSelected>)

Parameters:

BSTR filePath

BOOL appendToCurrentNetsSelected (TRUE = nets already set to
power/ground remain power/ground; FALSE = all nets not in the file are set to
non-power/ground.)

Return Value: None.

PY Example:
oDoc.ScrSetPowerGroundNetsFromFile('C:/Files/power_
ground_nets.txt',1)

ScrSetProjectModified
Determines whether you will be prompted to save before closing or loading a different project.

UI Command: None.

Syntax: obj.ScrSetProjectModified(<p>)

Parameters: BOOL p (TRUE = sets project as modified, will be prompted to save; FALSE =
no save prompt)
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Determines whether you will be prompted to save before closing or loading a different project.

Return Value: None.

PY Example: oDoc.ScrSetProjectModified(1)

ScrSetPsiOptionsFromFile
Sets general PSI simulation options from an XML configuration file.

UI Command: Simulation > PSI Options > Import Settings. Select file.

Syntax: obj.ScrSetPsiOptionsFromFile(<filename>)

Parameters: BSTR filename (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetPsiOptionsFromFile('D:/Tests/Test.sps')

ScrSetPsiPortType
Sets the PSI port type for a specified port.

UI Command: None.

Syntax: obj.ScrSetPsiPortType(<portName>, <portType>)

Parameters:
BSTR portName

BSTR portType (See: SIwave-PSI Best Practices - Port Setup)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetPsiPortType('Port1','Lumped')

ScrSetPsiSyzInterpOptions
Sets PSI SYZ Simulation options.

UI Command: Simulation > PSI > Compute SYZ Parameters.

Syntax:
obj.ScrSetPsiSyzInterpOptions(<interp>,
<fastsweep>, <adaptiveSamp>, <enforceDC>)

Parameters:

INT interp (0 = Discrete Sweep; 1 = Interpolating Sweep)

INT fastsweep (0 = Disable Fast Sweep; 1 = Enable Fast Sweep)

INT adaptiveSamp (0 = Disable Adaptive Sampling; 1 = Enable
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Sets PSI SYZ Simulation options.

Adaptive Sampling)

INT enforceDC (for Adaptive Sampling, 0 = do not enforce DC point and
causality; 1 = enforce DC point and causality)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetPsiSyzInterpOptions(1, 0, 1, 1)

ScrSetRefineBondwiresInDcSimulation
For DC simulations, selects or deselects option to refine mesh along bondwires.

UI Command: Simulation >  Options. On DC Advanced tab, select or deselect
Refine Mesh Along Bondwires.

Syntax:
obj.ScrSetRefineBondwiresInDcSimulation
(<refineBws>)

Parameters: BOOL refineBws (TRUE = select; FALSE = deselect)

Return Value: None.

PY Example: oDoc.ScrSetRefineBondwiresInDcSimulation(1)
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ScrSetRefineDcSimulation
Activates or deactivates adaptive mesh refinement during DC IR drop simulations.

UI Command: Simulation > Compute DC IR. Click Other Solver Options >
DC Advanced. Select or deselect Perform Adaptive Mesh Refinement.

Syntax: obj.ScrSetRefineDcSimulation(<refine>)

Parameters: INT refine (0 = deselect refinement; 1 = select refinement)

Return Value: None.

PY Example: oDoc.ScrSetRefineDcSimulation(1)

ScrSetRefineViasInDcSimulation
For DC simulations, selects or deselects option to refine mesh along vias.

UI Command: Simulation >Options. On DC Advanced tab, select or deselect
Refine Mesh Along Vias.

Syntax: obj.ScrSetRefineViasInDcSimulation(<refineVias>)

Parameters: BOOL refineBws (TRUE = select; FALSE = deselect)

Return Value: None.

PY Example: oDoc.ScrSetRefineViasInDcSimulation(1)

ScrSetRemoveCutoutsByArea
Selects whether SIwave will always preserve cutouts whose area is greater than the minimum
void area (controlled by the ScrSetMinCutoutArea function). By default, SIwave automatically
decides which cutouts are to be defeatured (i.e., not meshed) during simulation.

UI Command: Simulation >Options. Click SI/PI Advanced. Select or deselect Automatic
Mesh Refinement.

Syntax: obj.ScrSetRemoveCutoutsByArea <p>

Parameters: INT p (0 = automatic mesh refinement; 1 = no automatic mesh refinement)

Return Value: None.

PY Example: oDoc.ScrSetRemoveCutoutsByArea(1)
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ScrSetResonantModeMaxFreq
For Resonant Modes simulations, sets the maximum frequency for analysis.

UI Command: Simulation > Compute Resonant Modes. Enter aMaximum Frequency
value, in Hz.

Syntax: obj.ScrSetResonantModeMaxFreq(<freq>)

Parameters: DOUBLE freq (in Hz)

Return Value: None.

PY Example: oDoc.ScrSetResonantModeMaxFreq(2E+06)

ScrSetResonantModeMinFreq
For Resonant Modes simulations, sets the minimum frequency for analysis.

UI Command: Simulation > Compute Resonant Modes. Enter aMinimum Frequency
value, in Hz.

Syntax: obj.ScrSetResonantModeMinFreq(<freq>)

Parameters: DOUBLE freq (in Hz)

Return Value: None.

PY Example: oDoc.ScrSetResonantModeMinFreq(2E+06)
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ScrSetRLCValues
Changes RLC values for a specified RLC.

UI Command: None.

Syntax: obj.ScrSetRLCValues(<partName>, <r>, <l>, <c>)

Parameters:

BSTR partName

BSTR r (including unit of measure)

BSTR l (including unit of measure)

BSTR c (including unit of measure)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetRLCValues('RLC_XYZ_R', '1.5kohm', '1e-
12h', '1uf')
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ScrSetSignalNets
Selects nets to be designated signal nets.

UI Command: Simulation > Signal Net Analyzer. Select nets.

Syntax:
obj.ScrSetSignalNets(<netNames>,
<appendToCurrentNetsSelected>)

Parameters:
ARRAY netNames

BOOL appendToCurrentNetsSelected (TRUE = nets already set as signal
nets remain so; FALSE = all nets not in the array are set to non-signal nets.)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetSignalNets(['Net1','Net2','Net3'],1)
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ScrSetSignalNetsFromFile
Selects nets to be designated signal nets.

UI Command: Simulation > Signal Net Analyzer. Select nets.

Syntax:
obj.ScrSetSignalNetsFromFile(<filePath>,
<appendToCurrentNetsSelected>)

Parameters:
BSTR filePath

BOOL appendToCurrentNetsSelected (TRUE = nets already set as signal
nets remain so; FALSE = all nets not in the file are set to non-signal nets.)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetSignalNetsFromFile('C:/Files/signal_
nets.txt',1)
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ScrSetSimulationName
Sets the simulation name for a specified simulation type.

UI Command: From the Simulationmenu, click any option to compute a simulation and
open the corresponding simulation window. Specify the simulation name.

Syntax: obj.ScrSetSimulationName(<simType>, <simName>)

Parameters:
BSTR simType ( "ac", "dc", "eigen", "ff", "nf", "syz" or "hfss_syz")

BSTR simName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetSimulationName('syz', 'S-param no caps')
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ScrSetSIwaveSolverMemLimit
Sets the solver memory limit to an absolute value or percent of available system memory.

UI Command: From the Simulation tab, clickOptions or navigate to CPA Options.

Syntax:
obj.ScrSetSIwaveSolverMemLimit(<Number>,
<MemLimit>)

Parameters:

DOUBLE Number (any integer representing available memory units or
percentage (e.g., "50000", "50", "0.05", "50"))

BSTR MemLimit (unit of measurement or % to set the memory limit to a
percentage of available memory (i.e., "MB", "GB", "TB", "%"))

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetSIwaveSolverMemLimit('50', '%')
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ScrSetSketchedBwProfile
Sets a specified sketched profile to all bondwires of a specified model.

UI Command: From the Simulationmenu, click any option to compute a simulation and
open the corresponding simulation window. Specify the simulation name.

Syntax:
obj.ScrSetSketchedBwProfile(<bwModelName>,
<filePath>, <radius>)

Parameters:

BSTR bwModelName

BSTR filePath

DOUBLE radius

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetSketchedBwProfile('WB_PROFILE_1',
'SketchedProfile.bwp', 20)

Format of *.bwp:

UNITS microns

0.000000 400.000000

300.000000 700.000000

900.000000 700.000000

1200.000000 300.000000
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ScrSetSketchedBwProfileFromArray
Sets a sketched profile (array of points) to all bondwires of a specified model.

UI Command: None.

Syntax:
obj.ScrSetSketchedBwProfileFromArray(<modelName>,
<unitName>, <bwPointArray>, <radius>)

Parameters:

BSTR modelName

BSTR unitName

ARRAY bwPointArray (requires 8 doubles for 4 points)

DOUBLE (radius)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:

oDoc.ScrSetSketchedBwProfileFromArray('BW_PROFILE_
1', 'micron',
[0.0,400.0,300.0,700.0,900.0,700.0,1200.0,300.0],
20)
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ScrSetSnapLengthThreshold
For DC simulations, sets the maximum length value for snapping vertices.

UI Command: Simulation >Options. On DC Advanced tab, enter a value in the Snap
vertices separated by less than field.

Syntax:
obj.ScrSetSnapLengthThreshold
(<snapLengthThreshold>)

Parameters: BSTR snapLengthThreshold

Return Value: None.

PY Example: oDoc.ScrSetSnapLengthThreshold('0.0734235mil')

ScrSetSolderballMaterial
Assigns a material to a specified solderball.

NOTE: You must assign a solderball profile before assigning a material.

UI Command: Home > Solderball Properties. Assign a material.

Syntax:
obj.ScrSetSolderballMaterial(<padstackName>,
<material>)

Parameters:
BSTR padstackName

BSTR material

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetSolderballMaterial('BP_BOT_500X600',
'silver')
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ScrSetSolderballParameters
Assigns solderballs/bumps of the specified dimensions (in the design's geometry units) to the
specified padstack.

UI Command: Home > Solderball Properties. Select a padstack and assign
solderballs/bumps.

Syntax:
obj.ScrSetSolderballParameters(<padstackName>,
<aboveStackup>, <height>, <radius>)

Parameters:

BSTR padstackName

BOOL/INT aboveStackup (TRUE/1 = above stackup; FALSE/0 = below
stackup)

DOUBLE height

DOUBLE radius

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetSolderballParameters('BUMPPAD', 1, 100,
30)
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ScrSetSourceMagnitude
Sets the current or voltage magnitude of a specified source.

UI Command: None.

Syntax: obj.ScrSetSourceMagnitude(<refDes>, <magnitude>)

Parameters:
BSTR refDes

BSTR magnitude (including unit)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetSourceMagnitude('I_1', '2.5A')
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ScrSetSparamModelSetup
Configures an N-Port S-parameter model for specified part(s).

UI Command: None.

Syntax:
obj.ScrSetSparamModelSetup(<partName>,
<activeRefDesList>, <fileName>, <modelName>,
<refNet>, <pinOrder>)

Parameters:

BSTR partName

ARRAY activeRefDesList

BSTR fileName (including path)

BSTRmodelName

BSTR refNet

ARRAY pinOrder

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:

refdes1 = ['A1']

pinorder1 = []

doc.ScrSetSparamModelSetup('TESTPART', refdes1,
'D:/Tests/US142197/DLP11TB800UL2.s4p', 'Model1',
'NET_9', pinorder1)
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ScrSetSpiceModelSetup
Configures an N-Port Spice model for specified part(s).

UI Command: None.

Syntax:
obj.ScrSetSpiceModelSetup(<partName>,
<activeRefDesList>, <fileName>, <modelName>,
<pinOrder>)

Parameters:

BSTR partName

ARRAY activeRefDesList

BSTR fileName (including path)

BSTR modelName

ARRAY pinOrder

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:

refdes2 = ['A2']

pinorder2 = ['4', '3', '2', '1']

oDoc.ScrSetSpiceModelSetup('TESTPART', refdes2,
'D:/Tests/US142197/testmod.sp', 'Model2',
pinorder2)
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ScrSetSpiceSubcktFormat
Sets an appropriate output format for Full Wave Spice simulations.

UI Command: None.

Syntax: obj.ScrSetSpiceSubcktFormat(<format>)

Parameters: BSTR format (case-sensitive choices are: HSPICE, MSPICE, PSPICE, or
Spectre)

Return Value: None.

PY Example: oDoc.ScrSetSpiceSubcktFormat('PSPICE')

ScrSetStackupLayerThickness
Sets the thickness of a specified layer.

UI Command: Home > Layer Stackup Editor. Edit a layer's Thickness value.

Syntax:
obj.ScrSetStackupLayerThickness(<layerName>,
<thickness>, <redraw>)

Parameters:

BSTR layerName

BSTR thickness (including unit)

BOOL redraw (TRUE/1 = redraw; FALSE/0 = do not redraw)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetStackupLayerThickness('LAYER-1',
'0.79mils', 1)
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ScrSetStackupLayerThicknessUnit
Sets the layer thickness unit.

UI Command: None.

Syntax: obj.ScrSetStackupLayerThicknessUnit(<unit>)

Parameters: BSTR unit ("microns", "um", "mils", "mm", "cm", "inches", or "meters")

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetStackupLayerThicknessUnit('um')

ScrSetSweepFreqRange
Sets the minimum and maximum frequencies for a frequency sweep.

UI Command: None.

Syntax: obj.ScrSetSweepFreqRange(<minFreq>, <maxFreq>)

Parameters:

DOUBLE minFreq (in Hz; 1.0 = 1Hz, 1000.0 = 1kHz, 1e-6 = 1MHz; 1e-9 =
1GHz)

DOUBLE maxFreq (in Hz; 1.0 = 1Hz, 1000.0 = 1kHz, 1e-6 = 1MHz; 1e-9 =
1GHz)

Return Value: None.

PY Example: oDoc.ScrSetSweepFreqRange(5.0,5.0)

ScrSetSweepMaxFreq
Sets the maximum frequency for a frequency sweep.

UI Command: None.

Syntax: obj.ScrSetSweepMaxFreq(<maxFreq>)

Parameters: DOUBLE maxFreq (in Hz; 1.0 = 1Hz, 1000.0 = 1kHz, 1e-6 = 1MHz; 1e-9 =
1GHz)

Return Value: None.

PY Example: oDoc.ScrSetSweepMaxFreq(5.0)
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ScrSetSweepMinFreq
Sets the minimum frequency for a frequency sweep.

UI Command: None.

Syntax: obj.ScrSetSweepMinFreq(<minFreq>)

Parameters: DOUBLE minFreq (in Hz; 1.0 = 1Hz, 1000.0 = 1kHz, 1e-6 = 1MHz; 1e-9 =
1GHz)

Return Value: None.

PY Example: oDoc.ScrSetSweepMinFreq(5.0)

ScrSetSweepNumFreqPoints
Sets the number of frequency points for a frequency sweep.

UI Command: None.

Syntax: obj.ScrSetNumSweepFreqPoints(<numPoints>)

Parameters: INT numPoints

Return Value: None.

PY Example: oDoc.ScrSetSweepNumFreqPoints(200)

ScrSetSyzInterpSweep
Sets the SYZ-parameter sweep type to interpolating.

UI Command: Simulation > Compute SYZ Parameters. Select Interpolating Sweep.

Syntax: obj.ScrSetSyzInterpSweep(<p>)

Parameters: BOOL p (TRUE = Interpolating; FALSE = Discrete)

Return Value: None.

PY Example: oDoc.ScrSetSyzInterpSweep(True)
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ScrSetSyzInterpSweepParams
Sets the convergence criterion (error tolerance) and maximum number of points to use during
SYZ interpolating sweeps.

UI Command: Simulation > Compute SYZ Parameters. Select Interpolating Sweep and
enter a value for Error Tolerance.

Syntax:
obj.ScrSetSyzInterpSweepParams(<convergence>,
<maxInterpPts>)

Parameters:
DOUBLE convergence

INT maxInterpPts

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetSyzInterpSweepParams(0.005, 150)
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ScrSetTDCrosstalkScanParameters
Specifies the parameters for running a time domain Crosstalk Scan via ScrRunSimulation.

UI Command: Simulation > Crosstalk Scan > Time Domain. Set values for solver options.

Syntax:
obj.ScrSetTDCrosstalkScanParameters(<partNameList>,
<refDesNameList>, <pinNameList>, <impedanceList>,
<typeList>, <riseTimeList>, <voltageList>)

Parameters:

ARRAY partNameList

ARRAY refDesNameList

ARRAY pinNameList

ARRAY impedanceList

ARRAY typeList ("1" represents Driver; "0" represents Receiver)

ARRAY riseTimeList

ARRAY voltageList

**Each input parameter is an array of strings, and the number of elements in
the array should be the same for all parameters. The first 3 are used to identify
the pin and the rest are parameters to apply for the pin.

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:

parts = ["G83568-001", "IPD031-201"]

refdes = ["U1A1", "U2A5"]

pins = ["K7", "9"]

impedances = ["55ohms", "60"]

types = ["0", "1"]

risetimes = ["0", "6ns"]

voltages = ["0", "1.2V"]

oDoc.ScrSetTDCrosstalkScanParameters(parts, refdes,
pins, impedances, types, risetimes, voltages)
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ScrSetThermalPadOnLayer
Changes, adds, or deletes thermal pads of a specified padstack.

If no thermal pad exists, script adds thermal pads to the specified padstack.

If thermal pad exists, script modifies pad shape and/or dimensions.

To delete a pad, choose "None" as the shapeName.

UI Command: Home > Edit Padstack. Select Thermal Relief Pag Properties.

Syntax:
obj.ScrSetThermalPadOnLayer(<padstackName>,
<layerName>, <shapeName>, <widthString>,
<heightString>)

Parameters:

BSTR padstackName

BSTR layerName

BSTR shapeName ("None", "Circle", "Oblong", or "Rectangle")

BSTR widthString (in mils if no unit specified; for circle pads, this is the radius)

BSTR heightString (in mils if no unit specified)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example:
oDoc.ScrSetThermalPadOnLayer('VIA_M1_M2', 'METAL-
1', 'Rectangle', '1.2mm', '1.2mm')
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ScrSetTouchstoneExportFormatToDb
Sets the magnitude format in exported touchstone files.

UI Command: None.

Syntax: obj.ScrSetTouchstoneExportFormatToDb(<exportInDb>)

Parameters: BOOL exportInDb (TRUE = magnitude is specified in decibels [log of the
magnitude]; FALSE = default settings)

Return Value: None.

PY Example: oDoc.ScrSetTouchstoneExportFormatToDb(1)

ScrSetTouchstonePortOrder
Specifies port order in exported touchstone files.

NOTE: If any ports are not specified in the input, they will be sorted in alphabetical order and
added to the end of the list.

UI Command: None.

Syntax: obj.ScrSetTouchstonePortOrder(<portNamesList>)

Parameters: ARRAY portNamesList

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetTouchstonePortOrder(['port1','port2'])
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ScrSetTouchstonePortRemapping
Sets the alternate port naming convention when name remapping is enabled in touchstone file
exports.

UI Command: None.

Syntax:
obj.ScrSetTouchstonePortRemapping(<portName>,
<namingConv>)

Parameters:
BSTR portName

BSTR namingConv

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetTouchstonePortRemapping('left', 'foo')

ScrSetTraceCouplingDistance
Sets the XY coupling distance.

UI Command: Simulation >Options. On CPA tab, enter a value for XY coupling distance.

Syntax:
obj.ScrSetTraceCouplingDistance
(<traceCouplingDist>, <units>)

Parameters:
DOUBLE traceCouplingDist

BSTR units

Return Value: None.

PY Example: oDoc.ScrSetTraceCouplingDistance('7.79', 'mils')
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ScrSetUniformTemperature
Sets the uniform design temperature.

UI Command: Simulation >Options. On the SI/PI tab, enter a value in the Set uniform
design temperature to field.

Syntax: obj.ScrSetUniformTemperature(<temp>)

Parameters: BSTR temp (temperature, including units)

Return Value: None.

PY Example: oDoc.ScrSetUniformTemperature('100cel')

ScrSetZ0ScanParameters
Specifies the parameters for running an Impedance Scan via ScrRunSimulation.

UI Command: Simulation > Impedance Scan. Set Nominal Z0, Issue warning... and
Issue violation... values.

Syntax:
obj.ScrSetZ0ScanParameters(<impedance>,
<warningThreshold>, <violationThreshold>)

Parameters:

DOUBLE impedance

DOUBLE warningThreshold

DOUBLE violationThreshold

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrSetZ0ScanParameters(50,15,30)
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ScrSetZ0ScanReportImageHeight
When generating Impedance Scan reports, specifies the resolution (in pixels) of the smaller
dimension of the images. For designs where the board is wider than it is tall, this corresponds
to the y-resolution of the image.

UI Command: None.

Syntax: obj.ScrSetZ0ScanReportImageHeight(<imgHeight>)

Parameters: LONG imgHeight

Return Value:

BOOL

l 0 – Failure (invalid height)
l 1 – Success

PY Example: oDoc.ScrSetZ0ScanReportImageHeight(3000)
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ScrShowDcPowerTreePowerLossOfNets

Adds a list of every net and its corresponding power loss, beneath the power tree.

UI Command: Results Tab > DC IR Drop > [Simulation Name] > Export Power Tree
> Output Power Loss of every net.

Syntax: obj.ScrShowDcPowerTreePowerLossOfNets(<showList>)

Parameters: BOOL showList (True to activate or False to deactivate)

Return Value:

INT:

l 0 – if False;does not display the Power Loss On Every Net list beneath
the power tree.

l 1 – if True; displays the Power Loss On Every Net list beneath the
power tree

PY Example: oDoc.ScrShowDcPowerTreePowerLossOfNets('1')

Note:

Use before ScrExportDcPowerTree.

ScrShowSelectedNetsOnly
Determines whether SIwave displays all nets or selected nets only.

UI Command: None.

Syntax: obj.ScrShowSelectedNetsOnly(<selOnly>)

Parameters: BOOL selOnly (TRUE/1 = display only selected nets; FALSE/0 = display all
nets)

Return Value: None.

PY Example: oDoc.ScrShowSelectedNetsOnly(1)

ScrSIwaveEnable_3D_DDM
Enables or disables 3D DDM.

UI Command: None.

Syntax: obj.ScrSIwaveEnable_3D_DDM(<flag>)

Parameters: BOOL flag

Return Value: None.

PY Example: oDoc.ScrSIwaveEnable_3D_DDM(True)
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ScrSIwaveEnableHFSSRegions
Enables or disables HFSS Regions

Note: Region extents must exist in the layout for this setting to be meaningful.

UI Command: None.

Syntax: obj.ScrSIwaveEnableHFSSRegions(<flag>)

Parameters: BOOL flag

Return Value: None.

PY Example: oDoc.ScrSIwaveEnableHFSSRegions(True)

ScrSIwaveEnableReturnCurrentDistribution
Enables or disables tracing of return current distribution.

UI Command: Simulation >Options. On SI/PI Advanced tab, select Trace return current
distribution.

Syntax:
obj.ScrSIwaveEnableReturnCurrentDistribution
(<flag>)

Parameters: BOOL flag (TRUE/1 = select; FALSE/0 = deselect)

Return Value: None.

PY Example: oDoc.ScrSIwaveEnableReturnCurrentDistribution(1)

ScrSIwaveIncludeSourceParasitics
For Resonance Sweep/SYZ simulations, enables or disables option to include source
parasitics.

UI Command:
Simulation >Options. On SI/PI Advanced tab,
select Include Voltage/Current Source Connections/Parasitics in
Resonance/SYZ Simulations.

Syntax: obj.ScrSIwaveIncludeSourceParasitics(<flag>)

Parameters: BOOL flag (TRUE/1 = include; FALSE/0 = do not include)

Return Value: None.

PY Example: oDoc.ScrSIwaveIncludeSourceParasitics(1)
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ScrSIwaveSyzComputeExactDcPoint
For SYZ simulations, selects or deselects the Compute Exact DC Point option.

UI Command: Simulation > Compute SYZ Parameters. Select Compute Exact DC Point.

Syntax: obj.ScrSIwaveSyzComputeExactDcPoint(<flag>)

Parameters: BOOL flag (TRUE = Compute exact DC point; FALSE = Do not compute exact
DC point)

Return Value: None.

PY Example: oDoc.ScrSIwaveSyzComputeExactDcPoint(True)

Important:

The Compute Exact DC Point and Enforce Causality options are mutually
exclusive. Selecting both generates an error.

ScrSIwaveSyzEnforceCausality
For SYZ simulations, selects or deselects the Enforce Causality option.

UI Command: Simulation > Compute SYZ Parameters. Select Enforce Causality.

Syntax: obj.ScrSIwaveSyzEnforceCausality(<flag>)

Parameters: BOOL flag (TRUE = Enforce; FALSE = Do not enforce)

Return Value: None.

PY Example: oDoc.ScrSIwaveSyzEnforceCausality(True)

Important:

The Enforce Causality and Compute Exact DC Point options are mutually
exclusive. Selecting both generates an error.
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ScrSIwaveSyzEnforcePassivity
For SYZ simulations, selects or deselects the Enforce Passivity option.

UI Command: Simulation > Compute SYZ Parameters. Select Enforce Passivity.

Syntax: obj.ScrSIwaveSyzEnforcePassivity(<flag>)

Parameters: BOOL flag (TRUE = Enforce; FALSE = Do not enforce)

Return Value: None.

PY Example: oDoc.ScrSIwaveSyzEnforcePassivity(True)

ScrUnselectAll
Deselects all selected objects.

UI Command: Right-click in the Modeling workspace. Click Unselect All.

Syntax: obj.ScrUnselectAll()

Parameters: None.

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrUnselectAll()

ScrUpdateComponentTree
For scripts run in graphical mode, updates the component tree. Scripted modifications will not
display in the tree until this function is called.

NOTE: This script is inappropriate for scripts run in non-graphical mode.

UI Command: None.

Syntax: obj.ScrUpdateComponentTree

Parameters: None.

Return Value: None.

PY Example: oDoc.ScrUpdateComponentTree()
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ScrUseIcepakTemperatureDataInDc
Enables or disables the use of Icepak thermal data in DC simulations.

UI Command: Simulation > Compute DC IR. Select Icepak data.

Syntax: obj.ScrUseIcepakTemperatureDataInDc(<use>)

Parameters: BOOL use (TRUE = Use thermal data; FALSE = Do not use thermal data)

Return Value: None.

PY Example: oDoc.ScrUseIcepakTemperatureDataInDc(True)

ScrUseTouchstonePortRemapping
Enables or disables the use of port name remapping for touchstone file exports.

UI Command: None.

Syntax: obj.ScrUseTouchstonePortRemapping(remapNames)

Parameters: BOOL/INT remapNames (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

PY Example: oDoc.ScrUseTouchstonePortRemapping(1)

Solve
Solves a specified simulation.

UI Command: Launch button in simulation settings window.

Syntax: obj.Solve(solutionName)

Parameters: BSTR solutionName

Return Value: Simulation results in text format.

PY Example: oDoc.Solve('Near Field Sim 1')
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StopSimLink
Aborts a specified simulation.

UI Command: Process Monitor > Abort Simulation.

Syntax: obj.StopSimLink(<simID>, <abort>)

Parameters:
INT simID

BOOL abort (TRUE/1 = abort; FALSE/0 = do not abort)

Return Value: None.

PY Example: oDoc.StopSimLink(121, 1)

SupportSParamLink
Returns whether design supports S-parameter links.

UI Command: None.

Syntax: obj.SupportSParamLink()

Parameters: None.

Return Value: BOOL

PY Example: oDoc.SupportSParamLink()
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A

antipads

modifying 2-154

automatic mesh refinement 2-202

B

bondwires

assigning terminal type to 2-32

creating 4-point 2-30, 2-152

creating 5-point 2-31, 2-153

creating low 2-34

creating sketched 2-36

from array 2-37

finding nets associated with 2-104

generating list of 2-96

generating model list 2-96

refining mesh along 2-201

setting discretization for DC sim 2-191

setting low profile 2-182

setting mesh for DC sim 2-183

setting model 2-155

setting sketched from array 2-210

setting sketched profile 2-209

setting support layer 2-155

setting termination layer 2-156

setting via plating ratio 2-196

bounding box

assigning 2-100

C

capacitors

drawing 2-55

causality

enforcing 2-93

circles

drawing 2-56

circuit elements

activating 2-20

deactivating 2-20

deleting 2-50

placing 2-131

placing to reference pins 2-133

renaming 2-66

returning terminal nets 2-97

clipboard

copying image to 2-44

commands

list of available 2-1
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components

generating list by type 2-98

generating list of 2-96

updating component tree 2-229

crosstalk

setting threshold 2-159

D

DDM

3D

enabling 2-226

deleting

circuit elements 2-50

layers 2-52

nets 2-52

all 2-50

from file 2-53

multiple 2-53

padstacks 2-53

pin groups 2-54

solutions

DC 2-51

designs

assigning bounding box 2-100

clipping around nets 2-41

clipping nets 2-40

enabling s-parameter links 2-231

returning list of 2-16

setting uniform temperature 2-224

dies

locating layer location 2-100

returning names of 2-101

setting elevation 2-160

setting thickness 2-161

directories

returning 2-14

returning project 2-15

drawing

capacitors 2-55

circles 2-56

inductors 2-57

polygons 2-58

ports 2-59

rectangles 2-60

resistors 2-61

traces 2-62

vias 2-63

voltage probes 2-64

voltage sources 2-65

E

EMI scanner

exporting reports 2-79

setting parameters 2-162
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errors

adding to log 2-24

exporting

AC voltage probe data 2-89

ANF files 2-73

component files 2-73

connection reports 2-94

CPA reports 2-74

DC element data 2-79

DC power tree 2-21, 2-75, 2-226

DC reports 2-76

EMI scanner reports 2-79

Icepak projects 2-80

Icepak thermal plots 2-81

impedance reports 2-90

layer stackups 2-83

models 2-72

net delay reports 2-84

power data to Icepak 2-74

settings files 2-84

SNA reports 2-85

SYZ active dataset 2-87

SYZ results 2-87

Touchstone files 2-83

XFL files 2-89

F

files

ANF

exporting 2-73

importing 2-17, 2-115

CMP

importing 2-116

importing mapping 2-117

component

exporting 2-73

CPM

importing 2-119

EDB

importing 2-121

GDSII

importing 2-121

IPC2581

importing 2-122

ODB++

importing 2-17

PLOC

importing 2-119

PMAP

importing 2-124

PNG

saving workspace as 2-149
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returning directory of 2-14

returning path of 2-14

SEF

exporting 2-84

importing 2-124

SITEMP

selecting for Icepak sim 2-172

SIW

saving 2-19

SWS

importing 2-125

Touchstone

port remapping 2-230

port remapping for export 2-223

setting magnitude format 2-222

setting port order 2-222

XFL

exporting 2-89

importing 2-126

fitting

design 2-92

returning view window position 2-98

selected objects 2-92

to viewing window 2-92

frequency

setting maximum for sweeps 2-217

setting minimum for sweeps 2-218

setting points for sweeps 2-218

setting range for sweeps 2-217

H

HFSS Regions

enabling 2-227

I

IC die networks

creating 2-95

Icepak

configuring cabinets 2-170

exporting as project 2-80

exporting power data to 2-74

exporting thermal plots 2-81

running simulations 2-142

selecting component settings 2-171

selecting SITEMP file 2-172

setting board outline 2-170

setting meshing level 2-171

setting report image height 2-172

setting thermal settings 2-173

using data in DC sim 2-230

images

copying to clipboard 2-44

importing

ANF files 2-17, 2-115

capacitor derating attributes 2-116
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component files 2-116

component mapping files 2-117

CPA simulation options 2-118

CPM files 2-119

EDB files 2-121

GDSII files 2-121

IPC2581 files 2-122

layer stackup files 2-123

layer stackup XML files 2-123

layer stackups 2-122

ODB++ files 2-17

PLOC files 2-119

PMAP files 2-124

SIwave settings files 2-124, 2-125

XFL files 2-126

inductors

drawing 2-57

infinite ground plane

introducing 2-178

information

adding to log 2-24

L

layers

adding 2-25

adding padstacks 2-27

assign filler material 2-184

deleting 2-52

exporting stackups 2-83

importing layer stackup files 2-123

importing layer stackup XML 2-123

importing stackups 2-122

locating die on 2-100

modifying antipads 2-154

renaming 2-67

returning filler material 2-104

returning list of 2-102

returning material of 2-102

returning thickness of 2-103, 2-114

returning type of 2-103

selecting for sweep 2-197

setting bondwire support 2-155

setting bondwire termination 2-156

setting conformal coating 2-158

setting material 2-178

setting pads on 2-195

setting thermal pads on 2-221

setting thickness 2-179, 2-216

setting thickness unit 2-217

setting type 2-179

setting visibility 2-179

length

setting unit of 2-181
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licenses

HPC

setting type 2-169

setting vendor 2-169

logging

errors 2-24

information 2-24

warnings 2-27

M

magnitude

setting format for Touchstone 2-222

materials

adding 2-26

assigning to layer 2-178

editing 2-67

returning for layer 2-102

measurement

returning units of 2-103

mesh refinement

setting automatic 2-202

messages

logging 2-127

saving 2-149

models

deselecting objects 2-229

exporting 2-72

fitting to workspace 2-92

saving PNG of 2-149

selecting options for export 2-192

S-parameter

configuring N-ports 2-214

Spice

configuring N-ports 2-215

setting output format 2-216

multiprocessing 2-191

N

nets

checking whether selected 2-129

clipping 2-40

clipping design around 2-41

computing length 2-128

deleting 2-52

all 2-50

all but specified 2-139

from array 2-53

from file 2-53

deselecting 2-130

designating P/G 2-199

designating P/G from file 2-199

designating signal 2-205

designating signal from file 2-206

determining disjoint 2-128
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finding connecting RLCs 2-112

merging connected 2-127

preserving 2-139

renaming 2-68

returning

by bondwire profile 2-104

connected 2-99, 2-102, 2-107, 2-
108, 2-113, 2-114

connecting 2-106

connecting power/ground 2-105

list of all 2-104

power/ground 2-111

terminal 2-97

sanitizing 2-148

selecting 2-130, 2-150

selecting between components 2-151

selecting between nets 2-151

selecting connected 2-150

separating disjoint 2-129, 2-152

setting dummy 2-129

showing selected 2-226

Nexxim

launching 2-165

O

objects

deselecting all 2-229

operators

boolean unite 2-38

equals 2-12

reference equals 2-18

P

pads

setting on layer 2-195

setting thermal on layer 2-221

padstacks

adding 2-27

deleting 2-53

renaming 2-68

returning by associated pin 2-109

returning list of 2-108

setting material of 2-195

setting via plating 2-195

parts

changing type 2-39

creating ports on 2-50

paths

returning 2-14

setting DC thermal directory 2-99

pin groups

creating 2-45

by distance 2-47

by grid 2-48
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by net 2-49

deleting 2-54

returning list of 2-109

pins

finding associated padstack 2-109

returning list by net 2-110

returning list by part 2-111

planes

converting to traces 2-43

polygons

drawing 2-58

ports

creating on part 2-50

drawing 2-59

excluding part 2-137

placing across RLCs 2-135

placing between pins 2-137, 2-138

placing on selected nets 2-136

remapping for Touchstone 2-230

setting naming convention 2-198

setting PSI type 2-200

setting Touchstone order 2-222

setting Touchstone remapping 2-223

power data

exporting 2-74

projects

closing 2-12, 2-42

opening 2-18

returning active 2-13

returning directory of 2-15

returning list of 2-16

returning name of 2-14

saving as 2-149

setting save prompts 2-199

R

rectangles

drawing 2-60

regions

equipotential

adding 2-23

resistors

drawing 2-61

return current distribution

disabling 2-227

enabling 2-227

RLCs

returning list of connecting 2-112

setting values 2-204

S

sanitizing layout 2-148

save prompts

setting 2-199
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scripts

list of available 2-1

running from command line 1-1

running in SIwave 1-1

setting number of CPUs 2-191

simulations

aborting 2-231

AC

exporting voltage probe data 2-89

automatic mesh refinement 2-202

CPA

exporting reports 2-74

importing options 2-118

crosstalk scan

frequency domain

setting parameters 2-158

time domain

setting parameters 2-220

DC

adaptive mesh refinement 2-202

assigning capacitor derating 2-116

bondwire discretization 2-191

exporting element data 2-79

exporting loop resistance 2-140

plotting after simulation 2-197

refining along bondwires 2-201

refining along vias 2-202

returning connected nets 2-99, 2-
102, 2-107, 2-108, 2-113, 2-
114

running 2-141

setting energy error 2-163

setting ideal ground node 2-174

setting local refinement 2-181

setting maximum passes 2-182

setting mesh bondwires 2-183

setting mesh vias 2-183

setting minimum passes 2-185

setting minimum plane area 2-159

setting minimum void area 2-159

setting thermal directory 2-99

setting via discretization 2-192

using bias voltage 2-157

using Icepak temperature 2-158

using thermal data 2-230

enabling coupling

cavity field 2-69

coplanar 2-69

intra-plane 2-71

split plane 2-71

trace 2-72

far field

running 2-142

setting external excitations 2-163

setting options 2-164
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specifying interpolation 2-126

frequency sweep

running 2-142

generating unique name for 2-115

HFSS 3D Layout

importing settings 2-120, 2-168

Icepak

configuring cabinets 2-170

running 2-142

selecting component settings 2-171

selecting SITEMP file 2-172

setting board outline 2-170

setting meshing level 2-171

setting report image height 2-172

setting thermal settings 2-173

impedance scan

exporting reports 2-90

setting parameters 2-224

setting report image height 2-225

induced voltage

running 2-143

settings

cartesian 2-176

spherical

multi 2-175

single 2-177

introducing infinite ground plane 2-178

launching 2-230

naming 2-207, 2-208

near field

running 2-143

selecting Points frequency 2-187

selecting Range frequency 2-188

setting error tolerance 2-186, 2-189

setting external excitations 2-163

setting max. edge length 2-188

setting mesh frequencies 2-187

setting number of passes 2-186, 2-
189

setting surface offset 2-190

specifying interpolation 2-126

PSI

computing SYZ 2-200

enabling ERC 2-69

setting port type 2-200

setting XML configuration 2-200

resonant modes

creating surface plots 2-139

restoring frequency 2-140, 2-140

running 2-144

setting maximum frequency 2-203

setting minimum frequency 2-203

setting number of modes 2-191

running 2-54, 2-141, 2-145
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setting coupling distance 2-223

setting crosstalk threshold 2-159

setting minimum cutout area 2-184

setting minimum pad area 2-185

setting minimum plane area 2-185

setting number of CPUs 2-191

setting vertices snapping 2-211

signal net analyzer

exporting reports 2-84, 2-85

stopping 2-231

SYZ

checking existence of 2-17

computing exact DC point 2-228

computing Spice subcircuit 2-145

controlling passivity options 2-165

enabling parasitics 2-227

enforcing causality 2-93, 2-228

enforcing passivity 2-229

error tolerance 2-70, 2-71

plotting magnitude 2-197

plotting phase animation 2-197

returning data 2-15

returning port names 2-15

running 2-145

running PSI 2-200

selecting FWS format 2-167

setting column fitting options 2-164

setting interpolating options 2-219

setting interpolating sweep 2-218

setting pole/zero options 2-166

setting state-space options 2-167

specifying common ground 2-168

Z0 renormalization 2-166

SIwave

exiting 2-18

restoring window 2-19

saving 2-19

software

exiting 2-18

restoring window 2-19

saving 2-19

solderballs

assigning material 2-211

assigning terminal type 2-38

creating complex 2-33

creating simple 2-35

setting parameters 2-212

solutions

DC

deleting 2-51

exporting power tree 2-21, 2-75, 2-
226

exporting reports 2-76

Index-11

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave™ Scripting Guide

SYZ

exporting active dataset 2-87

exporting results 2-87

exporting to Touchstone 2-83

temperature

exporting report 2-81

sources

creating frequency dependent 2-134

S-parameters

enabling support 2-231

subcircuits

Spice

computing full-wave 2-42, 2-42

sweeps

clearing all 2-40

defining 2-29

defining stepped 2-28

running 2-142

selecting layers 2-197

setting distribution type 2-181

setting frequency points 2-218

setting frequency range 2-217

setting interpolating 2-218

setting interpolating options 2-219

setting maximum frequency 2-217

setting minimum frequency 2-218

specifying interpolation 2-126

T

temperature

setting uniform 2-224

tools

running validation check 2-45, 2-146

sanitizing layout 2-148

sanitizing nets 2-148

traces

cleaning overlapping 2-39

converting to planes 2-44, 2-44

drawing 2-62

V

validation checks

running 2-45, 2-146

running with options 2-147

version number

returning 2-16

vias

drawing 2-63

refining mesh for DC sim 2-202

setting discretization for DC sim 2-192

setting mesh for DC sim 2-183

setting plating 2-195

setting plating ratio 2-196

voltage probes

drawing 2-64
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voltage sources

drawing 2-65

setting magnitude 2-213

W

warnings

adding to log 2-27

windows

restoring 2-19
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