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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

* Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

» Bold type is used for the following:

o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

° On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign > Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter’ means to

press the key labeled Enter.
« |talic type is used for the following:

° Emphasis.

° The titles of publications.

o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

* The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key

or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

« The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

@ AL
O L.
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

* The menu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the File menu, click the Open Examples command" means you can click the File
menu and then click Open Examples to launch the dialog box.

* Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation > Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu
To access help from the Help menu, click Help and select from the menu:
* [product name] Help - opens the contents of the help. This help includes the help for the
product and its Getting Started Guides.
* [product name] Scripting Help - opens the contents of the Scripting Guide.

« [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction

In this Getting Started guide, you will learn how to set up and solve a Transient Thermal analysis
of a Mechanical design in the Ansys Electronics Desktop application. You will learn how to use
datasets to define time-varying parameters. Specifically, you will use datasets in piecewise con-
stant (pwc) functions to vary heat generation, convection film coeffieient, and the rate at which
field results are saved.

The focus is on transient thermal analysis and not solid modeling. Therefore, an Ansys Elec-
tronics Desktop project file has been provided as the starting point for the exercise.

By following the procedures in this guide, you will learn how to perform the following tasks:

« Open the source project and save it to working folder

« Set 3D Ul options (this guide is based on the current view orientation scheme introduced
in v2024 R1, not the legacy orientations)

* Modify the material properties (to reduce the transient event duration and solution time,
you will decrease the specific heat of all materials by an order of magnitude)

» Assign convection boundaries and define a dataset to vary one of the boundaries with
time

» Assign a heat generation excitation, including a dataset to vary it over time

» Define the ambient temperature

» Draw two points and assign each of them as a thermal monitor point

¢ Assign initial temperatures to selected objects

» Set up the solution, including a dataset to control the rate at which field results are saved

« Validate and solve the transient thermal analysis, monitoring the thermal results as the
solution progresses

» Create and animate a temperature overlay

» Create afields summary of the heat flow rate of the heat generation excitation and con-
vection boundaries

The model consists of a power resistor that generates 4 watts of heat in low-power mode (from 0
to 4 seconds) and 7.5 watts in high-power mode (from 4 to 40 seconds). It is a slightly modified
version of the model used in the Structural Solution — Power Resistor getting started guide. The
resistor body is ceramic, the end caps nickel, the leads are copper, and a solder termination is
included where the leads are connected to a printed circuit board (PCB), which is not included in
the model. Heat generation occurs in the resistor body, and heat is dissipated via convection,
which is assigned to all exposed faces except for two of them. This convection has a time-vary-
ing film coefficient. In low-power mode, the coefficient represents the slow-speed operation of
the circuit's cooling fan. During high-power operation, the film coefficient is increased to rep-
resent high-speed operation of the cooling fan. The convection film coefficient increases by a
lesser factor than the heat generation. Therefore, the resistor temperature will increase during
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high-power operation, though not as much as if the convection boundary parameters were to
remain constant.

The horizontal face of each solder joint, which is the PCB contact face, has a separate boundary
condition from the time-varying one. In the Structural Solution — Power Resistor getting started
guide, it was assumed that 0.5 watts of heat would conduct from the power resistor to the circuit
board at each solder joint. This effect was achieved using an assigned heat flux boundary, and
the setup resulted in the solder face being approximately 20° C above ambient temperature. For
this tranisent solution, we will assign a roughly equivalent convection boundary to produce the
same result. That is, based on the surface area of the solder-to-PCB contact faces, 0.5 W of
assumed heat flow per joint, and Delta T = 20° C, we will calculate the convection film coefficient
that produces these results. This method will be used as an alternative to assigning a time-vary-
ing heat flux boundary at the solder-to-PCB contact faces.

Introduction 1-2
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2 - Set Up the Project

In this chapter, you will perform the following tasks:

¢ Launch the Ansys Electronics Desktop application and close any open or new project
+ Open the source project file and save it to a different working folder

* Set 3D Ul options

Launch Ansys Electronics Desktop

For convenience, a shortcut to the Ansys Electronics Desktop (EDT) application is placed on
your desktop during program installation. Optionally, you may want to pin the shortcut to your
Windows Start Menu too. Before proceeding to the next topic, launch EDT and ensure that no

project is open, as follows:
@)

1. IfEDT is not already running, double-click the #1".1 M Ansys Electronics Desktop short-
cut on your desktop (or the same shortcut on your Start Menu) to launch it.

The application launches with a new project created automatically:

E Ansys Electronics Desktop 2024 R2 - Project
File Edit WYiew Project Tools Window Help

~ ~ = * [Eg Save Archive , Cut Undo % ]
/ \ = o
| L LA H H - E (==

o Restore Archive Copy Red

Mew Open  Open Save Save  Close ~ HF55 Q3D
- E:{amples .I'!'.S =4 Fasie x DEIEtE - -
Desktop View Simulation Automation Ansys Minerva Learning and Support

Project Manager o =
- Project1

Then, do the following:

a. Right-click the new project name (typically Projectx) at the top of the Project Man-
ager and choose Delete Project Permanently from Disk from the shortcut menu
that appears.

b. Click OK when prompted to confirm the deletion.

2. Alternatively, if EDT was already running, save and close any open projects before pro-
ceeding to the next topic.

Set Up the Project 2-1
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Open the Source Project

The source project file is installed with the Ansys Electromagnetics Suite and is located in the
...\Help\Mechanical subfolder. After opening this project, you will save it to a working folder to
avoid attempting to save changes to the source project. Since the source file is located under the
Program Files branch of the system drive, you likely have restricted write access. Additionally, it
is best to leave the source project unaltered .

~u

1. On the Desktop ribbon tab, click “—f& Open Examples.
The Open dialog box appears with the Example folder selected.

2. Click [£]1 Up One Level to navigate to the parent folder of Examples.
You will now be looking at the AnsysEM folder contents.

3. Locate the Help subfolder and double-click it.
4. Inthe Help folder, locate the Mechanical subfolder and double-click it.
5. Inthe Mechanical folder, select TransThermal_PwrResistor.aedt and click Open.

The model appearance should be as follows:

Set Up the Project 2-2
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Ansys
2024 R2

6. On the Desktop ribbon tab, click Iﬂ Save As.

7. Navigate to the working folder of your choice and click Save to keep the original source
project filename.

Set 3D Ul Options

Ensure that the legacy view orientation scheme is not being used, since the instructions and
images in this guide are based on the new view orientation scheme introduced in release 2024
R1.

1. From the menu bar, click View > Options.
The 3D Ul Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is cleared:

Set Up the Project 2-3
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3D Ul Options x

General | 30 Modeler Graphics |

[T Stereomode  (Affects only the newly created windows)
[ Drag Optimization
[+ Show Ansys logo
Default Color Key height |16 LT;;:’;J"WM ofvalues
When there is a selection

[¢ Selection always visible

[+ Settransparency of selecled objects |T

[+ Settransparency of non-selected objects IW
Default Rotation About
(" ModelCenter (~ CumentAxis (® ScreenCenter (~ Cursor
Middle Mouse Buton Drag

@ Rotate (~ Pan  Zoom
Gradual View Change

[v Animata

Animation Duration

! o 500 msecs

[~ Enable Legacy View Ornientation |

OK | Cancel

3. Click OK.
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3 - Modify Materials

The units and solution type have already been defined in the source design. Materials have also
been specified along with the desired color choices. However, we will revise the material prop-
erties for this exercise.

Thermal changes can take a fairly long time to occur due to the mass and specific heat of mater-
ials. These properties affect how much energy is needed to change the object's temperature.
For any given thermal power input, the time it takes to produce a given temperature change
increases in proportion to the product of specific heat and mass. To accelerate the achievement
of steady-state results, we will decrease the specific heat of each material in this model by one
order of magnitude. That is, each specific heat value will be divided by 10. The remaining prop-
erties will remain unchanged. As such, the time points in the transient solution of this model will
be approximately one-tenth of the actual time that would be required for the same results (when
based on the true material specific heat values).

Note: Even though you will be running a transient thermal solution, the duration of the
transient event will be sufficient to achieve steady-state results.

Modify the Specific Heat property of each material as follows:

1. Under Model > Solids > Al2_03_ceramic in the History Tree, select Body.
2. Inthe docked Properties window, choose Edit from the Material drop-down menu.

The Select Definition dialog box appears with the current material assignment selected.
Perform the following steps:

a. Click Clone Material(s).

b. The View/Edit Material dialog box appears, and it displays a new material with the
same properties as the cloned one except for the name, which has " - Copy" appen-
ded to it. Change the material name and specific heat value as follows:

» Material Name = Al2_03_ceramic_LSH (the "_LSH" suffix is for "Low Spe-
cific Heat")
» Specific Heat = 85 J/kg-C (the original value divided by 10)

c. Click OK to apply this material to the resistor body and to close the Select Definition
dialog box.

3. Under copperin the History Tree, select Wire_1 and Wire_2.
Repeat steps 2 through 2c but this time, specify the following properties:

+ Material Name = copper_LSH
« Specific Heat = 38.5 J/kg-C
4. Click OK.
5. Under nickel, DC in the History Tree, select EndCap_1 and EndCap_2.

Modify Materials 3-1
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Repeat steps 2 through 2c but this time, specify the following properties:

+ Material Name = nickel, DC_LSH
+ Specific Heat = 44.4 J/kg-C
6. Click OK.
7. Under solderin the History Tree, select Solder_1 and Solder_2.

Repeat steps 2 through 2c but this time, specify the following properties:

* Material Name = solder_LSH
+ Specific Heat=16.7 J/kg-C
8. Click in the Modeler window background area to clear the selection.

Modify Materials 3-2
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4 - Assign Convection Boundaries

You will assign two different convection boundaries to this model. The first one uses a calculated
and constant film coefficient that is intended to approximate conduction of heat from the solder
joints to the traces of a printed circuit board (PCB) that is not included in the model.

First Convection Boundary

As mentioned in the Introduction to this guide, a nearly identical power resistor is used in the
Structural Solution — Power Resistor getting started guide. A negative heat flux boundary was
assigned to each solder-to-PCB contact face to remove a specified amount of heat from the
model. The specified power was -0.5 W per face, and the resulting delta T, relative to ambient
temperature was approximately 20° C. That assumption was based on a total heat generation of
7.5 W in the resistor body.

For our transient thermal solution, we will calculate an equivalent convection boundary. The heat
generation in this solution varies. A convection boundary at the solder-to-PCB contact faces will
allow the temperature of these faces, and the heat conducted through them, to vary as the heat
generation varies. The derivation of the film coefficient follows:

» Assumed thermal power conducted to the PCB at each joint=0.5 W

Assumed solder face temperature = 40° C

Ambient temperature = 20° C
Delta-T at convection faces =40° C-20°C=20°Cor20°K
Surface area of PCB contact face of each solder joint = 12.0637 mm?2 = 1.20637 x 10" m?

Therefore, the Film Coefficient = 0.5 W /(20° K * 1.20637 x 10-> m2) = 2072 W / (m2. Assign
this boundary as follows:

1. Click in the Modeler window to make sure that it is active and then press F to switch to the
Face selection mode.

2. Select the top, horizontal face of each solder joint, as shown in the following image. Click
the first face and Ctrl+click the second one:

Assign Convection Boundaries 4-1
Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Mechanical: Transient Thermal Solution — Power Resistor

=

3. Right-click in the Modeler window and choose Assign Boundary > Convection from the
shortcut menu.

4. Inthe Convection dialog box that appears, specify the following settings:
* Name: Conduction_to_PCB
* Film Coefficient: Uniform 2072 w_per_m2kel

» Tenperature: AmbientTemp (units selection is unsupported; the units are spe-
cified in the variable definition)

Convection
Mame |Cnnductinn_tD_PCB
Film Coefficient
& |niform |2|3'?2 |w _per_m2kel ﬂ
" MNen-Uniform |
Temperaturs Ambient Temp | ﬂ
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Note:

In the next topic, you will verify that the AmbientTemp variable is set at 20° C.

5. Click OK.

Second Convection Boundary

The second convection boundary will be assigned to all exposed faces of the power resistor,
excluding the two faces where the first convection boundary has been assigned. The second
boundary will use a design dataset referenced within a piecewise constant function. The dataset
will specify two different film coefficients—one representing the low-speed mode of the circuit's
cooling fan, and the other the high-speed mode. The assumed film coefficients are 25 and 40 W/
(m2-K), respectively, for the low- and high-speed fan modes. The circuit will switch from low to
high power at 4 seconds and maintain high power throughout the remainder of the transient solu-
tion.

1. Select the thirteen faces indicated in the following image:

4 5

10

11

13
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Note:

For faces hidden from view, you can either rotate the model viewpoint or
Ctrl+click a face in front of the one you wish to select and then press B to change
the selection to the face Behind the initial selection.

2. Right-click Boundaries in the Project Manager and choose Assign > Convection from
the shortcut menu.

3. Inthe Convection dialog box that appears, specify the following settings:
 Name: Convection_vs_Time
* Film Coefficient: Uniform pwc(ds_Convection,Time) w_per_m2kel
e Tenperature: AmbientTemp

Convection

Mame |Cn:-n'-.rectiu:|n_us_'l“|me

Film Coefficient

{* nifom |pwu:|:ds_|:nnvectinn.'|"|me |w;uer_m3c;elﬂ

" Non-Uniform |

Temperature Ambignt Temp | j
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Note:

¢ "pwc indicates that the data will be interpreted using the piecewise con-
stant function. When a value changes at a given time, the parameter being
controlled steps to the new value at the previous timepoint and remains
constant throughout the interval from the previous timepoint to the current
one. Whereas, for a piecewise linear (pwl) function, the value would
change linearly (as a ramp) from the value at the previous timepoint to the
value at the current timepoint. This will become clearer when we define the
dataset.

¢ ds_Convection is the name of the dataset, and Time indicates that the
values will be defined as a function of time. That is, the convection film
coefficient will be time-varying in this case.

* \When a dataset is referenced in the uniform film coefficient, units selection
becomes disabled. Additionally, after completing the convection asign-
ment and dataset definition, if you revisit the Convection dialog box to
review the boundary properties, the film coefficient units will be blank. The
reason is that the units are specified within the dataset definition.

4. Click OK.

The Add Dataset dialog box appears. Note that the dataset Name and the units of the X
and Y columns have already been defined. We will change the time units from nano-
seconds (the default) to seconds, and we will keep the default convection film coefficient
units (w_per_m2kel).

5. Click the X column heading and choose s (seconds) from the drop-down menu.
6. Define the datapoints as shown in the following image:

Assign Convection Boundaries 4-5
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Edit Dataset O X
Mame: ||:|3_C0nve|:lil:|n g — Swap =T Data Import Dataset... ExportDatasel...|
Coordinates--Click on header to change urit A
ek nsys
X[S]‘T ¥ [w_per_mkel] | 2024 R2
a 25 0.0
4 %5 .
40 40 o
KR m
— =350
u_'| -
- - .
™ ]
| E ]
< 325 .
- z 1
— 2 ]
=300 -
Append Rows. .. ‘ ‘ 275 ]
250 IIII|IIII|IIII|IIII|IIII|IIII|IIII|IIII

o]

L]

5 10

Cancel |

15 20 2 30 35 40
X [s]

Within the Add Dataset dialog box, the data is always previewed according to the piece-
wise linear function (pwl). However, when the datset is referenced within a piecewise con-
stant function (pwc) it will be interpreted differently. Specifically, for this example, the
resultant curve of convection film coefficient versus time will be as follows:
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Interpretation of pwc(ds_Convection,Time)

40 &

35
30
25
20
15

10

Click OK.

The two convection boundaries that have been assigned are listed under Boundaries in
the Project Manager:

" .:;. Contacts
-[F Boundaries

...... @ Conduction_to_PCE —

...... ﬁ Convection_ws_TiMe -—
... B} Excitations

You can select either one to see a boundary visualization overlaid on the model geometry:
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9. Click in the Modeler window background to clear any selection or boundary visualization
before proceeding to the next topic.

Assign Convection Boundaries 4-8
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Note:

Convection boundaries are automatically excluded from portions of assignment faces
that are in default bonded contact with other solid objects. You need not use imprinting
operations to split such faces to isolate contact regions from convection boundaries.
However, for user-defined contact faces (those with thermal resistance), portions of lar-
ger faces that have thermal contact with other objects are not automatically excluded
from convection boundaries.

For this design, no thermal contact areas are assigned, and all objects are in default
bonded contact. Therefore, the portion of the body's OD face that is inserted into the
end caps, and the portion of each wire that passes through the solder will automatically
be excluded from participating in convective heat flow.

Verify Ambient Temperature

For a clean installation of the Ansys Electromagnetics Suite, the default ambient temperature in
Mechanical — Thermal designs is 20° C. Verify that this default temperature has not been
changed, and set it to 20° C for this design if it has been changed.

1. Using the menu bar, click Mechanical > Design Settings.

2. Inthe Ambient Conditions tab of the Mechanical Design Settings dialog box that
appears, ensure that the settings are as follows:

* Temperature = 20
» cel (°C) is selected in the units drop-down menu.

Mechanical Design Settings

Ambient Conditions || Export Settings | Set Material Ovenide | Validations |

Temperature 20 |n:e| j

3. Click OK.

Any boundary with AmbientTemp specified as the Temperature setting will be based on
this global 20° C value.
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5 - Assign Heat Generation

Heat input for this model comes from the resistor body. Apply a Heat Generation excitation to the
body as follows:

1. On the Draw ribbon tab, choose Object from the Select drop-down menu (or, with the
Modeler window active, press O) to switch to the Object selection mode.

2. Click the resistor Body with the cursor positioned well away from the EndCaps.

Alternatively, select Body from the History Tree (under Model > Solids > Al2_03_
ceramic_LSH).

2

3. Right-click Excitations in the Project Manager and choose Assign > Heat Generation
from the shortcut menu.

4. Inthe Heat Generation dialog box that appears, specify the following settings:
 Name: HeatGen_vs_Time
e Total Power: pwc(ds_HeatGen,Time) W
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Heat Generation

General ] Defautts ]

Mame |HeatGen_~.rs_'ﬁme

Tatal Power |pw-:[u:|s_HeatGen,'|"|me} |W ﬂ

IIse Defaults

Note:

o Total Power refers to the heat dissipated by the device, not the elec-
trical power the device conducts or outputs to the circuit. The power
specified is generated per each selected assignment object.

o When a dataset is referenced in the Total Power text box, units selec-
tion becomes disabled. Additionally, after completing the heat gen-
eration assignment and dataset definition, if you revisit the Heat
Generation dialog box to review the excitation properties, the total
power units will be blank. The reason is that the units are specified
within the dataset definition.

. Click OK.

The Add Dataset dialog box appears. Note that the dataset Name and the units of the X
and Y columns have already been defined. We will change the time units from nano-
seconds (the default) to seconds, and we will keep the default power units (W).

. Click the X column heading and choose s (seconds) from the drop-down menu.
. Define the datapoints as shown in the following image:
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Edit Dataset o X
Mame: |ds_HeatEBn — Swap Y Data Inport Dataset.. ExpurtDatasel...‘
Coordinates-Click oh header to change uni A
Al Y[W] 1[11]25 Rg
0 4 75
4 4 ]
40 75 70
N 65 3
B 60
Bl 2 ]
N 755
50
tippend Rows. . 45 —_
4[] IIII|IIIIIIIIIIII|IIII|IIIIIIIIIIII
0 5 10 5 20 5 I % 0
0K Caniel X s]

Within the Add Dataset dialog box, the data is always previewed according to the piece-
wise linear function (pwl). However, when the datset is referenced within a piecewise con-
stant function (pwc) it will be interpreted differently. Specifically, for this example, the
resultant curve of convection film coefficient versus time will be as follows:
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Interpretation of pwc(ds HeatGen,Time)

8. Click OK.
HeatGen_vs_Time appears under Excitations in the Project Manager:

--&' Boundaries
=2 Excitations

P B HeatGen_vs_Time tf—
.. Monitor

While this excitation is selected, you can visualize it on the model:
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9. Clear the selection.
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6 - Draw and Assign Thermal Monitor
Points

In transient thermal solutions, you can define thermal monitor points at which the solver will out-
put temperature versus time results. Unlike saved fields, temperatures at monitor points are
reported for every timestep and for every substep the solver runs during the full transient
anslysis duration. Since the data is written to your hard drive only for specified coordinates, the
memory requirement and solution time can be significantly lower than what is needed to save
fields results, which are global and recorded for all nodes or elements. Often, the monitor points
provide all the necessary output, and you can choose either to not save fields or to only save
them for several time points of interest.

You can assign monitor points to objects. However, the resultant point is at the object's centroid,
which may be outside of the object's body (for example, if the body is hollow, C-shaped, or L-
shaped). In such cases, you can draw a point inside the body's volume and assign a thermal
monitor to the point. You will do so now to provide thermal monitors at the centroid of the hole
where the lead wire is inserted into an end cap and at the center of a solder-to-PCB contact face.
The resistor body, which is the heat source, will be the hottest object. No point is needed
because the thermal monitor automatically includes a trace of the global maximum temperature.
The two points you draw are both at the centerline of a lead wire but are good indicators of the
minimal end cap temperature and the temperature where the solder contacts the PCB.

1. Onthe Draw ribbon tab, click ® Point. Then, complete the following steps:

a. Press Tab to jump to the X coordinate entry text box in the status bar at the bottom
of the Ansys Electronics Desktop window.

Important:

Be careful not to touch, move, or bump the mouse while using the key-

board to navigate and fill the coordinate entry text boxes. If you do, the

coordinate entry method will revert to the pointing mode, and any typed
coordinates will be replaced by the cursor location.

Type 24.25 in the X text box.
Press Tab.

Type 0 in the Y text box.
Press Tab.

Type 20 in the Z text box.

¥ III 7 |Absn|utj |Car‘tesian ﬂ mm

g. Press Enter.
2. Under Points in the History Tree, select Point1. Then:

-~ ® 2 o T
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3. Verify that the point is located at the centerline of the hole into which the right wire is inser-
ted into the right end cap and at the mid-length of the hole:

4. With Point1 still selected, right-click Monitor in the Project Manager, and choose
Assign > Point from the shortcut menu. Then, in the Monitor Setup dialog box that

appears:
a. Change the Name to EndCap.
b. Click OK.
5. Onthe Draw ribbon tab, click ® Point. Then, complete the following steps:
a. Press Tab.
b. Type 30 in the X text box.
c. Press Tab.
d. Type0intheY textbox.
e. Press Tab.
f. Type 3.5in the Z text box.
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dx: dy: IZI s Fi |F'~E|3ti“j |':3"tE5i3” ﬂ mm

g. PressEnter.
6. Under Points in the History Tree, select Point2. Then:

7. Verify that the point is located at the centerline of the right wire and in the plane of the top,
horizontal face of the solder:

>

8. With Point2 still selected, right-click Monitor in the Project Manager, and choose
Assign > Point. Then, in the Monitor Setup dialog box that appears:

a. Change the Name to Solder.
b. Click OK.
9. Clear the selection.
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7 - Assign Initial Temperatures

To shorten the transient event duration and solution time, you will specify initial temperatures for
all objects. These temperatures will be slightly less than the expected steady-state temperatures
that occur for the low-power operating mode. However, once the power is increased, it will take
longer to achieve steady-state results for the high-power mode.

There is a global initial temperature parameter in the solution setup that you will use in a later pro-
cedure for the lead wires and solder joints (four objects). For the remaining three objects (the
body and end caps), you will define an object-based intital temperature assignment, which will
override the global parameter.

1. Inthe Object selection mode, select the resistor Body.

2. Inthe Project Manager, right-click Initial Temperature and choose Assign from the short-
cut menu.

3. Inthe Temperature Patch dialog box that appears, specify the following properties:
¢ Patch Name = InitTemp_Body
* Initial Temperature =97cel

Tip:

As an alternative to choosing the units from the drop-down menu, you can
type them into the text box. You must use the exact abbreviations that are
supported, which are listed in the units drop-down menu. The input will be
accepted whether or not a space is used between the number and the units
abbreviation. If you later revisit the dialog box, the units will be shown as a
drop-down menu selection, rather than remaining appended to the number
in the text box.

Temperature Patch

Patch Mame: |In'rtTemp_Bu:u:|'_.'
Initial Temperature: |Er? cel j
4. Click OK.

5. Select objects EndCap_1 and EndCap_2.
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6. Right-click in the Modeler window and choose Assign Initial Temperature from the short-
cut menu.

7. Inthe Temperature Patch dialog box that appears, specify the following properties:
¢ Patch Name = InitTemp_EndCaps
* Initial Temperature = 82cel

Temperature Patch

Patch Name: |In'rtTemp_EndCaps
Initial Temperature: |82 cel j
8. Click OK.

The assigned initial temperatures are listed in the Project Manager.

--— Monitor

E| !,} Initial Temperature

! 4, InitTemp_Body mm—
!u InitTemp_EndCaps -

You can select each of them to see a visualization overlaid on the model geometery:
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9. Clear the selection.
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8 - Set Up, Validate, and Analyze Model

Create an analysis setup.p, validate the design, and run the analysis, as follows:

1. On the Simulation ribbon tab, click & Setup.
TheGeneral tab of the Thermal Solve Setup dialog box appears.

2. Specify the following parameters, all in units of seconds (s):
e Start:0's
o Stop:40s
o Step:1s

Thermal Solve Setup

Advanced ] Convergence | Initial Conditions ] Save Fields ] Defaults ]

Name |Setup'| [v Enabled
Salver Type |F'n:|gram Cortrolled j
Transient Setup
Start |0 E =l
Stop | 40 |s j
Time Step | 1 |s j

| Time variation preview I

Stepping |F'ru:ugram Controlled ﬂ

3. Click Time variation preview to see a plot of all time-varying boundaries and excitations:
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B " Variations Preview

ER o

=- [l ThermalConvection
. [w] FilmCoeff: Convectio

Note:

7 .50EHIO
7.00E+ID
B.50E+I0
3
o
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o 5.50E+I0
5.00E+HOD
4 50EHIOD

4 D0E+HOD
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L 3756401

[ 3.50E+01

[ 3256401

[ 3.00E+01

[ 2 75E+401

2.50E+HM

5 1

1

2
Time(s)

2

3

3B 4

0

e TheY axis on the left (red background) shows the values for the heat gen-
eration power. The Y axis on the right (green background) shows the con-
vection film coefficient values. The green film coefficient trace exactly
coincides with the red heat generation power trace and obscures it. Clear

the ThermalConvection checkbox to see the red trace.

« Each trace is based on a single value at each timestep (at each second in
this case). Up to 4 seconds, the low-power convection and heat generation
values are constant. Although the values immediately jump to the high-
power mode at 4 seconds (as defined in the datasets), the next requested
timestep after 4s is 5s, which reflects the increased values. Therefore, the
variations preview shows a ramp with the values changing over a one

second period, rather than a step change at 4s.

4. Close the Variations Preview window.
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5. Sselect the Intial Conditions tab, type 65 in the Initial Temperature text box, and
choose cel from the units drop-down menu:

Thermal Solve Setup

General ] Advanced ] Convergence | Initial Conditions | Save Fields ] Defaults ]

Initial Temperature |EE |I3E.'| j

Note:

This parameter sets the intial temperature globally, which applies to anthing that
does not have an object-based initial temperature assignemnt. In this case, 65°
C will be the starting temperature for the wires and solder, since the body and
end caps have overriding temperature assignments.

6. Selectthe Save Fields tab and then do the following:
» Select the Every option.
* Inthe Steps text box, type pwc(ds_SaveFields,Time).

Thermal Solve Setup

General | Advanced | Convergence | Inttial Conditions  Save Fields lDefaufts]

Field save times ...

" Mone

i+ Every |pwu:[u:|s_5aue Fields, Time Steps

7. Click OK to complete the transient solution setup.

The Edit Dataset dialog box appears. Note that the dataset Name and the units of the X
have already been defined. We will change the time units from nanoseconds (the default)
to seconds. The Y column values are dimensionless, and no unit will be selected.

8. Click the X column heading and choose s (seconds) from the drop-down menu.
9. Define the datapoints as shown in the following image:
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Edit Dataset o X
Name: |ds_5aveFieIds +— Swap - Data Imnpart Dataset... ExpurtDatasel...‘
Coordinates-Click oh header to change uni A
Nsys
)0 o S 2024 R2
0 1 20
15 1 ]
40 2 |
18 1
| 16 1
B > ]
- 14
12
tippend Rows. . ]
1[] IIII||IIIIIIIIIII||III|IIIIIIIIIIII
0 5 10 5 20 5 I % 0
0K Caniel X s]

Within the Add Dataset dialog box, the data is always previewed according to the piece-
wise linear function (pwl). However, when the datset is referenced within a piecewise con-
stant function (pwc) it will be interpreted differently. Specifically, for this example, the
resultant curve of the field-saving interval versus time will be as follows:
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Interpretation of pwc(ds_SaveFields, Time)

2 & @
1.5
1 ——o
0.5
0
0 4 8 12 16 20 24 28 32 36 40

The fields will be saved for every timestep from 0 through 4 seconds. Thereafter, fields will
be saved for every other timestep.

10. Click OK.

Setup1 has been added under Analysis in the Project Manager:
Eﬁ Analysis

E " }? Setupl 4

----- l@ Optimetrics

11. On the Simulation ribbon tab, click */ Validate.

The Validation Check window appears, and there should be no errors or warnings:
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12.

13.

Walidation Check: TransThermal_PowerResistor - MechanicalDesign X

Qf b echanicallesigr

" Design Setings
& 3D Model
,i\, Boundaries and Excitations

Yalidation Check completed, Emors 0 %Warnings: 1 ' Monitars

See Mezzage Window for details.

T

¥ Mesh Operations
¥ Analysiz Setup
" Optimetics

Cloze

Note:

There is a warning associated with Boundaries and Excitations. If you look in the
Messages window, you will see a warning about the initial temperature assign-
ments at the body and end caps overlapping. Each end cap shares a cylindrical
face with a portion of the body OD, and these objects are at two different initial
temperatures. This warning is inconsequential and can be ignored.

Click Close to dismiss the Validation Check window.

On the Simulation ribbon tab, click ok Analyze All.

The solution should take about thirty minutes to complete on a current, high-end computer
workstation. Procede immediately to the next topic while the solution is running.
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9 - Evaluate Results

In this final section, you will observe the thermal monitor results as the solution progresses, gen-
erate a mesh overlay, and overlay the temperature results for the last timestep. Additionally, you
will animate the temperature results versus time and create a summary of the heat flow rates.

The following three topics are covered in this section:

+ Thermal Monitor: Observe temperature versus time results (global maximum and at
monitor points)

* Mesh Overlay: Overlay the generated elements on the geometry in the Modeler window

+ Temperature Overlay: Overlay the temperature results at the last timestep and animate
them over the full transient event

Thermal Monitor

While the solution is still progressing, you can observe the temperature versus time results in the
Thermal Monitor, as follows:
1. Under Analysis in the Project Manager, right-click Setup1 and choose Thermal Monitor
from the shortcut menu.

The Solutions window appears with the Thermal Monitortab selected. The traces develop
gradually as each timestep is solved. The following figure is the appearance of the plot at
the conclusion of the solution. Annotation lines have been added to match each monitor

point to its trace:
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Profe | Mesh Statisics - Themal Monior |
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Observations:

¢ The global maximum temperature corresponds to the resistor body, which
is the source of heat generation. The maximum temperature is expected to
occur near the middle of the body's length. The combination of convection
at the end caps and wires, and conduction of heat through the wires and
solder, should make the ends of the body cooler than its center. The tem-
perature overlay created in the next topic will verify the expected behavior.

» For the low-power operating mode, steady-state temperature results are
achieved very quickly due to the well-chosen initial temperature assign-
ments, as intended.

« High-power operation occurs from 4 through 40 seconds (36 seconds dur-
ation). The rate of temperature change is maximal at the begining of this
interval, and the slope decreases until the traces level off. By the end of
the transient event, steady-state temperatures have been achieved at all
objects. More precisely, at the resolution of this plot, no further tem-
perature increase is observed beyone time = 33 seconds (or about
29 seconds after the power increase occurred).

Had the specific heat property of the materials not been modified, steady-
state results would have been achieved about 290 seconds (10 * 29 s)
after the beginning of the high-power mode. A longer-duration transient
analysis, using unmodified materials, would verify that expectation, albeit
with a significantly longer solution time. In addition to modifying the ana-
lysis setup, the time points in each design dataset would have to be
revised. Additionally, Save Fields could be set to None to lessen the
input/output time and storage requirements.

* Immediately after the switch to high-power mode occurs (at 4 seconds),
the temperature at the solder-to-PCB junction (blue trace) decreases
momentarily before starting to increase. This phenomenon is easy to
explain. The convection film coefficent increases at the same time as the
heat generation in the body increases. The enhanced convection at the
conical face of the solder immediately starts cooling it off before the
increased heat generation has sufficiently raised the body and end cap
temperatures and conducted down through the wires to the solder joints.
So there is a delay before solder heating begins.

A similar effect likely occurs at the end cap-to-wire intersection area, but to

a lesser extent and for a shorter duration, making it insignificant. The effect
is not apparent at the the end cap monitor point (green trace) due to the lim-
ited resoltuion of this plot.
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2. Close the Thermal Monitor window.

Mesh Overlay

Overlay a mesh plot on all sevem solid parts of the model, as follows:

1. In Object selection mode, click in the Modeler window and press Ctrl+A to select all
objects.

2. Right-click Field Overlays in the Project manager and choose Plot Mesh from the short-
cut menu.

The Create Mesh Plot dialog box appears:

Create Mesh Plot X

Mame:  |Meshl

Design Mame:  MechanicalDesign

Contest
Solution; |Setup'l : Salutian j
Field Type: | Fields J

Done | Cancel |

3. Click Done to accept the default plot setup and generate the mesh overlay.

Mesh1 appears under Field Overlays > MeshPlots in the Project Manager:

------ Results

E% Field Overlays

Your model should now resemble the following image:
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Ansys
2024 R2

After reviewing the mesh, hide it so that it won't obscure the temperature overlay you will
create next.

4. Under Field Overlays > MeshPlots in the Project Manager, right-click Mesh1 and clear the
Plot Visibility option.

Temperature Overlay

Create an overlay of the temperature results if the last timestep:
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1. Clickin the Modeler window to ensure that it is the active window. Then, press Ctrl+A to
select all objects.

2. Right-click Field Overlays and choose Plot Fields > Temperature. Then, in the Create
Field Plot dialog box that appears, do the following:

a. Under Intrinsic Variables, choose 40s from the Time drop-down menu.
b. Ensure that the remaining settings match the following image:

Create Field Plot s
[ Specify Mame |Temperatur32 Fields Calculatar .. | Surface Smoothing ...
[ Specify Folder |Temperature J Categony: |Standard -

Dezign: MechanicalD esignl [luantiby In Yolume
Solution: |Setup1 - Solution ﬂ Mag HeatFlux 5 Eﬁ!;l:lte;_p'l 5
Thermal Conductivity = EndEap_1

o = Thermal Conductivity v : -

Pl Ty = |F'E|':IS J Thermal Conductivity 2 ﬁ::z_'lz
o _ Surface Lozz Denszity El:udy_
Intrinzic Wariables / Wolume Loss Density All0bjects
Linked Heat Tranzsfer Coe
Save b Default | ¥ Plot on surface only
[ Streamline

Done | Carnicel

c. Click Done.
The color contour overlay and temperature legend appear in the Modeler window.

3. Press F6 to suppress shading of the CAD surfaces. Doing so improves the appearance of
the overlay contours on curved faces.

Your temperature overlay should now resemble the following image:
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Temperature Ansys
[cel] 2024 R2
Max: 123.603

124 .0
l 1Me7

1074

991

908
l 825

742

659

576

433

41.0
Min: 41.043

Optionally, continue to the final few steps to animate the temperature overlay.
4. Under Field Overlays > Temperature in the Project Manager, right-click Temperature1
and choose Animate from the shortcut menu.

5. Inthe Create Animation Setup dialog box that appears, ensure that all timesteps are selec-
ted:
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Maodify Animation Setup *

ET= I.-’-\.nimatin:nm D escription: ISwept variable Time
Swept Variable(s) | Design Point |
oo =] [

Select values:

Cancel |

6. Click OK.

It will take a minute or two for the frames to be generated for all timesteps before the anim-
ation begins to play.

7. Drag the Time annotation to position it as desired. You can also adjust the play speed,
start, stop, or reverse the animation using the controls in the Animation dialog box:
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Animation: Animation — *

|
\_|_1

.|

« (=] »| »

Speed
Frame: 7, Time = 10z
Export...
Clogze
Label:
EBackground: Fant v Show

Your animation should resemble the following one:
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8. Click Close when you are done reviewing the animation.

Congratulations on completing this transient thermal getting started guide. You can save and
close your project now.
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