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1 - Introduction to Scripting
SIwave has the ability to run saved scripts in VBScript or IronPython. It also contains a native
IronPython command shell.

The following topics contain more information about scripting in SIwave:

Running a Script

SIwave Script Commands

Running a Script
To run a script file in SIwave:

1. Click Tools. From the Scripting area, click Run Script.
TheOpen window appears.

2. Use the file browser to locate and select a *.vbs or *.py script file.
3. ClickOpen.

The script is executed.

To run a script file from a command line:

1. Type the following:
<path to siwave.exe> <path to *.siw file> -RunScript <path to *.py
file>

SIwave opens and the script is executed.

Alternatively, type the following to run the script and close SIwave:

<path to siwave.exe> <path to *.siw file> -RunScriptAndExit <path
to *.py file>

To run a script from the IronPython command shell:

1. Click Tools. From the Scripting area, click IronPython Comand Shell.
The command window appears.

2. Type an appropriate script commands and press Enter.

Using the IronPython Command Shell
This section describes IronPython and using the IronPython Command Shell in SIwave. It is
written for those already familiar with scripting in VBScript or JavaScript.

To launch the IronPython Command Shell:

SIwave Scripting Guide
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1. Click Tools. From the Scripting area, click IronPython Command Shell.
The IronPython Command Window appears.

Introduction to IronPython
IronPython is an implementation of the Python programming language targeting the .NET
runtime. IronPython uses the Python programming language syntax and standard python
libraries and can additionally use .NET classes and objects to give the best of both worlds. This
usage of .NET classes is seamless in that a class defined in a .NET assembly can be used as a
base class of a python class.

Scope

This section of the help provides a basic introduction to the use of IronPython in SIwave. If you
require a full tutorial on Python or IronPython, there are many online resources.

Python Compatibility

The version of IronPython in use is 2.7 and built on .NET framework version 4.0. While most
python files will execute under IronPython with no changes, python libraries that make use of
extensions written in the C programming language (NumPy or SciPy, for instance) cannot be
expected to work in IronPython. In such cases, it might be possible to locate .NET

Introduction to Scripting 1-2
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implementation of such libraries or explore the use of IronClad
(http://code.google.com/p/ironclad/).

Advantages of IronPython

The advantages that IronPython provides are significant:

l Python has a large ecosystem with plenty of supporting libraries, Visual IDEs and
debuggers. It is actively developed and enhanced.

l IronPython has access to the entire .NET ecosystem. This allows us, for instance, to create
a modern GUI using the System.Windows.Forms assembly from IronPython code and call
any other .NET assembly.

l The Python syntax of dictionaries is somewhat easier to read and write when supplying
arguments to the scripting methods.

Scripting Using IronPython
Interacting with script objects in IronPython is natural. Method calls are made just like in
VBScript, except that the argument syntax is somewhat simplified to follow natural Python
syntax. All primitive types (string, integer, double) map to the natural primitive types in python.

If you have existing VBScript/Javascript scripts, use them by either embedding into the
IronPython script or invoking them via run methods.

If you must write an IronPython script from scratch, consult this help, along with internet
resources. See IronPython Samples for a collection of pure IronPython snippets. These should
serve as a guide and reference.

IronPython Mini Cookbook
This topic presents simple counterparts between IronPython and VBScript. It does not provide a
full tutorial on IronPython syntax. Because IronPython is a Python implementation, you can
consult Python documentation for additional information.

Comments

VBScript IronPython

Comments start with a single quote:

' comment

Comments start with a hash:

# comment
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Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

http://code.google.com/p/ironclad/


SIwave Scripting Guide

Assigning/Creating Variables

VBScript IronPython

Declare with a Dim:

Dim doc

Assignment then needs a Set instruction:

Set doc = app.GetActiveProject()

No Set syntax. Simply create and assign:

doc = app.GetActiveProject()

Create Lists/Arrays

VBScript IronPython

Declare as array of String with 11 indices, from 0
through 10:

Dim myArray(0 to 10) as String

myArray(0) = "Hello"

myArray(1) = "bye"

Declare an array with no size:

Dim array2() as String

Re-dimension an array once size is known:

ReDim array2(0 to 2) as String

array2(0) = "this"

array2(1) = "also"

Declare an empty array:

myEmptyArray = []

Declare an array and initialize it with 5 ints:

myInitedArray = [ 1, 2, 3, 4, 5]

Python lists can have items of any type and there is
no pre-declaration. Declare an array and init with
mixed types:

mixed = ["hello", 1 ,2 ["nested"]]

Append to an array:

mixed.append( 3.5 )
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Create Dictionaries/Maps

VBScript IronPython

Declare with a Dim:

Dim dict

Use the CreateObject function with ProgID
Scripting.Dictionary:

Set dict = CreateObject _

("Scripting.Dictionary")

Add items using the object, key, item syntax:

dObject.Add key, item

An IronPython dictionary is a collection of name
value pairs. Just like arrays, there is no
restriction on the keys or the values. For
purposes of Ansys EM scripting, however, all
keys must be strings

Delimiters are curly braces. Use a colon
between the key and the value. Separate key
value pairs with a comma:

myDict = {

"a" : 1,

"b" : "hello there",

"c" : [ 1, 2, "abc"]

}

Boolean Values

VBScript IronPython

Boolean literals are in lower case:

true

false

The first letter is capitalized:

True

False
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Converting Numbers to Strings and Vice Versa

VBScript IronPython

Use CInt, CDbl, CBool, CLng to convert the string
representation to the number representation. Use
IsNumber to check before conversion:

Dim nStr = "100"

Dim n = CInt(nStr)

Use CStr to convert a number to its string
representation:

Dim v, vStr

v = 100

vStr = CStr(v)

Use integer() or float() or double() functions to cast
a string CONTAINING the string representation of
whatever you are casting to:

strInt = "3"

intVal = int(strVal)

floatVal = float(strVal)

Invoke the str() function with the int/float values as
needed. You can alternately use the string
formatting method listed below:

strVal = str(42)

strVal = str(42.345)

String Formatting/Concatenation

VBScript IronPython

String concatenation uses the & operator:

Dim allStr, str1

str1 = " how are you"

allStr = "Hello " & " There" &
str1

There seems to be no direct string formatting
function in VBScript. Ssing string concatenation or
using Replace are the two built-in options:

Dim fmt = "{1} climbs stalk {2}"

Dim str = Replace(fmt, "{1}",
"jack")

str = Replace(str, "{2"}, 10)

If you have two strings, you can always
concatenate them using the '+' operator:

str1 = "hello"

str2 = "world"

str12 = str1 + " " + str2

If you have different types (for instance a string and
an int), you must use the string formatting
commands. When formatting multiple arguments,
they must be entered as a tuple ( item1, item2, ):

num = 10

str3 = "%s climbs stalk %d" %
("jack", num)

str4 = "%d stalks" % num
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Looping over Lists

VBScript IronPython

Dim myArray(0 to 2) as String

myArray(0) = "alpha"

myArray(1) = "bravo"

myArray(2) = "charlie"

For Each i in myArray

Print i

Next

vals = [1, 3, 3.456]

def process(val):

return 2*val

for i in vals:

    print i

    print " -> " process(i)

Looping over a Range

VBScript IronPython

To loop over a range, specify start, end, and step:

For i = 0 To 10 Step 1

Print i

Next

for i in range(0, 10):

    print i

Indentation in IronPython

Python is a language where white space (spaces and tabs) is syntactically significant. You must
understand the basics of indentation before scripting in python.

Any statement that introduces a block of code should be written so that every line of the block
has the same indent (leading spaces or tabs) and the indent should be at least one more than
the indent of the introducing statement.

Note:

Python recommends the use of spaces over tabs.

Indenting Functions

Define a function that starts at 0 indentation:

def multInt(a,b):
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Every line following def multInt that is expected to be a part of the function, must be indented
to line up with the function.

def multInt(a,b):

    return a

Indenting If Conditions

Each line that belongs to the body of this function should have an indent that is more than the
indent used by the if statement.

def multInt(a,b):

If a%2 == 0:

       return (a * b) + 100

    else:

       return (a * b) + 1000

Methods in IronPython

Finding Methods

To list all methods available in the string module,import the module:

import string

Then get the directory listing:

dir(string)

This returns a list of all the methods available (as well as some __somename__ internal names
that can be ignored).

Help

Once you know a function name, you can get more help on it using the built-in helpmethod.

Translating Script Commands from VBScript to IronPython
This topic briefly describes scripting methods and arguments via VBScript samples. The
distinctions made here are significant and useful when translating scripts written in VBScript to
IronPython.
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Script Method Argument

Script method calls in VBscript generally take the form:

objectName.methodName ( arg1, arg2, ..)

The function call syntax is a standard followed by several programming languages. However,
the argument types in VBScript objects used for product scripting are restricted to the following:

l Primitive Types
l Named Arrays
l Named Functions

Primitive Types

Primitive types are the standard bool, int, float, double and string.

Named Arrays

Named arrays are a special construct used very commonly and can be found in many recorded
sample scripts.

A named array begins with Array(NAME:someName) followed by a collection of comma
separated values, which can be:

l Primitive values
l Arrays of primitive values
l Additional named arrays
l Keys, in the form keyName:= followed by a primitive value
l A function (described next)

Named Functions

Named functions are arrays which start with Array( without a leading NAME:name item.

They are always introduced by a key and can contain comma separated values of the following
type:

l A primitive value
l A key, in the form keyName:= followed by a primitive value
l Another function (nested function)

VBscript Method Call Types

VBScript method calls fall into two categories and the distinction between the two results in
syntax differences. These syntax differences are significant when converting VBScript to
IronPython.
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VBScript Functions

In VBScript terminology, functions return values. The syntax for this is one shared with
practically all programming languages:

Set oDesktop = oAnsoftApp.GetAppDesktop()

Set oProject = oDesktop.NewProject

Note:

If there are arguments, the method name is always followed by an argument list
enclosed in parentheses. If the argument list is empty, the parentheses can be omitted.

VBScript Sub-Routines

VBScript subroutines are those that do not have any return value. VBScript allows these to be
written without any parentheses even if they have a non-empty argument list.

oModule.CreateReport "XY Plot1", "Standard", "XY Plot", "optimtee :
optimtee", _

Array("Domain:=", "Sweep"), Array("Freq:=", Array("All"),
"offset:=",_

Array("0uin")), Array("X Component:=", "Freq", "Y Component:=", _

Array("dB20(S(1,1))", "dB20(S(1,2))", "dB20(S(1,3))", _

"dB20(S(2,1))", "dB20(S(2,2))", "dB20(S(2,3))", "dB20(S(3,1))",

"dB20(S(3,2))", "dB20(S(3,3))")), Array()

Converting VBScript Function Calls to IronPython Syntax

When used for scripting, IronPython function names are always followed by parentheses.

So:

l If you see a VBScript snippet that looks like a VBScript subroutine, add parentheses.
l If you see a VBScript function that has no arguments and no parentheses, add them around
an empty argument list.

The parentheses change is the only one to keep in mind when converting VBScript function calls
syntax to IronPython.
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Return Values

VBscript return values are sometimes assigned via the Set declaration. IronPython return
values are simple assignment (See: Iron Python Mini Cookbook).

Primitive Method Arguments

Replace each VBScript primitive with an equivalent IronPython primitive. The main thing to
notice here is that Boolean values in IronPython have their first letter capitalized.

(True instead of true and False instead of false)

The recommended approach is to simply replace a VBScript array with a Python array. The
mapping is quite simple:

l Change Array( to [ and close with ] instead of )
l Remove the line continuation symbol: _
l Map Boolean values correctly

Named Array Arguments

Formatting (which helps readability immensely) is not needed. All thatmust be done is:

l Add the parentheses, since the VBScript subroutine omits them
l Replace the Array( ) delimiters with [ ]
l Remove the Char(34) function (which introduced a double quote) and replace it with the
escaped double quote literal: \"

l Replace true with True
l Remove the line continuation symbol: _

Named Array Values with All Key Value Pairs

While it is generally not allowed to replace arrays and nested arrays with Python dictionaries, in
the case where the named array consists entirely of key value pairs, you can use a dictionary
and avoid typing the trailing := symbols after the keys. This further aids readability of the script.

l If all key value pairs
l Remove the trailing := after each key
l Replace the , after the key with a :
l If the named array is the top level argument, ensure that the NAME:name is present and is
split into NAME : name as a key value pair

l Enclose the converted array in a { } pair to declare the dictionary.
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Named Arrays with Nested Named Arrays

l Split the NAME:name field into a key value pair
l Translate array key value pair to a dictionary key value pair.
l Create a new key with the name of the nested array and keep the nested array (as an array
or as a dictionary) as its value. If the nested array is being retained as an array, the
NAME:name field should be retained in the array. If the nested array is being converted to a
dictionary, the name is optional: if also retained in the nested array, it must match the outer
key.

[ "NAME:name",

"key1:=" , 1,

"key2:=" , 2,

["NAME:name2", "R:=", 255]

]

Figure 1-1 Sample Script: Named array with nested named array in array syntax

The named array with a nested named array (after conversion to IronPython as named array)
can be converted to a dictionary as well. The dictionary can take any of the following forms

{ "NAME" : "name",

"key1" : 1,

"key2" : 2,

"name2" : ["NAME:name2", "R:=", 255]

}

Figure 1-2 Sample Script: Named array with nested named array as mixed dictionary +
array

{ "NAME" : "name",

"key1" : 1,

"key2" : 2,

"name2" : {"R" : 255}

}

Figure 1-3 Sample Script: Named array with nested named array in all dictionary syntax

{ "NAME" : "name",
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"key1" : 1,

"key2" : 2,

"name2" : {

"NAME" : "name2",

"R" : 255

}

}

Function Blocks

Function blocks in VBScript argument syntax are represented as arrays without the "NAME:.."
field. However, functions are always introduced by a key in a parent structure. Function blocks
can therefore never exist as a top-level argument. They are only found as the value pairs inside
a named array or inside another function block.

Important:

Function blocks and their items cannot be converted to dictionaries even though they
might be composed entirely of key value pairs.

The reason for this is the need to main the user-entered order. Every item in a function block is
expect to be transmitted to the script method in exactly the same order as typed out and this is
impossible to achieve when a dictionary is used (as the keys get reordered according to the
dictionary's internal tree/key sorting scheme).

When you see a function block, simply replace the Array( ) delimiters with python array
delimiters [ ]
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2 - Script Commands
The following scripts are available in SIwave:

l CloseProject
l CloseProjectNoForce
l GetActiveProject
l GetFileDir
l GetFilePath
l GetName
l GetNetworkDataSolution
l GetNetworkDataSolutionDefinition
l GetProjectDirectory
l GetProjectList
l GetTopDesignList
l GetVersion
l ImportAnfFile
l ImportODB
l IsSolutionDataAvailable
l OpenProject
l Quit
l ReferenceEquals
l RestoreWindow
l Save
l ScrActivateCktElem
l ScrActivateDcPowerTreePinAggregation
l ScrActivateInfiniteGroundPlane
l ScrAddEquipotentialRegion
l ScrAddError
l ScrAddInfo
l ScrAddLayer
l ScrAddMaterial
l ScrAddOneLayerPadstack
l ScrAddWarning
l ScrAppendSteppedSweep
l ScrAppendSweep
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l ScrAssign4PtBondwireProfile
l ScrAssign5PtBondwireProfile
l ScrAssignBondwireTerminalType
l ScrAssignComplexSolderballProfile
l ScrAssignLowBondwireProfile
l ScrAssignSimpleSolderballProfile
l ScrAssignSketchedBondwireProfile
l ScrAssignSketchedBondwireProfileFromArray
l ScrAssignSolderballTerminalType
l ScrBooleanUnite
l ScrChangePartType
l ScrCleanUpOvelappingtraces
l ScrClearAllSweeps
l ScrClipDesign
l ScrClipDesignAroundNets
l ScrCloseProject
l ScrCloseProjectNoSave
l ScrComputeFwsSubckt
l ScrComputeFwsSubcktForNamedSim
l ScrConvertPlanesToTraces
l ScrConvertTracesToPlanes
l ScrConvertTracesToPlanesByNet
l ScrCopyImageToClipBoard
l ScrCorrectValChkErrorsWarnings
l ScrCreatePinGroups
l ScrCreatePinGroupByDist
l ScrCreatePinGroupsByGrid
l ScrCreatePinGroupByNet
l ScrCreatePortsOnPart
l ScrDeleteAllNets
l ScrDeleteCktElem
l ScrDeleteDcSolution
l ScrDeleteLayer
l ScrDeleteNet
l ScrDeleteNets
l ScrDeleteNetsGivenInFile
l ScrDeletePadstack
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l ScrDeletePinGroup
l ScrDeleteSimulation
l ScrDrawCapacitor
l ScrDrawCircle
l ScrDrawInductor
l ScrDrawPolygon
l ScrDrawPort
l ScrDrawRectangle
l ScrDrawResistor
l ScrDrawTrace
l ScrDrawVia
l ScrDrawVoltageProbe
l ScrDrawVoltageSource
l ScrEditCktElemName
l ScrEditLayerName
l ScrEditMaterial
l ScrEditNetName
l ScrEditPadStackName
l ScrEnableCavityFieldCoupling
l ScrEnableCoPlaneCoupling
l ScrEnableErcSimSetup
l ScrEnableFwsRelativeErrorTol
l ScrEnableGUIRefresh
l ScrEnableIntraPlaneCoupling
l ScrEnableSplitPlaneCoupling
l ScrEnableTraceCoupling
l ScrExport3DModel
l ScrExportAnf
l ScrExportComponentFile
l ScrExportCpaSimReport
l ScrExportDcPowerDataToIcepak
l ScrExportDcPowerTree
l ScrExportDcSimReport
l ScrExportDcSimReportColorBarProperties
l ScrExportDcSimReportOptions
l ScrExportDcSimReportScaling
l ScrExportDcSimReportUnits
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l ScrExportElementData
l ScrExportEmiScanReport
l ScrExportIcepakProject
l ScrExportIcepakSimReport
l ScrExportIcepakSimReportColorBarProperties
l ScrExportIcepakSimReportScaling
l ScrExportIcepakSimReportUnits
l ScrExportLayerStackup
l ScrExportNamedSimToTouchstone
l ScrExportNetDelayReport
l ScrExportSettingsFile
l ScrExportSettingsFileSetOptions
l ScrExportSNAReport
l ScrExportSyzSimToTouchstone
l ScrExportToTouchstone
l ScrExportVprobeData
l ScrExportXfl
l ScrExportZ0ScanReport
l ScrExportZ0ScanReportColorBarProperties
l ScrExportZ0ScanReportScaling
l ScrFitAll
l ScrFitSelection
l ScrFitToViewingWindow
l ScrFwsEnforceCausality
l ScrGenerateConnectionReport
l ScrGenerateICDieNetwork
l ScrGetActiveComponentList
l ScrGetBondwiresOfBwModel
l ScrGetBwModelNameList
l ScrGetCktElemTerminalNetNames
l ScrGetComponentList
l ScrGetCurrentViewingWindow
l ScrGetDcConnectedNets
l ScrGetDcThermalDataDir
l ScrGetDesignBoundingBox
l ScrGetDieLayerName
l ScrGetDieNameList
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l ScrGetLayerMaterial
l ScrGetLayerNameList
l ScrGetLayerThickness
l ScrGetLayerType
l ScrGetLayoutLengthUnit
l ScrGetMetalLayerFillerMaterial
l ScrGetNetlistOfBondwireProfile
l ScrGetNetNameList
l ScrGetNetsAndCktElemsBetweenComponents
l ScrGetNetsAndCktElemsBetweenNets
l ScrGetPadstackNameList
l ScrGetPinGroupNameList
l ScrGetPinPadstackName
l ScrGetPinsOnNet
l ScrGetPinsOnPart
l ScrGetPwrGndNetNameList
l ScrGetRLCsBetweenNets
l ScrGetStackupLayerThickness
l ScrGetUniqueSimulationName
l ScrImportAnf
l ScrImportCapacitorDeratingTable
l ScrImportComponentFile
l ScrImportComponentMapFile
l ScrImportCpaSimulationOptions
l ScrImportCpmOrPloc
l ScrImportDDXFile
l ScrImportEDB
l ScrImportGDSII
l ScrImportIPC2581
l ScrImportLayerStackup
l ScrImportLayerStackupFile
l ScrImportLayerStackupXML
l ScrImportPmap
l ScrImportSettingsFile
l ScrImportSIwaveSimulationOptions
l ScrImportXfl
l ScrInterpolateSpectrum
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l ScrLogMessage
l ScrMergeConnectedNets
l ScrNetGetLength
l ScrNetIsDisjoint
l ScrNetIsSelected
l ScrNetSeparate
l ScrNetSetDummy
l ScrNetSetSelected
l ScrPlaceCircuitElement
l ScrPlaceCircuitElementsToNearestRefPin
l ScrPlaceFreqDependentSrc
l ScrPlacePortsAcrossRLCs
l ScrPlacePortsAtPinsOnSelectedNets
l ScrPlacePortsAtPinsOnSelectedNetsExcludePart
l ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut
l ScrPlotResModeVoltageDiff
l ScrPreserveNetsGivenInFile
l ScrReadDCLoopResInfo'
l ScrRestoreResonantModeMinFreq
l ScrRestoreSIwaveDCGeometryProcessingDefaultValues
l ScrRestoreSIwaveSIPIGeometryProcessingDefaultValues
l ScrRunDcSimulation
l ScrRunDDRWizard
l ScrRunFarFieldSimulation
l ScrRunFrequencySweepSimulation
l ScrRunIcepakSimulation
l ScrRunInducedVoltageSimulation
l ScrRunNearFieldSimulation
l ScrRunResonantModeSimulation
l ScrRunSimulation
l ScrRunSpiceSubcktSimulation
l ScrRunSyzParameterSimulation
l ScrRunValidationCheck
l ScrRunValidationCheckWithOptions
l ScrSanitizeLayout
l ScrSanitizeNets
l ScrSaveProjectAs
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l ScrSaveSimulationMessages
l ScrSaveToPngFile
l ScrSelectDcConnectedNets
l ScrSelectNet
l ScrSelectNetsBetweenComponents
l ScrSelectNetsBetweenNets
l ScrSeparateDisjointNets
l ScrSet4PtBwProfile
l ScrSet5PtBwProfile
l ScrSetAntiPadOnLayer
l ScrSetBwModel
l ScrSetBwSuppLayer
l ScrSetBwTermLayer
l ScrSetCapacitorDcBiasDeratingSim
l ScrSetCapacitorTemperatureDeratingSim
l ScrSetConformalCoatLayers
l ScrSetCrosstalkScanParameters
l ScrSetCrossTalkThreshold
l ScrSetDcMinPlaneAreaToMesh
l ScrSetDcMinVoidAreaToMesh
l ScrSetDcPowerDataThresholds
l ScrSetDieElevation
l ScrSetDieThickness
l ScrSetEmiScannerParameters
l ScrSetEnergyErrorPercentInDcSimulation
l ScrSetExternalExcitations
l ScrSetFarFieldSimOptions
l ScrSetFwsColFitOptions
l ScrSetFwsLaunchDesignerNexxim
l ScrSetFwsPassivityAlg
l ScrSetFwsPortRefZ
l ScrSetFwsPzOptions
l ScrSetFwsSsfAlg
l ScrSetFwsSubcktFormat
l ScrSetFwsUseCommonGround
l ScrSetHFSS3DLayoutSimOptions
l ScrSetHpcLicenseType
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l ScrSetHpcLicenseVendor
l ScrSetIcepakBoardOutlineFidelity
l ScrSetIcepakCabinetDimensions
l ScrSetIcepakComponentConfig
l ScrSetIcepakMeshingDetail
l ScrSetIcepakSimReportImageHeight
l ScrSetIcepakTemperatureFile
l ScrSetIcepakThermalEnv
l ScrSetIdealGroundNodeInDcSimulation
l ScrSetInducedVoltageMultipleIncidenceSpherical
l ScrSetInducedVoltageSingleIncidenceCartesian
l ScrSetInducedVoltageSingleIncidenceSpherical
l ScrSetInfiniteGroundPlaneLocation
l ScrSetLayerMaterial
l ScrSetLayerThickness
l ScrSetLayerType
l ScrSetLayerVisibility
l ScrSetLayoutLengthUnit
l ScrSetLocalRefinementPercentInDcSimulation
l ScrSetLogFreqPointDist
l ScrSetLowBwProfile
l ScrSetMaxRefinePassesInDcSimulation
l ScrSetMeshBondwiresInDcSimulation
l ScrSetMeshViasInDcSimulation
l ScrSetMetalLayerFillerMaterial
l ScrSetMinCutoutArea
l ScrSetMinPadAreaToMesh
l ScrSetMinPlaneAreaToMesh
l ScrSetMinRefinePassesInDcSimulation
l ScrSetNearFieldExportDataPath
l ScrSetNearFieldMeshingFrequencyDefault
l ScrSetNearFieldMeshingFrequencyPoints
l ScrSetNearFieldMeshingFrequencyRange
l ScrSetNearFieldSamplePointSpacing
l ScrSetNearFieldSolverOptions
l ScrSetNearFieldSurfaceOffset
l ScrSetNumBondwireSidesInDcSimulation
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l ScrSetNumCpusToUse
l ScrSetNumModesToCompute
l ScrSetNumViaSidesInDcSimulation
l ScrSetOptionsFor3DModelExport
l ScrSetPadOnLayer
l ScrSetPadstackMaterial
l ScrSetPadstackViaPlatingAbsolute
l ScrSetPadstackViaPlatingRatio
l ScrSetPlotAfterDcSimulation
l ScrSetPlotLayers
l ScrSetPlotSyzMag
l ScrSetPlotSyzPhase
l ScrSetPortNamingConvention
l ScrSetPowerGroundNets
l ScrSetPowerGroundNetsFromFile
l ScrSetProjectModified
l ScrSetPsiOptionsFromFile
l ScrSetPsiPortType
l ScrSetPsiSyzInterpOptions
l ScrSetRefineBondwiresInDcSimulation
l ScrSetRefineDcSimulation
l ScrSetRefineViasInDcSimulation
l ScrSetRemoveCutoutsByArea
l ScrSetResonantModeMaxFreq
l ScrSetResonantModeMinFreq
l ScrSetRLCValues
l ScrSetSignalNets
l ScrSetSignalNetsFromFile
l ScrSetSimulationName
l ScrSetSketchedBwProfile
l ScrSetSketchedBwProfileFromArray
l ScrSetSnapLengthThreshold
l ScrSetSolderballMaterial
l ScrSetSolderballParameters
l ScrSetSourceMagnitude
l ScrSetSparamModelSetup
l ScrSetSpiceModelSetup
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l ScrSetSpiceSubcktFormat
l ScrSetStackupLayerThickness
l ScrSetStackupLayerThicknessUnit
l ScrSetSweepFreqRange
l ScrSetSweepMaxFreq
l ScrSetSweepMinFreq
l ScrSetSweepNumFreqPoints
l ScrSetSyzInterpSweep
l ScrSetSyzInterpSweepParams
l ScrSetTDCrosstalkScanParameters
l ScrSetThermalPadOnLayer
l ScrSetTouchstoneExportFormatToDb
l ScrSetTouchstonePortOrder
l ScrSetTouchstonePortRemapping
l ScrSetTraceCouplingDistance
l ScrSetUniformTemperature
l ScrSetZ0ScanParameters
l ScrSetZ0ScanReportImageHeight
l ScrShowSelectedNetsOnly
l ScrSIwaveEnable_3D_DDM
l ScrSIwaveEnableHFSSRegions
l ScrSIwaveEnableReturnCurrentDistribution
l ScrSIwaveIncludeSourceParasitics
l ScrSIwaveSyzComputeExactDcPoint
l ScrSIwaveSyzEnforceCausality
l ScrSIwaveSyzEnforcePassivity
l ScrUnselectAll
l ScrUpdateComponentTree
l ScrUseIcepakTemperatureDataInDc
l ScrUseTouchstonePortRemapping
l Solve
l StopSimLink
l SupportSParamLink
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Note:

l This list contains all current SIwave scripting functions. Running dir(oApp) or
dir(oDoc) from the CommandWindow may show additional scripts. These are
scripts that are either obsolete or that are part of the Electronics Desktop scripting
environment and do not serve any function in SIwave.

l TPA is no longer supported. Ansys recommends using CPA.
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CloseProject
Closes the specified project and opens a new "Untitled" project.

UI Command: Click File > New.

Syntax: obj.CloseProject(<projectName>)

Parameters: BSTR projectName

Return Value: None.

VB Example: obj.CloseProject "project.siw"

IPY Example: oApp.CloseProject('project.siw')

Note:

The behavior of CloseProject() and CloseProjectNoForce() is identical when the
SIwave UI is invoked in graphical/interactive mode.

However, when invoked in extractor/non-interactive mode:

l CloseProject() will result in termination of the siwave.exe process.
l CloseProjectNoForce() will close any open projects, but will keep the siwave.exe
process active (so that subsequent script commands can be issued).

CloseProjectNoForce
Closes the specified project and opens a new "Untitled" project.

UI Command: Click File > New.

Syntax: obj.CloseProjectNoForce(<projectName>)

Parameters: BSTR projectName

Return Value: None.

VB Example: obj.CloseProjectNoForce "project.siw"

IPY Example: oApp.CloseProjectNoForce('project.siw')
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Note:

The behavior of CloseProjectNoForce() and CloseProject() is identical when the
SIwave UI is invoked in graphical/interactive mode.

However, when invoked in extractor/non-interactive mode:

l CloseProject() will result in termination of the siwave.exe process.
l CloseProjectNoForce() will close any open projects, but will keep the siwave.exe
process active (so that subsequent script commands can be issued).

Equals
Comparison operator. Returns whether two objects are equal.

UI Command: N/A

Syntax: obj.Equals(<comparisonObject>)

Parameters: VAR comparisonObject

Return Value: TRUE or FALSE

VB Example: obj.Equals(object)

IPY Example: oDoc.Equals(oDoc)

GetActiveProject
Returns the active project in SIwave.

UI Command: None.

Syntax: obj.GetActiveProject()

Parameters: None.

Return Value: Object of active project.

VB Example: Set obj = app.GetActiveProject

IPY Example: oDoc = oApp.GetActiveProject()
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GetFileDir
Returns the directory path of the open project.

UI Command: None.

Syntax: obj.GetFileDir()

Parameters: None.

Return Value: BSTR directory path

VB Example: fileDirPath = obj.GetFileDir

IPY Example: oDoc.GetFileDir()

GetFilePath
Returns the directory path of the open project.

UI Command: None.

Syntax: obj.GetFilePath()

Parameters: None.

Return Value: BSTR directory path

VB Example: fileDirPath = obj.GetFilePath

IPY Example: oDoc.GetFilePath()

GetName
Returns the name of the open SIwave project.

UI Command: None.

Syntax: obj.GetName()

Parameters: None.

Return Value: BSTR project name

VB Example: fileName = obj.GetName

IPY Example: oDoc.GetName()
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GetNetworkDataSolution
Returns network data for a previously run SYZ simulation.

UI Command: None.

Syntax: obj.GetNetworkDataSolution(<solnName>)

Parameters: BSTR solnName (name of a previously run SYZ simulation)

Return Value: BSTR network data

VB Example: obj.GetNetworkDataSolution("SYZ Sim 1")

IPY Example: oDoc.GetNetworkDataSolution('SYZ Sim 1')

GetNetworkDataSolutionDefinition
Returns port names for a previously run SYZ simulation.

UI Command: None.

Syntax: obj.GetNetworkDataSolutionDefinition(<solnName>)

Parameters: BSTR solnName (name of a previously run SYZ simulation)

Return Value: ARRAY of BSTR port names

VB Example: obj.GetNetworkDataSolutionDefinition("SYZ Sim 1")

IPY Example: oDoc.GetNetworkDataSolutionDefinition('SYZ Sim 1')

GetProjectDirectory
Returns the directory path of the open project.

UI Command: None.

Syntax: obj.GetProjectDirectory()

Parameters: None.

Return Value: BSTR directory path

VB Example: obj.GetProjectDirectory()

IPY Example: oApp.GetProjectDirectory()
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GetProjectList
Returns a list of all projects that are open in SIwave.

UI Command: None.

Syntax: obj.GetProjectList()

Parameters: None.

Return Value: ARRAY of strings containing names of all open projects.

VB Example: obj.GetProjectList()

IPY Example: oDoc.GetProjectList()

GetTopDesignList
Returns a list of all designs that are open in SIwave.

UI Command: None.

Syntax: obj.GetTopDesignList()

Parameters: None.

Return Value: ARRAY of strings containing names of all open designs.

VB Example: obj.GetTopDesignList()

IPY Example: oDoc.GetTopDesignList()

GetVersion
Returns SIwave version information.

UI Command: None.

Syntax: obj.GetVersion()

Parameters: None.

Return Value: BSTR version information

VB Example: obj.GetVersion()

IPY Example: oApp.GetVersion()
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ImportAnfFile
Imports an ANF file into a new project.

UI Command: Import > ANF.

Syntax: obj.ImportAnfFile(<filePath>)

Parameters: BSTR filePath

Return Value: None.

VB Example: Set obj = app.ImportAnfFile ( "C:/KWH/GSG.anf" )

IPY Example: oApp.ImportAnfFile('C:/KWH/GSG.anf')

ImportOdb
Imports an ODB++ file into a new project.

UI Command: Import >ODB++.

Syntax: obj.ImportOdb (<ODB++Filename>, <controlFilename>)

Parameters:
BSTR ODB++Filename

BSTR controlFilename (this string can be empty if no XML control file is used)

Return Value: None.

VB Example:
Set oTool = oDesktop.GetTool("ImportExport")

oTool.ImportOdb "test.tgz", "test.xml"

IPY Example: oApp.ImportOdb('test.tgz','test.xml')

IsSolutionDataAvailable
Checks for the existence of an SYZ simulation.

UI Command: None.

Syntax: obj.IsSolutionDataAvailable(<solnName>)

Parameters: BSTR solnName (name of a previously run SYZ simulation)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.IsSolutionDataAvailable("SYZ Sim 1")

IPY Example: oDoc.IsSolutionDataAvailable('SYZ Sim 1')
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OpenProject
Opens a previously created project, or imports an EDB folder, IPC2581 file, or ODB++ file.

UI Command: File >Open.

Syntax: obj.OpenProject(<filePath>)

Parameters: BSTR filePath

Return Value: None.

VB Example:
Set obj = app.OpenProject ( "C:/KWH/GSG_model.siw"
)

IPY Example: oApp.OpenProject('C:/KWH/GSG_model.siw')

Quit
Quits SIwave and closes the IronPython Command Window.

UI Command: File > Exit.

Syntax: obj.Quit

Parameters: None.

Return Value: None.

VB Example: app.Quit

IPY Example: oApp.Quit()

ReferenceEquals
Compares two objects and returns whether they are the same.

UI Command: None.

Syntax: obj.ReferenceEquals(<obj1>, <obj2>)

Parameters: obj1, obj2 (any type)

Return Value: BOOL

VB Example: obj.ReferenceEquals(obj1, obj2)

IPY Example: oDoc.ReferenceEquals(obj1, obj2)
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RestoreWindow
Restores a minimized SIwave window.

UI Command: None.

Syntax: obj.RestoreWindow

Parameters: None.

Return Value: None.

VB Example: obj.RestoreWindow()

IPY Example: oApp.RestoreWindow()

Save
Saves all changes made until the point in the scripting file where this function is called.

UI Command: File > Save.

Syntax: obj.Save

Parameters: None.

Return Value: None.

VB Example: obj.Save()

IPY Example: oDoc.Save()
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ScrActivateCktElem
Activates or deactivates specified circuit elements.

UI Command: None.

Syntax:
obj.ScrActivateCktElem(<elementName>, <elementType>,
<activate?>)

Parameters:

BSTR elementName

BSTR elementType (select from: cap, ind, res, port, vprobe, csource, vsource)

BOOL activate? (True to activate or False to deactivate)

Return Value:

INT result:

l 0 – Function succeeded
l 1 – Invalid input parameters (i.e., empty strings)
l 2 – Invalid second parameter (does not match cap, ind, res, port, vprobe,
csource, vsource)

l 3 – Specified circuit element could not be located in layout

VB Example:
result = obj.ScrActivateCktElem ("Port1","port",false)

result = obj.ScrActivateCktElem ("Port2","port",true)

IPY Example:
oDoc.ScrActivateCktElem ('Port1','port',False)

oDoc.ScrActivateCktElem ('Port2','port',True)
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ScrActivateDcPowerTreePinAggregation

Aggregates or unsets pins in a Power Tree on a net within a component.

UI Command: Results Tab > DC IR Drop > [Simulation Name] > Export Power Tree
> Aggregate pins on a net within a component as one block.

Syntax:
obj.ScrActivateDcPowerTreePinAggregation
(<aggregatePins>)

Parameters: BOOL aggregatePins (True to activate or False to deactivate)

Return Value:

INT:

l 0 – if False; unset pins aggregation for the next power tree export
l 1 – if True; sets pins aggregation for the next power tree export

VB Example: obj.ScrActivateDcPowerTreePinAggregation True

IPY Example: oDoc.ScrActivateDcPowerTreePinAggregation('1')

Note:

Use before ScrExportDcPowerTree.

Script Commands 2-21

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave Scripting Guide

ScrActivateInfiniteGroundPlane
Activates an infinite ground plane.

UI Command: Simulation >Options > SI/PI Advanced. Check/uncheck the Introduce
infinite ground plane box.

Syntax: obj.ScrActivateInfiniteGroundPlane(<activate>)

Parameters: BOOL activate (True to activate infinite ground plane or False to deactivate
infinite ground plane)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example: obj.ScrActivateInfiniteGroundPlane True

IPY Example: oDoc.ScrActivateInfiniteGroundPlane('1')

Note:

To activate an infinite ground layer a specified distance beneath the bottom layer, refer
to ScrSetInfiniteGroundPlaneLocation.
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ScrAddEquipotentialRegion
Creates an equipotential region located at a specified pin.

UI Command: None.

Syntax:
obj.ScrAddEquipotentialRegion (<partName>, <refDes>,
<pinName> , <regionOnTop>)

Parameters:

BSTR partName

BSTR refDes

BSTR pinName

BOOL regionOnTop (True to create the equipotential region above the top
metal layer, False to create it below the bottom metal layer)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
outcome = doc.ScrAddEquipotentialRegion "T1_A", "U1",
"10", True

IPY Example: oDoc.ScrAddEquipotentialRegion('T1_A','U1','10',True)
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ScrAddError
Logs an error to the Information / Errors / Warnings window.

UI Command: None.

Syntax: obj.ScrAddError(<error>)

Parameters: BSTR error

Return Value: None.

VB Example: obj.ScrAddError("This is my error.")

IPY Example: oDoc.ScrAddError('This is my error.')

ScrAddInfo
Logs information to the Information / Errors / Warnings window.

UI Command: None.

Syntax: obj.ScrAddInfo(<information>)

Parameters: BSTR information

Return Value: None.

VB Example: obj.ScrAddInfo("This is my information.")

IPY Example: oDoc.ScrAddInfo('This is my information.')
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ScrAddLayer
Adds a new layer above/below a given reference layer.

UI Command: Click Home > Layer stackup Editor. Then click either Add Above Selected
Layer or Add Below Selected Layer.

Syntax:
obj. ScrAddLayer (<newLayerName>, <referenceLayerName>,
<aboveBelow>, <layerTypeIndex>, <layerThickness>,
<materialName>)

Parameters:

BSTR newLayerName

BSTR referenceLayerName

BOOL aboveBelow (True to place new layer above; False to place it below)

INT layerTypeIndex (0 for dielectric, 1 for metal, 2 for wirebond)

INT layerThickness

BSTRmaterialName

Return Value: None.

VB Example:
obj.ScrAddLayer("new layer name", "reference layer
name", true, 1, 0.1, "copper")

IPY Example:
oDoc.ScrAddLayer('new layer name','reference layer
name',True,1,0.1,'copper')

Script Commands 2-25

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave Scripting Guide

ScrAddMaterial
Adds a new material to the database.

UI Command: Home > Edit Materials > [Conductors/Dielectrics] > Add.

Syntax:
obj.ScrAddMaterial (<materialType>, <materialName>,
<materialProperty1>, <materialProperty2>)

Parameters:

BSTRmaterialType (conductor or dielectric)

BSTR materialName

DOUBLE materialProperty1 (conductivity for conductor or permittivity for
dielectric)

DOUBLE materialProperty2 (permeability for conductor or loss tangent for
dielectric)

Return Value:

INT result:

l 0 – Function succeeded
l 1 – Material type is not "conductor" or "dielectric"
l 2 – Material name already exists in library
l 3 – Material parameters are not within an acceptable range

VB Example: obj.ScrAddMaterial("conductor", "Name", 0.1, 0.1)

IPY Example: oDoc.ScrAddMaterial('dielectric','Name',5,0.02)
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ScrAddOneLayerPadstack
Adds a new padstack.

UI Command: Home > Edit Padstacks > Add.

Syntax:
obj.ScrAddOneLayerPadstack (<padstackName>, <layerName>,
<shapeName>, <width>, <height>)

Parameters:

BSTR padstackName

BSTR layerName

BSTR shapeName (None, Circle, Oblong, or Rectangle)

BSTR width

BSTR height

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrAddOneLayerPadstack(        "NEW_PADSTACK", "METAL-1",
"Circle", "0.5mm", "0.5mm")

IPY Example:
oDoc.ScrAddOneLayerPadstack('NEW_PADSTACK','METAL-
1','Circle','0.5mm','0.5mm')

ScrAddWarning
Logs a warning to the Information / Errors / Warnings window.

UI Command: None.

Syntax: obj.ScrAddWarning(<warning>)

Parameters: BSTR warning

Return Value: None.

VB Example: obj.ScrAddWarning("This is my warning.")

IPY Example: oDoc.ScrAddWarning('This is my warning.')
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ScrAppendSteppedSweep
Defines a frequency sweep with the specified step size for the specified simulation type.

UI Command: From any simulation sweep setup tab, add a frequency sweep with a Linear
Step distribution.

Syntax:
obj.ScrAppendSteppedSweep(<simType>, <minimumFrequency>,
<maximumFrequency>, <stepSize>)

Parameters:

BSTR simType ("ac", "ff", "nf", "syz", "psi_syz", "psi_ac", or "hfss_syz")

DOUBLE minimumFrequency

DOUBLE maximumFrequency

DOUBLE stepSize (in Hz)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
outcome = obj.ScrAppendSteppedSweep("syz", 5000000.0,
5005000000.0, 100000000.0)

IPY Example:
oDoc.ScrAppendSteppedSweep('syz', 5000000.0,
5005000000.0, 100000000.0)
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ScrAppendSweep
Defines a frequency sweep with the specified number of frequencies for the specified
simulation type.

UI Command: From any simulation sweep setup tab, add a frequency sweep with a Linear or
By Decade distribution.

Syntax:
obj.ScrAppendSweep(<simType>, <minimumFrequency>,
<maximumFrequency>, <numPts>, <isLog>)

Parameters:

BSTR simType ("ac", "ff", "nf", "syz", "psi_syz", "psi_ac", or "hfss_syz")

DOUBLE minimumFrequency

DOUBLE maximumFrequency

INT numPts (number of frequencies in the frequency distribution)

BOOL isLog (True for By Decade distribution, False for Linear distribution)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

outcome = obj.ScrAppendSweep("syz", 5000000.0,
5000000000.0, 4, TRUE)

This creates a By Decade frequency sweep from 5MHz to 5GHz.

IPY Example:
oDoc.ScrAppendSweep('syz',5000000.0,5000000000.0,4,True)

This creates a By Decade frequency sweep from 5MHz to 5GHz
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ScrAssign4PtBondwireProfile
Creates a 4 point bondwire profile for a layer.

UI Command: Home > Bondwire Model Editor. Select JEDEC 4-Point from theModel
drop-down menu.

Syntax:
obj.ScrAssign4PtBondwireProfile
(<layerOrProfileName>, <h1>, <h2>, <radius>,
<supportLayerName>, <terminationLayerName>)

Parameters:

BSTR layerOrProfileName (either the name of a layer containing bondwires or
a specific bondwire model name)

DOUBLE h1

DOUBLE h2

DOUBLE radius

BSTR supportLayerName

BSTR terminationLayerName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrAssign4PtBondwireProfile "die2_die3", 0.3,
0.3, 0.01, "Signal", "Power"

IPY Example:
oDoc.ScrAssign4PtBondwireProfile('die2_
die3',0.3,0.3,0.01,'Signal','Power')
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ScrAssign5PtBondwireProfile
Creates a 5 point bondwire profile for a layer.

UI Command: Home > Bondwire Model Editor. Select JEDEC 5-Point from theModel
drop-down menu.

Syntax:
obj.ScrAssign5PtBondwireProfile(<layerOrProfileName>,
<h1>, <h2>, <radius>, <alpha>, <beta>,
<supportLayerName>, <terminationLayerName>)

Parameters:

BSTR layerOrProfileName (either the name of a layer containing bondwires or
a specific bondwire model name)

DOUBLE h1

DOUBLE h2

DOUBLE radius

DOUBLE alpha (angle in degrees)

DOUBLE beta (angle in degrees)

BSTR supportLayerName

BSTR terminationLayerName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrAssign5PtBondwireProfile "die1_die3", 0.31,
0.32, 0.011, 85.1, 5.1, "Top", "Ground"

IPY Example:
oDoc.ScrAssign5PtBondwireProfile('die1_
die3',0.31,0.32,0.011,85.1,5.1,'Top','Ground')
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ScrAssignBondwireTerminalType
Sets bondwire terminals to either sink or source terminal type.

UI Command: Home > Bondwire Model Editor.

Syntax:
obj.ScrAssignBondwireTerminalType(<netNameRegExp>,
<refDesRegExp>, <pinNameRegExp>, <isSink>)

Parameters:

BSTR netNameRegExp

BSTR refDesRegExp

BSTR pinNameRegExp

BOOL isSink (True for Sink, False for Source)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrAssignBondwireTerminalType "*Net_2*", "RT*",
"100-*", true

IPY Example:
oDoc.ScrAssignBondwireTerminalType('*Net_2*','RT*','100-
*',True)
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ScrAssignComplexSolderballProfile
Creates a complex solderball profile for a layer.

UI Command: Home > Solderball Properties. Select Complex from the Type drop-down
menu.

Syntax:
obj.ScrAssignComplexSolderballProfile(<padstackName>,
<height>, <radius>, <midRadius>, <frustumHeight>,
<placement>, <terminalType>)

Parameters:

BSTR padstackName

DOUBLE height

DOUBLE radius

DOUBLE midRadius

DOUBLE frustrumHeight

INT placement (0 for Above, 1 for Below)

INT terminalType (0 for Sink, 1 for Source)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrAssignComplexSolderballProfile "BGA", 0.5,
0.18, 0.225, 0.1666, 0, 0

IPY Example:
oDoc.ScrAssignComplexSolderballProfile
('BGA',0.5,0.18,0.225,0.1666,0,0)
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ScrAssignLowBondwireProfile
Creates a low bondwire profile for a layer.

UI Command: Home > Bondwire Model Editor. Select Low from theModel drop-down
menu.

Syntax:
obj.ScrAssignLowBondwireProfile(<layerName>, <h1>,
<h2>, <radius>, <alpha>, <beta>,
<supportLayerName>, <terminationLayerName>)

Parameters:

BSTR layerName (name of a layer containing bondwires)

DOUBLE h1

DOUBLE h2

DOUBLE radius

DOUBLE alpha

DOUBLE beta

BSTR supportLayerName

BSTR terminationLayerName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrAssignLowBondwireProfile "die2_die3", 0.3,
0.3, 0.01, 0.1, 0.1, "Signal", "Power"

IPY Example:
oDoc.ScrAssignLowBondwireProfile('die2_
die3',0.3,0.3,0.01,0.1,0.1,'Signal','Power')
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ScrAssignSimpleSolderballProfile
Creates a simple solderball profile for a layer.

UI Command: Home > Solderball Properties. Select Simple from the Type drop-down
menu.

Syntax:
obj.ScrAssignSimpleSolderballProfile(<padstackName>,
<height>, <radius>, <placement>, <terminalType>)

Parameters:

BSTR padstackName

DOUBLE height

DOUBLE radius

INT placement (0 for Above, 1 for Below)

INT terminalType (0 for Sink, 1 for Source)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrAssignSimpleSolderballProfile "BGA", 0.5,
0.225, 0, 0

IPY Example:
oDoc.ScrAssignSimpleSolderballProfile('BGA', 0.5, 0.225,
0, 0)
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ScrAssignSketchedBondwireProfile
Creates a sketched bondwire profile for a layer.

UI Command: Home > Bondwire Model Editor. Select Sketched from theModel drop-
down menu.

Syntax:
obj.ScrAssignSketchedBondwireProfile
(<layerOrProfileName>, <filePath>, <radius>,
<supportLayerName>, <terminationLayerName>)

Parameters:

BSTR layerOrProfileName (can be either the name of a layer containing
bondwires or a specific bondwire model name)

BSTR filePath

INT radius

BSTR supportLayerName

BSTR terminationLayerName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrAssignSketchedBondwireProfile "die1_die2",
"F:\TestScriptsForDocumentation\bw_pts.bwp", 0.012,
"Top", "Ground"

IPY Example:
oDoc.ScrAssignSketchedBondwireProfile('die1_die2',
'F:\TestScriptsForDocumentation\bw_pts.bwp', 0.012,
'Top', 'Ground')
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ScrAssignSketchedBondwireProfileFromArray
Creates a sketched bondwire profile for a layer, from an array.

UI Command: Home > Bondwire Model Editor. Select Sketched from theModel drop-
down menu.

Syntax:
obj.ScrAssignSketchedBondwireProfile(<layerName>,
<units>, <bwPoints>, <radius>, <supportLayerName>,
<terminationLayerName>)

Parameters:

BSTR layerName

BSTR units

ARRAY bwPoints (array of xy coordinates)

INT radius

BSTR supportLayerName

BSTR terminationLayerName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrAssignSketchedBondwireProfileFromArray
"die1_die2", "mm", xyPoints, 0.012, "Top", "Ground"

IPY Example:
oDoc.ScrAssignSketchedBondwireProfileFromArray('die1_
die2', 'mm', xyPoints, 0.012, 'Top', 'Ground')
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ScrAssignSolderballTerminalType
Sets specified Solderball Terminals to either Sink or Source type.

UI Command: Home > Solderball Properties. 

Syntax:
obj.ScrAssignSolderballTerminalType(<netNameRegExp>,
<referenceDesigRegExp>, <pinNameRegExp>, <isSink>)

Parameters:

BSTR netNameRegExp (narrows solderball terminals by net name)

BSTR referenceDesigRegExp (narrows solderball terminals by reference
designator)

BSTR pinNameRegExp (narrows solderball terminals by pin name)

BOOL isSink (TRUE sets sinks; FALSE sets sources)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrAssignSolderballTerminalType "*Net_2*",
"RT*", "100-*", true

IPY Example:
oDoc.ScrAssignSolderballTerminalType('*Net_2*', 'RT*',
'100-*', True)

ScrBooleanUnite
Performs a boolean unite on geometry from the specified nets.

UI Command: Tools > Unite. 

Syntax: obj.ScrBooleanUnite(<netNameList>)

Parameters: ARRAY netNameList

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
outcome = doc.ScrBooleanUnite
("netName1","netName2","netName3")

IPY Example: oDoc.ScrBooleanUnite(['netName1','netName2','netName3'])
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ScrChangePartType
Changes the part type for a specified part name.

UI Command: None.

Syntax: obj.ScrChangePartType(<partName>, <newType>)

Parameters:

BSTR partName

BSTR newType

l For existing parts with two pins, valid types: capacitor, inductor, resistor,
port, voltage probe, current source, voltage source

l For other existing parts, newType cannot be any of these

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrChangePartType ("288DIMMDDR4_EDGE_CONN-
BASE", "Discrete Device")

IPY Example:
oDoc.ScrChangePartType('288DIMMDDR4_EDGE_CONN-
BASE','Discrete Device')

ScrCleanUpOverlappingtraces
Converts overlapping traces to planes and then merges them.

UI Command: None.

Syntax: obj.ScrCleanUpOverlappingtraces(<layerNames>)

Parameters: ARRAY layerNames

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrCleanUpOverlappingtraces
("layer1","layer2","layer3")

IPY Example:
oDoc.ScrCleanUpOverlappingtraces
(['layer1','layer2','layer3'])
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ScrClearAllSweeps
Removes all frequency sweeps assigned to a particular simulation type.

UI Command: Simulation > SIwave > [Simulation Type]. Select the values in the
Frequency Range Setup box and click Delete Selection.

Syntax: obj.ScrClearAllSweeps (<sweepType>)

Parameters: BSTR sweepType (must be one of the following: "ac", "ff", "nf", "psi_syz", "syz"
or "hfss_syz")

Return Value:

BOOL

l 0 – Failure (sweepType is not a valid type)
l 1 – Success

VB Example: obj.ScrClearAllSweeps ("ff")

IPY Example: oDoc.ScrClearAllSweeps('ff')

ScrClipDesign
Clips designated nets using a specified polygon.

UI Command: None.

Syntax: obj.ScrClipDesign (<netNames>, <points>)

Parameters:
ARRAY netNames (nets to be clipped)

ARRAY points (vertices of clipping polygon)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

dim netNames (5)

netNames(0)="VCC"

netNames(1)="GND"

netNames(2)="Heg"

netNames(3)="NET-1"

netNames(4)="NET-2"

netNames(5)="PWR"

' points for polygon: (0.0, 0.0), (10.0, 20.0),

' (40.0, 40.0), (40.0, 0.0), (16.0, 4.0)

Script Commands 2-40

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave Scripting Guide

Clips designated nets using a specified polygon.

dim points(9)

points(0)=0.0

points(1)=0.0

points(2)=10.0

points(3)=20.0

points(4)=40.0

points(5)=40.0

points(6)=40.0

points(7)=0.0

points(8)=16.0

points(9)=4.0

' outcome is set to TRUE on success

outcome = obj.ScrClipDesign ( netNames, points )

IPY Example:

netNames = ['VCC', 'GND', 'Heg', 'NET-1', 'NET-2',
'PWR']

points = [0.0, 0.0, 10.0, 20.0, 40.0, 40.0, 40.0,
0.0, 16.0, 4.0]

outcome = obj.ScrClipDesign (netNames, points)
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ScrClipDesignAroundNets
Clips the design around nets.

UI Command: None.

Syntax:

obj.ScrClipDesignAroundNets(<netNames>,
<clipExtentDistance>, <simplifiedExtent>,
<traceCuttingOption>, <ignoreLayerVisibility>,
<reverseCutting>)

Parameters:

ARRAY netNames (array of strings holding the net names of the selected
nets)

BSTR clipExtentDistance (distance to push from the selected nets; must
include units and will not support wavelength based distance)

BOOL simplifiedExtent (TRUE to simplify edges or FALSE)

INT traceCuttingOption

l 0 – Cut traces that cross the boundary.
l 1 – Include all traces that overlap the extent.
l 2 – Include only traces that are completely inside the extent.

BOOL ignoreLayerVisibility (TRUE to ignore or FALSE)

BOOL reverseCutting (TRUE to clip outside the polygon or FALSE to keep
objects inside the clipping polygon)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrClipDesignAroundNets (netNames, "1mm", TRUE,
0, TRUE, FALSE)

IPY Example:
oDoc.ScrClipDesignAroundNets (netNames, '1mm', True, 0,
True, False)
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ScrCloseProject
Closes the current active project and opens a new "Untitled" project.

UI Command: Click File > New.

Syntax: obj.ScrCloseProject()

Parameters: None.

Return Value: None.

VB Example: obj.ScrCloseProject()

IPY Example: oDoc.ScrCloseProject()

ScrCloseProjectNoSave
Closes the current active project and opens a new "Untitled" project.

UI Command: Click File > New.

Syntax: obj.ScrCloseProjectNoSave()

Parameters: None.

Return Value: None.

VB Example: obj.ScrCloseProjectNoSave()

IPY Example: oDoc.ScrCloseProjectNoSave()

ScrComputeFwsSubckt
Computes a full-wave Spice subcircuit representing the specified S-parameter solution.

The ScrSetFwsSubcktFormat() function specifies the Spice format to use.

UI Command: Click Results > SYZ > [simulation name] > Compute FWS sub-circuit.

Syntax: obj.ScrComputeFwsSubckt(<syzSimName>, <path>)

Parameters:
BSTR syzSimName

BSTR path (save location)

Return Value:
INT
l 0 – Success
l Non-zero value – Failure

VB Example:
outcome=obj.ScrComputeFwsSubckt("SYZ Sweep 1",
"C:/sweep1" )

IPY Example:
oDoc.ScrComputeFwsSubckt('SYZ Sweep 1',
'C:/sweep1')
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ScrComputeFwsSubcktForNamedSim
Computes a full-wave Spice subcircuit for a specified simulation.

The ScrSetFwsSubcktFormat() function specifies the Spice format to use.

UI Command: Click Results > [simulation type] > [simulation name] > Compute FWS
sub-circuit.

Syntax:
obj.ScrComputeFwsSubcktForNamedSim(<simType>,
<simName>, <path>)

Parameters:

BSTR simType

BSTR simName

BSTR path

Return Value:
INT
l 0 – Success
l Non-zero value – Failure

VB Example:
outcome=obj.ScrComputeFwsSubcktForNamedSim('syz',
"SYZ Sweep 1", "C:/sweep1" )

IPY Example:
oDoc.ScrComputeFwsSubcktForNamedSim('syz', 'SYZ
Sweep 1', 'C:/sweep1')

ScrConvertPlanesToTraces
Performs plane to trace conversion on specified nets.

UI Command: Click Tools > Convert Planes to Traces.

Syntax: obj.ScrConvertPlanesToTraces (<netNameList>)

Parameters: ARRAY netNameList

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

dim netNames

netNames = Array("GND", "P28VA")

outcome = obj.ScrConvertPlanesToTraces(netNames)

IPY Example: oDoc.ScrConvertPlanesToTraces(['GND','P28VA'])
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ScrConvertTracesToPlanes
Performs trace to plane conversion on a specified trace.

UI Command: Click Tools > Convert Traces to Planes.

Syntax:
obj.ScrConvertTracesToPlanes (<layerName>, <netName>,
<mergeAll>, <minVoidArea>, <unitName>)

Parameters:

BSTR layerName

BSTR netName (If net name is "all", traces of all nets on the layer will be
converted)

BOOL mergeAll (TRUEmerges all planes; FALSE does not)

DOUBLE minVoidArea (all voids smaller than this value will be deleted)

BSTR unitName ("m", "meters", "mm", "cm", "um", "microns", "inches", "mils",
"nanometers", "nm", or "feet")

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrConvertTracesToPlanes
("BOTTOM","GND",true,0.001,"mm")

IPY Example:
oDoc.ScrConvertTracesToPlanes
('BOTTOM','GND',True,0.001,'mm')

ScrConvertTracesToPlanesByNet
Performs trace to plane conversion by a specified net.

UI Command: Click Tools > Convert Traces to Planes.

Syntax: obj.ScrConvertTracesToPlanesByNet (<netNameList)

Parameters: ARRAY netNameList

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

dim netNames

netNames = Array("GND", "P28VA")

outcome = obj.ScrConvertTracesToPlanes(netNames)

IPY Example: oDoc.ScrConvertTracesToPlanes(['GND','P28VA'])

Script Commands 2-45

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave Scripting Guide

ScrCopyImageToClipBoard
Copies the Modeling workspace to the clipboard.

UI Command: Right-click in the Modeling workspace and select Copy Image.

Syntax: obj.ScrCopyImageToClipBoard()

Parameters: None.

Return Value: None.

VB Example: obj.ScrCopyImageToClipBoard()

IPY Example: oDoc.ScrCopyImageToClipBoard()

ScrCorrectValChkErrorsWarnings
Used after "ScrRunValidationCheck " on page 2-141 and "ScrRunValidationCheckWithOptions"
on page 2-142 to apply autofixes to errors and warnings found during checks.

UI Command: None.

Syntax: obj.ScrCorrectValChkErrorsWarnings (<fixOptionArray>)

Parameters:

ARRAY fixOptionsArray (0 - deselects an option, 1 - selects an option)

Autofixes, as follows:

l 0 - disjoint errors
l 1 - overlapping via errors
l 2 - bondwire orientation errors
l 3- misalignment warnings
l 4 - bondwire misalignment warnings
l 5 - floating node errors

Return Value:
System.Int16 object at 0x000000000000002E [0]

(0 indicates successful completion of the command)

VB Example:

dim fixOptionArray(6)

fixOptionArray=Array("1","1","1","1","1","1")

obj.ScrCorrectValChkErrorsWarnings(fixOptionArray)

IPY Example:
oDoc.ScrCorrectValChkErrorsWarnings
(['1','1','1','1','1','1'])

ScrCreatePinGroups
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Creates a pin group containing specified pins.

UI Command: Tools > Create/Manage Pin Groups.

Syntax:
obj.ScrCreatePinGroups(<partName>, <refDes>,
<pinNumbers>, <groupName>, <applyToAllComponents>)

Parameters:

BSTR partName

BSTR refDes

ARRAY pinNumbers

BSTR groupName

BOOL applyToAllComponents (True = pin group should be created for all
parts with the given part name. When set to True, refDes is ignored.)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

dim pinNumbers

pinNumbers = Array("1","2","3","4")

outcome = obj.ScrCreatePinGroups("CSP_BGA", "BGA",
pinNumbers, "new_group_1", False)

IPY Example:
oDoc.ScrCreatePinGroups('CSP_BGA', 'BGA',
['1','2','3','4'], 'new_group_1', False)
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ScrCreatePinGroupByDist
Creates a pin group for pins a given distance from a specified pin.

UI Command: Tools > Create/Manage Pin Groups.

Syntax:
obj.ScrCreatePinGroupByDist (<partName>, <refDes>,
<pinNumber>, <groupName>, <maxDistance>,
<selectFromAllNets>)

Parameters:

BSTR partName

BSTR refDes

BSTR pinNumber

BSTR groupName

BSTR maxDistance

BOOL selectFromAllNets (True = pins will be selected regardless of their
nets. False = only pins from the same net as the specified pin are included.)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrCreatePinGroupByDist("T1_A", "U1", "14",
"TestPinGroupA", "450um", true)

IPY Example:
oDoc.ScrCreatePinGroupByDist('T1_A', 'U1', '14',
'TestPinGroupA', '450um', True)
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ScrCreatePinGroupsByGrid
Creates a pin group by dividing a component into a grid.

UI Command: Tools > Create/Manage Pin Groups.

Syntax:
obj.ScrCreatePinGroupsByGrid (<partName>, <refDes>,
<numRows>, <numCols>, <applyPerNet>,
<applyToAllComponents>)

Parameters:

BSTR partName

BSTR refDes

LONG numRows

LONG numCols

BOOL applyPerNet

BOOL applyToAllComponents

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrCreatePinGroupsByGrid ("DDR4_X4_FBGA78-
10X13,,", "U1", 3, 2, FALSE, TRUE)

IPY Example:
oDoc.ScrCreatePinGroupsByGrid ('DDR4_X4_FBGA78-10X13,,',
'U1', 3, 2, False, True)
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ScrCreatePinGroupByNet
Creates a pin group consisting of pins from a specified part within a specified net.

UI Command: Tools > Create/Manage Pin Groups.

Syntax:
obj.ScrCreatePinGroupByNet (<partName>, <refDes>,
<netName>, <groupName>, <applyToAllComponents>)

Parameters:

BSTR partName

BSTR refDes

BSTR netName

BSTR groupName

BOOL applyToAllComponents (True= pin groups will be created on all parts of
the specified partName regardless of the refDes; the resulting group names
will have an index number appended for uniqueness)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrCreatePinGroupByNet "T1_A", "U1", "GND",
"U1_GND", false

IPY Example:
oDoc.ScrCreatePinGroupByNet ('T1_A', 'U1', 'GND', 'U1_
GND', False)
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ScrCreatePortsOnPart
Creates ports between pins on the specified part.

Note: The positive terminals are either the specified pins, the pins on the specified net, or the
intersection of the two sets if both parameters are not empty. The negative terminal is chosen as the
closest pin on the reference net.

UI Command: Tools > Create/Manage Pin Groups.

Syntax:
obj.ScrCreatePortsOnPart (<partName>, <refDes>,
<posNet>, <posPinList>, <refNet>, <impedance>)

Parameters:

BSTR partName

BSTR refDes

BSTR posNet

ARRAY posPinList

BSTR refNet

BSTR impedance

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

dim posPinList

posPinList = Array("pin1","pin2","pin3")

doc.ScrCreatePortsOnPart("CP90-P4969-90", "V1P1",
"VREG_S9A_0P8", posPinList, "AGND", "35ohm")

IPY Example:
oDoc.ScrCreatePortsOnPart('CP90-P4969-90', 'V1P1',
'VREG_S9A_0P8', ['pin1','pin2','pin3'], 'AGND', '35ohm')

ScrDeleteAllNets
Deletes all nets in the design.

UI Command: Right-click nets, Edit > Delete.

Syntax: obj.ScrDeleteAllNets()

Parameters: None.

Return Value: None.

VB Example: obj.ScrDeleteAllNets()

IPY Example: oDoc.ScrDeleteAllNets()
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ScrDeleteCktElem
Deletes a specified circuit element.

UI Command: Right-click element, Edit > Delete.

Syntax: obj.ScrDeleteCktElem(<refDes>)

Parameters: BSTR refDes

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrDeleteCktElem("C_1")

IPY Example: oDoc.ScrDeleteCktElem('C_1')

ScrDeleteDcSolution
Deletes a DC solution.

UI Command: Results > DC IR Drop > [Solution Name] > Delete Solution.

Syntax: obj.ScrDeleteDcSolution()

Parameters: None.

Return Value: None.

VB Example: obj.ScrDeleteDcSolution()

IPY Example: oDoc.ScrDeleteDcSolution()
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ScrDeleteLayer
Deletes a specified layer.

UI Command: Home > Layer Stackup Editor. Select layer and click Delete Selected
Layers.

Syntax: obj.ScrDeleteLayer(<layerName>)

Parameters: None.

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrDeleteLayer("BOTTOM")

IPY Example: oDoc.ScrDeleteLayer('BOTTOM')

ScrDeleteNet
Deletes a specified net.

UI Command: None.

Syntax: obj.ScrDeleteNet(<netName>)

Parameters: BSTR netName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrDeleteNet("net69")

IPY Example: oDoc.ScrDeleteNet('net69')
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ScrDeleteNets
Deletes all nets in a given array.

UI Command: None.

Syntax: obj.ScrDeleteNets(<netNames>)

Parameters: ARRAY netNames

Return Value: None.

VB Example:

dim netNames

netNames = Array("net5","net6","net7","net8")

outcome = obj.ScrDeleteNets(netNames)

IPY Example: oDoc.ScrDeleteNets(['net5','net6','net7','net8'])

ScrDeleteNetsGivenInFile
Deletes all nets named in a given file.

UI Command: None.

Syntax: obj.ScrDeleteNetsGivenInFile(<fileName>)

Parameters: BSTR fileName (file path; file must have net names enclosed in double
quotes)

Return Value: None.

VB Example:
obj.ScrDeleteNetsGivenInFile("C:/NetFiles/nets_to_
delete.txt")

IPY Example:
oDoc.ScrDeleteNetsGivenInFile('C:/NetFiles/nets_to_
delete.txt')

ScrDeletePadstack
Deletes a specified padstack.

UI Command: None.

Syntax: obj.ScrDeletePadstack(<padstackName>)

Parameters: BSTR padstackName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrDeletePadstack("Stack")

IPY Example: oDoc.ScrDeletePadstack('Stack')
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ScrDeletePinGroup
Deletes a specified pin group.

UI Command: None.

Syntax:
obj.ScrDeletePinGroup(<pin_group_
name>,<deleteRefCktElems>)

Parameters:

BSTR pin_group_name

BOOL deleteRefCktElems (True = deletes references circuit element(s); False
= referenced circuit element(s) remove the reference to the pin group and
change the reference to the first pin of the pin group.)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrDeletePinGroup("U1_GND_Group", true)

IPY Example: oDoc.ScrDeletePinGroup('U1_GND_Group', True)

ScrDeleteSimulation
Delete a specified simulation or all simulations within a category (i.e., all DC IR Drop
Simulations).

UI Command: From the Simulation tab, navigate to the Results window. Then right-click a
solution or solution category and select Delete Solution/Category.

Syntax: obj.ScrDeleteSimulation(<simType>, <simName>)

Parameters:

BSTR simType (choose from: "ac", "dc", "eigen", "ff", "nf", "psi_ac", "psi_syz",
"syz", "hfss_syz", "pdn", "cpa", "icepak", "iv", "emi_scan", "em_mttf", "z0_
scan", "crosstalk_scan", "td_crosstalk_scan")

BSTR simName (enter the name of a specific simulation or "all" to delete all
simulations in the chosen category (i.e., simType)

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrDeleteSimulation("dc", "DCIR_122cel_uniform"
)

IPY Example: oDoc.ScrDeleteSimulation('dc', 'DCIR_122cel_uniform')
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ScrDrawCapacitor
Draws a capacitor in the specified location with specified parameters.

UI Command: Home > Circuit Elements > Add Capacitor.

Syntax:
obj.ScrDrawCapacitor(<capName>, <partName>, <px>, <py>,
<nx>, <ny>, <posLayerName>, <negLayerName>, <capVal>,
<seriesIndVal>, <seriesResVal>)

Parameters:

BSTR capName

BSTR partName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

DOUBLE capVal (capacitance, in Farads)

DOUBLE seriesIndVal (parasitic inductance, in Henries)

DOUBLE seriesResVal (parasitic resistance, in Ohms)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrDrawCapacitor
("Cappy","CL03A103KP3NNN",8500,4500,6000,-
500,"SURFACE","BASE",1E-07,1E-11,0)

IPY Example:
oDoc.ScrDrawCapacitor
('Cappy','CL03A103KP3NNN',8500,4500,6000,-
500,'SURFACE','BASE',1E-07,1E-11,0)
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ScrDrawCircle
Draws a circular plane.

UI Command: Home > Draw Circle.

Syntax:
obj.ScrDrawCircle(<ctrX>, <ctrY>, <radius>, <layerName>,
<netName>, <unit>)

Parameters:

DOUBLE ctrX (x coordinate of the center point)

DOUBLE ctrY (y coordinate of the center point)

DOUBLE radius

BSTR layerName

BSTR netName

BSTR unit

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrDrawCircle(100, 100, 20, "Top Metal", "NET-
1", "mm")

IPY Example:
oDoc.ScrDrawCircle(100, 100, 20, 'Top Metal', 'NET-1',
'mm')
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ScrDrawInductor
Draws an inductor in the specified location with specified parameters.

UI Command: Home > Circuit Elements > Add Inductor.

Syntax:
obj.ScrDrawInductor(<indName>, <partName>, <px>, <py>,
<nx>, <ny>, <posLayerName>, <negLayerName>, <indVal>)

Parameters:

BSTR indName

BSTR partName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

DOUBLE indVal (inductance, in Henries)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrDrawInductor("Indy","RLC_XYZ_
I",8500,4500,6000,1000,"SURFACE","BASE",1E-09)

IPY Example:
oDoc.ScrDrawInductor('Indy','RLC_XYZ_
I',8500,4500,6000,1000,'SURFACE','BASE',1E-09)
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ScrDrawPolygon
Draws a polygonal plane.

UI Command: Home > Draw Polygon.

Syntax:
obj.ScrDrawPolygon(<points>, <layerName>, <netName>,
<unit>)

Parameters:

ARRAY points (x, y, x, y, x, y, ...)

BSTR layerName

BSTR netName

BSTR unit

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:

dim points

points = Array(-10,10,5,-5,-25,-20,20,0)

outcome = obj.ScrDrawPolygon(points,"Top
Metal","NET-1","mm")

IPY Example:
oDoc.ScrDrawPolygon([-10,10,5,-5,-25,-20,20,0], 'Top
Metal', 'NET-1', 'mm')
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ScrDrawPort
Draws a port in the specified location with specified parameters.

UI Command: Home > Circuit Elements > Add Port.

Syntax:
obj.ScrDrawPort(<portName>, <px>, <py>, <nx>, <ny>,
<posLayerName>, <negLayerName>, <refZe>)

Parameters:

BSTR portName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

DOUBLE refZe (reference impedance, in Ohms)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrDrawPort
("Porty",8500,4500,6000,1000,"SURFACE","BASE",0.1)

IPY Example:
oDoc.ScrDrawPort
('Porty',8500,4500,6000,1000,'SURFACE','BASE',0.1)
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ScrDrawRectangle
Draws a rectangular plane.

UI Command: Home > Draw Rectangle.

Syntax:
obj.ScrDrawRectangle(<x1>, <y1>, <x2>, <y2>,
<layerName>, <netName>, <unit>)

Parameters:

DOUBLE x1

DOUBLE y1

DOUBLE x2

DOUBLE y2

BSTR layerName

BSTR netName

BSTR unit

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrDrawRectangle(100, 100, 200, 200, "Top
Metal", "NET-1", "mm")

IPY Example:
oDoc.ScrDrawRectangle (100, 100, 200, 200, 'Top Metal',
'NET-1', 'mm')
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ScrDrawResistor
Draws a resistor in the specified location with specified parameters.

UI Command: Home > Circuit Elements > Add Resistor.

Syntax:
obj.ScrDrawResistor(<resName>, <partName>, <px>, <py>,
<nx>, <ny>, <posLayerName>, <negLayerName>, <resVal>)

Parameters:

BSTR resName

BSTR partName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

DOUBLE resVal (resistance, in Ohms)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrDrawResistor("Resist","BBQ_
4L1FE",8500,4500,6000,1000,"SURFACE","BASE",50)

IPY Example:
oDoc.ScrDrawResistor('Resist','BBQ_
4L1FE',8500,4500,6000,1000,'SURFACE','BASE',50)
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ScrDrawTrace
Draws a trace.

UI Command: Home > Draw Trace.

Syntax:
obj.ScrDrawTrace(<points>, <width>, <layerName>,
<netName>, <unit>)

Parameters:

ARRAY points (x, y, x, y, x, y, ...)

DOUBLE width

BSTR layerName

BSTR netName

BSTR unit

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:

dim points

points = Array(10,-10,-5,5,25,20,-20,0)

outcome = obj.ScrDrawTrace(points,0.5,"Top
Metal","NET-1","mm")

IPY Example:
oDoc.ScrDrawTrace([-10,10,5,-5,-25,-20,20,0], '0.5',
'Top Metal', 'NET-1', 'mm')
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ScrDrawVia
Draws a via.

UI Command: Home > Drop Via.

Syntax:
obj.ScrDrawVia(<ctrX>, <ctrY>, <topLayer>, <botLayer>,
<padstack>, <netName>, <offsetX>, <offsetY>, <rotAngle>,
<unit>)

Parameters:

DOUBLE ctrX

DOUBLE ctrY

BSTR topLayer

BSTR botLayer

BSTR padstack

BSTR netName

DOUBLE offsetX

DOUBLE offsetY

DOUBLE rotAngle

BSTR unit

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrDrawVia (100, 100, "Top Metal", "Bottom
Metal", "Thru Via", "NET-1", 0.0, 0.0, 0.0, "mm")

IPY Example:
oDoc.ScrDrawVia(100, 100, 'Top Metal', 'Bottom Metal',
'Thru Via', 'NET-1', 0.0, 0.0, 0.0, 'mm')
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ScrDrawVoltageProbe
Draws a voltage probe in the specified location with specified parameters.

UI Command: Home > Circuit Elements > Add Voltage Probe.

Syntax:
obj.ScrDrawVoltageProbe(<probeName>, <px>, <py>, <nx>,
<ny>, <posLayerName>, <negLayerName>)

Parameters:

BSTR probeName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrDrawVoltageProbe
("ProbeOno",6500,4000,5000,1500,"SURFACE","BASE")

IPY Example:
oDoc.ScrDrawVoltageProbe
('ProbeOno',6500,4000,5000,1500,'SURFACE','BASE')
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ScrDrawVoltageSource
Draws a frequency independent voltage source in the specified location with specified
parameters.

UI Command: Home > Circuit Elements > Add Voltage Source.

Syntax:
obj.ScrDrawVoltageSource(<sourceName>, <partName>, <px>,
<py>, <nx>, <ny>, <posLayerName>, <negLayerName>, <mag>,
<phase>, <seriesRes>)

Parameters:

BSTR sourceName

BSTR partName

DOUBLE px (positive terminal x location)

DOUBLE py (positive terminal y location)

DOUBLE nx (negative terminal x location)

DOUBLE ny (negative terminal y location)

BSTR posLayerName

BSTR negLayerName

DOUBLE mag (magnitude, in Volts)

DOUBLE phase (phase, in degrees)

DOUBLE seriesRes (parasitic resistance, in Ohms)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrDrawVoltageSource("Sourcey","PRT1_
00543",5000,4500,4500,3000,"SURFACE","BASE",1,0,1E-
06)

IPY Example:
oDoc.ScrDrawVoltageSource('Sourcey','PRT1_
00543',5000,4500,4500,3000,'SURFACE','BASE',1,0,1E-06)
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ScrEditCktElemName
Edits an existing circuit element's name.

UI Command: Components window. Right-click [circuit element] > Edit
Circuit Element. Change name.

Syntax: obj.ScrEditCktElemName(<name>, <type> <newName>)

Parameters:

BSTR name

BSTR type ("cap", "ind", "res", "port", "vprobe", "csource", or "vsource")

BSTR newName

Return Value:

INT:

l 0 – Success
l 1 – One of the input parameters is an empty string.
l 2 – type value is unacceptable.
l 3 – Cannot find component to rename.
l 4 – newName is already taken.

VB Example:
obj.ScrEditCktElemName("port_old", "port", "port_
new")

IPY Example:
oDoc.ScrEditCktElemName('port_old', 'port', 'port_
new')
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ScrEditLayerName
Sets a new name for a specified layer.

UI Command: Click Home > Layer Stackup Editor. Enter a value in the Name field.

Syntax: obj.ScrEditLayerName(<layerName>, <newLayerName>)

Parameters:
BSTR layerName

BSTR newLayerName

Return Value: None.

VB Example: obj.ScrEditLayerName("MY LAYER","MY NEW LAYER")

IPY Example: oDoc.ScrEditLayerName('MY LAYER','MY NEW LAYER')

ScrEditMaterial
Edits an existing material.

UI Command: Home > Edit Materials.

Syntax:
obj.ScrEditMaterial(<matType>, <matName>,
<epsOrSigma>, <ltOrPerm>)

Parameters:

BSTR matType (conductor or dielectric)

BSTR matName

DOUBLE epsOrSigma (conductivity for conductor or permittivity for dielectric)

DOUBLE ltOrPerm (permeability for conductor or loss tangent for dielectric)

Return Value:

INT result:

l 0 – Success
l 1 – Material type is not "conductor" or "dielectric"
l 2 – Material name does not exist in library
l 3 – Material parameters are not within an acceptable range

VB Example:
obj.ScrEditMaterial("conductor", "unobtanium",
5.7E+07, 0.5)

IPY Example:
oDoc.ScrEditMaterial('conductor', 'unobtanium',
5.7E+07, 0.5)
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ScrEditNetName
Edits an existing net's name.

UI Command: Nets window. Right-click net and select Edit Net Name.

Syntax: obj.ScrEditNetName(<netName>, <newNetName>)

Parameters:
BSTR netName

BSTR newNetName

Return Value: None.

VB Example: obj.ScrEditNetName("MY NET", "MY NEW NET")

IPY Example: oDoc.ScrEditNetName('MY NET', 'MY NEW NET')

ScrEditPadStackName
Edits an existing padstack's name.

UI Command: Home > Edit Padstacks. Enter a new Name.

Syntax:
obj.ScrEditPadStackName(<oldPadstackName>,
<newPadstackName>)

Parameters:
BSTR oldPadstackName

BSTR newPadstackName

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrEditPadStackName("MY PADSTACK",
"MY NEW PADSTACK")

IPY Example:
oDoc.ScrEditPadStackName('MY PADSTACK',
'MY NEW PADSTACK')
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ScrEnableCavityFieldCoupling
Enables or disables cavity field coupling detection and solution during simulation.

Note: Does not apply to DC IR simulations.

UI Command: Simulation >Options to open the SIwave Options window. On
SI/PI Advanced tab, select Cavity field check box.

Syntax: obj.ScrEnableCavityFieldCoupling <flag>

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

VB Example: obj.ScrEnableCavityFieldCoupling True

IPY Example: oDoc.ScrEnableCavityFieldCoupling(1)

ScrEnableCoPlaneCoupling
Enables or disables coplanar waveguide coupling detection and solution during simulation.

Note: Does not apply to DC IR simulations.

UI Command: Simulation >Options to open the SIwave Options window. On
SI/PI Advanced tab, select Coplane check box.

Syntax: obj.ScrEnableCoPlaneCoupling <flag>

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

VB Example: obj.ScrEnableCoPlaneCoupling True

IPY Example: oDoc.ScrEnableCoPlaneCoupling(1)

ScrEnableErcSimSetup
For PSI simulations, enables or disables option to perform ERC during simulation setup

UI Command: Simulation > PSI Options. Select Perform ERC during simulation setup.

Syntax: obj.ScrEnableErcSimSetup(<flag>)

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

VB Example: obj.ScrEnableErcSimSetup True

IPY Example: oDoc.ScrEnableErcSimSetup(1)
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ScrEnableFwsRelativeErrorTol
Enables or disables relative error tolerance.

UI Command: Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit.
Select Advanced > Enable Relative Error Tolerance.

Syntax: obj.ScrEnableFwsRelativeErrorTol <flag>

Parameters: BOOL flag (True enables; False disables)

Return Value: None.

VB Example: obj.ScrEnableFwsRelativeErrorTol True

IPY Example: oDoc.ScrEnableFwsRelativeErrorTol(True)
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ScrEnableGUIRefresh
Enables or disables refreshing GUI.

UI Command: None.

Syntax: obj.ScrEnableGUIRefresh <flag>

Parameters: BOOL flag (True enables; False disables)

Return Value: None.

VB Example: obj.ScrEnableGUIRefresh True

IPY Example: oDoc.ScrEnableGUIRefresh (True)

ScrEnableIntraPlaneCoupling
Enables or disables low-frequency intra-plane coupling detection and solution during
simulation.

Note: Does not apply to DC IR simulations.

UI Command: Simulation >Options to open the SIwave Options window. On
SI/PI Advanced tab, select Intra-plane check box.

Syntax: obj.ScrEnableIntraPlaneCoupling <flag>

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

VB Example: obj.ScrEnableIntraPlaneCoupling True

IPY Example: oDoc.ScrEnableIntraPlaneCoupling(1)

ScrEnableSplitPlaneCoupling
Enables or disables split plane coupling detection and solution during simulation.

Note: Does not apply to DC IR simulations.

UI Command: Simulation >Options to open the SIwave Options window. On
SI/PI Advanced tab, select Split-plane check box.

Syntax: obj.ScrEnableSplitPlaneCoupling <flag>

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

VB Example: obj.ScrEnableSplitPlaneCoupling True

IPY Example: oDoc.ScrEnableSplitPlaneCoupling(1)
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ScrEnableTraceCoupling
Enables or disables trace coupling detection and solution during simulation.

Note: Does not apply to DC IR simulations.

UI Command: Simulation >Options to open the SIwave Options window. On
SI/PI Advanced tab, select Trace check box.

Syntax: obj.ScrEnableTraceCoupling <flag>

Parameters: BOOL flag (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value: None.

VB Example: obj.ScrEnableTraceCoupling True

IPY Example: oDoc.ScrEnableTraceCoupling(1)

ScrExport3DModel
Exports a 3D Model file.

UI Command: Export > Export to [HFSS 3D, Q3D Extractor].

Syntax: obj.ScrExport3DModel <exportTypeName> <outFilePath>

Parameters:
BSTR exportTypeName (HFSS, MAXWELL, Q3D, or X_B/X_T)

BSTR outFilePath (including extension)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrExport3DModel("Q3D",
"C:/SampleFiles/test.aedt")

IPY Example:
oDoc.ScrExport3DModel
('Q3D','C:/SampleFiles/test.aedt')
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ScrExportAnf
Exports an Ansys Neutral File (*.anf).

UI Command: Export > ANF.

Syntax: obj.ScrExportAnf <filePath>

Parameters: BSTR filePath (including extension)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrExportAnf("D:/Tests/testExport.anf")

IPY Example: oDoc.ScrExportAnf('D:/Tests/testExport.anf')

ScrExportComponentFile
Exports a component file (*.cmp) to be paired with an exported ANF file.

UI Command: Export > Component File.

Syntax: obj.ScrExportComponentFile <filePath>

Parameters: BSTR filePath (including extension)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrExportComponentFile
("D:/Tests/testExport.cmp")

IPY Example:
oDoc.ScrExportComponentFile
('D:/Tests/testExport.cmp')
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ScrExportCpaSimReport (IronPython)
Exports a CPA simulation report in HTML format.

UI Command: Results > RLGC > [Simulation Name] > Export Simulation Report.

Syntax: obj.ScrExportCpaSimReport(<simName>, <filePath>)

Parameters:
BSTR simName

BSTR filePath

Return Value:

INT:

l 0 – Success
l 1 – Cannot find CPA simulation by simName provided.
l 2 – Export failed.

VB Example:
obj.ScrExportCpaSimReport("CPA Sim 1",
"C:/Directory/")

IPY Example:
oDoc.ScrExportCpaSimReport('CPA Sim
1','C:/Directory/')

ScrExportDcPowerDataToIcepak
Enables or disables generation of DC power data for use in thermal simulations.

UI Command: None.

Syntax: obj.ScrExportDcPowerDataToIcepak(<exportPowerData>)

Parameters: BOOL exportPowerData (True = enable; False = disable)

Return Value: None.

VB Example: obj.ScrExportDcPowerDataToIcepak True

IPY Example: oDoc.ScrExportDcPowerDataToIcepak(True)
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ScrExportDcPowerTree

Note:

Use after ScrActivateDcPowerTreePinAggregation.

Exports a DC power tree of a previously run DC simulation.

UI Command: Results > DC IR > [Simulation Name] > Export Power Tree.

Syntax:
obj.ScrExportDcPowerTree(<simName>, <thresholds_
csv_file>, <output_image_file>)

Parameters:

BSTR simName (DC IR simulation must already be completed)

BSTR thresholds_csv_file (path to CSV file containing voltage and current
threshold values for every node; include file extension)

BSTR output_image_file (path to the file the tree will be exported to; include
file extension)

Return Value:

INT:

l 0 – Success
l 1 – Cannot find DC simulation by simName provided.
l 2 – Export failed.

VB Example:
obj.ScrExportDcPowerTree ("DC Drop 1",
"D:/thresholds.csv", "D:/pwrtree.png")

IPY Example:
oDoc.ScrExportDcPowerTree('DC Drop 1',
'D:/thresholds.csv', 'D:/pwrtree.png')
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ScrExportDcSimReport
Exports a simulation report for a previously run DC simulation.

To specify additional options, see: ScrExportDcSimReportColorBarProperties,
ScrExportDcSimReportOptions, ScrExportDcSimReportScaling, and
ScrExportDcSimReportUnits.

UI Command: Results > DC IR > [Simulation Name] > Export Report.

Syntax:
obj.ScrExportDcSimReport(<simName>,
<backgroundColor>, <htmReportFilenameWithPath>)

Parameters:

BSTR simName (DC IR simulation must already be completed)

BSTR backgroundColor ('black', 'white', or '', where empty string uses the
current SIwave background colors)

BSTR htmReportFilenameWithPath

Return Value:

INT:

l 0 – Success
l 1 – Cannot find DC simulation by simName provided.
l 2 – Export failed.

VB Example:
obj.ScrExportDcSimReport("DC IR Sim 1", "white",
"C:/Project1/report.htm")

IPY Example:
oDoc.ScrExportDcSimReport('DC IR Sim 1', 'white',
'C:/Project1/report.htm')

ScrExportDcSimReportColorBarProperties
Used before ScrExportDcSimReport to set color bar properties for DC report generation.

UI Command: Advanced > Color Scale. Select Color Bar Properties.

Syntax:
obj.ScrExportDcSimReportColorBarProperties
(<numDiv>, <numDigit>, <bFlipColorScale>,
<bWhiteBeyondMinMax>)

Parameters:

INT numDiv

INT numDigit

BOOL bFlipColorScale

BOOL bWhiteBeyondMinMax

Return Value:
INT:

l 0 – Success
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Used before ScrExportDcSimReport to set color bar properties for DC report generation.
l Else – Failure

VB Example:
obj.ScrExportDcSimReportColorBarProperties
(14,3,False,True)

IPY Example:
oDoc.ScrExportDcSimReportColorBarProperties
(14,3,False,True)

ScrExportDcSimReportOptions
Used before ScrExportDcSimReport to set options for DC report generation.

UI Command: Results > DC IR > [Simulation Name] > Export Report. Specify options.

Syntax:
obj.ScrExportDcSimReportOptions(<showDevices>,
<filtersXmlFilenameWithPath>)

Parameters:

BOOL showDevices (True to show devices and device names for devices with
pins on signal nets that are involved in the current simulation)

BSTR filtersXmlFilenameWithPath (full path to XML file containing filters for
current, voltage or power plots on selected layers and nets)

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrExportDcSimReportOptions(TRUE,
"C:/Projects/filter.xml")

IPY Example:
oDoc.ScrExportDcSimReportOptions(True,
'C:/Projects/filter.xml')

ScrExportDcSimReportScaling
Used before ScrExportDcSimReport to set scaling options for DC report generation.

UI Command: None.

Syntax:
obj.ScrExportDcSimReportScaling(<layerName>,
<plotType>, <minVal>, <maxVal>, <bLogScale>)

Parameters:

BSTR layerName (specify a layer name, "All", or "All Bondwires/Vias")

BSTR plotType ("Current Density", "Voltage", "Power Density", "Via Current",
or "All")

DOUBLE minVal

DOUBLE maxVal
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Used before ScrExportDcSimReport to set scaling options for DC report generation.

BOOL bLogScale (True = Log; False = Linear)

**Use -1 for both minVal & maxVal to set the plot range back to original and
also to set bLogScale independently without affecting the range.

Return Value:

INT:

l 0 – Success
l 1 – layerName value is unacceptable.
l 2 – plotType value is unacceptable.

VB Example:
obj.ScrExportDcSimReportScaling
("All","Voltage",0.00,50.0,TRUE)

IPY Example:
oDoc.ScrExportDcSimReportScaling
('All','Voltage',0.00,50.0,True)

ScrExportDcSimReportUnits
Used before ScrExportDcSimReport to set units for DC report generation.

UI Command: Results > DC IR > [Simulation Name] > Export Report.

Syntax:
obj.ScrExportDcSimReportUnits(<curDenUnits>,
<vltUnits>, <pwrDenUnits>)

Parameters:

BSTR curDenUnits ("A/um^2", "A/mil^2", "A/mm^2", "A/cm^2", "A/in^2", or
"A/m^2")

BSTR vltUnits ("uV", "mV", or "V")

BSTR pwrDenUnits ("W/um^3", "W/mil^3", "W/mm^3", "W/cm^3", "W/in^3", or
"W/m^3")

Return Value:

INT:

l 0 – Success
l 1 – curDenUnits value is unacceptable.
l 2 – vltUnits value is unacceptable.
l 3 – curDenUnits value is unacceptable.

VB Example:
obj.ScrExportDcSimReportUnits
("A/um^2","V","W/um^3")

IPY Example:
oDoc.ScrExportDcSimReportUnits
('A/um^2','V','W/um^3')
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ScrExportElementData
Exports the element data from a DC simulation report.

UI Command: Results > DC IR > [Simulation Name] > Export Element Data.

Syntax:
obj.ScrExportElementData(<simName>, <fileName>,
<tabTitle>)

Parameters:

BSTR simName

BSTR fileName

BSTR tabTitle

Return Value:

INT:

l 0 – Success
l 3 – Cannot find DC simulation by simName provided.
l Else – Export failed.

VB Example:
obj.ScrExportElementData("DC Script Sim",
"D:/Tests/viaReportOut.txt", "Vias")

IPY Example:
oDoc.ScrExportElementData('DC Script Sim',
'D:/Tests/viaReportOut.txt', 'Vias')

ScrExportEmiScanReport
Generates an HTML EMI scanner report, with images of violations.

UI Command: Results > EMI Scanner > [SimulationName] > Export Report with
Images.

Syntax: obj.ScrExportEmiScanReport(<simName>, <reportPath>)

Parameters:
BSTR simName

BSTR reportPath (include file extension)

Return Value:

INT:

l 0 – Success
l 1 – Cannot find simulation by simName provided.
l 2 – Export failed.

VB Example:
obj.ScrExportEmiScanReport("EMI Scan Sim 1",
"D:/AutomationTest/EMI.htm")

IPY Example:
oDoc.ScrExportEmiScanReport("EMI Scan Sim 1",
"D:/AutomationTest/EMI.htm")
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ScrExportIcepakProject
Exports an Icepak project for standalone use. A DC simulation may be specified to provide
power data to the Icepak project.

UI Command: Export > Icepak.

Syntax:
obj.ScrExportIcepakProject(<projectPath>,
<dcSimName>)

Parameters:
BSTR projectPath

BSTR dcSimName (leave string empty to omit)

Return Value:

INT

l 0 – Success
l 1 – Project directory could not be created.
l 2 – An EDB could not be exported for the project.
l 3 – Error generating the project import script.
l 4 – Specified DC simulation could not be found OR failure generating
Icepak launch script.

VB Example: obj.ScrExportIcepakProject("D:/icepakProj","")

IPY Example:
oDoc.ScrExportIcepakProject('D:/icepakProj',
'DC Sim 1')
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ScrExportIcepakSimReport
Generates an HTML report file containing Icepak thermal plots taken at various elevations.

To specify additional options, see: ScrExportIcepakSimReportColorBarProperties,
ScrExportIcepakSimReportScaling, and ScrExportIcepakSimReportUnits.

UI Command: Results > Temperature > Export Report.

Syntax:
obj.ScrExportIcepakSimReport(<simName>,
<fileNameWithPath>)

Parameters:
BSTR simName

BSTR fileNameWithPath (include file extension)

Return Value:

INT:

l 0 – Success
l 1 – Cannot find Icepak simulation by simName provided.
l 2 – Export failed.

VB Example:
obj.ScrExportIcepakSimReport("Icepak Script Sim",
"D:/AutomationTest/ScriptReportTest.htm")

IPY Example:
oDoc.ScrExportIcepakSimReport("Icepak Script Sim",
"D:/AutomationTest/ScriptReportTest.htm")

ScrExportIcepakSimReportColorBarProperties
Used before ScrExportIcepakSimReport to set color bar properties for Icepak report
generation.

UI Command: Advanced > Color Scale. Select Color Bar Properties.

Syntax:
obj.ScrExportIcepakSimReportColorBarProperties
(<numDiv>, <numDigit>, <bFlipColorScale>,
<bWhiteBeyondMinMax>)

Parameters:

INT numDiv

INT numDigit

BOOL bFlipColorScale

BOOL bWhiteBeyondMinMax

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrExportIcepakSimReportColorBarProperties
(14,3,False,True)
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Used before ScrExportIcepakSimReport to set color bar properties for Icepak report
generation.

IPY Example:
oDoc.ScrExportIcepakSimReportColorBarProperties
(14,3,False,True)

ScrExportIcepakSimReportScaling
Used before ScrExportIcepakSimReport to set scaling options for Icepak report generation.

UI Command: None.

Syntax:
obj.ScrExportIcepakSimReportScaling(<minVal>,
<maxVal>, <bLogScale>)

Parameters:

DOUBLE minVal

DOUBLE maxVal

BOOL bLogScale (True = Log; False = Linear)

**Use -1 for both minVal & maxVal to set the plot range back to original and
also to set bLogScale independently without affecting the range.

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrExportIcepakSimReportScaling
(0.00,50.0,FALSE)

IPY Example:
oDoc.ScrExportIcepakSimReportScaling
(0.00,50.0,False)

ScrExportIcepakSimReportUnits
Used before ScrExportIcepakSimReport to set units for Icepak report generation.

UI Command: None.

Syntax: obj.ScrExportIcepakSimReportUnits(<tempUnits>)

Parameters: BSTR tempUnits ("C", "F", or "K")

Return Value:

INT:

l 0 – Success
l 1 – tempUnits value is unacceptable.

VB Example: obj.ScrExportIcepakSimReportUnits("F")

IPY Example: oDoc.ScrExportIcepakSimReportUnits('F')
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ScrExportLayerStackup
Exports the current layer stackup to a specified file (*.stk OR *.xml).

UI Command: Export > Layer Stackup, OR Export > Layer Stackup XML.

Syntax: obj.ScrExportLayerStackup(<outputFileName>)

Parameters: BSTR outputFileName (include extension)

Return Value: None.

VB Example: obj.ScrExportLayerStackup("C:/Documents/stack.xml")

IPY Example:
oDoc.ScrExportLayerStackup
('C:/Documents/stack.stk')

ScrExportNamedSimToTouchstone
Exports SYZ simulation results to a specified touchstone file.

UI Command: Results > SYZ > [Simulation Name] > Export Touchstone File.

Syntax:
obj.ScrExportNamedSimToTouchstone(<simType>,
<simName>, <file>)

Parameters:

BSTR simType (syz, psi_syz, or hfss_syz)

BSTR simName (previously run simulation)

BSTR file (full path for the touchstone file to be generated; do not include file
extension)

Return Value:

INT:

l 0 – Success
l 1 – simType value is unacceptable.
l 2 – simName does not exist OR path cannot be created.

VB Example:
obj.ScrExportNamedSimToTouchstone("hfss_syz", "Sim
1", "D:/results")

IPY Example:
oDoc.ScrExportNamedSimToTouchstone('hfss_syz', 'Sim
1', 'D:/results')
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ScrExportNetDelayReport
Exports a net delay report in HTML format.

UI Command: Simulation > Signal Net Analyzer. Click Export Net Delays and select
appropriate options.

Syntax:
obj.ScrExportNetDelayReport(<reportPath>,
<netNameRegExp>, <lengthUnits>, <delayUnits>,
<onlyDieToBall>)

Parameters:

BSTR reportPath (full file path for report to be exported)

BSTR netNameRegExp (regular expression; use '.*' to include all nets)

BSTR lengthUnits (pass empty string to use default 'microns')

BSTR delayUnits (pass empty string to use default 'ps')

BOOL onlyDieToBall (True to enforceOnly include paths from Die pin to
BGA solderball option; else False)

Return Value:

INT

l 0 – Success
l 1 – Licensing Failure

VB Example:
obj.ScrExportNetDelayReport
("C:/MyFiles/netdelay.htm", ".*", "", "", True)

IPY Example:
oDoc.ScrExportNetDelayReport
('C:/MyFiles/netdelay.htm','.*','','',1)

ScrExportSettingsFile
Exports an SIwave Settings file (*.sef).

Use ScrExportSettingsFileSetOptions to specify additional options.

UI Command: Export > Settings File.

Syntax: obj.ScrExportSettingsFile(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example: obj.ScrExportSettingsFile "C:/Path/my_settings.sef"

IPY Example: oDoc.ScrExportSettingsFile('C:/Path/my_settings.sef')
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ScrExportSettingsFileSetOptions
Selects Settings File (*.sef) options used with ScrExportSettingsFile.

UI Command: Export > Settings File. Use the check boxes to select export options.

Syntax: obj.ScrExportSettingsFileSetOptions(<optionArray>)

Parameters:

ARRAY optionArray of BOOLs (1 = enable export; 0 = disable export)

INDEX:

l 0 – Plane Extents
l 1 – Solder Balls and Bumps
l 2 – Bondwires
l 3 – Net Selections
l 4 – Differential Nets and Extended Differential Nets
l 5 – Extended Nets
l 6 – Padstacks (includes Padshapes)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:

Dim expOptions (7)

  expOptions(0) = 1

  expOptions(1) = 0

  expOptions(2) = 1

  expOptions(3) = 0

  expOptions(4) = 0

  expOptions(5) = 1

  expOptions(6) = 0

obj.ScrExportSettingsFileSetOptions expOptions

IPY Example: oDoc.ScrExportSettingsFileSetOptions([1,0,1,0,0,1,0])

ScrExportSNAReport
Exports a Signal Net Analyzer output report in either HTML or CSV format.

UI Command: Simulation > Signal Net Analyzer. From the Signal Net Analyzer window,
click Export Table.

Syntax: obj.ScrExportSNAReport(<reportPath>, <netNameRegExp>,
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Exports a Signal Net Analyzer output report in either HTML or CSV format.
<lengthUnits>, <delayUnits>,
<onlyDieToBall>,<exportToCSV>)

Parameters:

BSTR reportPath (full file path for report to be exported)

BSTR netNameRegExp (regular expression; use '.*' to include all nets)

BSTR lengthUnits (pass empty string to use default 'mm')

BSTR delayUnits (pass empty string to use default 'ps')

BOOL onlyDieToBall (True to enforceOnly include paths from Die pin to
BGA solderball option; else False)

BOOL exportToCSV (True to export to CSV file; False to export to HTML file)

Return Value:

INT

l 0 – Success
l 1 – Licensing Failure

VB Example:

HTML File:

obj.ScrExportSNAReport "C:/MyFiles/snaRpt.htm",
".*", "", "", False, False

CSV File:

obj.ScrExportSNAReport "C:/MyFiles/snaRpt.csv",
".*", "microns", "ns", False, True

IPY Example:

HTML File:

oDoc.ScrExportSNAReport
('C:/MyFiles/snaRpt.htm','.*','','',0,0)

CSV File:

oDoc.ScrExportSNAReport
('C:/MyFiles/snaRpt.csv','.*','microns','ns',0,1)
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ScrExportSyzSimToTouchstone
Exports SYZ simulation results to a specified touchstone file.

UI Command: Results > SYZ > [Simulation Name] > Export Touchstone File.

Syntax:
obj.ScrExportSyzSimToTouchstone(<syzSimName>,
<touchstonePath>)

Parameters:
BSTR syzSimName

BSTR touchstonePath

Return Value:

INT:

l 0 – Success
l 1 – Simulation name does not exist OR path cannot be created

VB Example:
obj.ScrExportSyzSimToTouchstone("SYZ Sweep 1",
"C:/sweep1")

IPY Example:
oDoc.ScrExportSyzSimToTouchstone('SYZ Sweep 1',
'C:/sweep1')

ScrExportToTouchstone
Exports the active dataset as SYZ data in touchstone format.

UI Command: Results > SYZ > [Simulation Name] > Export Touchstone File.

Syntax: obj.ScrExportToTouchstone(<filePath>)

Parameters: BSTR filePath

Return Value:

INT:

l 0 – Success
l 1 – SYZ Simulation does not exist OR path cannot be created.

VB Example:
obj.ScrExportToTouchstone
("D:/Tests/testExport.s2p")

IPY Example:
oDoc.ScrExportToTouchstone
('D:/Tests/testExport.s2p')
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ScrExportVprobeData
Exports voltage probe data for a specified AC sweep to a text file.

UI Command: None.

Syntax:
obj.ScrExportVprobeData(<acSimName>,
<bstrVprobeFilePath>)

Parameters:
BSTR acSimName

BSTR bstrVprobeFilePath (include file extension *.vpb)

Return Value:

INT

l 0 – Success
l 1 – AC simulation name does not exist OR file path cannot be created.

VB Example:
obj.ScrExportVprobeData("AC Sweep 1",
"C:\Files\probe_data.vpb")

IPY Example:
oDoc.ScrExportVprobeData('AC Sweep 1',
'C:/Files/probe_data.vpb')

ScrExportXfl
Exports an XFL file.

UI Command: Export > XFL.

Syntax: obj.ScrExportXfl(<filePath>)

Parameters: BSTR filePath (path for export)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrExportXfl("C:/Directory/filename.xfl")

IPY Example: oDoc.ScrExportXfl('C:/Directory/filename.xfl')
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ScrExportZ0ScanReport
Generates an HTML report file containing impedance plots taken for every layer.

To specify additional report options, use ScrExportZ0ScanReportColorBarProperties and
ScrExportZ0ScanReportScaling.

UI Command: Results > Impedance Scan > Export Report.

Syntax:
obj.ScrExportZ0ScanReport(<simName>,
<fileNameWithPath>)

Parameters:
BSTR simName

BSTR fileNameWithPath (include file extension)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrExportZ0ScanReport("Z0 Scan 1",
"D:/AutomationTest/ScriptReportTest.htm")

IPY Example:
oDoc.ScrExportZ0ScanReport('Z0 Scan 1',
'D:/AutomationTest/ScriptReportTest.htm')
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ScrExportZ0ScanReportColorBarProperties
Used before ScrExportZ0ScanReport to set color bar properties for impedance report
generation.

UI Command: Advanced > Color Scale. Select Color Bar Properties.

Syntax:
obj.ScrExportZ0ScanReportColorBarProperties
(<numDiv>, <numDigit>, <bFlipColorScale>,
<bWhiteBeyondMinMax>)

Parameters:

INT numDiv

INT numDigit

BOOL bFlipColorScale

BOOL bWhiteBeyondMinMax

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrExportZ0ScanReportColorBarProperties
(14,3,False,True)

IPY Example:
oDoc.ScrExportZ0ScanReportColorBarProperties
(14,3,False,True)
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ScrExportZ0ScanReportScaling
Used before ScrExportZ0ScanReport to set scaling options for impedance report generation.

UI Command: None.

Syntax:
obj.ScrExportZ0ScanReportScaling(<minVal>,
<maxVal>, <bLogScale>)

Parameters:

DOUBLE minVal

DOUBLE maxVal

BOOL bLogScale (True = Log; False = Linear)

**Use -1 for both minVal & maxVal to set the plot range back to original and
also to set bLogScale independently without affecting the range.

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrExportZ0ScanReportScaling(0.00,50.0,TRUE)

IPY Example: oDoc.ScrExportZ0ScanReportScaling(0.00,50.0,True)

ScrFitAll
Fits the design to the modeling workspace.

UI Command: View > Fit All.

Syntax: obj.ScrFitAll

Parameters: None.

Return Value: None.

VB Example: obj.ScrFitAll()

IPY Example: oDoc.ScrFitAll()

ScrFitSelection
Fits selected object(s) to the modeling workspace.

UI Command: View > Fit Selection.

Syntax: obj.ScrFitSelection

Parameters: None.

Return Value: None.

VB Example: obj.ScrFitSelection()

IPY Example: oDoc.ScrFitSelection()
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ScrFitToViewingWindow
Fits selected object(s) to the viewing window. See: GetCurrentViewingWindow.

UI Command: None.

Syntax: obj.ScrFitToViewingWindow(<unit>, <viewBox>)

Parameters:
BSTR unit (unit of measure)

ARRAY viewBox (structured array containing X,Y coordinates)

Return Value: None.

VB Example:

Dim obj

Dim viewBox

viewBox = obj.GetCurrentViewingWindow("mm")

obj.ScrFitToViewingWindow "mm", viewBox

IPY Example:
oDoc.ScrFitToViewingWindow('um',['-54','-
27','54','27'])

ScrFwsEnforceCausality
Controls option to check whether s-parameter data is passive.

UI Command: Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit. Select
Enforce Causality check box.

Syntax: obj.ScrFwsEnforceCausality(<flag>)

Parameters: BOOL flag (True to enforce)

Return Value: None.

VB Example: obj.ScrFwsEnforceCausality(true)

IPY Example: oDoc.ScrFwsEnforceCausality(True)
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ScrGenerateConnectionReport
Exports a net connection report to a specified HTML file in the project directory.

UI Command: Advanced > Export Connection Report.

Syntax: obj.ScrGenerateConnectionReport(<fileName>)

Parameters: BSTR fileName (including file extension)

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrGenerateConnectionReport("connRpt.html")

IPY Example: oDoc.ScrGenerateConnectionReport('connRpt.html')
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ScrGenerateICDieNetwork
Generates an IC die network.

UI Command: Tools > Create IC Die Network. Set options in IC Die Network Generation
window.

Syntax:

obj.ScrGenerateICDieNetwork (<icPartName>,
<refDes>, <net>, <networkName>, <resVal>,
<useStarPattern>, <capVal>, <esr>, <toNet>,
<useAutoRadius>, <resRadius>, <capRadius>)

Parameters:

BSTR icPartName

BSTR refDes

BSTR net

BSTR networkName

BSTR resVal

BOOL useStarPattern (True = star pattern; False = grid pattern)

BSTR capVal

BSTR esr

BSTR toNet

BOOL useAutoRadius (True = auto radius; False = specify radius)

BSTR resRadius (leave string blank for auto radius)

BSTR capRadius (leave string blank for auto radius)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.doc.ScrGenerateICDieNetwork("CD90-P2913-1",
"U13", "AGND", "U13_AGND", "3.0mOhm", TRUE, "", "",
"", TRUE, "", "")

IPY Example:
oDoc.ScrGenerateICDieNetwork('CD90-P2913-1', 'U13',
'AGND', 'U13_AGND', '3.0mOhm', True, '', '', '',
True, '', '')
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ScrGetActiveComponentList
Returns list of all active components of a specified type.

UI Command: None.

Syntax: obj.ScrGetActiveComponentList(<compType>)

Parameters: BSTR compType (can be "All", "RLC", or any category shown in the
Components workspace, e.g. "Discrete Devices", "Pin Groups")

Return Value: ARRAY nameList

VB Example: obj.ScrGetActiveComponentList("All")

IPY Example: oDoc.ScrGetActiveComponentList('Current Sources')

ScrGetBondwiresOfBwModel
Returns list of all bondwires associated with the given bondwire model.

UI Command: None.

Syntax: obj.ScrGetBondwiresOfBwModel(<modelName>)

Parameters: BSTR modelName

Return Value: ARRAY bwList (list of bondwires)

VB Example: obj.ScrGetBondwiresOfBwModel("Z1-MT8530-LOOP1")

IPY Example: oDoc.ScrGetBondwiresOfBwModel('Z1-MT8530-LOOP1')

ScrGetBwModelNameList
Returns list of all bondwire models.

UI Command: None.

Syntax: obj.ScrGetBwModelNameList()

Parameters: None.

Return Value: ARRAY bwModelNameList (list of bondwire models)

VB Example: Dim bwModelNameList = obj.ScrGetBwModelNameList()

IPY Example: oDoc.ScrGetBwModelNameList()
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ScrGetCktElemTerminalNetNames
Returns names of the two nets to which a specified circuit element is connected.

UI Command: None.

Syntax:
obj.ScrGetCktElemTerminalNetNames(<name>, <type>,
<pnet>, <nnet>)

Parameters:

BSTR name (the circuit element Reference Designator)

BSTR type ("cap", "ind", "res", "port", "vprobe", "csource" or "vsource")

ARRAY pnet

ARRAY nnet

Return Value:

INT

l 0 – Success
l 1 – Either name OR type is not specified.
l 2 – Type is unrecognized.
l 3 – Name cannot be found.
l 4 – Circuit element's positive terminal is floating (has not been connected
to a net).

l 5 – Circuit element's negative terminal is floating (has not been connected
to a net).

VB Example:
obj.ScrGetCktElemTerminalNetNames
("C1","cap",pnet,nnet)

IPY Example:
oDoc.ScrGetCktElemTerminalNetNames
('C1','cap',pnet,nnet)
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ScrGetComponentList
Returns an array containing names of all parts of the specified type.

UI Command: None.

Syntax: obj.ScrGetComponentList(<compType>)

Parameters:

BSTR compType ("all", "rlc", "capacitors", "inductors", "resistors", "ports",
"voltage probes", "current sources", "voltage sources", "integrated circuits",
"input/output", or "discrete devices"; separate using a comma to specify more
than one type)

Return Value: ARRAY componentList

VB Example:
obj.ScrGetComponentList("rlc, ports, integrated
circuits")

IPY Example:
oDoc.ScrGetComponentList('rlc, ports, integrated
circuits')

ScrGetCurrentViewingWindow
Returns the position of the viewing window.

UI Command: None.

Syntax: obj.ScrGetCurrentViewingWindow(<units>)

Parameters: BSTR units

Return Value: ARRAY containing X,Y coordinates. Results can be used with
ScrFitToViewingWindow.

VB Example: obj.ScrGetCurrentViewingWindow("um")

IPY Example: oDoc.ScrGetCurrentViewingWindow('um')
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ScrGetDcConnectedNets
Returns an array containing all nets and RLCs that form a connection to the specified net.

UI Command: None.

Syntax:
obj.ScrGetDcConnectedNets(<netNameList>, <nets>,
<cktElems>)

Parameters:

ARRAY netNameList (input list of net names that are connected)

ARRAY nets (list of net names that are DC-connected to the input list)

ARRAY cktElems (names of circuit elements that form connections between
the DC-connected nets)

Return Value:

BOOL

l 0 – Success
l 1 – Failure

VB Example:
obj.ScrGetDcConnectedNets(netNameList, nets,
cktElems)

IPY Example:
oDoc.ScrGetDcConnectedNets(netNameList, nets,
cktElems)

ScrGetDcThermalDataDir
Sets variable thermalDataDirBstr to the path of the DC Thermal directory.

UI Command: None.

Syntax:
obj.ScrGetDcThermalDataDir(<simName>,
<thermalDataDirBstr>)

Parameters:
BSTR simName (DC simulation name)

ARRAY thermalDataDirBstr (empty)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:

Dim thermalDataDirBstr()

obj.ScrGetDcThermalDataDir("DC IR Sim
1",thermalDataDirBstr)

IPY Example:

thermalDataDirBstr = []

oDoc.ScrGetDcThermalDataDir('DC IR Sim
1',thermalDataDirBstr)
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ScrGetDesignBoundingBox
Assigns the design's bounding box, in specified units, to variable designBBox.

UI Command: None.

Syntax: obj.ScrGetDesignBoundingBox(<units>, <designBBox>)

Parameters:
BSTR units ('um', 'in', 'm', 'microns', 'mils', 'mm', 'cm', 'inches', or 'meters')

ARRAY designBBox (empty)

Return Value:

ARRAY designBBox populates with 3D bounding box
coordinates, represented by corner points (x1,y1,z1) and (x2, y2, z2).

BOOL:

l 1 – Success
l 0 – Failure

VB Example:
Dim designBBox()

obj.ScrGetDesignBoundingBox("mm",designBBox)

IPY Example:
designBBox= []

oDoc.ScrGetDesignBoundingBox('mm',designBBox)

ScrGetDieLayerName
Returns the layer on which a specified die exists.

UI Command: None.

Syntax: obj.ScrGetDieLayerName(<dieName>)

Parameters: BSTR dieName

Return Value: BSTR layer name

VB Example: obj.ScrGetDieLayerName "DIE"

IPY Example: oDoc.ScrGetDieLayerName('DIE')
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ScrGetDieNameList
Returns an array containing all die names.

UI Command: None.

Syntax: obj.ScrGetDieNameList()

Parameters: None.

Return Value: ARRAY dieNameList

VB Example: obj.ScrGetDieNameList()

IPY Example: oDoc.ScrGetDieNameList()

ScrGetLayerMaterial
Returns the material of a specified layer.

UI Command: None.

Syntax: obj.ScrGetLayerMaterial(<layerName>)

Parameters: BSTR layerName

Return Value: BSTR materialName

VB Example: obj.ScrGetLayerMaterial("BOTTOM")

IPY Example: oDoc.ScrGetLayerMaterial('BOTTOM')

ScrGetLayerNameList
Returns an array containing names of all layers in the project.

UI Command: None.

Syntax: obj.ScrGetLayerNameList()

Parameters: None.

Return Value: ARRAY layerNameList

VB Example: obj.ScrGetLayerNameList()

IPY Example: oDoc.ScrGetLayerNameList()
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ScrGetLayerThickness
Returns the thickness of a specified layer.

UI Command: None.

Syntax: obj.ScrGetLayerThickness(<layerName>)

Parameters: BSTR layerName

Return Value: DOUBLE layer thickness

VB Example: obj.ScrGetLayerThickness "TOP_LAYER"

IPY Example: oDoc.ScrGetLayerThickness('TOP_LAYER')

ScrGetLayerType
Returns a specified layer's type.

UI Command: None.

Syntax: obj.ScrGetLayerType(<layerName>)

Parameters: BSTR layerName

Return Value:

INT

l 0 – Dielectric
l 1 – Metal
l 2 –Wirebond

VB Example: obj.ScrGetLayerType("SURFACE_LAYER")

IPY Example: oDoc.ScrGetLayerType('SURFACE_LAYER')

ScrGetLayoutLengthUnit
Returns the current unit of measure.

UI Command: None.

Syntax: obj.ScrGetLayoutLengthUnit()

Parameters: None.

Return Value: BSTR unit

VB Example: obj.ScrGetLayoutLengthUnit()

IPY Example: oDoc.ScrGetLayoutLengthUnit()
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ScrGetMetalLayerFillerMaterial
Returns a specified metal layer's filler material.

UI Command: None.

Syntax: obj.ScrGetMetalLayerFillerMaterial(<layerName>)

Parameters: BSTR layerName

Return Value: BSTR materialName

VB Example: obj.ScrGetMetalLayerFillerMaterial("LAYER3")

IPY Example: oDoc.ScrGetMetalLayerFillerMaterial('LAYER3')

ScrGetNetlistOfBondwireProfile
Returns a list of nets associated with a given bondwire profile

UI Command: None.

Syntax: obj.ScrGetNetlistOfBondwireProfile(<profileName>)

Parameters: BSTR profileName

Return Value: ARRAY netNameList

VB Example: obj.ScrGetNetlistOfBondwireProfile("Bw Profile")

IPY Example: oDoc.ScrGetNetlistOfBondwireProfile('Bw Profile')

ScrGetNetNameList
Returns a list of nets in the project.

UI Command: None.

Syntax: obj.ScrGetNetNameList()

Parameters: None.

Return Value: ARRAY netNameList

VB Example: obj.ScrGetNetNameList()

IPY Example: oDoc.ScrGetNetNameList()
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ScrGetNetsAndCktElemsBetweenComponents
Returns a list of all power/ground nets and RLCs that form a connection between specified
components.

UI Command: None.

Syntax:
obj.ScrGetNetsAndCktElemsBetweenComponents
(<partName1>, <refDes1>, <partName2>, <refDes2>,
<nets>, <cktElems>)

Parameters:

BSTR partName1

BSTR refDes1

BSTR partName2

BSTR refDes2

ARRAY nets (empty)

ARRAY cktElems (empty)

Return Value:

ARRAY nets (filled)

ARRAY cktElems (filled)

INT outcome:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrGetNetsAndCktElemsBetweenComponents
("288DIMMDDR4_EDGE_CONN-BASE", "J1", "DDR4_X4_
FBGA78-10X13", "U1", nets2, elems2)

IPY Example:
oDoc.ScrGetNetsAndCktElemsBetweenComponents
('288DIMMDDR4_EDGE_CONN-BASE', 'J1', 'DDR4_X4_
FBGA78-10X13','U1', nets2, elems2)
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ScrGetNetsAndCktElemsBetweenNets
Returns a list of all nets and RLCs that form a connection between specified components.

UI Command: None.

Syntax:
obj.ScrGetNetsAndCktElemsBetweenNets(<net1>,
<net2>, <refDes2>, <nets>, <cktElems>)

Parameters:

BSTR net1

BSTR net2

ARRAY nets (empty)

ARRAY cktElems (empty)

Return Value:

ARRAY nets (filled)

ARRAY cktElems (filled)

INT outcome:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrGetNetsAndCktElemsBetweenNets("VDD", "GND",
nets, elems)

IPY Example:
oDoc.ScrGetNetsAndCktElemsBetweenNets('VDD', 'GND',
nets, elems)

ScrGetPadstackNameList
Returns a list of all padstack names in the project.

UI Command: None.

Syntax: obj.ScrGetPadstackNameList()

Parameters: None.

Return Value: ARRAY padstackNameList

VB Example: obj.ScrGetPadstackNameList()

IPY Example: oDoc.ScrGetPadstackNameList()
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ScrGetPinGroupNameList
Returns a list of all pin group names on specified part(s) or in the entire project.

UI Command: None.

Syntax: obj.ScrGetPinGroupNameList(<partName>,<refDes>)

Parameters:
BSTR partName (leave empty to search entire project)

BSTR refDes (leave empty to search entire project)

Return Value: ARRAY pinGroupNameList

VB Example:
obj.ScrGetPinGroupNameList("288DIMMDDR4_EDGE_CONN-
BASE", "J1")

IPY Example: oDoc.ScrGetPinGroupNameList()

ScrGetPinPadstackName
Returns the padstack name associated with a specified pin.

UI Command: None.

Syntax:
obj.ScrGetPinPadstackName(<partName>, <refDes>,
<pinName>)

Parameters:

BSTR partName

BSTR refDes

BSTR pinName

Return Value: BSTR padstackName

VB Example: obj.ScrGetPinPadstackName("DIE", "U1", "394")

IPY Example: oDoc.ScrGetPinPadstackName('DIE','U1','394')
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ScrGetPinsOnNet
Returns a list of identifying information for pins on a specified net.

UI Command: None.

Syntax:
obj.ScrGetPinsOnNet(<netName>, <partName>,
<refDes>, <pinNames>, <partNames>, <refDesOut>)

Parameters:

BSTR netName

BSTR partName (use empty string or "any" to disable this filter)

BSTR refDes (use empty string or "any" to disable this filter)

ARRAY pinNames (empty)

ARRAY partNames (empty)

ARRAY refDesOut (empty)

Return Value:

ARRAY pinNames (filled)

ARRAY partNames (filled)

ARRAY refDesOut (filled)

BOOL outcome:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrGetPinsOnNet("GND", "ANY", "", pins, parts,
refDesList)

IPY Example:
oDoc.ScrGetPinsOnNet ('GND', 'ANY', '', pins,
parts, refDesList)
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ScrGetPinsOnPart
Returns a list of identifying information for pins on a specified part.

UI Command: None.

Syntax:
obj.ScrGetPinsOnPart(<partName>, <refDes>,
<pinNames>, <netNames>)

Parameters:

BSTR partName

BSTR refDes

ARRAY pinNames (empty)

ARRAY netNames (empty)

Return Value:

ARRAY pinNames (filled)

ARRAY netNames (filled)

BOOL outcome:

l 0 – Failure
l 1 – Success

VB Example: obj.ScrGetPinsOnPart("T1_A", "U1", pins, nets)

IPY Example: oDoc.ScrGetPinsOnPart('T1_A', 'U1', pins, nets)

ScrGetPwrGndNetNameList
Returns a list of Power/Ground nets in the project.

UI Command: None.

Syntax: obj.ScrGetPwrGndNetNameList()

Parameters: None.

Return Value: ARRAY pwrGndNetNameList

VB Example: obj.ScrGetPwrGndNetNameList()

IPY Example: oDoc.ScrGetPwrGndNetNameList()
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ScrGetRLCsBetweenNets
Finds RLCs that directly connect any pair of nets from the specified list.

UI Command: None.

Syntax:
obj.ScrGetRLCsBetweenNets(<netNameList>,
<includeR>, <includeL>, <includeC>, <ctkElems>)

Parameters:

ARRAY netNameList

BOOL includeR

BOOL includeL

BOOL includeC

ARRAY cktElems (empty)

Return Value:

ARRAY cktElems (filled)

INT outcome:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrGetRLCsBetweenNets(netsIn, FALSE, FALSE,
TRUE, elems1)

IPY Example:
oDoc.ScrGetRLCsBetweenNets(netsIn1, False, False,
True, elems1)

ScrGetStackupLayerThickness
Returns the thickness of a specified layer.

UI Command: None.

Syntax: obj.ScrGetStackupLayerThickness(<layerName>)

Parameters: BSTR layerName

Return Value: BSTR layer thickness

VB Example: obj.ScrGetStackupLayerThickness("Layer 1")

IPY Example: oDoc.ScrGetStackupLayerThickness('Layer 1')
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ScrGetUniqueSimulationName
Generates a unique simulation name based on a given simulation type.

UI Command: None.

Syntax: obj.ScrGetUniqueSimulatioName(<simType>)

Parameters: BSTR simType ("ac", "dc", "eigen", "ff", "nf", "syz", or "hfss_syz")

Return Value: BSTR uniqueSimName

VB Example: obj.ScrGetUniqueSimulationName("syz")

IPY Example: oDoc.ScrGetUniqueSimulationName('nf')

ScrImportAnf
Imports a specified Ansys Neutral File (*.anf)

UI Command: Import > ANF.

Syntax: obj.ScrImportAnf(<anfBstr>)

Parameters: BSTR anfBstr (file path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrImportAnf("C:/anfFiles/design1.anf")

IPY Example: oDoc.ScrImportAnf('C:/anfFiles/design1.anf')
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ScrImportCapacitorDeratingTable
Assigns capacitor derating attributes and opens modified SIwave file.

UI Command: Simulation >Options. Under DC Bias, click Open.

Syntax:
obj.ScrImportCapacitorDeratingTable
(<bDeratingTablePath>, <errors>)

Parameters:
BSTR bDeratingTablePath

ARRAY errors

Return Value:
INT number of capacitors in the derating file that could not be found in the
design.

l -1 – Failure

VB Example:
obj.ScrImportCapacitorDeratingTable
(objShell.CurrentDirectory + "\derating_
table.csv",errors)

IPY Example:
oDoc.ScrImportCapacitorDeratingTable
('C:/csvfiles/derating_table.csv','errors')

ScrImportComponentFile
Imports a specified component file (*.cmp)

UI Command: Import > Component File.

Syntax: obj.ScrImportComponentFile(<cmpBstr>)

Parameters: BSTR cmpBstr (file path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrImportComponentFile
("C:/ComponentFiles/design1.cmp")

IPY Example:
oDoc.ScrImportComponentFile
('C:/ComponentFiles/design1.cmp')
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ScrImportComponentMapFile
Imports a specified component mapping file (*.cmp)

UI Command: Import > Component File.

Syntax: obj.ScrImportComponentMapFile(<fileName>)

Parameters: BSTR fileName (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrImportComponentMapFile
("C:/ComponentFiles/design1.cmp")

IPY Example:
oDoc.ScrImportComponentMapFile
('C:/ComponentFiles/design1.cmp')
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ScrImportCpaSimulationOptions
Loads an SIwave Simulation Settings file (*.sws).

UI Command: Click Simulation. From the CPA area, selectOptions. From the options
window, click Import Settings.

Syntax: obj.ScrImportCpaSimulationOptions(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

Dim app, doc, outcome, objShell

Set objShell = WScript.CreateObject
("WScript.Shell")

Set app = CreateObject("SIwave.Application.2024.2")

Set doc = app.OpenProject(objShell.CurrentDirectory
+ "\test_project.siw")

doc.ScrImportCpaSimulationOptions
(objShell.CurrentDirectory + "\simulation_
settings.sws")

doc.ScrSaveProjectAs(objShell.CurrentDirectory +
"\test_project_w_new_sim_settings.siw")

IPY Example:
oDoc.ScrImportCpaSimulationOptions('C:/Path/simulation_
settings.sws')
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ScrImportCpmOrPloc
Imports a CPM or PLOC file.

UI Command: Import > Ansys CPM/PLOC File.

Syntax:
obj.ScrImportCpmOrPloc(<plocFileName>, <partName>,
<refName>, <controlFileName>)

Parameters:

BSTR plocFileName (can also be CPM file name)

BSTR partName

BSTR refName (Reference Designator)

BSTR controlFileName (containing keywords listed below; for auto
connection, use empty string)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrImportCpmOrPloc
("C:/SAMPLEFILES/cpmfile.cpm","CSP_BGA","BGA","")

IPY Example:
oDoc.ScrImportCpmOrPloc
('C:/SAMPLEFILES/cpmfile.cpm','CSP_BGA','BGA','')

Option Keywords and Example Values
DieCenterX -149.997058

DieCenterY 484.129583

FlipDie TRUE

RotationAngle 0

ScalingFactor 0.9

Tolerance 0.0

CreatePorts TRUE

CreateSources FALSE
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ScrImportDDXFile
Imports a DDX file; the file's settings are substituted for the active project's settings when the
DDR wizard is run and can be saved to the project afterward.

UI Command: Simulation > DDRwizard > Load Configuration File.

Syntax: obj.ScrImportDDXFile(<filename>)

Parameters: BSTR filename (full file path)

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrImportDDXFile("c:/example_file.ddx")

IPY Example: oDoc.ScrImportDDXFile('c:/example_file.ddx')
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ScrImportEDB
Imports an EDB folder into a new project.

UI Command: Import > Ansys EDB.

Syntax: obj.ScrImportEDB (<folderPath>)

Parameters: BSTR filePath

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrImportEDB "C:/Files/Edb"

IPY Example: oApp.ScrImportEDB('C:/Files/Edb')

ScrImportGDSII
Imports a GDSII file (*.strm, *.gds) into a new project.

UI Command: Import >GDSII.

Syntax: obj.ScrImportGDSII(<filePath>, <controlFilePath>)

Parameters:
BSTR filePath

BSTR controlFilePath (pass an empty string to use the default control file)

Return Value:

INT:

l 0 – Success
l 1 – Failure generating control file
l 2 – Error translating the file

VB Example: obj.ScrImportGDSII "C:/Files/MyProject.gds" ""

IPY Example: oDoc.ScrImportGDSII('C:/Files/MyProject.gds','')
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ScrImportIPC2581
Imports an IPC2581 file, as well as optional RLC part value and XML control files, into a new
project

UI Command: Import > IPC2581. 

Syntax:
obj.ScrImportIPC2581 (<designFile>, <controlFile>,
<partFile>)

Parameters:

BSTR designFile (full path)

BSTR controlFile (full path, use empty string for none)

BSTR partFile (full path, use empty string for none)

Return Value:

INT:

l 0 – Success
l 1 – Error translating the file.
l 2 – Error reading part mapping file.

VB Example:
obj.ScrImportIPC2581 "C:/Files/mydesign.cvg"
"C:/Files/controlfile.xml" "C:/Files/partfile.dat"

IPY Example:
oApp.ScrImportIPC2581('C:/Files/mydesign.cvg',
'C:/Files/controlfile.xml',
'C:/Files/partfile.dat')

ScrImportLayerStackup
Imports a layer stackup file.

UI Command: Import > Layer Stackup.

Syntax: obj.ScrImportLayerStackup(<fileName>)

Parameters: BSTR fileName (full path)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrImportLayerStackup
("C:/StackupFiles/stack1.stk")

IPY Example: oDoc.ScrImportLayerStackup('C:/StackupFiles/stack1.stk')
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ScrImportLayerStackupFile
Imports a layer stackup file.

UI Command: Import > Layer Stackup.

Syntax: obj.ScrImportLayerStackupFile(<fileName>)

Parameters: BSTR fileName (full path)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrImportLayerStackupFile
("C:/StackupFiles/stack1.stk")

IPY Example:
oDoc.ScrImportLayerStackupFile
('C:/StackupFiles/stack1.stk')

ScrImportLayerStackupXML
Imports a layer stackup XML file.

UI Command: Import > Layer Stackup XML.

Syntax: obj.ScrImportLayerStackupXML(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

Dim app, doc, outcome, objShell

Set objShell = WScript.CreateObject
("WScript.Shell")

Set app = CreateObject("SIwave.Application.2024.2")

Set doc = app.OpenProject(objShell.CurrentDirectory
+ "\test_project.siw")

outcome = doc.ScrImportLayerStackupXML
(objShell.CurrentDirectory + "\layer_stackup.xml")

IPY Example:
oDoc.ScrImportLayerStackupXML
('C:/StackupFiles/stack1.xml')
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ScrImportPmap
Imports a *.pmap file to map locally defined capacitor and inductor part names to s-parameter
models from the component library

UI Command: None.

Syntax: obj.ScrImportPmap(<fileName>)

Parameters: BSTR fileName (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrImportPmap ("E:/Files/foo.pmap")

IPY Example: oDoc.ScrImportPmap('C:/Files/foo.pmap')

ScrImportSettingsFile
Loads an SIwave Settings file (*.sef).

UI Command: Import > Settings File.

Syntax: obj.ScrImportSettingsFile(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example: obj.ScrImportSettingsFile "C:/Path/my_settings.sef"

IPY Example: oDoc.ScrImportSettingsFile('C:/Path/my_settings.sef')
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ScrImportSIwaveSimulationOptions
Loads an SIwave Simulation Settings file (*.sws).

UI Command: Click Simulation. From the SIwave area, selectOptions. From the options
window, click Import Settings.

Syntax: obj.ScrImportSIwaveSimulationOptions(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

Dim app, doc, outcome, objShell

Set objShell = WScript.CreateObject
("WScript.Shell")

Set app = CreateObject("SIwave.Application.2024.2")

Set doc = app.OpenProject(objShell.CurrentDirectory
+ "/test_project.siw")

doc.ScrImportSIwaveSimulationOptions
(objShell.CurrentDirectory + "/simulation_
settings.sws")

doc.ScrSaveProjectAs(objShell.CurrentDirectory +
"/test_project_w_new_sim_settings.siw")

IPY Example:
oDoc.ScrImportSIwaveSimulationOptions
('C:/Path/simulation_settings.sws')
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ScrImportXfl
Imports an XFL file.

UI Command: Import > XFL File.

Syntax: obj.ScrImportXfl(<filePath>)

Parameters: BSTR filePath (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

Dim version, doc, outcome

Set app = CreateObject("SIwave.Application.2024.2")

outcome = doc.ScrImportXfl
("C:/Directory/filename.xfl")

doc.ScrSaveProjectAs("C:/Directory/filename.siw")

app.Quit

IPY Example: oDoc.ScrImportXfl('C:/Directory/filename.xfl')

ScrInterpolateSpectrum
Specifies interpolation option for Frequency Sweep, Far Field, or Near Field simulations.

Important: Interpolation is active by default and Ansys recommends not changing this setting.

UI Command:
From the Simulationmenu, click either Compute Frequency Sweep,
Compute Far Field, or Compute Near Field. Then, select or deselect the
Interpolate spectrum at missing frequency points check box .

Syntax: obj.ScrInterpolateSpectrum(<interpolate>)

Parameters: BOOL interpolate

Return Value: None.

VB Example: obj.ScrInterpolateSpectrum True

IPY Example: oDoc.ScrInterpolateSpectrum(True)
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ScrLogMessage
Logs a specified message to the Messages window and to the project *.log file.

UI Command: None.

Syntax: obj.ScrLogMessage(<message>)

Parameters: BSTR message

Return Value: None.

VB Example: obj.LogMessage("This is my message.")

IPY Example: oDoc.LogMessage('This is my message.')

ScrMergeConnectedNets
Merges connected nets in a specified list.

UI Command: None.

Syntax: obj.ScrMergeConnectedNets(<inNetNameList>)

Parameters: ARRAY inNetNameList

Return Value: ARRAY outNetNameList (if no nets are connected, this will be the same as
inNetNameList)

VB Example:

obj.ScrMergeConnectedNets inNetList, outNetList

inNetNameList=Array("NET_1","NET_2")

outNetNameList=obj.ScrMergeConnectedNets
(inNetNameList)

inNetNameList: list of nets to be merged

outNetNameList: list of nets which are resulted
from the merging operation

IPY Example:

inNetNameList = ['NET_1','NET_2']

outNetNameList = obj.ScrMergeConnectedNets
(inNetNameList)
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ScrNetGetLength
Computes the shortest length between a specified source and sink.

UI Command: None.

Syntax:
Dim length = obj.ScrNetGetLength(<netName>,
<sourceName>, <sinkName>)

Parameters:

BSTR netName

BSTR sourceName

BSTR sinkName

Return Value: DOUBLE length (returns 0.0 if net, source, or sink does not exist)

VB Example:
Dim len = obj.ScrNetGetLength("HOT_INS_DIS",
"D1:HOT_INS_DIS:292", "P1:HOT_INS_DIS:E4")

IPY Example:
oDoc.ScrNetGetLength('HOT_INS_DIS', 'D1:HOT_INS_
DIS:292', 'P1:HOT_INS_DIS:E4')

ScrNetIsDisjoint
Checks whether a net is disjoint.

UI Command: None.

Syntax: obj.ScrNetIsDisjoint(<netName>)

Parameters: BSTR netName

Return Value:

BOOL

l 0 – Not Disjoint
l 1 – Disjoint

VB Example: obj.ScrNetIsDisjoint("MY-NET")

IPY Example: oDoc.ScrNetIsDisjoint('MY-NET')
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ScrNetIsSelected
Checks whether a net is selected.

UI Command: None.

Syntax: obj.ScrNetIsSelected(<netName>)

Parameters: BSTR netName

Return Value:

BOOL

l 0 – Not Selected
l 1 – Selected

VB Example: obj.ScrNetIsSelected("MY-NET")

IPY Example: oDoc.ScrNetIsSelected('MY-NET')

ScrNetSeparate
If a net is disjoint, separates it and sets new net names.

UI Command: None.

Syntax: obj.ScrNetSeparate(<netName>)

Parameters: BSTR netName

Return Value: None.

VB Example: obj.ScrNetSeparate("MY-NET")

IPY Example: oDoc.ScrNetSeparate('MY-NET')

ScrNetSetDummy
Sets a specified net to be a dummy net and appends DUMMY_ to the front of the net name.

UI Command: None.

Syntax: obj.ScrNetSetDummy(<netName>)

Parameters: BSTR netName

Return Value: None.

VB Example: obj.ScrNetSetDummy("MY-NET")

IPY Example: oDoc.ScrNetSetDummy('MY-NET')

Script Commands 2-124

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave Scripting Guide

ScrNetSetSelected
Selects or deselects a specified net.

UI Command: None.

Syntax: obj.ScrNetSetSelected(<netName>, <select>)

Parameters:
BSTR netName

BOOL select (1 = select; 0 = deselect)

Return Value: None.

VB Example: obj.ScrNetSetSelected("MY-NET", 1)

IPY Example: oDoc.ScrNetSetSelected('MY-NET', 1)
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ScrPlaceCircuitElement
Attaches a circuit element of the specified type to the design.

The element can be connected between any two points, pins or pin groups.

UI Command: Home > Circuit Elements > Add [Capacitor / Inductor / Resistor / Port /
Voltage Probe / Voltage Source / Current Source].

Syntax:

obj.ScrPlaceCircuitElement(<givenElementName>,
<givenPartName>, <circuitElementType>,
<posTermConnectionType>, <posTermParam1>,
<posTermParam2>, <posTermParam3>,
<refTermConnectionType>, <refTermParam1>,
<refTermParam2>, <refTermParam3>, <capVal>, <indVal>,
<resVal>, <refZRe>, <mag>, <phase>)

Parameters:

BSTR givenElementName (name of circuit element to be created)

BSTR givenPartName (part name of circuit element to be created)

INT circuitElementType (0 = capacitor; 1 = inductor; 2 = resistor; 3 = port; 4 =
current source; 5 = voltage source; 6 = voltage probe)

INTposTermConnectionType (0 = attachment to PIN; 1 = attachment to PIN
GROUP; 2 = attachment at COORDINATES)

BSTR posTermParam1 (partName or x)

BSTR posTermParam2 (refDes or y)

BSTR posTermParam3 (pinName, groupName, or layerName)

INT refTermConnectionType (0 = attachment to PIN; 1 = attachment to PIN
GROUP; 2 = attachment at COORDINATES)

BSTR refTermParam1 (partName or x)

BSTR refTermParam2 (refDes or y)

BSTR refTermParam3 (pinName, groupName, or layerName)

double capVal (capacitance)

double indVal (inductance)

double resVal (resistance)

double refZRe (impedance)

double mag (magnitude)

double phase (phase)
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Attaches a circuit element of the specified type to the design.

The element can be connected between any two points, pins or pin groups.

Use an empty string for any parameters that are not applicable.

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:

' outcome is set to TRUE on success

' Create a Capacitor:

outcome = obj.ScrPlaceCircuitElement "cap_1", "cap_
part", 0, 1, "100354431", "Q3", "pinGrp_4", 1,
"100349132", "U26", "pinGroup_10", 4.7e-9, 2e-11,
3e-3, 0.0, 0.0, 0.0

' Create a Resistor:

outcome = obj.ScrPlaceCircuitElement "res_1", "res_
part", 2, 0, "100354431", "Q3", "2_1", 0,
"100349132", "U26", "HS_1", 50.0, 0.0, 0.0, 0.0,
0.0, 0.0

' Create a Voltage Source:

outcome = obj.ScrPlaceCircuitElement "vs_1", "vs_
part", 5, 0, "100354431", "Q3", "2_1", 0,
"100349132", "U26", "HS_1", 0.0, 0.0, 5e-6, 0.0,
3.0, 180.0

IPY Example:

oDoc.ScrPlaceCircuitElement ('cap_1', 'cap_part',
0, 1, '100354431', 'Q3', 'pinGrp_4', 1,
'100349132', 'U26', 'pinGroup_10', 4.7e-9, 2e-11,
3e-3, 0.0, 0.0, 0.0)
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ScrPlaceCircuitElementsToNearestRefPin
Creates ports or sources connecting to the nearest reference pins of the given reference
terminal net.

UI Command: None.

Syntax:

obj.ScrPlaceCircuitElementsToNearestRefPin
(<circuitElementType <val>, <posPartName>,
<posUnitName>, <posNetName>, <refPartName>,
<refUnitName>, <refNetName>, <newElemList>)

Parameters:

INT circuitElementType (3 = port; 4 = current source; 5 = voltage source)

DOUBLE val

BSTR posPartName

BSTR posUnitName

BSTR posNetName

BSTR refPartName

BSTR refUnitName

BSTR refNetName

ARRAY newElemList

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example:

Dim result, newElemList result =
obj.ScrPlaceCircuitElementsToNearestRefPin(3, 50.0,
"SQFP28X28_208", "U1", "ARBLINK", "SQFP28X28_208",
"U2", "GND", newElemList)

IPY Example:
oDoc.ScrPlaceCircuitElementsToNearestRefPin (3,
50.0, 'SQFP28X28_208', 'U1', 'ARBLINK', 'SQFP28X28_
208', 'U2', 'GND', newElemList)
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ScrPlaceFreqDependentSrc
Creates a frequency dependent source.

UI Command: None.

Syntax:

obj.ScrPlaceFreqDependentSrc(<givenElementName>,
<circuitElementType>, <posTermConnectionType>,
<posTermParam1>, <posTermParam2>, <posTermParam3>,
<refTermConnectionType>, <refTermParam1>,
<refTermParam2>, <refTermParam3>, <filename>)

Parameters:

BSTR givenElementName

INT circuitElementType (4 = current source; 5 = voltage source)

INT posTermConnectionType (0 = pin; 1 = pin group; 2 = coordinate)

BSTR posTermParam1 (part name for pins or pin groups; x coordinate for
coordinate connections)

BSTR posTermParam2 (reference designator for pins or pin groups; y
coordinate for coordinate connections)

BSTR posTermParam3 (pin name or pin group name; ignored for coordinate
connections)

INT refTermConnectionType (0 = pin; 1 = pin group; 2 = coordinate)

BSTR refTermParam1 (part name for pins or pin groups; x coordinate for
coordinate connections)

BSTR refTermParam2 (reference designator for pins or pin groups; y
coordinate for coordinate connections)

BSTR refTermParam3 (pin name or pin group name; ignored for coordinate
connections)

BSTR filename

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
result = doc.ScrPlaceFreqDependentSrc("I1", 4, 2,
"1.0", "1.0", "METAL-1", 2, "2.0", "1.0", "METAL-
1", "e:/SrcFreqData.txt")

IPY Example:
oDoc.ScrPlaceFreqDependentSrc('I1', 4, 2, '1.0',
'1.0', 'METAL-1', 2, '2.0', '1.0', 'METAL-1',
'e:/SrcFreqData.txt')
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ScrPlacePortsAcrossRLCs
Creates ports across specified RLCs.

UI Command: None.

Syntax:
obj.ScrPlacePortsAcrossRLCs(<zref>, <rlcName>,
<rlcType>, <portsCreated>)

Parameters:

DOUBLE zref

BSTR rlcName

BSTR rlcType ('cap' for capacitor; 'ind' for inductor; 'res' for resistor)

ARRAY portsCreated (empty)

Return Value:

ARRAY portsCreated (list of port names)

INT outcome:

l 0 – Success
l 1 – Name or type is an empty string
l 2 – rlcType is invalid
l 3 – Specified RLC could not be found
l 4 – Error filling the array portsCreated

VB Example:

Dim portsCreated()

obj.ScrPlacePortsAcrossRLCs
(50,"C3A3","cap",portsCreated)

IPY Example:

portsCreated=[]

oDoc.ScrPlacePortsAcrossRLCs
(50,'C3A3','cap',portsCreated)
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ScrPlacePortsAtPinsOnSelectedNets
Creates ports with specified impedance for each of the pins found in a specified reference net.

UI Command: None.

Syntax:
obj.ScrPlacePortsAtPinsOnSelectedNets(<zref>,
<refNetName>, <connectToPinGroup>, <portsCreated>)

Parameters:

DOUBLE zref (impedance)

BSTR refNetName (reference net)

BOOL connectToPinGroup

ARRAY portsCreated (empty)

Return Value:

ARRAY portsCreated (filled)

INT:

l 0 – Success
l Else – Failure

VB Example:

Dim portsCreated()

obj.ScrPlacePortsAtPinsOnSelectedNets(50.0, "MY_
NET", True, portsCreated)

IPY Example:

portsCreated = []

oDoc.ScrPlacePortsAtPinsOnSelectedNets(50.0, 'MY_
NET', 1, portsCreated)
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ScrPlacePortsAtPinsOnSelectedNetsExcludePart
Creates ports between pins on the selected nets and the reference net unless the pins belong
to the specified part.

UI Command: None.

Syntax:
obj.ScrPlacePortsAtPinsOnSelectedNetsExcludePart
(<zref>, <refNetName>, <partName>, <refDes>,
<connectToPinGroup>, <portsCreated>)

Parameters:

DOUBLE zref

BSTR refNetName

BSTR partName

BSTR refDes

BOOL connectToPinGroup

ARRAY portsCreated (empty)

Return Value:

ARRAY portsCreated (filled)

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrPlacePortsAtPinsOnSelectedNetsExcludePart
(50.0, "GND", "T1_A", "U1", false, ports)

IPY Example:
oDoc.ScrPlacePortsAtPinsOnSelectedNetsExcludePart
(50.0, 'GND', 'T1_A', 'U1', false, ports)
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ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut
Creates ports between pins on the selected nets and the reference net while outputting the port
names and pin names.

UI Command: None.

Syntax:
obj.ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut
(<zref>, <refNetName>, <connectToPinGroup>,
<portsCreated>, <posPinNames>, <refPinNames>)

Parameters:

DOUBLE zref

BSTR refNetName

BOOL connectToPinGroup (True = connect; False = do not connect)

ARRAY portsCreated (empty)

ARRAY posPinNames (empty)

ARRAY refPinNames (empty)

Return Value:

ARRAY portsCreated (filled)

ARRAY posPinNames (filled)

ARRAY refPinNames (filled)

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut
(50.0, "GND", false, ports, posPins, refPins)

IPY Example:
oDoc.ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut
(50.0, 'GND', false, ports, posPins, refPins)
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ScrPlotResModeVoltageDiff
Generates voltage difference surface plots for the specified resonant mode simulation.

Note: A layer pair can be specified and, if present, will restrict the voltage difference computation to just
these two layers. If the layer pair is omitted, plots will be generated for all possible layer pair
combinations.

UI Command: None.

Syntax:
obj.ScrPlotResModeVoltageDiff(<resonantSimName>,
<layerA>, <layerB>)

Parameters:

BSTR resonantSimName

BSTR layerA

BSTR layerB

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrPlotResModeVoltageDiff("Resonant Sim 1",
"SURFACE", "INNER1" )

IPY Example:
oDoc.ScrPlotResModeVoltageDiff('Resonant Sim 1',
'SURFACE', 'INNER1')

ScrPreserveNetsGivenInFile
Deletes all nets except those specified in a text file.

Note: The file should contain net names in quotation marks.

UI Command: None.

Syntax: obj.ScrPreserveNetsGivenInFile(<fileName>)

Parameters: BSTR fileName (full path)

Return Value: None.

VB Example:
obj.ScrPreserveNetsGivenInFile("C:/My
Files/nets.txt")

IPY Example:
oDoc.ScrPreserveNetsGivenInFile('C:/My
Files/nets.txt')
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ScrReadDCLoopResInfo
Given the name of an SIwave DC simulation, exports a list of sources and a corresponding list
of loop resistance values.

UI Command: Results > DC IR Drop > Loop Resistance Info.

Syntax:
obj.ScrReadDCLoopResInfo(<simName>, <sourceNames>,
<loopResData>)

Parameters:

BSTR simName

ARRAY sourceNames (empty)

ARRAY loopResData (empty)

Return Value:

ARRAY sourceNames (filled)

ARRAY loopResData (filled)

INT:

l 0 – Success
l Else – Failure

VB Example:

Dim sourceNames()

Dim loopResData()

obj.ScrReadDCLoopResInfo("DC IR Sim 1",
sourceNames, loopResData)

IPY Example:

sourceNames = []

loopResData = []

oDoc.ScrReadDCLoopResInfo('DC IR Sim 1',
sourceNames, loopResData)

ScrRestoreResonantModeMinFreq
Restores the minimum suggested resonant mode frequency.

UI Command: Simulation > Compute Resonant Modes. Click Restore Recommended
Minimum Frequency.

Syntax: obj.ScrRestoreResonantModeMinFreq()

Parameters: None.

Return Value: None.

VB Example: obj.ScrRestoreResonantModeMinFreq()

IPY Example: oDoc.ScrRestoreResonantModeMinFreq()
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ScrRestoreSIwaveDCGeometryProcessingDefaultValues
Restores the default DC geometry processing values.

UI Command:

From the Simulation tab > SIwave area, selectOptions to open the SIwave
Options window. Navigate to the DC Advanced tab, then click Restore Defaults
adjacent to any/all of the three parameters at the top of the window (i.e., Ignore
geometry smaller than, Ignore voids smaller than, and/or Snap vertices
separated by less than).

Syntax: obj.ScrRestoreSIwaveDCGeometryProcessingDefaultValues()

Parameters: None.

Return Value: None.

VB Example:
obj.ScrRestoreSIwaveDCGeometryProcessingDefaultValues
()

IPY Example:
oDoc.ScrRestoreSIwaveDCGeometryProcessingDefaultValues
()

ScrRestoreSIwaveSIPIGeometryProcessingDefaultValues
Restores the default SI/PI geometry processing values.

UI Command:

From the Simulation tab > SIwave area, selectOptions to open the SIwave Options
window. Navigate to the SI/PI Advanced tab, then click Restore Defaults adjacent to
any/all of the four parameters in theGeometry Processing area (i.e., Do not mesh
voids smaller than, Explicitly mesh pads larger than, Ignore planes smaller
than, and/or Snap vertices separated by less than).

Syntax: obj.ScrRestoreSIwaveSIPIGeometryProcessingDefaultValues()

Parameters: None.

Return Value: None.

VB Example:
obj.ScrRestoreSIwaveSIPIGeometryProcessingDefaultValues
()

IPY Example:
oDoc.ScrRestoreSIwaveSIPIGeometryProcessingDefaultValues
()

ScrRunDcSimulation
Runs a DC IR simulation.

UI Command: Simulation > Compute DC IR.

Syntax: obj.ScrRunDcSimulation(<reprocessGeom>)

Parameters: INT reprocessGeom (1 = runs the simulation; 0 = sets up the simulation but
does not run it)
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Runs a DC IR simulation.

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrRunDcSimulation(1)

IPY Example: oDoc.ScrRunDcSimulation(1)

ScrRunDDRWizard
Runs the DDR wizard using the active project's current settings.

UI Command: Simulation > DDRwizard.

Syntax: obj.ScrRunDDRWizard()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrRunDDRWizard()

IPY Example: oDoc.ScrRunDDRWizard()

ScrRunFarFieldSimulation
Runs a Far Field simulation.

UI Command: Simulation > Compute Far Field.

Syntax: obj.ScrRunFarFieldSimulation()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrRunFarFieldSimulation()

IPY Example: oDoc.ScrRunFarFieldSimulation()

ScrRunFrequencySweepSimulation
Runs a Frequency Sweep simulation.

UI Command: Simulation > Compute Frequency Sweeps.

Syntax: obj.ScrRunFrequencySweepSimulation()
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Runs a Frequency Sweep simulation.

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrRunFrequencySweepSimulation()

IPY Example: oDoc.ScrRunFrequencySweepSimulation()

ScrRunIcepakSimulation
Runs an Icepak simulation.

UI Command: Simulation > Icepak.

Syntax: obj.ScrRunIcepakSimulation(<icepakSimName>, <dcSimName>)

Parameters:
BSTR icepakSimName

BSTR dcSimName

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrRunIcepakSimulation("Icepak 4", "DC IR Sim
1")

IPY Example: oDoc.ScrRunIcepakSimulation('Icepak 4', 'DC IR Sim 1')

ScrRunInducedVoltageSimulation
Runs a Plane Wave Induced Voltage simulation for one frequency with a single incident wave.

UI Command: Simulation > Compute Induced Voltage.

Syntax:
obj.ScrRunInducedVoltageSimulation(<freq>, <phi>,
<theta>, <e0_phi>, <e0_theta>, <magnitude>)

Parameters:

DOUBLE freq

DOUBLE phi (for incident vector in spherical system)

DOUBLE theta (for incident vector in spherical system)

DOUBLE e0_phi (for polarization vector in XY cartesian system on the
orthogonal plane of the incident vector)

DOUBLE e0_theta (for polarization vector in XY cartesian system on the
orthogonal plane of the incident vector)

DOUBLE magnitude
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Runs a Plane Wave Induced Voltage simulation for one frequency with a single incident wave.

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrRunInducedVoltageSimulation(1500000, 10, 45,
1, 3, 1)

IPY Example:
oDoc.ScrRunInducedVoltageSimulation(1500000, 10, 45, 1,
3, 1)

ScrRunNearFieldSimulation

Note:

Use after ScrSetNearFieldExportDataPath.

Runs a Near Field simulation.

UI Command: Simulation > Compute Near Field.

Syntax: obj.ScrRunNearFieldSimulation(<freq>, <computeH>)

Parameters:
DOUBLE freq(uency)

INT computeH (obsolete variable; use either 0 or 1)

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrRunNearFieldSimulation(5.0, 1)

IPY Example: oDoc.ScrRunNearFieldSimulation(5.0, 0)

ScrRunResonantModeSimulation
Runs a Resonant Modes simulation.

UI Command: Simulation > Compute Resonant Modes.

Syntax: obj.ScrRunResonantModeSimulation()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrRunResonantModeSimulation()

IPY Example: oDoc.ScrRunResonantModeSimulation()
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ScrRunSimulation
Runs the specified simulation.

UI Command: Simulation > [Simulation Type].

Syntax: obj.ScrRunSimulation(<simType>, <simName>)

Parameters:

BSTR simType (choose from: "ac", "dc", "ddrwizard", "eigen", "ff", "nf", "psi_
ac", "psi_syz", "syz", "hfss_syz", "pdn", "cpa", "icepak", "iv", "emi_scan", "em_
mttf", "z0_scan", "crosstalk_scan", "td_crosstalk_scan")

BSTR simName

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrRunSimulation("syz", "SYZ Sweep 1" )

IPY Example: oDoc.ScrRunSimulation('syz', 'SYZ Sweep 1')

ScrRunSpiceSubcktSimulation
Computes Spice Subcircuit based on a previously run SYZ sweep.

UI Command: Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit.

Syntax: obj.ScrRunSpiceSubcktSimulation()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrRunSpiceSubcktSimulation()

IPY Example: oDoc.ScrRunSpiceSubcktSimulation()

ScrRunSyzParameterSimulation
Computes an SYZ sweep.

UI Command: Simulation > Compute SYZ Parameters.

Syntax: obj.ScrRunSyzParameterSimulation()

Parameters: None.

Return Value:

INT:

l 0 – Success
l Else – Failure
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Computes an SYZ sweep.

VB Example: obj.ScrRunSyzParameterSimulation()

IPY Example: oDoc.ScrRunSyzParameterSimulation()

ScrRunValidationCheck
Runs a Validation Check on the current project.

UI Command: Tools > Validation Check.

Syntax: obj.ScrRunValidationCheck

Parameters: None.

Return Value: ARRAY results (number of errors, number of warnings)

VB Example: obj.ScrRunValidationCheck()

IPY Example: oDoc.ScrRunValidationCheck()
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ScrRunValidationCheckWithOptions
Runs a Validation Check using specified parameters.

UI Command: Tools > Validation Check.

Syntax:
obj.ScrRunValidationCheckWithOption (<optionArray>,
<simType>)

Parameters:

ARRAY optionArray (0 - deselects an option, 1 - selects an option)

l Self-Intersecting Polygons
l Disjoint Nets (Floating Nodes)
l DC-Short Errors
l Identical/Overlapping Vias
l Bondwire Collisions
l Illegal Bondwire Connections
l Misalignments
l Less Than Two Terminals

INT simType

l 0 – No Associated Simulation
l 1 – Resonant Modes
l 2 – Frequency Sweep
l 3 – SYZ Parameters
l 4 – Far Field
l 5 – Near Field
l 6 – DC Current/Voltage
l 7 – PSI AC or SYZ
l 8 – 3D Export
l 9 – CPA Solution
l 10 – Impedance/Crosstalk Scan

Return Value: None.

VB Example:

dim optionArray

optionArray=Array("1","1","1","1","1","0","1","0")

obj.ScrRunValidationCheckWithOptions
(optionArray,"3")

IPY Example:
oDoc.ScrRunValidationCheckWithOptions
(['1','1','1','1','1','0','1','0'],'3')
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ScrSanitizeLayout
Runs the Sanitize Layout operation on all Power/Ground nets in the project.

UI Command: Tools > Sanitize Layout.

Syntax: obj.ScrSanitizeLayout()

Parameters: None.

Return Value: None.

VB Example: obj.ScrSanitizeLayout()

IPY Example: oDoc.ScrSanitizeLayout()

ScrSanitizeNets
Runs the Sanitize Layout operation on specified nets.

UI Command: Tools > Sanitize Layout.

Syntax: obj.ScrSanitizeNets(<netNameList>)

Parameters: ARRAY netNameList (containing strings)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:

dim netNameList(2)

netNameList(0) = "NET-1"

netNameList(1) = "NET-2"

netNameList(2) = "NET-3"

outcome = obj.ScrSanitizeNets(netNameList)

IPY Example: oDoc.ScrSanitizeNets(['NET-1','NET-2','NET-3'])
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ScrSaveProjectAs
Saves the current project under a different file name.

UI Command: File > Save As.

Syntax: obj.ScrSaveProjectAs(<projName>)

Parameters: BSTR projName (without file extension)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSaveProjectAs
("C:/Users/Ansys/Documents/Ansys/pcb1")

IPY Example:
oDoc.ScrSaveProjectAs
('C:/Users/Ansys/Documents/Ansys/pcb1')

ScrSaveSimulationMessages
Saves messages for a specified simulation in a specified folder.

UI Command: None.

Syntax: obj.ScrSaveSimulationMessages(<simName>,<outFilePath>)

Parameters:
BSTR simName

BSTR outFilePath

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSaveSimulationMessages("Sweep1",
"C:/FilePath/")

IPY Example: oDoc.ScrSaveSimulationMessages('Sweep1','C:/FilePath/')

ScrSaveToPngFile
Saves the current modeling workspace as an image file (*.png).

UI Command: None.

Syntax: obj.ScrSaveToPngFile(<fileName>)

Parameters: BSTR fileName (full path with extension)

Return Value: None.

VB Example: obj.ScrSaveToPngFile("D:/capture.png")

IPY Example: oDoc.ScrSaveToPngFile('D:/capture.png')
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ScrSelectDcConnectedNets
Selects all nets and RLCs which form a connection to the specified net.

UI Command: None.

Syntax: obj.ScrSelectDcConnectedNets(<netNameList>)

Parameters: ARRAY netNameList

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

dim netNameList

netNameList(0)="VCC"

netNameList(1)="GND"

netNameList(2)="Heg"

netNameList(3)="NET-1"

netNameList(4)="NET-2"

netNameList(5)="PWR"

outcome = obj.ScrSelectDcConnectedNets(netNameList)

IPY Example:
oDoc.ScrSelectDcConnectedNets
(['VCC','GND','Heq','NET-1','NET-2','PWR'])

ScrSelectNet
Selects or deselects a specified net.

UI Command: None.

Syntax: obj.ScrSelectNet(<netName>,<select>)

Parameters:
BSTR netName

INT select (1 selects the net; 0 deselects it)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSelectNet("GND", 1)

IPY Example: oDoc.ScrSelectNet('GND', 1)
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ScrSelectNetsBetweenComponents
Selects all Power/Ground nets and RLCs that form a connection between the specified
components.

UI Command: None.

Syntax:
obj.ScrSelectNetsBetweenComponents(<partname1>,
<refDes1>, <partname2>, <refDes2>)

Parameters:

BSTR partname1

BSTR refDes1

BSTR partname2

BSTR refDes2

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSelectNetsBetweenComponents("288DIMMDDR4_
EDGE_CONN-BASE", "J1", "DDR4_X4_FBGA78-10X13,,",
"U1")

IPY Example:
oDoc.ScrSelectNetsBetweenComponents('288DIMMDDR4_
EDGE_CONN-BASE', 'J1', 'DDR4_X4_FBGA78-10X13,,',
'U1')

ScrSelectNetsBetweenNets
Selects all nets and RLCs that form a connection between the specified nets.

UI Command: None.

Syntax: obj.ScrSelectNetsBetweenNets(<net1>, <net2>)

Parameters:
BSTR net1

BSTR net2

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSelectNetsBetweenNets("VDD", "GND")

IPY Example: oDoc.ScrSelectNetsBetweenNets('VDD', 'GND')
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ScrSeparateDisjointNets
Separates all electrically disjoint nets into independent nets.

UI Command: None.

Syntax: obj.ScrSeparateDisjointNets()

Parameters: None.

Return Value: INT numSeparatedNets

VB Example: obj.ScrSeparateDisjointNets()

IPY Example: oDoc.ScrSeparateDisjointNets()

ScrSet4PtBwProfile
Assigns a 4 point bondwire profile to all bondwires of a given model.

UI Command: None.

Syntax:
obj.ScrSet4PtBwProfile(<modelName>, <h1>, <h2>,
<radius>)

Parameters:

BSTR modelName

DOUBLE h1

DOUBLE h2

DOUBLE radius

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSet4PtBwProfile("WB_PROFILE_1", 100, 200,
20)

IPY Example:
oDoc.ScrSet4PtBwProfile('WB_PROFILE_1', 100, 200,
20)
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ScrSet5PtBwProfile
Assigns a 5 point bondwire profile to all bondwires of a given model.

UI Command: None.

Syntax:
obj.ScrSet5PtBwProfile(<modelName>, <h1>, <h2>,
<radius>, <alpha>, <beta>)

Parameters:

BSTR modelName

DOUBLE h1

DOUBLE h2

DOUBLE radius

DOUBLE alpha

DOUBLE beta

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSet5PtBwProfile("WB_PROFILE_1", 100, 200,
20, 85, 5)

IPY Example:
oDoc.ScrSet5PtBwProfile('WB_PROFILE_1', 100, 200,
20, 85, 5)
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ScrSetAntiPadOnLayer
Adds or changes a given padstack's antipads. Can also be used to delete antipads.

Note: If an antipad already exists, the script alters it. If one does not exist, the script creates one.

UI Command: None.

Syntax:
obj.ScrSetAntiPadOnLayer(<padstackName>,
<layerName>, <shapeName>, <widthString>,
<heightString>)

Parameters:

BSTR padstackName

layerName

shapeName ("None" to delete an antipad; otherwise, "Circle", "Oblong", or
"Rectangle")

widthString (including unit of measure)

heightString (including unit of measure)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetAntiPadOnLayer("VIA_M1_M2", "METAL-1",
"Rectangle", "0.1cm", "0.1cm")

IPY Example:
oDoc.ScrSetAntiPadOnLayer('VIA_M1_M2', 'METAL-1',
'Rectangle', '0.1cm', '0.1cm')
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ScrSetBwModel
Sets the given model to bondwires

UI Command: None.

Syntax: obj.ScrSetBwModel(<bwIndexArray>, <bwModelName>)

Parameters:
ARRAY bwIndexArray

BSTR bwModelName

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetBwModel bwList, "WB_profile_1"

IPY Example: oDoc.ScrSetBwModel(bwList, 'WB_profile_1')

ScrSetBwSuppLayer
Sets the support layer of given bondwires.

UI Command: None.

Syntax:
obj.ScrSetBwSuppLayer(<bwIndexArray>,
<suppLayerName>)

Parameters:
ARRAY bwIndexArray

BSTR suppLayerName

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetBwSuppLayer bwList, "CU-1"

IPY Example: oDoc.ScrSetBwSuppLayer(bwList, 'CU-1')
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ScrSetBwTermLayer
Sets the termination layer of given bondwires.

UI Command: None.

Syntax:
obj.ScrSetBwTermLayer(<bwIndexArray>,
<termLayerName>)

Parameters:
ARRAY bwIndexArray

BSTR termLayerName

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetBwTermLayer bwList, "WB_loop2"

IPY Example: oDoc.ScrSetBwTermLayer(bwList, 'WB_loop2')
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ScrSetCapacitorDcBiasDeratingSim
Opens Set Capacitor Temperature and DC Bias Voltage window and select simulation for
DC bias derating.

UI Command: Click Simulation >Options > Use bias voltage computed by DC IR
simulation. Select simulation.

Syntax:
obj.ScrSetCapacitorDcBiasDeratingSim
(<simulationName>)

Parameters: BSTR simulationName

Return Value:

INT

l 1 – Failure
l 0 – Success

VB Example:

Set objShell = WScript.CreateObject
("WScript.Shell")

Set app = CreateObject("SIwave.Application.2024.2")

Set doc = app.OpenProject(objShell.CurrentDirectory
+ "\temp_dep_caps1.siw")

' pick DC voltage across caps computed by DC IR sim
named "DC 3"

' outcome == 0 indicates success

' outcome == 1 indicates that specified DC
simulation could not be found in existing results
set

outcome = doc.ScrSetCapacitorDcBiasDeratingSim("DC
3")

doc.ScrSaveProjectAs(objShell.CurrentDirectory +
"\modified_dcsim.siw")

doc.ScrSetCapacitorDcBiasDeratingSim("") ' revert
to user-defined DC bias derating values

doc.ScrSaveProjectAs(objShell.CurrentDirectory +
"\modified_user_def_dc.siw")

app.Quit

IPY Example:
oDoc.ScrSetCapacitorDcBiasDeratingSim('Simulation
Name')
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ScrSetCapacitorTemperatureDeratingSim
Opens Set Capacitor Temperature and DC Bias Voltage window and select simulation for
temperature derating.

UI Command: Click Simulation >Options > Use temperature computed by Icepak
simulation. Select simulation.

Syntax:
obj.ScrSetCapacitorTemperatureDeratingSim
(<simulationName>)

Parameters: BSTR simulationName

Return Value:

INT

l 1 – Failure
l 0 – Success

VB Example:

Set objShell = WScript.CreateObject
("WScript.Shell")

Set app = CreateObject("SIwave.Application.2024.2")

Set doc = app.OpenProject(objShell.CurrentDirectory
+ "\temp_dep_caps1.siw")

' pick temperature at caps computed by Icepak sim
"Icepak Sim 2"

' outcome == 0 indicates success

' outcome == 1 indicates that specified Icepak
simulation could not be found in existing results
set

outcome = doc.ScrSetCapacitorTemperatureDeratingSim
("Icepak Sim 2")

doc.ScrSaveProjectAs(objShell.CurrentDirectory +
"\modified_temp_sim.siw")

doc.ScrSetCapacitorTemperatureDeratingSim("") '
revert to user-defined temperature derating values

doc.ScrSaveProjectAs(objShell.CurrentDirectory +
"\modified_user_def_temps.siw")

app.Quit

IPY Example:
oDoc.ScrSetCapacitorTemperatureDeratingSim
('Simulation Name')
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ScrSetConformalCoatLayers
Introduce or remove conformal coating (a set of dielectric layers on the top and bottom of
every package and PCB in the design).

These layers have a default material of "SolderMask" and a default thickness of 15 microns.

UI Command: None.

Syntax: obj.ScrSetConformalCoatLayers(<setConformalCoat>)

Parameters: INT setConformalCoat (1 = add conformal coat layers, 0 = remove all
conformal coat layers)

Return Value: INT number of layers changed, added, or removed.

VB Example: obj.ScrSetConformalCoatLayers(1)

IPY Example: oDoc.ScrSetConformalCoatLayers(1)

ScrSetCrosstalkScanParameters
Specifies the parameters for running a Crosstalk Scan via ScrRunSimulation.

UI Command: Simulation > Crosstalk Scan > Frequency Domain. Set values for the
solver options.

Syntax:

obj.ScrSetCrosstalkScanParameters
(<FEXTWarningLevel>, <FEXTViolationThreshold>,
<NEXTWarningLevel>, <NEXTViolationThreshold>,
<freq>, <minTraceLengthInMM>)

Parameters:

DOUBLE FEXTWarningLevel

DOUBLE FEXTViolationThreshold

DOUBLE NEXTWarningLevel

DOUBLE NEXTViolationThreshold

DOUBLE freq

DOUBLE minTraceLengthInMM

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetCrosstalkScanParameters(15, 30, 12, 24,
1000000000, 1.2)

IPY Example:
oDoc.ScrSetCrosstalkScanParameters(15, 30, 12, 24,
1000000000, 1.2)
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ScrSetCrossTalkThreshold
Specifies the cross-talk threshold to use when determining which structures are coupled, in
dB.

UI Command: Click Simulation >Options to open the SIwave Options window. Click SI/PI
Advanced tab and enter a value in the Cross-talk threshold box.

Syntax: obj.ScrSetCrossTalkThreshold(<xtalkInDb>)

Parameters: DOUBLE xtalkInDb (specified value MUST be negative)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetCrossTalkThreshold(-60.0)

IPY Example: oDoc.ScrSetCrossTalkThreshold(-60.0)

ScrSetDcMinPlaneAreaToMesh
For DC IR simulations, sets the minimum plane area to be meshed.

UI Command: Simulation >Options > SI/PI Advanced. Enter a value in the Ignore planes
smaller than field.

Syntax:
obj.ScrSetDcMinPlaneAreaToMesh
(<minPlaneAreaToMesh>)

Parameters: BSTRminPlaneAreaToMesh (including unit of measure)

Return Value: None.

VB Example: obj.ScrSetDcMinPlaneAreaToMesh "5669.2mil2"

IPY Example: oDoc.ScrSetDcMinPlaneAreaToMesh('5669.2mil2')

ScrSetDcMinVoidAreaToMesh
For DC IR simulations, sets the minimum void area to be meshed.

UI Command: Simulation >Options > DC Advanced. Enter a value in the Ignore voids
smaller than field.

Syntax:
obj.ScrSetDcMinVoidAreaToMesh
(<dcMinVoidAreaToMesh>)

Parameters: BSTR dcMinVoidAreaToMesh (including unit of measure)

Return Value: None.

VB Example: obj.ScrSetMinVoidAreaToMesh "3199.01mil2"

IPY Example: oDoc.ScrSetDcMinVoidAreaToMesh('3199.01mil2')
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ScrSetDcPowerDataThresholds
For DC IR simulations, sets the minimum thermal cell size and minimum power per cell.

Note: These settings are no longer visible in SIwave, and are only applicable for exporting data
for Icepak in an old format.

UI Command: None.

Syntax:
obj.ScrSetDcPowerDataThresholds
(<minThermCellSizeInUm>,<minPwrLossPerCellInMilliwatts)

Parameters:
DOUBLE minThermCellSizeInUm

DOUBLE minPwrLossPerCellInMilliwatts

Return Value: None.

VB Example: obj.ScrSetDcPowerDataThresholds 12.0, 1.75

IPY Example: oDoc.ScrSetDcPowerDataThresholds(12.0, 1.75)

ScrSetDieElevation
Sets a specified die's elevation.

UI Command: Advanced > Die Stackup.

Syntax: obj.ScrSetDieElevation(<dieName>,<elevation>)

Parameters:
BSTR dieName

DOUBLE elevation

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetDieElevation("DIE_1", 100.0)

IPY Example: oDoc.ScrSetDieElevation('DIE_1', 100.0)
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ScrSetDieThickness
Sets a specified die's thickness.

UI Command: Advanced > Die Stackup.

Syntax: obj.ScrSetDieThickness(<dieName>,<thickness>)

Parameters:
BSTR dieName

DOUBLE thickness

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetDieThickness("DIE_1", 100.0)

IPY Example: oDoc.ScrSetDieThickness('DIE_1', 100.0)
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ScrSetEmiScannerParameters
Sets the parameters for running an EMI scan via ScrRunSimulation.

If this function is not called, the scan runs with the EMI parameters already set in the file.

If none are set, the scan runs using the default "EM Rules" with auto-tagging.

UI Command: Simulation > EMI Scanner.

Syntax:
obj.ScrSetEmiScannerParameters
(<rulesXmlFilenameWithPath>, <rulesProfileIndex>,
<tagsXmlFilenameWithPath>)

Parameters:

BSTR rulesXmlFilenameWithPath (If rulesXmlFilenameWithPath is left an
empty string, rulesProfileIndex is used)

INT rulesProfileIndex, where:

l 0 – Rules file specified by <rulesXmlFilenameWithPath>
l 1 – EM Rules – [install_dir]/config/EMIScanner/Defaults/EM_emsat.xml
l 2 – SI Rules – [install_dir]/config/EMIScanner/Defaults/SI_emsat.xml
l 3 – EM+SI Rules – [install_dir]/config/EMIScanner/Defaults/EM_SI_
emsat.xml

l 4 – Rules (0-100MHz) – [install_dir]/config/EMIScanner/Defaults/EMSAT-
STGprofile-000-100Mb.cfg

l 5 – Rules (100MHz-500MHz) – [install_
dir]/config/EMIScanner/Defaults/EMSAT-STGprofile-100-500Mb.cfg

l 6 – Rules (500MHz-1000MHz) – [install_
dir]/config/EMIScanner/Defaults/EMSAT-STGprofile-500-1000Mb.cfg

l 7 – Rules (1GHz+) – [install_dir]/config/EMIScanner/Defaults/EMSAT-
STGprofile-1Gb-and-higher.cfg

BSTR tagsXmlFilenameWithPath

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetEmiScannerParameters
"C:/Projects/rules.xml", 0, "C:/Projects/tags.tgs"

IPY Example:
oDoc.ScrSetEmiScannerParameters
('C:/Projects/rules.xml', 0,
'C:/Projects/tags.tgs')
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ScrSetEnergyErrorPercentInDcSimulation
For DC IR simulations, sets the minimum void area to be meshed.

UI Command: Simulation >Options > DC Advanced. Enter a value in the Energy Error
field.

Syntax:
obj.ScrSetEnergyErrorPercentInDcSimulation
(<energyErrorPercent>)

Parameters: DOUBLE energyErrorPercent

Return Value: None.

VB Example: obj.ScrSetEnergyErrorPercentInDcSimulation "5.1"

IPY Example: oDoc.ScrSetEnergyErrorPercentInDcSimulation('5.1')

ScrSetExternalExcitations
Directs SIwave to use external (non-linear) excitation files containing current or voltage source
frequency response data.

UI Command:

From the Simulationmenu, click either Compute Frequency Sweep,
Compute Far Field, or Compute Near Field. Select the Use sources
defined in an external file check box and specify the source of the
excitations.

Syntax: obj.ScrSetExternalExcitations(<filePath>)

Parameters: BSTR filePath

Return Value: None.

VB Example:

' set current/voltage sources to reference I(f)/V
(f) data in "C:/sources.txt"

obj.ScrSetExternalExcitations "C:/sources.txt"

' set current/voltage sources back to linear
magnitude/phase values

obj.ScrSetExternalExcitations "

IPY Example: oDoc.ScrSetExternalExcitations('C:/sources.txt')
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ScrSetFarFieldSimOptions
Sets options for Far Fields simulations.

UI Command: Simulation > Compute Far Field. Set Phi and Theta options.

Syntax:
obj.ScrSetFarFieldSimOptions(<phiStart>, <phiStop>,
<phiStepSize>, <thetaStart>, <thetaStop>,
<thetaStepSize>)

Parameters:

DOUBLE phiStart

DOUBLE phiStop

INT phiStepSize

DOUBLE thetaStart

DOUBLE thetaStop

INT thetaStepSize

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetFarFieldSimOptions(0, 360, 10, 0, 180,
10)

IPY Example:
oDoc.ScrSetFarFieldSimOptions(0, 360, 10, 0, 180,
10)

ScrSetFwsColFitOptions
Controls FWS Sub-circuit column fitting options.

UI Command:
Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Specify Column
Fitting options.

Syntax: obj.ScrSetFwsColFitOptions(<option>)

Parameters:

INT option, where:

l 0 – One matrix entry at a time
l 1 – One matrix column at a time

Return Value: None.

VB Example: obj.ScrSetFwsColFitOptions 0

IPY Example: oDoc.ScrSetFwsColFitOptions(0)
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ScrSetFwsLaunchDesignerNexxim
After computing a Full Wave SPICE Subcircuit, opens the results in Electronics Desktop.

UI Command: None.

Syntax: obj.ScrSetFwsLaunchDesignerNexxim(<launch>)

Parameters: INT launch (1 = launch; 0 = do not launch)

Return Value: None.

VB Example: obj.ScrSetFwsLaunchDesignerNexxim 1

IPY Example: oDoc.ScrSetFwsLaunchDesignerNexxim(1)

ScrSetFwsPassivityAlg
Controls FWS Sub-circuit Full Wave SPICE export passivity options.

UI Command:
Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Select passivity
enforcement options.

Syntax: obj.ScrSetFwsPassivityAlg(<option>)

Parameters:

INT option, where:

l 0 – Do not enforce passivity
l 1 – Passivity enforcement through convex optimization
l 2 – Passivity enforcement by perturbation
l 3 – Passivity enforcement by IFPV (iterative fitting of passivity violations)

Return Value: None.

VB Example: obj.ScrSetFwsPassivityAlg 0

IPY Example: oDoc.ScrSetFwsPassivityAlg(0)
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ScrSetFwsPortRefZ
For Full Wave SPICE, sets whether port reference impedances are to be renormalized and, if
so, specifies reference impedance.

UI Command:

Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Enter a value in
the Renormalize all S-parameters to __ ohms before generating model
option.

Syntax: obj.ScrSetFwsPortRefZ(renormalize, refZ)

Parameters:

BOOL renormalize, where:

l TRUE – Renormalize
l FALSE – Do not renormalize

DOUBLE refZ (reference impedence, value ignored if renormalize = FALSE)

Return Value: None.

VB Example: obj.ScrSetFwsPortRefZ(True, 75.0)

IPY Example: oDoc.ScrSetFwsPortRefZ(True, 75.0)

ScrSetFwsPzOptions
For Full Wave SPICE, sets pole/zero fitting options.

UI Command:

Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Select the options
in the HSPICE/Spectre Pole/Zero Fitting Options box for the fitting error
tolerance, and maximum pole/zero order.

Syntax: obj.ScrSetFwsPzOptions(<fitError>, <maxOrder>)

Parameters:
DOUBLE fitError (fitting error tolerance)

INT maxOrder (maximum pole/zero order)

Return Value: None.

VB Example: obj.ScrSetFwsPzOptions(0.001, 200)

IPY Example: oDoc.ScrSetFwsPzOptions(0.001, 200)

Script Commands 2-162

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave Scripting Guide

ScrSetFwsSsfAlg
For Full Wave SPICE, specifies State-Space Fitting Algorithm options.

UI Command:
Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Specify State-
Space Fitting Algorithm options.

Syntax: obj.ScrSetFwsSsfAlg(<algorithm>)

Parameters:

INT algorithm, where:

l 0 – TWS
l 1 – Iterative Rational Function

Return Value: None.

VB Example: obj.ScrSetFwsSsfAlg 0

IPY Example: oDoc.ScrSetFwsSsfAlg(0)

ScrSetFwsSubcktFormat
Specifies the full-wave Spice subcircuit format for export.

UI Command:
Click Results > SYZ > [Simulation Name] > Compute FWS Sub-circuit to
open the Compute Full Wave SPICE Subcircuit window. Select the Spice
subcircuit format from the Full Wave Spice Subcircuit Format box.

Syntax: obj.ScrSetFwsSubcktFormat(<format>)

Parameters:

INT format, where:

l 0 – HSPICE-compatible format
l 1 – Maxwell Spice compatible format
l 2 – PSPICE compatible format
l 3 – Cadence Spectre compatible format
l 4 – Nexxim S-element format
l 5 – State space model
l 6 – Simplorer model

Return Value: None.

VB Example: obj.ScrSetFwsSubcktFormat 0

IPY Example: oDoc.ScrSetFwsSubcktFormat(0)
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ScrSetFwsUseCommonGround
For full-wave Spice subcircuit generation, specifies whether or not to use a common ground
for all ports.

UI Command:
Click Results > [Simulation Name] > Compute FWS Sub-circuit to open
the Compute Full Wave SPICE Subcircuit window. Select the Use
common ground for Spice output check box.

Syntax: obj.ScrSetFwsUseCommonGround(<useCommonGround>)

Parameters:

BOOL, where:

l FALSE – Do not use common ground.
l TRUE – Use common ground.

Return Value: None.

VB Example: obj.ScrSetFwsUseCommonGround True

IPY Example: oDoc.ScrSetFwsUseCommonGround(True)

ScrSetHFSS3DLayoutSimOptions
Imports simulation settings for an HFSS 3D Layout Simulation.

UI Command: Click Simulation > HFSS 3D Layout. Click Import Settings and select a file.

Syntax: obj.ScrSetHFSS3DLayoutSimOptions(<filename>)

Parameters: BSTR filename (full file path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

' outcome is TRUE on success, FALSE if specified
"filename" does not exist or is not the right
format (this file is most easily generated by
exporting from the HFSS 3D Layout Simulation Setup
window).outcome = obj.ScrSetHFSS3DLayoutSimOptions
( "c:/simsettings.dss" )

IPY Example:
oDoc.ScrSetHFSS3DLayoutSimOptions
('c:/simsettings.dss')

Script Commands 2-164

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave Scripting Guide

ScrSetHpcLicenseType
Sets the HPC license type.

Important: Use ScrSetHpcLicenseVendor to choose license vendor.

UI Command: Simulation >Options. On theMultiprocessing tab, select Use
HPC licensing and eitherWorkgroup (formerly 'Pool') or Pack.

Syntax: obj.ScrSetHpcLicenseType(<licenseType>)

Parameters: BSTR licenseType ('workgroup' or 'pack'; case insensitive; use 'mp' to
deselect Use HPC licensing)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetHpcLicenseType "workgroup"

IPY Example: oDoc.ScrSetHpcLicenseType('pack')

ScrSetHpcLicenseVendor
Sets the HPC license vendor.

Important: Use ScrSetHpcLicenseType to choose license type.

UI Command:
Simulation >Options. On theMultiprocessing tab, select Use
HPC licensing and either Use Ansys HPC licenses or Use
legacy Electronics HPC licenses.

Syntax: obj.ScrSetHpcLicenseVendor(<vendor>)

Parameters: BSTR vendor ('ansys' or 'electronics', case insensitive)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetHpcLicenseVendor "Ansys"

IPY Example: oDoc.ScrSetHpcLicenseVendor('Electronics')
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ScrSetIcepakBoardOutlineFidelity
Specifies the minimum edge length when modifying the board outline for export to Icepak. This
minimum edge length is used when discretizing arcs into a series of straight lines and when
simplifying the outline to remove very small edges.

UI Command: None.

Syntax: obj.ScrSetIcepakBoardOutlineFidelity(<distInMM>)

Parameters: DOUBLE distInMM

Return Value:

INT

l 0 – Success
l 1 – Specified distance is too small

VB Example: obj.ScrSetIcepakBoardOutlineFidelity(1.5)

IPY Example: oDoc.ScrSetIcepakBoardOutlineFidelity(1.5)

ScrSetIcepakCabinetDimensions
Configures the cabinet settings for Icepak convection simulations.

UI Command: None.

Syntax:
obj.ScrSetIcepakCabinetDimensions
(<horizPadPercent>, <vertAbovePadPercent>,
<vertBelowPadPercent>)

Parameters:

DOUBLE horizPadPercent

DOUBLE vertAbovePadPercent

DOUBLE vertBelowPadPercent

Return Value:

INT:

l 0 – Success
l 1 – Specified percentages are invalid.

VB Example:
obj.ScrSetIcepakCabinetDimensions(35.0, 125.0,
55.0)

IPY Example:
oDoc.ScrSetIcepakCabinetDimensions(35.0, 125.0,
55.0)
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ScrSetIcepakComponentConfig
Selects a component settings file to use for Icepak convection simulations.

UI Command: None.

Syntax: obj.ScrSetIcepakComponentConfig(<fileName>)

Parameters: BSTR fileName (full file path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetIcepakComponentConfig
("D:/Tests/IcepakScriptTest.pwrd")

IPY Example:
oDoc.ScrSetIcepakComponentConfig
('D:/Tests/IcepakScriptTest.pwrd')

ScrSetIcepakMeshingDetail
Sets the meshing detail level for Icepak simulations.

UI Command: None.

Syntax: obj.ScrSetIcepakMeshingDetail(<meshLevel>)

Parameters: BSTR meshLevel

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrSetIcepakMeshingDetail("basic")

IPY Example: oDoc.ScrSetIcepakMeshingDetail('basic')
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ScrSetIcepakSimReportImageHeight
When generating Icepak reports or Icepak report data in a DC report, specifies the resolution
(in pixels) of the smaller dimension of the images. For designs where the board is wider than it
is tall, this corresponds to the y-resolution of the image.

UI Command: None.

Syntax: obj.ScrSetIcepakSimReportImageHeight(<imgHeight>)

Parameters: LONG imgHeight

Return Value:

BOOL

l 0 – Failure (invalid height)
l 1 – Success

VB Example: obj.ScrSetIcepakSimReportImageHeight(1024)

IPY Example: oDoc.ScrSetIcepakSimReportImageHeight(1024)

ScrSetIcepakTemperatureFile
Specifies an external Icepak solution file (*.sitemp) for use in specifying temperature for a DC
simulation.

UI Command: Simulation > Compute DC IR. Select Import temperature map from
Icepak. Select External .sitemp file. Click Browse and select file.

Syntax: obj.ScrSetIcepakTemperatureFile(<sitempFilename>)

Parameters: BSTR sitempFilename (full file path)

Return Value:

BOOL

l 0 – Failure (file does not exist)
l 1 – Success

VB Example: obj.ScrSetIcepakTemperatureFile("d:/abcd.sitemp")

IPY Example: oDoc.ScrSetIcepakTemperatureFile('d:/abcd.sitemp')

Script Commands 2-168

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave Scripting Guide

ScrSetIcepakThermalEnv
Sets the thermal environment settings to use for Icepak simulations.

UI Command: Simulation > Icepak. Select an appropriate settings.

Syntax:

obj.ScrSetIcepakThermalEnv(<convection>,
<forcedAir>, <topOrAmbientTempC>,
<topOrOverallFlowDir>, <topOrOverallFlowSpeed>,
<bottomTempC>, <bottomFlowDir>, <bottomFlowSpeed>,
<gravVecX>, <gravVecY>, <gravVecZ>)

Parameters:

BOOL convection (TRUE = convection; FALSE = conduction)

BOOL forcedAir (TRUE = forced convection; FALSE = natural convection)

DOUBLE topOrAmbientTempC (temperature above PCB, in Celsius)

BSTR topOrOverallFlowDir (flow direction above PCB)

DOUBLE topOrOverallFlowSpeed (flow speed above PCB)

DOUBLE bottomTempC (temperature below PCB, in Celsius)

BSTR bottomFlowDir (flow direction below PCB)

DOUBLE bottomFlowSpeed (flow speed below PCB)

DOUBLE gravVecX (gravity vector x for natural convection)

DOUBLE gravVecY (gravity vector y for natural convection)

DOUBLE gravVecZ (gravity vector z for natural convection)

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example:
obj.ScrSetIcepakThermalEnv(TRUE, TRUE, 22.3, "+Y",
2.5, 0.0, "", 0.0, 0.0, 0.0, 0.0)

IPY Example:
oDoc.ScrSetIcepakThermalEnv(True, True, 22.3, '+Y',
2.5, 0.0, '', 0.0, 0.0, 0.0, 0.0)
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ScrSetIdealGroundNodeInDcSimulation
For a DC IR simulation, sets the Ideal Ground Node (the precise 0V).

IMPORTANT: This script should be called before running a DC solve using
ScrRunDcSimulation or ScrRunSimulation with tag dc.

UI Command: Simulation > Compute DC IR. Select an ideal ground node.

Syntax:
obj.ScrSetIdealGroundNodeInDcSimulation(<circuit_
element_name>, <node_type_id>)

Parameters:

BSTR circuit_element_name (name of the circuit element in the design on
which the ideal ground is)

INT node_type_id (which terminal of the circuit element is ideal ground),
where:

l 0 – Neither Terminal
l 1 – Negative Terminal
l 2 – Positive Terminal

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetIdealGroundNodeInDcSimulation("VU6", 1)

IPY Example: oDoc.ScrSetIdealGroundNodeInDcSimulation('VU6', 1)
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ScrSetInducedVoltageMultipleIncidenceSpherical
For a Plane Wave Induced Voltage simulation with multiple incident waves specified in
spherical system having a sweep of phi & theta angles and the polarization, specified as either
having 1 on X or 1 on Y or both, on the orthogonal plane of every incidence vector.

IMPORTANT: This script and ScrAppendSweep should be called before running a Plane Wave
Induced Voltage solve using ScrRunSimulation with tag iv.

UI Command: Simulation > Compute Induced Voltage. Specify settings.

Syntax:

obj.ScrSetInducedVoltageMultipleIncidenceSpherical
(<phi_start>, <phi_stop>, <phi_step>, <theta_
start>, <theta_stop>, <theta_step>, <phi_checked>,
<theta_checked>, <save_for_all_angles>,
<Magnitude>)

Parameters:

DOUBLE phi_start (for sweep in phi)

DOUBLE phi_stop (for sweep in phi)

DOUBLE phi_step (for sweep in phi)

DOUBLE theta_start (for sweep in theta)

DOUBLE theta_stop (for sweep in theta)

DOUBLE theta_step (for sweep in theta)

DOUBLE e0_phi (polarization for phi sweep)

DOUBLE e0_theta (polarization for theta sweep)

INT save_for_all_angles (1 = save; 0 = do not save)

DOUBLE magnitude

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

obj.ScrClearAllSweeps "iv"

obj.ScrAppendSweep "iv", 1500000, 3000000, 8, false

obj.ScrAppendSweep "iv", 3000000, 5000000, 2, true

obj.ScrSetInducedVoltageMultipleIncidenceSpherical
0, 20, 5, 90, 105, 5, 0, 0, 0, 1

obj.ScrRunSimulation "iv", "tstmultiple"

IPY Example:
oDoc.ScrSetInducedVoltageMultipleIncidenceSpherical
(0, 20, 5, 90, 105, 5, 0, 0, 0, 1)
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ScrSetInducedVoltageSingleIncidenceCartesian
For a Plane Wave Induced Voltage simulation with a single incident wave and polarization both
specified in cartesian system on the XYZ plane. The incident wave vector and the polarization
vector should be orthogonal. This is tested by verifying if the dot product of the vectors leads
to zero.

IMPORTANT: This script and ScrAppendSweep should be called before running a Plane Wave
Induced Voltage solve using ScrRunSimulation with tag iv.

UI Command: Simulation > Compute Induced Voltage. Specify settings.

Syntax:
obj.ScrSetInducedVoltageSingleIncidenceCartesian
(<incidence_x>, <incidence_y>, <incidence_z>, <e0_
x>, <e0_y>, <e0_z>, <e0_magnitude>)

Parameters:

DOUBLE incidence_x (for incident vector)

DOUBLE incidence_y (for incident vector)

DOUBLE incidence_z (for incident vector)

DOUBLE e0_x (for polarization vector)

DOUBLE e0_y (for polarization vector)

DOUBLE e0_z (for polarization vector)

DOUBLE e0_magnitude

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

obj.ScrClearAllSweeps "iv"

obj.ScrAppendSweep "iv", 1500000, 3000000, 8, false

obj.ScrAppendSweep "iv", 3000000, 5000000, 2, true

obj.ScrSetInducedVoltageSingleIncidenceCartesian 1,
0, 0, 0, 1, 1, 1

obj.ScrRunSimulation "iv", "tstcartesian"

IPY Example:
oDoc.ScrSetInducedVoltageSingleIncidenceCartesian
(1, 0, 0, 0, 1, 1, 1)
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ScrSetInducedVoltageSingleIncidenceSpherical
For a Plane Wave Induced Voltage simulation with a single incident wave specified in spherical
system (degrees) and polarization specified as a XY vector on the orthogonal plane of
incidence vector.

IMPORTANT: This script and ScrAppendSweep should be called before running a Plane Wave
Induced Voltage solve using ScrRunSimulation with tag iv.

UI Command: Simulation > Compute Induced Voltage. Specify settings.

Syntax:
obj.ScrSetInducedVoltageSingleIncidenceSpherical
(<phi>, <theta>, <e0_phi>, <e0_theta>, <e0_
magnitude>)

Parameters:

DOUBLE phi (for incident vector)

DOUBLE theta (for incident vector)

DOUBLE e0_phi (for polarization vector)

DOUBLE e0_theta (for polarization vector)

DOUBLE e0_magnitude

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

obj.ScrClearAllSweeps "iv"

obj.ScrAppendSweep "iv", 1500000, 3000000, 8, false

obj.ScrAppendSweep "iv", 3000000, 5000000, 2, true

obj.ScrSetInducedVoltageSingleIncidenceSpherical
10, 45, 1, 3, 1

obj.ScrRunSimulation "iv", "tstspherical"

IPY Example:
oDoc.ScrSetInducedVoltageSingleIncidenceSpherical
(10, 45, 1, 3, 1)
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ScrSetInfiniteGroundPlaneLocation
Introduces an infinite ground plane the specified distance below the bottom layer.

UI Command: Simulation >Options > SI/PI Advanced. Select Introduce infinite ground
plane and enter a value in mils.

Syntax: obj.ScrSetInfiniteGroundPlaneLocation(<elev>)

Parameters: DOUBLE elev

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetInfiniteGroundPlaneLocation "3.1"

IPY Example: oDoc.ScrSetInfiniteGroundPlaneLocation('3.1')

ScrSetLayerMaterial
Assigns a specified material to a specified layer.

UI Command: Home > Layer stackup Editor. Click Edit Layer Properties. Select a
material from theMaterial drop-down menu.

Syntax:
obj.ScrSetLayerMaterial(<layerNameBstr>,
<layerMaterialBstr>)

Parameters:
BSTR layerNameBstr

BSTR layerMaterialBstr

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

' outcome is TRUE on success, FALSE if specified
layer or material could not be located

outcome = obj.ScrSetLayerMaterial ( "SURFACE",
"copper" )

IPY Example: oDoc.ScrSetLayerMaterial('SURFACE', 'copper')
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ScrSetLayerThickness
Changes the thickness of a specified layer. The thickness value must be in the project's
underlying length units.

UI Command: Home > Layer stackup Editor. Click Edit Layer Properties. Enter the
thickness in the Thickness field.

Syntax:
obj.ScrSetLayerThickness(<layerNameBstr>,
<thickness>, <redraw>)

Parameters:

BSTR layerNameBstr

DOUBLE thickness

BOOL redraw (TRUE = redraw; FALSE = do not redraw)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

' set the thickness of layer "SURFACE" to 35um
(assuming the database units are mm)

' outcome is TRUE on success, FALSE if specified
layer could not be located

outcome = obj.ScrSetLayerThickness( "SURFACE",
0.035, True )

IPY Example: oDoc.ScrSetLayerThickness('SURFACE', 0.035, True)

ScrSetLayerType
Sets a specified layer's type.

UI Command: Home > Layer stackup Editor. Select the layer you want to update. Then
select a material type from the Type drop-down menu.

Syntax: obj.ScrSetLayerType(<layerName>, <layerTypeIndex>)

Parameters:

BSTR layerName

INT layerTypeIndex, where:

l 0 – Dielectric
l 1 – Metal
l 2 –Wirebond

Return Value: None.

VB Example: obj.ScrSetLayerType("layer name", 1)

IPY Example: oDoc.ScrSetLayerType('layer name', 1)
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ScrSetLayerVisibility
Sets the visibility of the specified layer, or of specific object types on that layer.

UI Command: Select a layer in the Layers Workspace. Turn on visibility for the layer or for
specific object types using the check boxes.

Syntax:
obj.ScrSetLayerVisibility(<layerNameBstr>,
<planeVis>, <traceVis>, <padVis>, <viaVis>,
<cktElemVis>)

Parameters:

BSTR layerNameBstr

BOOL planeVis (TRUE = planes visible; FALSE = planes not visible)

BOOL traceVis (TRUE = traces visible; FALSE = traces not visible)

BOOL padVis (TRUE = pads visible; FALSE = pads not visible)

BOOL viaVis (TRUE = vias visible; FALSE = vias not visible)

BOOL cktElemVis (TRUE = circuit elements visible; FALSE = circuit elements
not visible)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

'Make planes, traces, pads, and vias on layer L1
visible, but not circuit elements'

outcome is TRUE on success, FALSE if specified
layer could not be located.

outcome = obj.ScrSetLayerVisibility( "L1", True,
True, True, True, False)

IPY Example:
oDoc.ScrSetLayerVisibility('L1', True, True, True,
True, False)
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ScrSetLayoutLengthUnit
Sets the layout length unit.

UI Command: None.

Syntax: obj.ScrSetLayoutLengthUnit <unitName>

Parameters: BSTR unitName ("microns", "um", "mils", "mm", "cm", "inches", or "meters")

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetLayoutLengthUnit "um"

IPY Example: oDoc.ScrSetLayoutLengthUnit('um')

ScrSetLocalRefinementPercentInDcSimulation
For a DC IR simulation, sets the local refinement percentage.

UI Command: Simulation >Options > DC Advanced. Enter a value in the Local
Refinement field.

Syntax:
obj.ScrSetLocalRefinementPercentInDcSimulation
(<localRefinePercent>)

Parameters: DOUBLE localRefinePercent

Return Value: None.

VB Example: obj.ScrSetLocalRefinementPercentInDcSimulation 20

IPY Example: oDoc.ScrSetLocalRefinementPercentInDcSimulation(20)

ScrSetLogFreqPointDist
Sets the distribution type for frequency sweeps.

UI Command: None.

Syntax: obj.ScrSetLogFreqPointDist(<flag>)

Parameters: INT flag (1 = log-based frequency distribution; 0 = linear distribution)

Return Value: None.

VB Example: obj.ScrSetLogFreqPointDist 1

IPY Example: oDoc.ScrSetLogFreqPointDist(1)
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ScrSetLowBwProfile
Sets low bondwire profile to all bondwires of a specified model.

UI Command: None.

Syntax:
obj.ScrSetLowBwProfile(<bwModelName>, <h1>, <h2>,
<radius>, <alpha>, <beta>, <units>)

Parameters:

BSTR bwModelName

DOUBLE h1

DOUBLE h2

DOUBLE radius

DOUBLE alpha

DOUBLE beta

BSTR units

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetLowBwProfile "WB_PROFILE_1", 100, 200,
20, 85, 5, "mm"

IPY Example:
oDoc.ScrSetLowBwProfile('WB_PROFILE_1', 100, 200,
20, 85, 5, 'mm')

ScrSetMaxRefinePassesInDcSimulation
Sets the maximum number of mesh refinement passes for DC IR drop simulations.

UI Command:
Simulation > Compute DC IR. ClickOther solver options button and
choose the DC Advanced tab. From the Adaptive Mesh Refinement
Parameters group, type a value in theMaximum Number of Passes box.

Syntax:
obj.ScrSetMaxRefinePassesInDcSimulation
(<maxPasses>)

Parameters: INT maxPasses

Return Value: None.

VB Example: obj.ScrSetMaxRefinePassesInDcSimulation 5

IPY Example: oDoc.ScrSetMaxRefinePassesInDcSimulation(5)
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ScrSetMeshBondwiresInDcSimulation
Sets the Mesh Bondwires setting.

UI Command: Simulation >Options. Click DC Advanced tab and selectMesh Bondwires
check box.

Syntax: obj.ScrSetMeshBondwiresInDcSimulation(<meshBws>)

Parameters: BOOL meshBws (TRUE = mesh bondwires; FALSE = do not mesh bondwires)

Return Value: None.

VB Example: obj.ScrSetMeshBondwiresInDcSimulation True

IPY Example: oDoc.ScrSetMeshBondwiresInDcSimulation(1)

ScrSetMeshViasInDcSimulation
Specifies whether or not to mesh vias during DC IR drop simulations.

UI Command: Simulation > Compute DC IR. ClickOther solver options button and
choose the DC Advanced tab. Select Mesh Vias.

Syntax: obj.ScrSetMeshViasInDcSimulation(<meshVias>)

Parameters: BOOL meshVias (TRUE = mesh vias; FALSE = do not mesh vias)

Return Value: None.

VB Example: obj.ScrSetMeshViasInDcSimulation True

IPY Example: oDoc.ScrSetMeshViasInDcSimulation(True)
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ScrSetMetalLayerFillerMaterial

Assigns a specified filler material to a specified metal layer.

UI Command: Home > Layer Stackup Editor. Select metal layer and change Dielectric
Fill.

Syntax:
obj.ScrSetMetalLayerFillerMaterial(<layerNameBstr>,
<layerFillerMaterialBstr>)

Parameters:
BSTR layerNameBstr

BSTR layerFillerMaterialBstr

Return Value:

BOOL

0 – Failure

1 – Success

VB Example:

' outcome is TRUE on success, FALSE if specified
layer or material could not be located outcome =
obj.ScrSetMetalLayerFillerMaterial("SURFACE", "FR-
4")

IPY Example:
oDoc.ScrSetMetalLayerFillerMaterial('SURFACE', 'FR-
4')

ScrSetMinCutoutArea
Controls the cutout defeaturing area threshold; all cutouts below this value are ignored during
simulations.

This function is not applicable to DC IR drop simulations, during which all salient geometry is
meshed and simulated (no cutouts are defeatured).

UI Command: Simulation >Options. Enter the area threshold in the Do not explicitly
mesh any voids than field.

Syntax: obj.ScrSetMinCutoutArea(<minVoidArea>, <unitsBstr>)

Parameters:
DOUBLE minVoidArea

BSTR unitsBstr

Return Value: None.

VB Example:

'defeature all cutouts less than 10mm2 during
simulations.

obj.ScrSetMinCutoutArea 10, mm

IPY Example: oDoc.ScrSetMinCutoutArea(10, 'mm')
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ScrSetMinPadAreaToMesh
Sets the minimum pad area for meshing.

UI Command: Simulation >Options > SI/PI Advanced. Enter a value in the Explicitly
mesh pads larger than field.

Syntax: obj.ScrSetMinPadAreaToMesh(<minPadAreaToMesh>)

Parameters: BSTRminPadAreaToMesh (including unit of measure)

Return Value: None.

VB Example: obj.ScrSetMinPadAreaToMesh "112000mil2"

IPY Example: oDoc.ScrSetMinPadAreaToMesh('112000mil2')

ScrSetMinPlaneAreaToMesh
Sets the minimum plane area for meshing.

UI Command: Simulation >Options > SI/PI Advanced. Enter a value in the Ignore planes
smaller than field.

Syntax: obj.ScrSetMinPlaneAreaToMesh(<minPlaneAreaToMesh>)

Parameters: BSTRminPlaneAreaToMesh (including unit of measure)

Return Value: None.

VB Example: obj.ScrSetMinPlaneAreaToMesh "5769.2mil2"

IPY Example: oDoc.ScrSetMinPlaneAreaToMesh('5769.2mil2')

ScrSetMinRefinePassesInDcSimulation
Sets the minimum number of mesh refinement passes for DC IR drop simulations.

UI Command:
Simulation > Compute DC Current/Voltage. From the Adaptive Mesh
Refinement Parameters group, type a value in theMinimum Number of
Passes field.

Syntax:
obj.ScrSetMinRefinePassesInDcSimulation
(<minPasses>)

Parameters: INT minPasses

Return Value: None.

VB Example: obj.ScrSetMinRefinePassesInDcSimulation 1

IPY Example: oDoc.ScrSetMinRefinePassesInDcSimulation(1)
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ScrSetNearFieldExportDataPath

For Near Field simulations, sets an export directory for Near Field data in *.and or *.nfd format.

UI Command:
Simulation > Compute Near Field. Beneath the Near Field Solver Options,
area, check the box and navigate to an appropriate directory to save the
exported data.

Syntax: obj.ScrSetNearFieldExportDataPath('[User-selected
directory path]')

Parameters: BSTR export path (output file name with complete path)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetNearFieldExportDataPath("D:/NF_
export.and")

IPY Example:
oDoc.ScrSetNearFieldExportDataPath('D:/NF_
export.and')

Note:

Use before ScrRunNearFieldSimulation.
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ScrSetNearFieldMeshingFrequencyDefault
For Near Field simulations, selects the Default meshing frequency.

UI Command: Simulation > Compute Near Field. ForMeshing Frequencies for the
Observation Mesh, select Default.

Syntax: obj.ScrSetNearFieldMeshingFrequencyDefault()

Parameters: None.

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetNearFieldMeshingFrequencyDefault()

IPY Example: oDoc.ScrSetNearFieldMeshingFrequencyDefault()

ScrSetNearFieldMeshingFrequencyPoints
For Near Field simulations, selects the Points meshing frequency.

UI Command: Simulation > Compute Near Field. ForMeshing Frequencies for the
Observation Mesh, select Points and enter values.

Syntax:
obj.ScrSetNearFieldMeshingFrequencyPoints
(<freqPoints>)

Parameters: ARRAY freqPoints (contains strings in ascending order; uses Hz)

Return Value:

INT

l 1 – Success
l 2 – Array values aren't strings
l 3 – One or more strings wasn't fully numeric
l 4 – Duplicate value or bad order

VB Example:

obj.ScrSetNearFieldMeshingFrequencyPoints
freqPoints

#Array of frequencies

Dim freqPoints (3)

freqPoints( 0 ) = "5e+10"

freqPoints( 1 ) = "1e+11"

freqPoints( 2 ) = "1.2e+11"

IPY Example:
oDoc.ScrSetNearFieldMeshingFrequencyPoints
(['5e+10','1e+11','1.2e+11'])
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ScrSetNearFieldMeshingFrequencyRange
For Near Field simulations, selects the Range meshing frequency.

UI Command: Simulation > Compute Near Field. ForMeshing Frequencies for the
Observation Mesh, select Points and enter values.

Syntax:
obj.ScrSetNearFieldMeshingFrequencyRange
(<startFreq>,<stopFreq>)

Parameters:
DOUBLE startFreq (in Hz)

DOUBLE stopFreq (in Hz)

Return Value:

INT

l 1 – Success
l Else – Error

VB Example:
obj.ScrSetNearFieldMeshingFrequencyRange
(5e+10,1e+11)

IPY Example:
oDoc.ScrSetNearFieldMeshingFrequencyRange
(5e+10,1e+11)

ScrSetNearFieldSamplePointSpacing
Modifies the "Maximum Edge Length" option for Near Field simulations.

UI Command: Simulation > Compute Near Field. SetMaximum Edge Length.

Syntax: obj.ScrSetNearFieldSamplePointSpacing(<spacing>)

Parameters: DOUBLE spacing (in the project's native units)

Return Value:

BOOL:

l 0 – Failure (spacing too small)
l 1 – Success

VB Example: obj.ScrSetNearFieldSamplePointSpacing(132.034)

IPY Example: oDoc.ScrSetNearFieldSamplePointSpacing(132.034)
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ScrSetNearFieldSolverOptions
For Near Field simulations, sets options for number of passes and error tolerance.

UI Command:
Simulation > Compute Near Field. Under Near Field Solver Options, enter
values forMin. Adapt Passes,Max. Adapt Passes, and Global Error
Tolerance.

Syntax:
obj.ScrSetNearFieldSolverOptions(<minAdaptPasses>,
<maxAdaptPasses>, <gErrorTol>)

Parameters:

INT minAdaptPasses

INT maxAdaptPasses

DOUBLE gErrorTol

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetNearFieldSolverOptions(1, 10, 0.5)

IPY Example: oDoc.ScrSetNearFieldSolverOptions(1, 10, 0.5)
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ScrSetNearFieldSurfaceOffset
Controls the position of the surface over which near fields are computed. The positions are
offset values in the design's length units with respect to the design's bounding cuboid.

UI Command: Simulation > Compute Near Field. Enter offset values in the Cuboid
Surface Positions box.

Syntax:
obj.ScrSetNearFieldSurfaceOffset(<px>, <nx>, <py>,
<ny>, <pz>, <nz>)

Parameters:

DOUBLE px (positive x)

DOUBLE nx (negative x)

DOUBLE py (positive y)

DOUBLE ny (negative y)

DOUBLE pz (positive z)

DOUBLE nz (negative z)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

' places the near field surface 1mm above, below,
front, behind, to the left and to the right of the
design

' (assuming the design's length units are mm)

' outcome is TRUE on success, FALSE if any of the
specified offset values are *NOT* positive

outcome = obj.ScrSetNearFieldSurfaceOffset(1.0,
1.0, 1.0, 1.0, 1.0, 1.0)

IPY Example:
oDoc.ScrSetNearFieldSurfaceOffset(1.0, 1.0, 1.0,
1.0, 1.0, 1.0)
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ScrSetNumBondwireSidesInDcSimulation
For DC IR simulations, sets the number of Bondwire sides.

UI Command: Simulation >Options. On DC Advanced tab, set number for
Bondwire Discretization.

Syntax:
obj.ScrSetNumBondwireSidesInDcSimulation
(<numBwSides>)

Parameters: INT numBwSides

Return Value: None.

VB Example: obj.ScrSetNumBondwireSidesInDcSimulation(12)

IPY Example: oDoc.ScrSetNumBondwireSidesInDcSimulation(12)

ScrSetNumCpusToUse
Sets the number of CPUs (cores) to use during simulation.

UI Command: Simulation >Options. ClickMultiprocessing. Select the Number of CPUs
to use when computing solution.

Syntax: obj.ScrSetNumCpusToUse(<numCpus>)

Parameters: INT numCpus

Return Value: None.

VB Example: obj.ScrSetNumCpusToUse 4

IPY Example: oDoc.ScrSetNumCpusToUse(4)

ScrSetNumModesToCompute
Sets the number of modes to solve for during resonant simulations.

UI Command: Simulation > Compute Resonant Modes. Enter a value in the # of Modes
to Compute field.

Syntax: obj.ScrSetNumModesToCompute(<numModes>)

Parameters: INT numModes

Return Value: None.

VB Example: obj.ScrSetNumModesToCompute 10

IPY Example: oDoc.ScrSetNumModesToCompute(10)
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ScrSetNumViaSidesInDcSimulation
Sets the number of sides to use when generating polyhedral mesh approximations to
cylindrical vias during DC IR drop simulations.

UI Command:
Simulation > Compute DC IR. ClickOther solver options button and
choose the DC Advanced tab. Select the number of sides in the Via
Discretization field.

Syntax: obj.ScrSetNumViaSidesInDcSimulation(<numViaSides>)

Parameters: INT numViaSides

Return Value: None.

VB Example:
' model vias as extruded regular octagons

obj.ScrSetNumViaSidesInDcSimulation 8

IPY Example: oDoc.ScrSetNumViaSidesInDcSimulation(8)

ScrSetOptionsFor3DModelExport
Selects an options file for exporting a 3D model.

UI Command: Export > 3D Export Options.

Syntax: obj.ScrSetOptionsFor3DModelExport(<filePath>)

Parameters: BSTR filePath

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetOptionsFor3DModelExport
"C:/Files/options.config"

IPY Example:
oDoc.ScrSetOptionsFor3DModelExport
('C:/Files/options.config')

List of options and example values:

NUM_PADS_FACET_COUNT 8

NUM_ANTIPAD_FACET_COUNT 8

DEFAULT_SOLDERBALL_FACET_COUNT 8

VIA_SEGMENTS 8

DEFAULT_BONDWIRE_FACET_COUNT 6

UNITE_NETS 0
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List of options and example values:

EXCLUDE_TERMINALS_FROM_UNITE 1

TOTAL_VIA_FILL 0

IGNORE_DIELECTRICS 0

SEPARATE_DIELECTRICS 1

UNITE_LAYERS_WITH_SAME_MATERIALS 1

IGNORE_UNCONNECTED_PADS 1

CLIP_TRACES 0

CUT_DIELECTRICS 0

CREATE_SHEET_BODIES 0

GENERATE_TERMINALS 0

IGNORE_PLANES_WITH_AREA_LESS_THAN_THRESOLD 1

IGNORE_FLOAT_BODIES 0

MIN_PLANE_AREA 0.358979

MIN_EDGE_LENGTH_PADS 1um

MIN_EDGE_LENGTH_PLANES 1um

MIN_EDGE_LENGTH_TRACES 1um

MIN_DIELECTRIC_EDGE_LENGTH 10um

DIELECTRIC_EXPANSION_FACTOR 0.100000

IGNORE_HOLES 1

MIN_HOLE_AREA 0.358979

REMOVE-PLATING_TAILS 0

SUBTRACT_METAL_FROM_SUBSTRATE 0

DISCRETIZE_ARCS 0

CHOP_TRACE_ENDS 0

AIRBOX_THICKNESS_FACTOR 1.100000

AIRBOX_PAD_AMOUNT_PLUS_Z 0.500000

AIRBOX_PAD_AMOUNT_MINUS_Z 0.500000
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List of options and example values:

PORT_PAD_AMOUNT 0.500000

CREATE_PORTS_FOR_PWR_GND_NETS 0

PORTS_FOR_PWR_GND_NETS 0

LAUNCH_HFSS 1

USE_CAUSAL_MATERIALS 1

AUTO_DC_THICKNESS 1

HFSS_VERSION 2014

SOLVE_CAPACITANCE 1

SOLVE_DC_RESISTANCE 0

SOLVE_DC_INDUCTANCE_RESISTANCE 0

SOLVE_AC_INDUCTANCE_RESISTANCE 0

SOLVE_PROJECT 0

LAUNCH_Q3D 1

ASSIGN_SOLDER_BALLS_AS_SOURCES 0

Q3D_MERGE_SOURCES 0

Q3D_MERGE_SINKS 0

Q3D_VERSION 2014

ACIS_VERSION 0
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ScrSetPadOnLayer
Changes an existing pad's shape or dimension; deletes an existing pad (by passing a shape of
"None"); or adds a pad to the specified layer.

UI Command: Home > Edit Padstacks.

Syntax:
obj.ScrSetPadOnLayer(<padstackName>, <layerName>,
<shape>, <width>, <height>)

Parameters:

BSTR padstackName

BSTR layerName

BSTR shape ("None", "Circle", "Oblong", or "Rectangle")

BSTR width (including unit of measure)

BSTR height (including unit of measure)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetPadOnLayer("VIA_M1_M2", "METAL-1",
"Circle", "0.6mm", "0.6mm")

IPY Example:
oDoc.ScrSetPadOnLayer('VIA_M1_M2', 'METAL-1',
'Circle', '0.6mm', '0.6mm')

ScrSetPadstackMaterial
Changes a padstack's material.

UI Command: Home > Edit Padstacks.

Syntax:
obj.ScrSetPadstackMaterial(<padstackName>,
<materialName>)

Parameters:
BSTR padstackName

BSTR materialName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetPadstackMaterial("VIA_M1_M2",
"magnesium")

IPY Example:
oDoc.ScrSetPadstackMaterial('VIA_M1_M2',
'magnesium')
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ScrSetPadstackViaPlatingAbsolute
Changes a padstack's via plating absolute value.

UI Command: Home > Edit Padstacks. Select Absolute and set value.

Syntax:
obj.ScrSetPadstackViaPlatingAbsolute
(<padstackName>, <viaPlatingAbsolute>)

Parameters:
BSTR padstackName

BSTR viaPlatingAbsolute (including unit of measure; assumed to be meters if
no unit specified)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetPadstackViaPlatingAbsolute("VIA_M1_M2",
"0.1mm")

IPY Example:
oDoc.ScrSetPadstackViaPlatingAbsolute('VIA_M1_M2',
'0.1mm')

ScrSetPadstackViaPlatingRatio
Changes a padstack's via plating ratio.

UI Command: Home > Edit Padstacks. Select Ratio and select value.

Syntax:
obj.ScrSetPadstackViaPlatingRatio(<padstackName>,
<value>)

Parameters:
BSTR padstackName

DOUBLE value (percentage between 0 and 1; e.g., 0.6 = 60%)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetPadstackViaPlatingRatio("VIA_M1_M2", 0.6)

IPY Example:
oDoc.ScrSetPadstackViaPlatingRatio('VIA_M1_M2',
0.6)
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ScrSetPlotAfterDcSimulation
Controls whether or not current/power/voltage plots are generated after DC IR drop simulations
conclude.

UI Command: Simulation > Compute DC IR. ClickOther Solver Options > DC. Select
Plot Current Density and Voltage Distribution.

Syntax: obj.ScrSetPlotAfterDcSimulation(<plot>)

Parameters: BOOL plot (TRUE = plot; FALSE = do not plot)

Return Value: None.

VB Example: obj.ScrSetPlotAfterDcSimulation True

IPY Example: oDoc.ScrSetPlotAfterDcSimulation(True)

ScrSetPlotLayers
Sets the layers specified for a Frequency Sweep.

UI Command: Simulation > Compute Frequency Sweeps. From the Voltage Surface
Plot Options area, select layers.

Syntax: obj.ScrSetPlotLayers(<plotLayer>,<refLayer>)

Parameters:
BSTR plotLayer

BSTR refLayer (ground)

Return Value:

INT:

l 0 – Success
l Else – Failure

VB Example: obj.ScrSetPlotLayers "L2" "GND"

IPY Example: oDoc.ScrSetPlotLayers('L2','GND')

ScrSetPlotSyzMag
Selects "Plot Magnitude" for various simulations.

UI Command: Results > [Simulation Type] > [Simulation Name] > Plot Magnitude.

Syntax: obj.ScrSetPlotSyzMag(<flag>)

Parameters: BOOL flag (TRUE = plot magnitude; FALSE = do not plot magnitude)

Return Value: None.

VB Example: obj.ScrSetPlotSyzMag True

IPY Example: oDoc.ScrSetPlotSyzMag(1)
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ScrSetPlotSyzPhase
Selects "Plot Phase Animation" for various simulations.

UI Command: Results > [Simulation Type] > [Simulation Name] > View Results >
Phase Animation.

Syntax: obj.ScrSetPlotSyzPhase(<flag>)

Parameters: BOOL flag (TRUE = plot phase animation; FALSE = do not plot phase
animation)

Return Value: None.

VB Example: obj.ScrSetPlotSyzPhase True

IPY Example: oDoc.ScrSetPlotSyzPhase(1)

ScrSetPortNamingConvention
Sets the port naming convention used in the following port generation commands:

ScrPlacePortsAtPinsOnSelectedNets, ScrPlacePortsAtPinsOnSelectedNetsPinNamesOut,
ScrPlacePortsAtPinsOnSelectedNetsExcludePart

UI Command: None.

Syntax:
obj.ScrSetPortNamingConvention
(<namingConvention>)

Parameters: BSTR namingConvention

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetPortNamingConvention("TestPort_
$POSTERMINAL_$NETNAME_Test")

IPY Example:
oDoc.ScrSetPortNamingConvention('TestPort_
$POSTERMINAL_$NETNAME_Test')
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ScrSetPowerGroundNets
Selects nets to be designated power and ground nets.

UI Command: Power/Ground Identification in Nets window.

Syntax:
obj.ScrSetPowerGroundNets(<netNames>,
<appendToCurrentNetsSelected>)

Parameters:

ARRAY netNames

BOOL appendToCurrentNetsSelected (TRUE = nets already set to
power/ground remain power/ground; FALSE = all nets not in the array are set
to non-power/ground.)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:

dim netNames(3)

netNames(0)="Net 1"

netNames(1)="Net 2"

netNames(2)="Net 3"

outcome = obj.ScrSetPowerGroundNets(netNames, TRUE)

IPY Example:
oDoc.ScrSetPowerGroundNets
(['Net1','Net2','Net3'],1)

ScrSetPowerGroundNetsFromFile
Selects nets to be designated power and ground nets.

UI Command: Power/Ground Identification in Nets window.

Syntax:
obj.ScrSetPowerGroundNetsFromFile(<filePath>,
<appendToCurrentNetsSelected>)

Parameters:

BSTR filePath

BOOL appendToCurrentNetsSelected (TRUE = nets already set to
power/ground remain power/ground; FALSE = all nets not in the file are set to
non-power/ground.)

Return Value: None.

VB Example:
obj.ScrSetPowerGroundNetsFromFile("C:/Files/power_
ground_nets.txt", TRUE)

IPY Example:
oDoc.ScrSetPowerGroundNetsFromFile('C:/Files/power_
ground_nets.txt',1)
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ScrSetProjectModified
Determines whether you will be prompted to save before closing or loading a different project.

UI Command: None.

Syntax: obj.ScrSetProjectModified(<p>)

Parameters: BOOL p (TRUE = sets project as modified, will be prompted to save; FALSE =
no save prompt)

Return Value: None.

VB Example: obj.ScrSetProjectModified True

IPY Example: oDoc.ScrSetProjectModified(1)

ScrSetPsiOptionsFromFile
Sets general PSI simulation options from an XML configuration file.

UI Command: Simulation > PSI Options > Import Settings. Select file.

Syntax: obj.ScrSetPsiOptionsFromFile(<filename>)

Parameters: BSTR filename (full path)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetPsiOptionsFromFile("D:/Tests/Test.sps")

IPY Example: oDoc.ScrSetPsiOptionsFromFile('D:/Tests/Test.sps')

ScrSetPsiPortType
Sets the PSI port type for a specified port.

UI Command: None.

Syntax: obj.ScrSetPsiPortType(<portName>, <portType>)

Parameters:
BSTR portName

BSTR portType (See: SIwave-PSI Best Practices - Port Setup)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetPsiPortType("Port1","Lumped")

IPY Example: oDoc.ScrSetPsiPortType('Port1','Lumped')
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ScrSetPsiSyzInterpOptions
Sets PSI SYZ Simulation options.

UI Command: Simulation > PSI > Compute SYZ Parameters.

Syntax:
obj.ScrSetPsiSyzInterpOptions(<interp>,
<fastsweep>, <adaptiveSamp>, <enforceDC>)

Parameters:

INT interp (0 = Discrete Sweep; 1 = Interpolating Sweep)

INT fastsweep (0 = Disable Fast Sweep; 1 = Enable Fast Sweep)

INT adaptiveSamp (0 = Disable Adaptive Sampling; 1 = Enable
Adaptive Sampling)

INT enforceDC (for Adaptive Sampling, 0 = do not enforce DC point and
causality; 1 = enforce DC point and causality)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetPsiSyzInterpOptions(1, 0, 1, 1)

IPY Example: oDoc.ScrSetPsiSyzInterpOptions(1, 0, 1, 1)

ScrSetRefineBondwiresInDcSimulation
For DC simulations, selects or deselects option to refine mesh along bondwires.

UI Command: Simulation >  Options. On DC Advanced tab, select or deselect
Refine Mesh Along Bondwires.

Syntax:
obj.ScrSetRefineBondwiresInDcSimulation
(<refineBws>)

Parameters: BOOL refineBws (TRUE = select; FALSE = deselect)

Return Value: None.

VB Example: obj.ScrSetRefineBondwiresInDcSimulation True

IPY Example: oDoc.ScrSetRefineBondwiresInDcSimulation(1)
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ScrSetRefineDcSimulation
Activates or deactivates adaptive mesh refinement during DC IR drop simulations.

UI Command: Simulation > Compute DC IR. Click Other Solver Options >
DC Advanced. Select or deselect Perform Adaptive Mesh Refinement.

Syntax: obj.ScrSetRefineDcSimulation(<refine>)

Parameters: INT refine (0 = deselect refinement; 1 = select refinement)

Return Value: None.

VB Example: obj.ScrSetRefineDcSimulation(1)

IPY Example: oDoc.ScrSetRefineDcSimulation(1)

ScrSetRefineViasInDcSimulation
For DC simulations, selects or deselects option to refine mesh along vias.

UI Command: Simulation >Options. On DC Advanced tab, select or deselect
Refine Mesh Along Vias.

Syntax: obj.ScrSetRefineViasInDcSimulation(<refineVias>)

Parameters: BOOL refineBws (TRUE = select; FALSE = deselect)

Return Value: None.

VB Example: obj.ScrSetRefineViasInDcSimulation True

IPY Example: oDoc.ScrSetRefineViasInDcSimulation(1)

ScrSetRemoveCutoutsByArea
Selects whether SIwave will always preserve cutouts whose area is greater than the minimum
void area (controlled by the ScrSetMinCutoutArea function). By default, SIwave automatically
decides which cutouts are to be defeatured (i.e., not meshed) during simulation.

UI Command: Simulation >Options. Click SI/PI Advanced. Select or deselect Automatic
Mesh Refinement.

Syntax: obj.ScrSetRemoveCutoutsByArea <p>

Parameters: INT p (0 = automatic mesh refinement; 1 = no automatic mesh refinement)

Return Value: None.

VB Example: obj.ScrSetRemoveCutoutsByArea(1)

IPY Example: oDoc.ScrSetRemoveCutoutsByArea(1)
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ScrSetResonantModeMaxFreq
For Resonant Modes simulations, sets the maximum frequency for analysis.

UI Command: Simulation > Compute Resonant Modes. Enter aMaximum Frequency
value, in Hz.

Syntax: obj.ScrSetResonantModeMaxFreq(<freq>)

Parameters: DOUBLE freq (in Hz)

Return Value: None.

VB Example: obj.ScrSetResonantModeMaxFreq(2E+06)

IPY Example: oDoc.ScrSetResonantModeMaxFreq(2E+06)

ScrSetResonantModeMinFreq
For Resonant Modes simulations, sets the minimum frequency for analysis.

UI Command: Simulation > Compute Resonant Modes. Enter aMinimum Frequency
value, in Hz.

Syntax: obj.ScrSetResonantModeMinFreq(<freq>)

Parameters: DOUBLE freq (in Hz)

Return Value: None.

VB Example: obj.ScrSetResonantModeMinFreq(2E+06)

IPY Example: oDoc.ScrSetResonantModeMinFreq(2E+06)
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ScrSetRLCValues
Changes RLC values for a specified RLC.

UI Command: None.

Syntax: obj.ScrSetRLCValues(<partName>, <r>, <l>, <c>)

Parameters:

BSTR partName

BSTR r (including unit of measure)

BSTR l (including unit of measure)

BSTR c (including unit of measure)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetRLCValues "RLC_XYZ_R", "1.5kohm", "1e-
12h", "1uf"

IPY Example:
oDoc.ScrSetRLCValues('RLC_XYZ_R', '1.5kohm', '1e-
12h', '1uf')
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ScrSetSignalNets
Selects nets to be designated signal nets.

UI Command: Simulation > Signal Net Analyzer. Select nets.

Syntax:
obj.ScrSetSignalNets(<netNames>,
<appendToCurrentNetsSelected>)

Parameters:
ARRAY netNames

BOOL appendToCurrentNetsSelected (TRUE = nets already set as signal
nets remain so; FALSE = all nets not in the array are set to non-signal nets.)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:

dim netNames(3)

netNames(0)="Net 1"

netNames(1)="Net 2"

netNames(2)="Net 3"

outcome = obj.ScrSetSignalNets(netNames, TRUE)

IPY Example: oDoc.ScrSetSignalNets(['Net1','Net2','Net3'],1)
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ScrSetSignalNetsFromFile
Selects nets to be designated signal nets.

UI Command: Simulation > Signal Net Analyzer. Select nets.

Syntax:
obj.ScrSetSignalNetsFromFile(<filePath>,
<appendToCurrentNetsSelected>)

Parameters:
BSTR filePath

BOOL appendToCurrentNetsSelected (TRUE = nets already set as signal
nets remain so; FALSE = all nets not in the file are set to non-signal nets.)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetSignalNetsFromFile("C:/Files/signal_
nets.txt", TRUE)

IPY Example:
oDoc.ScrSetSignalNetsFromFile('C:/Files/signal_
nets.txt',1)
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ScrSetSimulationName
Sets the simulation name for a specified simulation type.

UI Command: From the Simulationmenu, click any option to compute a simulation and
open the corresponding simulation window. Specify the simulation name.

Syntax: obj.ScrSetSimulationName(<simType>, <simName>)

Parameters:
BSTR simType ( "ac", "dc", "eigen", "ff", "nf", "syz" or "hfss_syz")

BSTR simName

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

' outcome is TRUE on success, FALSE if specified
"simType" does not match one of the six strings
mentioned

outcome = obj.ScrSetSimulationName ( "syz", "S-
param no caps" )

IPY Example: oDoc.ScrSetSimulationName('syz', 'S-param no caps')
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ScrSetSketchedBwProfile
Sets a specified sketched profile to all bondwires of a specified model.

UI Command: From the Simulationmenu, click any option to compute a simulation and
open the corresponding simulation window. Specify the simulation name.

Syntax:
obj.ScrSetSketchedBwProfile(<bwModelName>,
<filePath>, <radius>)

Parameters:

BSTR bwModelName

BSTR filePath

DOUBLE radius

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetSketchedBwProfile "WB_PROFILE_1",
"SketchedProfile.bwp", 20

IPY Example:
oDoc.ScrSetSketchedBwProfile('WB_PROFILE_1',
'SketchedProfile.bwp', 20)

Format of *.bwp:

UNITS microns

0.000000 400.000000

300.000000 700.000000

900.000000 700.000000

1200.000000 300.000000
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ScrSetSketchedBwProfileFromArray
Sets a sketched profile (array of points) to all bondwires of a specified model.

UI Command: None.

Syntax:
obj.ScrSetSketchedBwProfileFromArray(<modelName>,
<unitName>, <bwPointArray>, <radius>)

Parameters:

BSTR modelName

BSTR unitName

ARRAY bwPointArray (requires 8 doubles for 4 points)

DOUBLE (radius)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:

obj.ScrSetSketchedBwProfileFromArray "BW_PROFILE_
1", "micron", bwPointArray, 20

Array of 4 point sketched profile

Dim bwPoints (8)

bwPoints( 0 ) = 0.0

bwPoints( 1 ) = 400.0

bwPoints( 2 ) = 300.0

bwPoints( 3 ) = 700.0

bwPoints( 4 ) = 900.0

bwPoints( 5 ) = 700.0

bwPoints( 6 ) = 1200.0

bwPoints( 7 ) = 300.0

IPY Example:

oDoc.ScrSetSketchedBwProfileFromArray('BW_PROFILE_
1', 'micron',
[0.0,400.0,300.0,700.0,900.0,700.0,1200.0,300.0],
20)
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ScrSetSnapLengthThreshold
For DC simulations, sets the maximum length value for snapping vertices.

UI Command: Simulation >Options. On DC Advanced tab, enter a value in the Snap
vertices separated by less than field.

Syntax:
obj.ScrSetSnapLengthThreshold
(<snapLengthThreshold>)

Parameters: BSTR snapLengthThreshold

Return Value: None.

VB Example: obj.ScrSetSnapLengthThreshold("0.0734235mil")

IPY Example: oDoc.ScrSetSnapLengthThreshold('0.0734235mil')

ScrSetSolderballMaterial
Assigns a material to a specified solderball.

NOTE: You must assign a solderball profile before assigning a material.

UI Command: Home > Solderball Properties. Assign a material.

Syntax:
obj.ScrSetSolderballMaterial(<padstackName>,
<material>)

Parameters:
BSTR padstackName

BSTR material

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetSolderballMaterial("BP_BOT_500X600",
"silver")

IPY Example:
oDoc.ScrSetSolderballMaterial('BP_BOT_500X600',
'silver')
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ScrSetSolderballParameters
Assigns solderballs/bumps of the specified dimensions (in the design's geometry units) to the
specified padstack.

UI Command: Home > Solderball Properties. Select a padstack and assign
solderballs/bumps.

Syntax:
obj.ScrSetSolderballParameters(<padstackName>,
<aboveStackup>, <height>, <radius>)

Parameters:

BSTR padstackName

BOOL/INT aboveStackup (TRUE/1 = above stackup; FALSE/0 = below
stackup)

DOUBLE height

DOUBLE radius

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

' creates solder bumps at the "BALL600" padstack
that are 500um tall and have a radius of 200um

' (assuming the design units are um)

' outcome is TRUE on success, FALSE if a padstack
with the specified name could not be located

outcome = obj.ScrSetSolderballParameters ( 
"BALL600", False, 500, 200 )

' creates solder bumps at the "BUMPPAD" padstack
that are 100um tall and have a radius of 30um

' (assuming the design units are um)

outcome = obj.ScrSetSolderballParameters ( 
"BUMPPAD", True, 100, 30 )

IPY Example:
oDoc.ScrSetSolderballParameters('BUMPPAD', 1, 100,
30)
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ScrSetSourceMagnitude
Sets the current or voltage magnitude of a specified source.

UI Command: None.

Syntax: obj.ScrSetSourceMagnitude(<refDes>, <magnitude>)

Parameters:
BSTR refDes

BSTR magnitude (including unit)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: outcome = obj.ScrSetSourceMagnitude ("I_1", "2.5A")

IPY Example: oDoc.ScrSetSourceMagnitude('I_1', '2.5A')
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ScrSetSparamModelSetup
Configures an N-Port S-parameter model for specified part(s).

UI Command: None.

Syntax:
obj.ScrSetSparamModelSetup(<partName>,
<activeRefDesList>, <fileName>, <modelName>,
<refNet>, <pinOrder>)

Parameters:

BSTR partName

ARRAY activeRefDesList

BSTR fileName (including path)

BSTRmodelName

BSTR refNet

ARRAY pinOrder

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

Dim refdes1(0)

refdes1(0) = "A1"

Dim pinorder1()

doc.ScrSetSparamModelSetup "TESTPART", refdes1,
"D:/Tests/US142197/DLP11TB800UL2.s4p", "Model1",
"NET_9", pinorder1

IPY Example:

refdes1 = ['A1']

pinorder1 = []

doc.ScrSetSparamModelSetup('TESTPART', refdes1,
'D:/Tests/US142197/DLP11TB800UL2.s4p', 'Model1',
'NET_9', pinorder1)
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ScrSetSpiceModelSetup
Configures an N-Port Spice model for specified part(s).

UI Command: None.

Syntax:
obj.ScrSetSpiceModelSetup(<partName>,
<activeRefDesList>, <fileName>, <modelName>,
<pinOrder>)

Parameters:

BSTR partName

ARRAY activeRefDesList

BSTR fileName (including path)

BSTR modelName

ARRAY pinOrder

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

Dim refdes2(0)

refdes2(0) = "A2"

Dim pinorder2(3

pinorder2(0) = "4"

pinorder2(1) = "3"

pinorder2(2) = "2"

pinorder2(3) = "1"

obj.ScrSetSpiceModelSetup "TESTPART", refdes2,
"D:/Tests/US142197/testmod.sp", "Model2", pinorder2

IPY Example:

refdes2 = ['A2']

pinorder2 = ['4', '3', '2', '1']

oDoc.ScrSetSpiceModelSetup('TESTPART', refdes2,
'D:/Tests/US142197/testmod.sp', 'Model2',
pinorder2)
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ScrSetSpiceSubcktFormat
Sets an appropriate output format for Full Wave Spice simulations.

UI Command: None.

Syntax: obj.ScrSetSpiceSubcktFormat(<format>)

Parameters: BSTR format (case-sensitive choices are: HSPICE, MSPICE, PSPICE, or
Spectre)

Return Value: None.

VB Example: obj.ScrSetSpiceSubcktFormat "HSPICE"

IPY Example: oDoc.ScrSetSpiceSubcktFormat('PSPICE')

ScrSetStackupLayerThickness
Sets the thickness of a specified layer.

UI Command: Home > Layer Stackup Editor. Edit a layer's Thickness value.

Syntax:
obj.ScrSetStackupLayerThickness(<layerName>,
<thickness>, <redraw>)

Parameters:

BSTR layerName

BSTR thickness (including unit)

BOOL redraw (TRUE/1 = redraw; FALSE/0 = do not redraw)

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetStackupLayerThickness("LAYER-1",
"0.79mils", True)

IPY Example:
oDoc.ScrSetStackupLayerThickness('LAYER-1',
'0.79mils', 1)
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ScrSetStackupLayerThicknessUnit
Sets the layer thickness unit.

UI Command: None.

Syntax: obj.ScrSetStackupLayerThicknessUnit(<unit>)

Parameters: BSTR unit ("microns", "um", "mils", "mm", "cm", "inches", or "meters")

Return Value:

BOOL:

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetStackupLayerThicknessUnit "um"

IPY Example: oDoc.ScrSetStackupLayerThicknessUnit('um')

ScrSetSweepFreqRange
Sets the minimum and maximum frequencies for a frequency sweep.

UI Command: None.

Syntax: obj.ScrSetSweepFreqRange(<minFreq>, <maxFreq>)

Parameters:

DOUBLE minFreq (in Hz; 1.0 = 1Hz, 1000.0 = 1kHz, 1e-6 = 1MHz; 1e-9 =
1GHz)

DOUBLE maxFreq (in Hz; 1.0 = 1Hz, 1000.0 = 1kHz, 1e-6 = 1MHz; 1e-9 =
1GHz)

Return Value: None.

VB Example: obj.ScrSetSweepFreqRange(5.0,5.0)

IPY Example: oDoc.ScrSetSweepFreqRange(5.0,5.0)

ScrSetSweepMaxFreq
Sets the maximum frequency for a frequency sweep.

UI Command: None.

Syntax: obj.ScrSetSweepMaxFreq(<maxFreq>)

Parameters: DOUBLE maxFreq (in Hz; 1.0 = 1Hz, 1000.0 = 1kHz, 1e-6 = 1MHz; 1e-9 =
1GHz)

Return Value: None.

VB Example: obj.ScrSetSweepMaxFreq(5.0)

IPY Example: oDoc.ScrSetSweepMaxFreq(5.0)
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ScrSetSweepMinFreq
Sets the minimum frequency for a frequency sweep.

UI Command: None.

Syntax: obj.ScrSetSweepMinFreq(<minFreq>)

Parameters: DOUBLE minFreq (in Hz; 1.0 = 1Hz, 1000.0 = 1kHz, 1e-6 = 1MHz; 1e-9 =
1GHz)

Return Value: None.

VB Example: obj.ScrSetSweepMinFreq(5.0)

IPY Example: oDoc.ScrSetSweepMinFreq(5.0)

ScrSetSweepNumFreqPoints
Sets the number of frequency points for a frequency sweep.

UI Command: None.

Syntax: obj.ScrSetNumSweepFreqPoints(<numPoints>)

Parameters: INT numPoints

Return Value: None.

VB Example: obj.ScrSetSweepNumFreqPoints(200)

IPY Example: oDoc.ScrSetSweepNumFreqPoints(200)

ScrSetSyzInterpSweep
Sets the SYZ-parameter sweep type to interpolating.

UI Command: Simulation > Compute SYZ Parameters. Select Interpolating Sweep.

Syntax: obj.ScrSetSyzInterpSweep(<p>)

Parameters: BOOL p (TRUE = Interpolating; FALSE = Discrete)

Return Value: None.

VB Example:

' switch to interpolating sweeps

obj.ScrSetSyzInterpSweep True

' switch back to discrete sweeps

obj.ScrSetSyzInterpSweep False

IPY Example: oDoc.ScrSetSyzInterpSweep(True)
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ScrSetSyzInterpSweepParams
Sets the convergence criterion (error tolerance) and maximum number of points to use during
SYZ interpolating sweeps.

UI Command: Simulation > Compute SYZ Parameters. Select Interpolating Sweep and
enter a value for Error Tolerance.

Syntax:
obj.ScrSetSyzInterpSweepParams(<convergence>,
<maxInterpPts>)

Parameters:
DOUBLE convergence

INT maxInterpPts

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

' outcome is TRUE on success, FALSE if
"maxInterpPts" exceeds the number of discrete sweep
points

outcome = obj.ScrSetSyzInterpSweepParams ( 0.005,
150)

IPY Example: oDoc.ScrSetSyzInterpSweepParams(0.005, 150)
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ScrSetTDCrosstalkScanParameters
Specifies the parameters for running a time domain Crosstalk Scan via ScrRunSimulation.

UI Command: Simulation > Crosstalk Scan > Time Domain. Set values for solver options.

Syntax:
obj.ScrSetTDCrosstalkScanParameters(<partNameList>,
<refDesNameList>, <pinNameList>, <impedanceList>,
<typeList>, <riseTimeList>, <voltageList>)

Parameters:

ARRAY partNameList

ARRAY refDesNameList

ARRAY pinNameList

ARRAY impedanceList

ARRAY typeList ("1" represents Driver; "0" represents Receiver)

ARRAY riseTimeList

ARRAY voltageList

**Each input parameter is an array of strings, and the number of elements in
the array should be the same for all parameters. The first 3 are used to identify
the pin and the rest are parameters to apply for the pin.

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetTDCrosstalkScanParameters(parts, refdes,
pins, impedances, types, risetimes, voltages)

IPY Example:

parts = ["G83568-001", "IPD031-201"]

refdes = ["U1A1", "U2A5"]

pins = ["K7", "9"]

impedances = ["55ohms", "60"]

types = ["0", "1"]

risetimes = ["0", "6ns"]

voltages = ["0", "1.2V"]

oDoc.ScrSetTDCrosstalkScanParameters(parts, refdes,
pins, impedances, types, risetimes, voltages)
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ScrSetThermalPadOnLayer
Changes, adds, or deletes thermal pads of a specified padstack.

If no thermal pad exists, script adds thermal pads to the specified padstack.

If thermal pad exists, script modifies pad shape and/or dimensions.

To delete a pad, choose "None" as the shapeName.

UI Command: Home > Edit Padstack. Select Thermal Relief Pag Properties.

Syntax:
obj.ScrSetThermalPadOnLayer(<padstackName>,
<layerName>, <shapeName>, <widthString>,
<heightString>)

Parameters:

BSTR padstackName

BSTR layerName

BSTR shapeName ("None", "Circle", "Oblong", or "Rectangle")

BSTR widthString (in mils if no unit specified; for circle pads, this is the radius)

BSTR heightString (in mils if no unit specified)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
obj.ScrSetThermalPadOnLayer("VIA_M1_M2", "METAL-1",
"Rectangle", "1.2mm", "1.2mm")

IPY Example:
oDoc.ScrSetThermalPadOnLayer('VIA_M1_M2', 'METAL-
1', 'Rectangle', '1.2mm', '1.2mm')
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ScrSetTouchstoneExportFormatToDb
Sets the magnitude format in exported touchstone files.

UI Command: None.

Syntax: obj.ScrSetTouchstoneExportFormatToDb(<exportInDb>)

Parameters: BOOL exportInDb (TRUE = magnitude is specified in decibels [log of the
magnitude]; FALSE = default settings)

Return Value: None.

VB Example: obj.ScrSetTouchstoneExportFormatToDb True

IPY Example: oDoc.ScrSetTouchstoneExportFormatToDb(1)

ScrSetTouchstonePortOrder
Specifies port order in exported touchstone files.

NOTE: If any ports are not specified in the input, they will be sorted in alphabetical order and
added to the end of the list.

UI Command: None.

Syntax: obj.ScrSetTouchstonePortOrder(<portNamesList>)

Parameters: ARRAY portNamesList

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:

Dim ports(1)

ports(0) = "port1"

ports(1) = "port2"

outcome = doc.ScrSetTouchstonePortOrder ports

IPY Example: oDoc.ScrSetTouchstonePortOrder(['port1','port2'])
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ScrSetTouchstonePortRemapping
Sets the alternate port naming convention when name remapping is enabled in touchstone file
exports.

UI Command: None.

Syntax:
obj.ScrSetTouchstonePortRemapping(<portName>,
<namingConv>)

Parameters:
BSTR portName

BSTR namingConv

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example:
outcome = obj.ScrSetTouchstonePortRemapping "left",
"foo"

IPY Example: oDoc.ScrSetTouchstonePortRemapping('left', 'foo')

ScrSetTraceCouplingDistance
Sets the XY coupling distance.

UI Command: Simulation >Options. On CPA tab, enter a value for XY coupling distance.

Syntax:
obj.ScrSetTraceCouplingDistance
(<traceCouplingDist>, <units>)

Parameters:
DOUBLE traceCouplingDist

BSTR units

Return Value: None.

VB Example: obj.ScrSetTraceCouplingDistance("7.79", "mils")

IPY Example: oDoc.ScrSetTraceCouplingDistance('7.79', 'mils')
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ScrSetUniformTemperature
Sets the uniform design temperature.

UI Command: Simulation >Options. On the SI/PI tab, enter a value in the Set uniform
design temperature to field.

Syntax: obj.ScrSetUniformTemperature(<temp>)

Parameters: BSTR temp (temperature, including units)

Return Value: None.

VB Example: obj.ScrSetUniformTemperature "100cel"

IPY Example: oDoc.ScrSetUniformTemperature('100cel')

ScrSetZ0ScanParameters
Specifies the parameters for running an Impedance Scan via ScrRunSimulation.

UI Command: Simulation > Impedance Scan. Set Nominal Z0, Issue warning... and
Issue violation... values.

Syntax:
obj.ScrSetZ0ScanParameters(<impedance>,
<warningThreshold>, <violationThreshold>)

Parameters:

DOUBLE impedance

DOUBLE warningThreshold

DOUBLE violationThreshold

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrSetZ0ScanParameters(50,15,30)

IPY Example: oDoc.ScrSetZ0ScanParameters(50,15,30)
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ScrSetZ0ScanReportImageHeight
When generating Impedance Scan reports, specifies the resolution (in pixels) of the smaller
dimension of the images. For designs where the board is wider than it is tall, this corresponds
to the y-resolution of the image.

UI Command: None.

Syntax: obj.ScrSetZ0ScanReportImageHeight(<imgHeight>)

Parameters: LONG imgHeight

Return Value:

BOOL

l 0 – Failure (invalid height)
l 1 – Success

VB Example: obj.ScrSetZ0ScanReportImageHeight(3000)

IPY Example: oDoc.ScrSetZ0ScanReportImageHeight(3000)

ScrShowSelectedNetsOnly
Determines whether SIwave displays all nets or selected nets only.

UI Command: None.

Syntax: obj.ScrShowSelectedNetsOnly(<selOnly>)

Parameters: BOOL selOnly (TRUE/1 = display only selected nets; FALSE/0 = display all
nets)

Return Value: None.

VB Example: obj.ScrShowSelectedNetsOnly(True)

IPY Example: oDoc.ScrShowSelectedNetsOnly(1)

ScrSIwaveEnable_3D_DDM
Enables or disables 3D DDM.

UI Command: None.

Syntax: obj.ScrSIwaveEnable_3D_DDM(<flag>)

Parameters: BOOL flag

Return Value: None.

VB Example: obj.ScrSIwaveEnable_3D_DDM TRUE

IPY Example: oDoc.ScrSIwaveEnable_3D_DDM(True)

Script Commands 2-220

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave Scripting Guide

ScrSIwaveEnableHFSSRegions
Enables or disables HFSS Regions

Note: Region extents must exist in the layout for this setting to be meaningful.

UI Command: None.

Syntax: obj.ScrSIwaveEnableHFSSRegions(<flag>)

Parameters: BOOL flag

Return Value: None.

VB Example: obj.ScrSIwaveEnableHFSSRegions TRUE

IPY Example: oDoc.ScrSIwaveEnableHFSSRegions(True)

ScrSIwaveEnableReturnCurrentDistribution
Enables or disables tracing of return current distribution.

UI Command: Simulation >Options. On SI/PI Advanced tab, select Trace return current
distribution.

Syntax:
obj.ScrSIwaveEnableReturnCurrentDistribution
(<flag>)

Parameters: BOOL flag (TRUE/1 = select; FALSE/0 = deselect)

Return Value: None.

VB Example: obj.ScrSIwaveEnableReturnCurrentDistribution(True)

IPY Example: oDoc.ScrSIwaveEnableReturnCurrentDistribution(1)

ScrSIwaveIncludeSourceParasitics
For Resonance Sweep/SYZ simulations, enables or disables option to include source
parasitics.

UI Command:
Simulation >Options. On SI/PI Advanced tab,
select Include Voltage/Current Source Connections/Parasitics in
Resonance/SYZ Simulations.

Syntax: obj.ScrSIwaveIncludeSourceParasitics(<flag>)

Parameters: BOOL flag (TRUE/1 = include; FALSE/0 = do not include)

Return Value: None.

VB Example: obj.ScrSIwaveIncludeSourceParasitics(True)

IPY Example: oDoc.ScrSIwaveIncludeSourceParasitics(1)
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ScrSIwaveSyzComputeExactDcPoint
For SYZ simulations, selects or deselects the Compute Exact DC Point option.

UI Command: Simulation > Compute SYZ Parameters. Select Compute Exact DC Point.

Syntax: obj.ScrSIwaveSyzComputeExactDcPoint(<flag>)

Parameters: BOOL flag (TRUE = Compute exact DC point; FALSE = Do not compute exact
DC point)

Return Value: None.

VB Example: obj.ScrSIwaveSyzComputeExactDcPoint TRUE

IPY Example: oDoc.ScrSIwaveSyzComputeExactDcPoint(True)

Important:

The Compute Exact DC Point and Enforce Causality options are mutually
exclusive. Selecting both generates an error.

ScrSIwaveSyzEnforceCausality
For SYZ simulations, selects or deselects the Enforce Causality option.

UI Command: Simulation > Compute SYZ Parameters. Select Enforce Causality.

Syntax: obj.ScrSIwaveSyzEnforceCausality(<flag>)

Parameters: BOOL flag (TRUE = Enforce; FALSE = Do not enforce)

Return Value: None.

VB Example: obj.ScrSIwaveSyzEnforceCausality TRUE

IPY Example: oDoc.ScrSIwaveSyzEnforceCausality(True)

Important:

The Enforce Causality and Compute Exact DC Point options are mutually
exclusive. Selecting both generates an error.
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ScrSIwaveSyzEnforcePassivity
For SYZ simulations, selects or deselects the Enforce Passivity option.

UI Command: Simulation > Compute SYZ Parameters. Select Enforce Passivity.

Syntax: obj.ScrSIwaveSyzEnforcePassivity(<flag>)

Parameters: BOOL flag (TRUE = Enforce; FALSE = Do not enforce)

Return Value: None.

VB Example: obj.ScrSIwaveSyzEnforcePassivity TRUE

IPY Example: oDoc.ScrSIwaveSyzEnforcePassivity(True)

ScrUnselectAll
Deselects all selected objects.

UI Command: Right-click in the Modeling workspace. Click Unselect All.

Syntax: obj.ScrUnselectAll()

Parameters: None.

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: obj.ScrUnselectAll()

IPY Example: oDoc.ScrUnselectAll()

ScrUpdateComponentTree
For scripts run in graphical mode, updates the component tree. Scripted modifications will not
display in the tree until this function is called.

NOTE: This script is inappropriate for scripts run in non-graphical mode.

UI Command: None.

Syntax: obj.ScrUpdateComponentTree

Parameters: None.

Return Value: None.

VB Example: obj.ScrUpdateComponentTree

IPY Example: oDoc.ScrUpdateComponentTree()
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ScrUseIcepakTemperatureDataInDc
Enables or disables the use of Icepak thermal data in DC simulations.

UI Command: Simulation > Compute DC IR. Select Icepak data.

Syntax: obj.ScrUseIcepakTemperatureDataInDc(<use>)

Parameters: BOOL use (TRUE = Use thermal data; FALSE = Do not use thermal data)

Return Value: None.

VB Example: obj.ScrUseIcepakTemperatureDataInDc True

IPY Example: oDoc.ScrUseIcepakTemperatureDataInDc(True)

ScrUseTouchstonePortRemapping
Enables or disables the use of port name remapping for touchstone file exports.

UI Command: None.

Syntax: obj.ScrUseTouchstonePortRemapping(remapNames)

Parameters: BOOL/INT remapNames (TRUE/1 = Enable; FALSE/0 = Disable)

Return Value:

BOOL

l 0 – Failure
l 1 – Success

VB Example: outcome = obj.ScrUseTouchstonePortRemapping (TRUE)

IPY Example: oDoc.ScrUseTouchstonePortRemapping(1)

Solve
Solves a specified simulation.

UI Command: Launch button in simulation settings window.

Syntax: obj.Solve(solutionName)

Parameters: BSTR solutionName

Return Value: Simulation results in text format.

VB Example: obj.Solve("Far Field Sim 1")

IPY Example: oDoc.Solve('Near Field Sim 1')
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StopSimLink
Aborts a specified simulation.

UI Command: Process Monitor > Abort Simulation.

Syntax: obj.StopSimLink(<simID>, <abort>)

Parameters:
INT simID

BOOL abort (TRUE/1 = abort; FALSE/0 = do not abort)

Return Value: None.

VB Example: obj.StopSimLink(121, True)

IPY Example: oDoc.StopSimLink(121, 1)

SupportSParamLink
Returns whether design supports S-parameter links.

UI Command: None.

Syntax: obj.SupportSParamLink()

Parameters: None.

Return Value: BOOL

VB Example: obj.SupportSParamLink()

IPY Example: oDoc.SupportSParamLink()
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A

antipads

modifying 2-149

automatic mesh refinement 2-198

B

bondwires

assigning terminal type to 2-32

creating 4-point 2-30, 2-147

creating 5-point 2-31, 2-148

creating low 2-34

creating sketched 2-36

from array 2-37

finding nets associated with 2-103

generating list of 2-96

generating model list 2-96

refining mesh along 2-197

setting discretization for DC sim 2-187

setting low profile 2-178

setting mesh for DC sim 2-179

setting model 2-150

setting sketched from array 2-205

setting sketched profile 2-204

setting support layer 2-150

setting termination layer 2-151

setting via plating ratio 2-192

bounding box

assigning 2-100

C

capacitors

drawing 2-56

causality

enforcing 2-93

circles

drawing 2-57

circuit elements

activating 2-20

deactivating 2-20

deleting 2-52

placing 2-126

placing to reference pins 2-128

renaming 2-67

returning terminal nets 2-97

clipboard

copying image to 2-46

commands

list of available 2-1
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components

generating list by type 2-98

generating list of 2-96

updating component tree 2-223

crosstalk

setting threshold 2-155

D

DDM

3D

enabling 2-220

deleting

circuit elements 2-52

layers 2-53

nets 2-53

all 2-51

from file 2-54

multiple 2-54

padstacks 2-54

pin groups 2-55

solutions

DC 2-52

designs

assigning bounding box 2-100

clipping around nets 2-42

clipping nets 2-40

enabling s-parameter links 2-225

returning list of 2-16

setting uniform temperature 2-219

dies

locating layer location 2-100

returning names of 2-101

setting elevation 2-156

setting thickness 2-157

directories

returning 2-14

returning project 2-15

drawing

capacitors 2-56

circles 2-57

inductors 2-58

polygons 2-59

ports 2-60

rectangles 2-61

resistors 2-62

traces 2-63

vias 2-64

voltage probes 2-65

voltage sources 2-66

E

EMI scanner

exporting reports 2-80

setting parameters 2-158
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errors

adding to log 2-24

exporting

AC voltage probe data 2-89

ANF files 2-74

component files 2-74

connection reports 2-94

CPA reports 2-75

DC element data 2-80

DC power tree 2-21, 2-76

DC reports 2-77

EMI scanner reports 2-80

Icepak projects 2-81

Icepak thermal plots 2-82

impedance reports 2-90

layer stackups 2-84

models 2-73

net delay reports 2-85

power data to Icepak 2-75

settings files 2-85

SNA reports 2-86

SYZ active dataset 2-88

SYZ results 2-88

Touchstone files 2-84

XFL files 2-89

F

files

ANF

exporting 2-74

importing 2-17, 2-110

CMP

importing 2-111

importing mapping 2-112

component

exporting 2-74

CPM

importing 2-114

EDB

importing 2-116

GDSII

importing 2-116

IPC2581

importing 2-117

ODB++

importing 2-17

PLOC

importing 2-114

PMAP

importing 2-119

PNG

saving workspace as 2-144
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returning directory of 2-14

returning path of 2-14

SEF

exporting 2-85

importing 2-119

SITEMP

selecting for Icepak sim 2-168

SIW

saving 2-19

SWS

importing 2-120

Touchstone

port remapping 2-224

port remapping for export 2-218

setting magnitude format 2-217

setting port order 2-217

XFL

exporting 2-89

importing 2-121

fitting

design 2-92

returning view window position 2-98

selected objects 2-92

to viewing window 2-93

frequency

setting maximum for sweeps 2-212

setting minimum for sweeps 2-213

setting points for sweeps 2-213

setting range for sweeps 2-212

H

HFSS Regions

enabling 2-221

I

IC die networks

creating 2-95

Icepak

configuring cabinets 2-166

exporting as project 2-81

exporting power data to 2-75

exporting thermal plots 2-82

running simulations 2-138

selecting component settings 2-167

selecting SITEMP file 2-168

setting board outline 2-166

setting meshing level 2-167

setting report image height 2-168

setting thermal settings 2-169

using data in DC sim 2-224

images

copying to clipboard 2-46

importing

ANF files 2-17, 2-110

capacitor derating attributes 2-111
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component files 2-111

component mapping files 2-112

CPA simulation options 2-113

CPM files 2-114

EDB files 2-116

GDSII files 2-116

IPC2581 files 2-117

layer stackup files 2-118

layer stackup XML files 2-118

layer stackups 2-117

ODB++ files 2-17

PLOC files 2-114

PMAP files 2-119

SIwave settings files 2-119, 2-120

XFL files 2-121

inductors

drawing 2-58

infinite ground plane

introducing 2-174

information

adding to log 2-24

L

layers

adding 2-25

adding padstacks 2-27

assign filler material 2-180

deleting 2-53

exporting stackups 2-84

importing layer stackup files 2-118

importing layer stackup XML 2-118

importing stackups 2-117

locating die on 2-100

modifying antipads 2-149

renaming 2-68

returning filler material 2-103

returning list of 2-101

returning material of 2-101

returning thickness of 2-102, 2-109

returning type of 2-102

selecting for sweep 2-193

setting bondwire support 2-150

setting bondwire termination 2-151

setting conformal coating 2-154

setting material 2-174

setting pads on 2-191

setting thermal pads on 2-216

setting thickness 2-175, 2-211

setting thickness unit 2-212

setting type 2-175

setting visibility 2-176

length

setting unit of 2-177
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licenses

HPC

setting type 2-165

setting vendor 2-165

logging

errors 2-24

information 2-24

warnings 2-27

M

magnitude

setting format for Touchstone 2-217

materials

adding 2-26

assigning to layer 2-174

editing 2-68

returning for layer 2-101

measurement

returning units of 2-102

mesh refinement

setting automatic 2-198

messages

logging 2-122

saving 2-144

models

deselecting objects 2-223

exporting 2-73

fitting to workspace 2-92

S-parameter

configuring N-ports 2-209

saving PNG of 2-144

selecting options for export 2-188

Spice

configuring N-ports 2-210

setting output format 2-211

multiprocessing 2-187

N

nets

checking whether selected 2-124

clipping 2-40

clipping design around 2-42

computing length 2-123

deleting 2-53

all 2-51

all but specified 2-134

from array 2-54

from file 2-54

deselecting 2-125

designating P/G 2-195

designating P/G from file 2-195

designating signal 2-201

designating signal from file 2-202

determining disjoint 2-123
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finding connecting RLCs 2-109

merging connected 2-122

preserving 2-134

renaming 2-69

returning

by bondwire profile 2-103

connected 2-99

connecting 2-105

connecting power/ground 2-104

list of all 2-103

power/ground 2-108

terminal 2-97

sanitizing 2-143

selecting 2-125, 2-145

selecting between components 2-146

selecting between nets 2-146

selecting connected 2-145

separating disjoint 2-124, 2-147

setting dummy 2-124

showing selected 2-220

Nexxim

launching 2-161

O

objects

deselecting all 2-223

operators

boolean unite 2-38

equals 2-13

reference equals 2-18

P

pads

setting on layer 2-191

setting thermal on layer 2-216

padstacks

adding 2-27

deleting 2-54

renaming 2-69

returning by associated pin 2-106

returning list of 2-105

setting material of 2-191

setting via plating 2-192

parts

changing type 2-39

creating ports on 2-51

paths

returning 2-14

setting DC thermal directory 2-99

pin groups

creating 2-46

by distance 2-48

by grid 2-49
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by net 2-50

deleting 2-55

returning list of 2-106

pins

finding associated padstack 2-106

returning list by net 2-107

returning list by part 2-108

planes

converting to traces 2-44

polygons

drawing 2-59

ports

creating on part 2-51

drawing 2-60

excluding part 2-132

placing across RLCs 2-130

placing between pins 2-132, 2-133

placing on selected nets 2-131

remapping for Touchstone 2-224

setting naming convention 2-194

setting PSI type 2-196

setting Touchstone order 2-217

setting Touchstone remapping 2-218

power data

exporting 2-75

projects

closing 2-12, 2-43

opening 2-18

returning active 2-13

returning directory of 2-15

returning list of 2-16

returning name of 2-14

saving as 2-144

setting save prompts 2-196

R

rectangles

drawing 2-61

regions

equipotential

adding 2-23

resistors

drawing 2-62

return current distribution

disabling 2-221

enabling 2-221

RLCs

returning list of connecting 2-109

setting values 2-200

S

S-parameters

enabling support 2-225

sanitizing layout 2-143
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save prompts

setting 2-196

scripts

list of available 2-1

running from command line 1-1

running in SIwave 1-1

translating VBscript to IronPython 1-8

setting number of CPUs 2-187

simulations

aborting 2-225

AC

exporting voltage probe data 2-89

automatic mesh refinement 2-198

CPA

exporting reports 2-75

importing options 2-113

crosstalk scan

frequency domain

setting parameters 2-154

time domain

setting parameters 2-215

DC

adaptive mesh refinement 2-198

assigning capacitor derating 2-111

bondwire discretization 2-187

exporting element data 2-80

exporting loop resistance 2-135

plotting after simulation 2-193

refining along bondwires 2-197

refining along vias 2-198

returning connected nets 2-99

running 2-136

setting energy error 2-159

setting ideal ground node 2-170

setting local refinement 2-177

setting maximum passes 2-178

setting mesh bondwires 2-179

setting mesh vias 2-179

setting minimum passes 2-181

setting minimum plane area 2-155

setting minimum void area 2-155

setting thermal directory 2-99

setting via discretization 2-188

using bias voltage 2-152

using Icepak temperature 2-153

using thermal data 2-224

enabling coupling

cavity field 2-70

coplanar 2-70

intra-plane 2-72

split plane 2-72

trace 2-73

far field

running 2-137
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setting external excitations 2-159

setting options 2-160

specifying interpolation 2-121

frequency sweep

running 2-137

generating unique name for 2-110

HFSS 3D Layout

importing settings 2-115, 2-164

Icepak

configuring cabinets 2-166

running 2-138

selecting component settings 2-167

selecting SITEMP file 2-168

setting board outline 2-166

setting meshing level 2-167

setting report image height 2-168

setting thermal settings 2-169

impedance scan

exporting reports 2-90

setting parameters 2-219

setting report image height 2-220

induced voltage

running 2-138

settings

cartesian 2-172

spherical

multi 2-171

single 2-173

introducing infinite ground plane 2-174

launching 2-224

naming 2-203

near field

running 2-139

selecting Points frequency 2-183

selecting Range frequency 2-184

setting error tolerance 2-182, 2-185

setting external excitations 2-159

setting max. edge length 2-184

setting mesh frequencies 2-183

setting number of passes 2-182, 2-
185

setting surface offset 2-186

specifying interpolation 2-121

PSI

computing SYZ 2-197

enabling ERC 2-70

setting port type 2-196

setting XML configuration 2-196

resonant modes

creating surface plots 2-134

restoring frequency 2-135, 2-136

running 2-139

setting maximum frequency 2-199

setting minimum frequency 2-199

Index-10

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



SIwave Scripting Guide

setting number of modes 2-187

running 2-55, 2-137, 2-140

setting coupling distance 2-218

setting crosstalk threshold 2-155

setting minimum cutout area 2-180

setting minimum pad area 2-181

setting minimum plane area 2-181

setting number of CPUs 2-187

setting vertices snapping 2-206

signal net analyzer

exporting reports 2-85, 2-86

stopping 2-225

SYZ

checking existence of 2-17

computing exact DC point 2-222

computing Spice subcircuit 2-140

controlling passivity options 2-161

enabling parasitics 2-221

enforcing causality 2-93, 2-222

enforcing passivity 2-223

error tolerance 2-71, 2-72

plotting magnitude 2-193

plotting phase animation 2-194

returning data 2-15

returning port names 2-15

running 2-140

running PSI 2-197

selecting FWS format 2-163

setting column fitting options 2-160

setting interpolating options 2-214

setting interpolating sweep 2-213

setting pole/zero options 2-162

setting state-space options 2-163

specifying common ground 2-164

Z0 renormalization 2-162

SIwave

exiting 2-18

restoring window 2-19

saving 2-19

software

exiting 2-18

restoring window 2-19

saving 2-19

solderballs

assigning material 2-206

assigning terminal type 2-38

creating complex 2-33

creating simple 2-35

setting parameters 2-207

solutions

DC

deleting 2-52

exporting power tree 2-21, 2-76

exporting reports 2-77
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SYZ

exporting active dataset 2-88

exporting results 2-88
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