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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It includes instructions to define transient settings, solve, and analyze a simple heat pipe
model.

This chapter contains the following topic:

l Sample Project - The Heat Pipe

Sample Project - The Heat Pipe
In this project, you will learn how to define a dataset and assign transient settings. Icepak solves
conservation equations of mass, momentum, and energy to provide flow and thermal fields.

Figure 1-1: Heat Pipe
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2 - Set Up the Project
This chapter contains the following topics:

l "Launch the Ansys Electronics Desktop" below
l Set the Solution Type

Launch the Ansys Electronics Desktop
A shortcut of the Ansys Electronics Desktop application appears on your desktop once the applic-
ation is installed.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

Getting Started with Icepak: Transient Simulation
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3. ClickOK.

Open the Project

1. On the Desktop ribbon tab, click Open Examples. Then:
a. In theOpen dialog box that appears, click the parent folder icon ( ) once to move

up one level above the Examples folder.
b. Double-click the Help folder and then the Icepak folder.
c. Select the file Heat_Pipe_Geometry.aedt and clickOpen.

2. The model is displayed in the 3D Modeler window.

Note: You can hide the grid by selecting View >Grid Settings and then selecting
Hide in theGrid Spacing dialog box. Also, from the View > Coordinate Systems
menu, you can hide the large coordinate triad and display a smaller coordinate triad
in the bottom of the 3D Modeler window.
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Figure 2-1: Heat Pipe model in the 3D Modeler window

3. From the Filemenu, select Save As, and save the project in the desired working dir-
ectory.

Set Solution Type
Specify the design’s solution type as follows:

1. Click Icepak >Solution Type.

The Solution Type dialog box appears.

2. Under Solution types, select Transient.
3. Under Problem types, ensure Temperature and Flow is selected and clickOK.

Note:

To automatically set Transient as the default solution type for new designs,
select Save as default
.
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Figure 2-2: Solution Type
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3 - Define Transient Simulation Settings
Certain boundary condition and native 3D component parameters can be defined as transient. In
this simulation, the block power is transient. We'll also examine the fan component's Transient
Strength option.

Note:

Refer to Transient Thermal Properties Dependency in the main Icepak help for a list
of which boundary condition and native 3D component parameters can be defined as
transient.

This chapter contains the following topics:
l Review the Piecewise Linear Dataset
l Assign the Piecewise Linear Dataset
l Review the Transient Fan Option

Review the Piecewise Linear Dataset
This transient simulation uses a piecewise linear variation function to define time-dependent
power in the block object. Perform the following steps to review the dataset that specifies the
piecewise linear power.

1. From the Icepakmenu, select Design Datasets.
2. In the Datasets dialog box, select the ds_pwr dataset and click Edit.

Getting Started with Icepak: Transient Simulation
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3. Note the X and Y column values. The X column is specified in seconds, and the Y axis spe-
cifies the multiplier to be applied to the assigned boundary condition's total power value. In
this project, the dataset is assigned to the block_1 boundary condition. In the next section,
you will assign transient power to the block and review the total power values at the spe-
cified time intervals.

4. Click Cancel to close the Edit Dataset dialog box.
5. Click Done to close the Datasets dialog box.

Assign the Piecewise Linear Dataset
Assign transient power to the block boundary condition using the existing dataset.

1. In the Project Manager, expand Thermal to view the assigned Icepak boundary con-
ditions.

2. Double-click block_1.
3. For Total Power, enable the check box and select Transient from the drop-down list.
4. Click Edit to open the Total Power - Transient Variation dialog box.
5. For Variation function, select Piecewise Linear.
6. For S0, enter 25 W.
7. For Variation, select ds_pwr.
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8. Click Apply to assign the piecewise linear dataset to the variation function. The graph is
updated with the curve.

9. ClickOk to close the Total Power -Transient Variation dialog box.
10. ClickOK to close the Block Thermal Model dialog box.

Review the Transient Fan Option
This model also includes a fan native 3D component. Open the fan properties to review its tran-
sient option, Transient Strength.

1. In the Project Manager, expand 3D Components.
2. Right-click fan_1_1 and select Edit Definition.

3-3

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak: Transient Simulation

3. On the Property tab, click the check box next to Transient Strength.
4. Review the Transient Strength - Transient Variation dialog box. Note the Variation func-

tion options.

5. This simulation does not include Transient Strength, so click Cancel to close the Tran-
sient Strength - Transient Variation dialog box.

6. Click Cancel to close the Fan Component dialog box.
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4 - Review the Solve Setup and Run the
Analysis

Before running the analysis, review the available transient options in the solve setup.

This chapter contains the following topics:
l Review the Solve Setup
l Run the Analysis and Monitor the Results

Review the Solve Setup
1. In the Project Manager, expand Analysis.
2. Double-click Setup1 to open the Icepak Solve Setup Dialog.
3. On theGeneral tab, enter the settings under Transient Setup. The duration of the sim-

ulation is 30 seconds with a time step occurring every 2 second, and 150 iterations will
occur for each time step.

Getting Started with Icepak: Transient Simulation
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4. Click Preview to display the Variations Preview dialog box, which shows all parameters
defined as transient for the analysis. The block object's transient power is displayed.
Close the dialog box.
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5. On the Save Fields tab, enter 1 to ensure that fields for post-processing will be saved
every time step. Note the Varying option, which allows you to save fields data at varying
intervals using a transient variation function.
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6. Click OK to close the Icepak Solve Setup Dialog.

Run the Analysis and Monitor the Results
1. In the Project Manager, right-click Analysis and select Analyze.
2. Right-click Setup1 and select Thermal Monitor to open the Solutions dialog box.
3. Note the X axis on the monitor graph is Time(s). The graph displays the monitor tem-

perature data at each time step.
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4. Click the Flow Monitor tab to review the monitor flow data at each time step.

4-5

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak: Transient Simulation

5. Click Close.
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5 - Post-process the Solution
After the analysis is compete, post-process the results to review temperature data at the various
time steps.

This chapter contains the following topics:
l Create a Fields Summary
l Create a Temperature Plot
l Animate the Temperature Plot

Create a Fields Summary
Create a fields summary report to display the temperature of the block at each time step.

1. In the Project Manager, right-click Field Overlays.
2. Select Create Fields Summary.
3. In the Fields Summary dialog box, select All times in the Time drop-down list.
4. In the Setup Calculation dialog box, retain the selections for Entity Type,Geometry

Type, and Side.
5. Under Entity, select block_1.
6. UnderQuantity, select Temperature.

Getting Started with Icepak: Transient Simulation
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7. From the Add drop-down list, select Add as a Single Calculation.
8. In the Fields Summary dialog box, review the temperature of the block at each time step.
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9. ClickOK.

Create a Temperature Plot
1. In the history tree, expand Solids.
2. Expandmaterial_1,material_3, andmaterial_4.
3. Press the Shift key and select all geometry undermaterial_1,material_3, andmaterial_

4.
4. Right-click in the 3D Modeler window.
5. Select Plot Fields > Temperature > SurfTemperature.
6. Under Intrinsic Variables, select a Time of 24s.
7. Select Plot on surface only.
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8. Click Done.
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Modify the Temperature Plot Range
To enhance the visualization of animating the temperature plot, first modify the range of tem-
peratures displayed.

1. In the 3D Modeler window, right-click on the Temperature legend and selectModify.
2. In the Heat Pipe -- Temperature dialog box, click the Scale tab.
3. Select Use Limits and enter the following values:

l Min: 22
l Max: 35
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4. Click Apply and then Close.

Animate the Temperature Plot
1. In the Project Manager, expand Field Overlays > Temperature.
2. Right-click SurfTemperature1 and select Animate.
3. In the Select Animation dialog box, clickOK.
4. In the Animation dialog box, adjust the Speed slider bar to slow the animation.
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5. When finished viewing the animation, close the Animation dialog box.
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